Loading ...
Sorry, an error occurred while loading the content.

RE: [jasspa] Problems using ishell and cygwin

Expand Messages
  • Phillips, Steven
    Also because cygwin no longer echos the chars on the prompt, ME takes over the entry of text on the prompt (i.e. when ME sees a line from the shell in the form
    Message 1 of 3 , Mar 31, 2004
    • 0 Attachment
      Also because cygwin no longer echos the chars on the prompt, ME takes over the entry of text on the prompt (i.e. when ME sees a line from the shell in the form of "my-prompt>" it takes over key input until you press return and then pushes the whole command at the shell in one go). So while on a prompt pressing backspace does not send a C-h down to the shell, ME handles the key itself etc.

      Without this cygwin shell support would be impossible or at least unusable so this is a necessary evil. Unfortunately it does have a couple of draw-backs:

      ME MUST spot the prompt, I believe this may be the cause of both issues below. You must set the %cygwin-prompt variable to a regex string that will match your prompt. If ME fails to spot the prompt it will not take input control so the key input will go directly to the shell and will not be echoed, this may be what is causing issue (1). Also as the %cygwin-prompt is a regex you must be very careful when the prompt contains regex delimiters (such as '[' or '\(' etc), this could be the cause of (2). I suggest you cut and paste your prompt text into another temp buffer, enable magic mode and use the search commands to check the prompt regex.

      Multi-line input commands such as a for loop will get a reasonable prompt for the first line and then all will go 'dead' as ME will not be in prompt mode and the shell will not echo.

      During the execution of a large command I often start typing the next command (e.g. during the execution of 'tar cvf src.tar *' I start typing 'gzip src.tar'). As ME is not in prompt mode these keys are sent directly to the shell which means that they are not lost but not echoed when the prompt returns, this can cause confusion!

      Shell key bindings do not work on the prompt, this is because ME is doing it (but as ME supports most standard ME bindings this is probably an advantage :)

      The file completion is a bit odd, again this is because me is doing it.

      Note that the same feature is used by windows ishell command which attempts to use cmd inside ME and has the same problem.

      Steve

      > -----Original Message-----
      > From: Jon Green [mailto:jon@...]
      > Sent: 31 March 2004 22:58
      > To: jasspa@yahoogroups.com
      > Subject: Re: [jasspa] Problems using ishell and cygwin
      >
      >
      > azynheira wrote:
      > > Hello All,
      > >
      > > Noticed two problems while using ishell and cygwin.
      > >
      > > 1) Sometimes when using cygwin shell no echo is made of my
      > commands to
      > > the shell. Only the output comes back.
      >
      > The echo is synthetic for cygwin as the shell does not
      > echo (it used to in pre B20). I will keep a look out for
      > this and try to fix. If you know how to provoke it
      > reliably then please post.
      >
      > >
      > > 2) If in ishell the prompt has some type of delimiters like {}[]()
      > > that closes the bracket matching code highligths it and no input is
      > > possible. Only if I use something different like the usual '>' will
      > > the shell allow any kind of input.
      > >
      >
      > Is this the same from the command line (i.e. outside of
      > ME ?) For some of these characters then you need to escape
      > them in the BASH environment.
      >
      > > Any suggestions ?
      > >
      > >
      > > Azy
      > >
      > >
      > >
      > >
      > >
      > ______________________________________________________________
      > ____________
      > >
      > > This is an unmoderated list. JASSPA is not responsible for
      > the content of
      > > any material posted to this list.
      > >
      > > To unsubscribe, send a mail message to
      > >
      > > mailto:jasspa-unsubscribe@yahoogroups.com
      > >
      > > or visit http://groups.yahoo.com/group/jasspa and
      > > modify your account settings manually.
      > >
      > >
      > >
      > > Yahoo! Groups Links
      > >
      > >
      > >
      > >
      > >
      > >
      >
      >
      >
      >
      > ______________________________________________________________
      > ____________
      >
      > This is an unmoderated list. JASSPA is not responsible for
      > the content of
      > any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.