Loading ...
Sorry, an error occurred while loading the content.

RE: [jasspa] Corrected CSS Mode + Example

Expand Messages
  • Phillips, Steven
    The look-back limit for Hilight schemes is only 255 (meUByte), there is also quite a large cost in using the main hilighting scheme in the lookback as the main
    Message 1 of 12 , Mar 26, 2004
    • 0 Attachment
      The look-back limit for Hilight schemes is only 255 (meUByte), there is also quite a large cost in using the main hilighting scheme in the lookback as the main hilighting scheme has a lot of tokens so increasing beyond this is not the way forward.

      I am currently considering using the new indent 'fast look-back scheme' concept for hilighting as well. In this approach the fast look-back scheme only defines a few tokens ('<?php' '?>' etc) and has no practical look-back line limit (although should still be set to something near reasonable) this is then used to identify whether the first line displayed is html, php, vb, lua etc. ME can then start hilighting from the top using the correct hilighting scheme, getting the right answer.

      The building blocks for this is already there but I need to think through some practical performance issues first and its not going to be in this release - due out very very soon. I might however push out a prototype for this if there is interest.

      Steve
      > -----Original Message-----
      > From: Jon Green [mailto:jon@...]
      > Sent: 26 March 2004 10:08
      > To: jasspa@yahoogroups.com
      > Subject: Re: [jasspa] Corrected CSS Mode + Example
      >
      >
      > first last wrote:
      >
      > > Thanks for the answer Bruno. That explains all.
      > >
      > > I assume that is perfectly reasonable if you are mixing html and php
      > > but as I never do that, I pass through the limit quite often (and I
      > > can't use that at work, my boss would tell me that I need to change
      > > editor).
      > >
      > > How can I increase that limit? I have searched for lookback
      > and I can't
      > > find anything related to a limit and, as I've said before, I know
      > > nothing of the macro language.
      > >
      > > Thanks
      > >
      > > Gabriel
      > >
      >
      > Change the 50 to a 250 (or 400 or whatever) and see if this
      > solves the
      > problem in the line (hkcss.emf::34):-
      >
      > 0 hilight .hilight.css 3 50 $global-scheme
      > ^^^ change.
      > Jon.
      >
      >
      >
      >
      >
      > ------------------------ Yahoo! Groups Sponsor
      > ---------------------~-->
      > Buy Ink Cartridges or Refill Kits for your HP, Epson, Canon or Lexmark
      > Printer at MyInks.com. Free s/h on orders $50 or more to the
      > US & Canada.
      > http://www.c1tracking.com/l.asp?cid=5511
      > http://us.click.yahoo.com/mOAaAA/3exGAA/qnsNAA/89EolB/TM
      > --------------------------------------------------------------
      > -------~->
      >
      > ______________________________________________________________
      > ____________
      >
      > This is an unmoderated list. JASSPA is not responsible for
      > the content of
      > any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.