Loading ...
Sorry, an error occurred while loading the content.

2479Re: Problem while running gdiff via the command line

Expand Messages
  • azynheira
    Oct 21, 2009
    • 0 Attachment
      Hi All,
      I was quite happy with the proposed solution, until I have tryed it in Linux.

      The old problem occurs - Tryed it with tcsh or bash, with or without toolbar its exactly the same - No diff is possible.

      I'm looking into it :-)

      Regards,
      Pedro

      --- In jasspa@yahoogroups.com, "azynheira" <pedro.gomes@...> wrote:
      >
      > That's perfect Steve! :-)
      > Thanks All!
      > Pedro
      > --- In jasspa@yahoogroups.com, Steven Phillips <bill@> wrote:
      > >
      > > What a simple solution! I had wondered how to get the error message
      > > visible on windows, a pause is just what we need. Please try the
      > > following change to get a 5sec pause:
      > >
      > > *** d:\me\macros\gdiff.emf.~0~ Wed Oct 21 08:49:44 2009
      > > --- d:\me\macros\gdiff.emf Wed Oct 21 10:24:29 2009
      > > ***************
      > > *** 923,935 ****
      > > set-variable #l1 $buffer-fname
      > > !else
      > > ; more than 2 files given - error
      > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
      > > 0 quick-exit
      > > !endif
      > > next-buffer
      > > !until &seq $buffer-bname #l2
      > > !if &seq #l1 ""
      > > ! ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
      > > !else
      > > gdiff #l0 #l1
      > > !endif
      > > --- 923,935 ----
      > > set-variable #l1 $buffer-fname
      > > !else
      > > ; more than 2 files given - error
      > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
      > > 0 quick-exit
      > > !endif
      > > next-buffer
      > > !until &seq $buffer-bname #l2
      > > !if &seq #l1 ""
      > > ! 5000 ml-write "[Usage error: me \"@gdiff\" <old> <new>]"
      > > !else
      > > gdiff #l0 #l1
      > > !endif
      > > [EXIT 1]
      > >
      > >
      > > azynheira wrote:
      > > >
      > > >
      > > > Hi Steve,
      > > > This one works ok :-). The only thing missing is some pause in case of
      > > > error (the message in the modeline appears), instead of quick-exiting
      > > > to the OS. But I think we can live with it ...
      > > >
      > > > Regards,
      > > > Pedro
      > > >
      > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>,
      > > > Steven Phillips <bill@> wrote:
      > > > >
      > > > > Pedro,
      > > > >
      > > > > Could you please try the attached version, I've had a little hack...
      > > > >
      > > > > Steve
      > > > >
      > > > > azynheira wrote:
      > > > > >
      > > > > >
      > > > > > Hi Jon,
      > > > > > I tryed to use the gdiff from the command line with my huge toolbar
      > > > > > and the problem stays the same (I used the version in the
      > > > > > http://www.jasspa.com/development/patches-20091017/
      > > > <http://www.jasspa.com/development/patches-20091017/>
      > > > > > <http://www.jasspa.com/development/patches-20091017/
      > > > <http://www.jasspa.com/development/patches-20091017/>> directory.
      > > > > >
      > > > > > I'll try to debug the stuff and provide more accurate feedback.
      > > > > >
      > > > > > Regards,
      > > > > > Pedro
      > > > > >
      > > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>
      > > > <mailto:jasspa%40yahoogroups.com>,
      > > > > > "azynheira" <pedro.gomes@> wrote:
      > > > > > >
      > > > > > > Hi Jon,
      > > > > > > I will give them a try and get back to you,
      > > > > > >
      > > > > > > Thanks,
      > > > > > > Pedro
      > > > > > >
      > > > > > > --- In jasspa@yahoogroups.com <mailto:jasspa%40yahoogroups.com>
      > > > <mailto:jasspa%40yahoogroups.com>, Jon
      > > > > > Green <jon@> wrote:
      > > > > > > >
      > > > > > > > azynheira wrote:
      > > > > > > > > Hello All,
      > > > > > > > > I've found some bug in gdiff :-)
      > > > > > > > > If I execute gdiff as an independent tool via:
      > > > > > > > > me "@gdiff" <old> <new>
      > > > > > > > > and I have the toolbar enabled, gdiff will never diff anything
      > > > > > and complain with the usual message "gdiff Error: usage <new> <old".
      > > > > > > > >
      > > > > > > > > If I disable the toolbar it will work perfectly. It seems gdiff
      > > > > > and toolbar do not mix together.
      > > > > > > > >
      > > > > > > > > Another minor problem is that if diff.exe (in Win32 of course!)
      > > > > > does not exist in the PATH it will not complain and will think the
      > > > > > files are equal :-)
      > > > > > > > >
      > > > > > > > > My 10c :P
      > > > > > > > > Pedro
      > > > > > > > >
      > > > > > > >
      > > > > > > > Hi Pedro,
      > > > > > > >
      > > > > > > > I have placed all of the fixed macro files (and changes) in the
      > > > > > following directory:
      > > > > > > >
      > > > > > > > http://www.jasspa.com/development/patches-20091017/
      > > > <http://www.jasspa.com/development/patches-20091017/>
      > > > > > <http://www.jasspa.com/development/patches-20091017/
      > > > <http://www.jasspa.com/development/patches-20091017/>>
      > > > > > > >
      > > > > > > > There is also an update to the gdiff which should be the last.
      > > > > > > >
      > > > > > > > Regards
      > > > > > > > Jon.
      > > > > > > >
      > > > > > >
      > > > > >
      > > > > >
      > > > >
      > > >
      > > >
      > >
      >
    • Show all 14 messages in this topic