Loading ...
Sorry, an error occurred while loading the content.

1803RE: [jasspa] function (method) name hilighting -- not working for me

Expand Messages
  • Phillips, Steven
    Mar 24 1:30 AM
    • 0 Attachment
      Tom,

      The List Items and the hilighting are 2 separate things. The List Items
      is a 'one shot' operation which uses the full syntax of ME's regex
      engine, it can afford to be a bit slower in favour of getting better
      results. The hilighter on the other hand has only a sub-set of regex at
      its disposal and must be quick, it must also operate on a single line.

      So differences between the 2 are not that uncommon and sometimes the
      hilighting cannot be fixed. However can you please send me an example
      and I will see if I can fix the hilighting for you,

      Steve

      > -----Original Message-----
      > From: jasspa@yahoogroups.com [mailto:jasspa@yahoogroups.com]
      > On Behalf Of Thomas Hundt
      > Sent: 23 March 2006 20:14
      > To: JASSPA MicroEmacs Mailing List (W)
      > Subject: [jasspa] function (method) name hilighting -- not
      > working for me
      >
      > I'm having a problem with method name highlighting in Java.
      > It won't "hilight" them in the program text, but will in the
      > item list.
      >
      > I think my default scheme color is blue on background, but
      > even if I edit it in the scheme editor (Schemes, Section:
      > Programming Langs,
      > Scheme: Function Names) to, say, red on yellow, it still
      > doesn't display that way in the program text.
      >
      > But: if I do Tools>Java>List Items (F6), it opens an item
      > list window on the left, and displays the names there -- in
      > the hilighted format I set in the scheme editor!
      >
      > So, I have to conclude that
      > a) it does "know" which pieces of text are the function names
      > (i.e., the parsing is working correctly -- it isn't missing a
      > tags file or anything like that)
      > b) similarly, it knows what the highlighting should look like
      > c) it just isn't applying a and b to the program text window.
      >
      > Any suggestions? (Is it working for you?)
      >
      > I'm not sure it's ever worked for me. Just to see if I was
      > doing something weird, I renamed my company directory to
      > something else, and fired up the editor, and it still behaves
      > the same.
      >
      > Thanks,
      >
      > -Tom Hundt
      >
      >
      >
      >
      >
      > ______________________________________________________________
      > ____________
      >
      > This is an unmoderated list. JASSPA is not responsible for
      > the content of any material posted to this list.
      >
      > To unsubscribe, send a mail message to
      >
      > mailto:jasspa-unsubscribe@yahoogroups.com
      >
      > or visit http://groups.yahoo.com/group/jasspa and modify your
      > account settings manually.
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
    • Show all 3 messages in this topic