Loading ...
Sorry, an error occurred while loading the content.

1051Re: [jasspa] Corrected CSS Mode + Example

Expand Messages
  • Bruno Sabin
    Mar 24, 2004
    • 0 Attachment
      Hello Gabriel,

      > Completely unrelated to this mode, sometimes on the PHP mode I get
      > the colours or the indentation lost, but only one of them at the
      > time. Does anyone else get the same error?

      there is currently a hilight lookback limited to 200 lines in this
      buffer mode. This means that you will see the PHP hilighting stops
      hilighting when the line at the top of the current window is more
      than 200. A quick workaround to this is to drop the special token
      "#?php" (without the quotes) every 199 or less lines.

      Bruno
      --
      _________________________________________________________________
      Bruno Sabin Parametric Technology Corp.

      Dont wait for your ship to come in, swim out to it

      mailto:bsabin@...

      Tuesday, March 23, 2004, 8:34:20 PM, you wrote:

      > Hi there,

      > Thanks for the cleanup, I tend to chose the Perl macros as the base for
      > everything I do (don't ask me why) and I still don't know anything
      > about the ME macro system, I just add/delete as I go along.

      > The duplicates come from the fact that I got the list of keywords from
      > the w3c site and then run a script to extract them. As I haven't had
      > much time I haven't gone through checking it.

      > The modified file seems to work perfectly. I haven't tested it at work
      > so I don't know if it crashes or not, will test that tomorrow.

      > I enclose a stylesheet so you can see a couple of words that don't come
      > up right (I don't know if I did include them or not).

      > A couple of improvements would be great if someone could make them:
      > -words starting with . are class names (variables?).
      > -could it be possible to hightlight colour names such as "white",
      > "black" and so on and html colours (#00aaff and so on) with the same
      > colour? That would be a great help.

      > Completely unrelated to this mode, sometimes on the PHP mode I get the
      > colours or the indentation lost, but only one of them at the time. Does
      > anyone else get the same error?

      > Thanks to everyone involved in fixing the mode.

      > Gabriel

      > ________________________________________________________________________
      > Yahoo! Messenger - Communicate instantly..."Ping"
      > your friends today! Download Messenger Now
      > http://uk.messenger.yahoo.com/download/index.html

      > __________________________________________________________________________

      > This is an unmoderated list. JASSPA is not responsible for the content of
      > any material posted to this list.

      > To unsubscribe, send a mail message to

      > mailto:jasspa-unsubscribe@yahoogroups.com

      > or visit http://groups.yahoo.com/group/jasspa and
      > modify your account settings manually.



      > Yahoo! Groups Links
    • Show all 12 messages in this topic