Loading ...
Sorry, an error occurred while loading the content.

Messages List

7959

Re: O2 Sensor

A bad O2 sensor can definetely give you milage issues. I'm not familiar with that motor so I can't give you recommendations on how to get it off. Good luck!
Steve Gardiner
Aug 12, 2013
#7959
 
7958

O2 Sensor

Dear Group, I have a 99 Rodeo four cylinder.  I have been having issues trying to get the o2 sensor off.  It is the upper one.  Any suggestions on how to
Matthew Miller
Aug 8, 2013
#7958
 
7957

foxnews

http://www.mcoermigk.de/xriww/epdw [Non-text portions of this message have been removed]
JOE PARISI
Mar 10, 2013
#7957
 
7956

Re: 99 Isuzu Rodeo By Pass Hose

Call St. Charles Isuzu.  Great prices and free shipping.  They're info is listed here somewhere.  Steve G Sent from my pocket computer.  ... From: Matthew
Steve Gardiner
Mar 1, 2013
#7956
 
7955

Re: 99 Isuzu Rodeo By Pass Hose

No I can't cut it off.  It has two smaller hoses that run off the top of it.  I called a Isuzu dealership that is three hours away.  They call it a Water
Matthew Miller
Mar 1, 2013
#7955
 
7954

Re: 99 Isuzu Rodeo By Pass Hose

Can you cut it off cleanly and use a hose??? The 2.3L and 2.6L have stubs coming of the lower hose pipe and the heater pipe around the back of the engine, and
sword_king
Mar 1, 2013
#7954
 
7953

99 Isuzu Rodeo By Pass Hose

Dear Member, I have a 1999 Isuzu Rodeo 2.2L 2WD.  I have been told it is the Heater By Pass Hose that I am looking for.  It is a dark grey or black plastic
Matthew Miller
Feb 28, 2013
#7953
 
7951

cv axle

the R outer cv joint has failed on my 90 trooper w/v6. i have herd there are two different styles and one is a pain w/clips in the differential the other just
G&T
Sep 20, 2012
#7951
 
7949

need help on a isuzu repairs

i got a 91 isuzu stylus that sat for about 7 to 8 year low miles on it but there is fuel a fuel pressure problem and i cannot fine where it is losing pressure
pebbles
Jun 7, 2012
#7949
 
7948

Re: R/CV joint

Welcome to the group. I have indeed found two styles. For a quick fix, one might try just swapping the outer and this is where the 2 style don't mix. I can't
Little Buddy
May 29, 2012
#7948
 
7947

R/CV joint

the R outer cv joint has failed on my 90 trooper w/v6. i have herd there are two different styles and one is a pain . i am a pretty good shade tree mech.
G&T
May 29, 2012
#7947
 
7946

Re: 1992 amigo 2.6 no spark.

Couldn't have said it better myself sword_king,thanks for the description!  I would have never dreamed the Alt could cause so much trouble but it can on these
DAVID KELLEY
Mar 29, 2012
#7946
 
7945

Re: 1992 amigo 2.6 no spark.

I suppose you may be on to something my friend. We do get one spark at first crank over then nothing. I will have them check on these things. ~Thanks. MJ
Mike
Mar 29, 2012
#7945
 
7944

Re: 1992 amigo 2.6 no spark.

Always no spark, or does it attempt to start once in a while and then nothing? If it never even fires, not once, ever, you may have a corroded or melted a wire
sword_king
Mar 29, 2012
#7944
 
7943

Re: 1992 amigo 2.6 no spark.

I am not sure it could be this as the alt was replaced with in 20k I had a problem where I would have to hold the key on the start position and keep the clutch
Mike
Mar 29, 2012
#7943
 
View First Topic Go to View Last Topic
Loading 1 - 15 of total 7,959 messages