Loading ...
Sorry, an error occurred while loading the content.

EchoLink Problem here

Expand Messages
  • kokohead2001
    Can anyone help me with this one. Ive got Echolink enabled with the embedded node. I can connect to any Echolink node with star and node number. and
    Message 1 of 5 , Aug 17 12:52 PM
    • 0 Attachment
      Can anyone help me with this one. Ive got Echolink enabled with the
      embedded node. I can connect to any Echolink node with star and
      node number. and disconnect with 73. I connect to the echolink test
      server and it onnects and I transmit audio but nothing comes back. I
      can connect to an echolink node and it connects, they dont hear me and
      I dont hear them. Ive dont the irlp troubleshoot script, it is all
      OK, EXCEPT; it tells me there is corruption in the environmen
      file,and its saying the problem exists at or near the folg lines

      ./home/irlp/features/features.env

      and below that

      if ["$USE_ECHOIRLP" = YES] ; then
      .$HOME/features/EchoIRLP/custom/echo_environment
      fi

      Please check troubleshooting docs to resolve this problem.

      ==================
      But I cant find those docs so my problem remains 'unresolved' Can
      anyone give me any advise?

      ALOHA de Gary, working on Node 3212
    • Ed Yoho
      ... My guess would be UDP ports 5198 & 5199 are not forwarded to your node s IP. Take a look at your router setup and copy the IRLP UDP forwarding except
      Message 2 of 5 , Aug 17 4:25 PM
      • 0 Attachment
        kokohead2001 wrote:
        > Can anyone help me with this one. Ive got Echolink enabled with the
        > embedded node. I can connect to any Echolink node with star and
        > node number. and disconnect with 73. I connect to the echolink test
        > server and it onnects and I transmit audio but nothing comes back. I
        > can connect to an echolink node and it connects, they dont hear me and
        > I dont hear them. Ive dont the irlp troubleshoot script, it is all
        > OK, EXCEPT; it tells me there is corruption in the environmen
        > file,and its saying the problem exists at or near the folg lines
        >
        > ./home/irlp/features/features.env
        >
        > and below that
        >
        > if ["$USE_ECHOIRLP" = YES] ; then
        > .$HOME/features/EchoIRLP/custom/echo_environment
        > fi
        >
        > Please check troubleshooting docs to resolve this problem.
        >
        > ==================
        > But I cant find those docs so my problem remains 'unresolved' Can
        > anyone give me any advise?
        >
        > ALOHA de Gary, working on Node 3212
        >

        My guess would be UDP ports 5198 & 5199 are not forwarded to your node's
        IP. Take a look at your router setup and copy the IRLP UDP forwarding
        except change the port numbers to those used by EchoLink (5198 & 5199).

        Ed Yoho
        W6YJ
      • kokohead2001
        ... node s ... NO Ed, the ports ARE forwarded in the router, and I just double checked and confirmed it again. It sounded like ports to me too but I had
        Message 3 of 5 , Aug 17 5:31 PM
        • 0 Attachment
          --- In irlp-embedded@yahoogroups.com, Ed Yoho <w6yj_yahoo@...> wrote:
          >
          > kokohead2001 wrote:
          > > Can anyone help me with this one. Ive got Echolink enabled with the
          > > embedded node. I can connect to any Echolink node with star and
          > > node number. and disconnect with 73. I connect to the echolink test
          > > server and it onnects and I transmit audio but nothing comes back. I
          > > can connect to an echolink node and it connects, they dont hear me and
          > > I dont hear them. Ive dont the irlp troubleshoot script, it is all
          > > OK, EXCEPT; it tells me there is corruption in the environmen
          > > file,and its saying the problem exists at or near the folg lines
          > >
          > > ./home/irlp/features/features.env
          > >
          > > and below that
          > >
          > > if ["$USE_ECHOIRLP" = YES] ; then
          > > .$HOME/features/EchoIRLP/custom/echo_environment
          > > fi
          > >
          > > Please check troubleshooting docs to resolve this problem.
          > >
          > > ==================
          > > But I cant find those docs so my problem remains 'unresolved' Can
          > > anyone give me any advise?
          > >
          > > ALOHA de Gary, working on Node 3212
          > >
          >
          > My guess would be UDP ports 5198 & 5199 are not forwarded to your
          node's
          > IP. Take a look at your router setup and copy the IRLP UDP forwarding
          > except change the port numbers to those used by EchoLink (5198 & 5199).
          >
          > Ed Yoho
          > W6YJ
          >
          NO Ed, the ports ARE forwarded in the router, and I just double
          checked and confirmed it again. It sounded like ports to me too but I
          had forwarded 5198-5199 UDP to the node box

          Thanks, ALOHA
        • Ed Yoho
          ... The two environment error messages you got from the troubleshoot-irlp script are not really problems (just lines not in a stock IRLP node environment
          Message 4 of 5 , Aug 18 9:09 AM
          • 0 Attachment
            >
            > NO Ed, the ports ARE forwarded in the router, and I just double
            > checked and confirmed it again. It sounded like ports to me too but I
            > had forwarded 5198-5199 UDP to the node box
            >
            > Thanks, ALOHA
            >

            The two environment error messages you got from the troubleshoot-irlp
            script are not really problems (just lines not in a 'stock' IRLP node
            environment file).

            It does appear the ports are correct. I was able to connect _once_ and
            it did not time out as it would if the ports are not open of if TBD is
            not running.

            A possible hint is the node is not showing on the EchoLink status page.
            After noticing that, I tried to re-connect and the connection timed out.

            Ed Yoho
            W6YJ
          • kokohead2001
            ... with the ... test ... back. I ... me and ... is all ... 5199). ... I HAVE RESOLVED THE PROBLEM, THANKS TO ED, W6YJ I had saved the original files before I
            Message 5 of 5 , Aug 18 10:16 AM
            • 0 Attachment
              --- In irlp-embedded@yahoogroups.com, "kokohead2001" <kh6gmp@...> wrote:
              >
              > --- In irlp-embedded@yahoogroups.com, Ed Yoho <w6yj_yahoo@> wrote:
              > >
              > > kokohead2001 wrote:
              > > > Can anyone help me with this one. Ive got Echolink enabled
              with the
              > > > embedded node. I can connect to any Echolink node with star and
              > > > node number. and disconnect with 73. I connect to the echolink
              test
              > > > server and it onnects and I transmit audio but nothing comes
              back. I
              > > > can connect to an echolink node and it connects, they dont hear
              me and
              > > > I dont hear them. Ive dont the irlp troubleshoot script, it
              is all
              > > > OK, EXCEPT; it tells me there is corruption in the environmen
              > > > file,and its saying the problem exists at or near the folg lines
              > > >
              > > > ./home/irlp/features/features.env
              > > >
              > > > and below that
              > > >
              > > > if ["$USE_ECHOIRLP" = YES] ; then
              > > > .$HOME/features/EchoIRLP/custom/echo_environment
              > > > fi
              > > >
              > > > Please check troubleshooting docs to resolve this problem.
              > > >
              > > > ==================
              > > > But I cant find those docs so my problem remains 'unresolved' Can
              > > > anyone give me any advise?
              > > >
              > > > ALOHA de Gary, working on Node 3212
              > > >
              > >
              > > My guess would be UDP ports 5198 & 5199 are not forwarded to your
              > node's
              > > IP. Take a look at your router setup and copy the IRLP UDP forwarding
              > > except change the port numbers to those used by EchoLink (5198 &
              5199).
              > >
              > > Ed Yoho
              > > W6YJ
              > >
              > NO Ed, the ports ARE forwarded in the router, and I just double
              > checked and confirmed it again. It sounded like ports to me too but I
              > had forwarded 5198-5199 UDP to the node box
              >
              > Thanks, ALOHA
              >

              I HAVE RESOLVED THE PROBLEM, THANKS TO ED, W6YJ
              I had saved the original files before I did any editing and this
              morning oopied them back to the node box and then edited them line by
              line with putty, did the flashsync and rcirlp and now audio is passing
              with no problem, MARK THIS PROBLEM SOLVED, Thanks and ALOHA
            Your message has been successfully submitted and would be delivered to recipients shortly.