Loading ...
Sorry, an error occurred while loading the content.

Re: [irlp-embedded] Error in script file Common-functions.sh

Expand Messages
  • dcameron@irlp.net
    It could be a common problem. The permissions of the messages file needs to be related to the repeater user. To do this log in as root and type: chown
    Message 1 of 5 , Aug 29, 2007
    • 0 Attachment
      It could be a common problem. The permissions of the messages file needs to be related to the repeater user.

      To do this log in as root and type:

      chown repeater.repeater /home/irlp/log/messages
      chmod 664 /home/irlp/log/messages

      Don't forget to run flash_sync when you are complete.

      Not sure how this occured on you node.

      Dave Cameron

      --------------------------------------------------------
      David Cameron - VE7LTD
      IRLP System Designer - http://www.irlp.net

      -----Original Message-----
      From: "gauthier_jacques" <gauthier_jacques@...>

      Date: Wed, 29 Aug 2007 14:39:58
      To:irlp-embedded@yahoogroups.com
      Subject: [irlp-embedded] Error in script file Common-functions.sh


      I'm receivin a error in my script file "common-functions.sh" file, it
      reads as follows after cold boot.

      enabling Irlp node ... /home/irlp/scripts/common-functions.sh: line
      66 /home/irlp.log/messages:permission denied

      Now I believe this is simply permissions to write to the messages
      file.Because my log file is empty!! But since I didn't change anything
      ie; permissions, I'm curious why this would happen, as well on how to
      fix it?

      If anyone could lend assistance it would be greatly appreciated

      Jack
      VE3JGJ / VE3WBT
    • Keith VE7GDH
      Dave VE7LTD wrote... ... Just before doing the fix, I would suggest that Jack looks at the messages file to see it is currently owned by... ls -alph
      Message 2 of 5 , Aug 29, 2007
      • 0 Attachment
        Dave VE7LTD wrote...

        > It could be a common problem. The permissions of the messages
        > file needs to be related to the repeater user.

        Just before doing the fix, I would suggest that Jack looks at the messages
        file to see it is currently owned by...

        ls -alph /home/irlp/log/messages

        and then go ahead and fix up the ownership and permissions. I would only
        expect two users - repeater and root - but I would be curious about who
        owned the file before fixing the problem.

        Keith VE7GDH
        Node 1148
      • gauthier_jacques
        Thank s Dave and Keith, I checked the permissions before the change and it read as follows -RW-R--R-- 1 Root after the change it reads -RW-RW-R-- 1 Repeater I
        Message 3 of 5 , Aug 29, 2007
        • 0 Attachment
          Thank's Dave and Keith,
          I checked the permissions before the change and it read as follows

          -RW-R--R-- 1 Root
          after the change it reads
          -RW-RW-R-- 1 Repeater
          I then re-booted tested the logging, and everything is fine :-)







          --- In irlp-embedded@yahoogroups.com, "Keith VE7GDH" <ve7gdh@...>
          wrote:
          >
          > Dave VE7LTD wrote...
          >
          > > It could be a common problem. The permissions of the messages
          > > file needs to be related to the repeater user.
          >
          > Just before doing the fix, I would suggest that Jack looks at the
          messages
          > file to see it is currently owned by...
          >
          > ls -alph /home/irlp/log/messages
          >
          > and then go ahead and fix up the ownership and permissions. I would
          only
          > expect two users - repeater and root - but I would be curious about
          who
          > owned the file before fixing the problem.
          >
          > Keith VE7GDH
          > Node 1148
          >
        • gauthier_jacques
          I checked the permissions as Keith suggested it read as follows, -RW-R--R-- 1 Root after Dave s suggestions it reads, -RW-RW-R-- 1 Repeater After which I
          Message 4 of 5 , Aug 29, 2007
          • 0 Attachment
            I checked the permissions as Keith suggested it read as follows,

            -RW-R--R-- 1 Root
            after Dave's suggestions it reads,
            -RW-RW-R-- 1 Repeater

            After which I tested the log file using the 9999 reflector, it logged
            it OK, I re-booted my node and everything came up error free.

            thnx's Dave Keith for ur assistance:-)

            Jack
            VE3JGj / VE3BT
            Node 2266
          Your message has been successfully submitted and would be delivered to recipients shortly.