Loading ...
Sorry, an error occurred while loading the content.

Apache 2 not owned by repeater

Expand Messages
  • ae7i
    I was trying to get IRLPVcon going and it wouldn t work because it said HTTPD wasn t loaded first. I am using Debian and used the following commands: apt-get
    Message 1 of 5 , Aug 3 4:38 PM
    • 0 Attachment
      I was trying to get IRLPVcon going and it wouldn't work because it said HTTPD wasn't loaded first. I am using Debian and used the following commands:
      apt-get install apache2
      /etc/init/apache2 start

      The message received was:
      Starting web server: apache2/var/lock/apache2 already exists but is not a directory owned by repeater.
      Please fix manually. Aborting.
      failed!

      I am just learning BASH, so wasn't quite sure where to go from here. Does anyone have tips as to how I can get HTTPD working so that I can then use Vcon?

      Thanks,

      Craig, AE7I
      Node 7062
    • ae7i
      I just heard back from K6IB about Vcon. It isn t compatible with Apache2 at this time. As a newbie to Linux, I didn t understand the difference. He hopes to
      Message 2 of 5 , Aug 4 9:52 AM
      • 0 Attachment
        I just heard back from K6IB about Vcon. It isn't compatible with Apache2 at this time. As a newbie to Linux, I didn't understand the difference. He hopes to eventually find a way to make it compatible, but his time for the project is limited.

        I will go back to the drawing board on this project... read more about bash and try to understand the differences between the various versions of Apache, etc.

        Craig - AE7I
        Node 7062

        --- In irlp-embedded@yahoogroups.com, "ae7i" <cmsande@...> wrote:
        >
        > I was trying to get IRLPVcon going and it wouldn't work because it said HTTPD wasn't loaded first. I am using Debian and used the following commands:
        > apt-get install apache2
        > /etc/init/apache2 start
        >
        > The message received was:
        > Starting web server: apache2/var/lock/apache2 already exists but is not a directory owned by repeater.
        > Please fix manually. Aborting.
        > failed!
        >
        > I am just learning BASH, so wasn't quite sure where to go from here. Does anyone have tips as to how I can get HTTPD working so that I can then use Vcon?
        >
        > Thanks,
        >
        > Craig, AE7I
        > Node 7062
        >
      • David Cameron
        This is not an embedded node if it is running Debian. This question would be better asked on the IRLP Yahoogroup. Dave Cameron ... David Cameron - VE7LTD IRLP
        Message 3 of 5 , Aug 5 8:26 AM
        • 0 Attachment
          This is not an embedded node if it is running Debian. This question would be better asked on the IRLP Yahoogroup.

          Dave Cameron
          --------------------------------------------------------
          David Cameron - VE7LTD
          IRLP System Designer - http://www.irlp.net

          From: "ae7i" <cmsande@...>
          Sender: irlp-embedded@yahoogroups.com
          Date: Sat, 03 Aug 2013 23:38:35 -0000
          To: <irlp-embedded@yahoogroups.com>
          ReplyTo: irlp-embedded@yahoogroups.com
          Subject: [irlp-embedded] Apache 2 not owned by repeater

           

          I was trying to get IRLPVcon going and it wouldn't work because it said HTTPD wasn't loaded first. I am using Debian and used the following commands:
          apt-get install apache2
          /etc/init/apache2 start

          The message received was:
          Starting web server: apache2/var/lock/apache2 already exists but is not a directory owned by repeater.
          Please fix manually. Aborting.
          failed!

          I am just learning BASH, so wasn't quite sure where to go from here. Does anyone have tips as to how I can get HTTPD working so that I can then use Vcon?

          Thanks,

          Craig, AE7I
          Node 7062

        • Craig Sande
          Accept my apologies. I will need to review terms. I am an IRLP newbie :) 73, Craig AE7I
          Message 4 of 5 , Aug 5 11:30 AM
          • 0 Attachment
            Accept my apologies. I will need to review terms. I am an IRLP newbie :)

            73, Craig AE7I

            On Monday, August 5, 2013, David Cameron wrote:
             

            This is not an embedded node if it is running Debian. This question would be better asked on the IRLP Yahoogroup.

            Dave Cameron

            --------------------------------------------------------
            David Cameron - VE7LTD
            IRLP System Designer - http://www.irlp.net

            From: "ae7i" <cmsande@...>
            Date: Sat, 03 Aug 2013 23:38:35 -0000
            Subject: [irlp-embedded] Apache 2 not owned by repeater

             

            I was trying to get IRLPVcon going and it wouldn't work because it said HTTPD wasn't loaded first. I am using Debian and used the following commands:
            apt-get install apache2
            /etc/init/apache2 start

            The message received was:
            Starting web server: apache2/var/lock/apache2 already exists but is not a directory owned by repeater.
            Please fix manually. Aborting.
            failed!

            I am just learning BASH, so wasn't quite sure where to go from here. Does anyone have tips as to how I can get HTTPD working so that I can then use Vcon?

            Thanks,

            Craig, AE7I
            Node 7062

          • Rick Bates
            And yet oddly enough, during my replacing the hardware for node 7962, httpd (Apache-2) was installed via yum and it works with the k6ib scripts. The ONLY
            Message 5 of 5 , Aug 7 12:11 AM
            • 0 Attachment

              And yet oddly enough, during my replacing the hardware for node 7962, httpd (Apache-2) was installed via yum and it works with the k6ib scripts.  The ONLY thing I had to do was to disable SELinux security (which also resolved a sound system issue, because SELinux negated specific permissions).  I did wander through the .conf file but I don’t remember making any changes (and I’m trying to document what has been done).

               

              The new hardware is an Atom based mini-ITX system (with SSD and oodles of memory, ZERO moving parts) running CentOS 6.4 [32 bit] (because other than the Debian flavor, no other IRLP install disk will load).  It’s not perfect, but it’s on line and able to do pretty much all I need it to do including the n0anm wx scripts, kk7av cwid scripts (mostly), k6ib control/display scripts and EchoIRLP and a few more things.  I’m still chasing down some anomalies, but I’m pretty happy with it.  I know the few issues left to fix, but haven’t had the time this week to do much with it.  So far, the fixes are brute force scripts (reset the audio levels to what I want, not what you think I want), later I’ll make it more elegant.

               

              Try ‘apt-get install httpd’ if it didn’t install.  The format may be off, I’m used to yum.  After install it should start by default on boot up or (you’ll need to translate, I don’t speak Debian which is why I stayed CentOS) ‘service httpd start’.

               

              I suppose it’s possible that file (or tree) configuration is different on Debian vs CentOS, which would mean research and some scripts changes.

               

              Failing that, you might try the ‘native’ remote admin feature (which I’ve never tried).  I doubt they’re as ‘pretty’ as the vcon/vmap web based controls, but that’s semantics.

               

              73,

              Rick wa6nhc/6

              7962, 3598

               


              From: ae7i

              I just heard back from K6IB about Vcon. It isn't compatible with Apache2 at this time. As a newbie to Linux, I didn't understand the difference. He hopes to eventually find a way to make it compatible, but his time for the project is limited.

              I will go back to the drawing board on this project... read more about bash and try to understand the differences between the various versions of Apache, etc.

              Craig - AE7I
              Node 7062

              --- In irlp-embedded@yahoogroups.com, "ae7i" <cmsande@...> wrote:

              >
              > I was trying to get IRLPVcon going and it wouldn't work because it said
              HTTPD wasn't loaded first. I am using Debian and used the following commands:
              > apt-get install apache2
              > /etc/init/apache2 start
              >
              > The message received was:
              > Starting web server: apache2/var/lock/apache2 already exists but is not a
              directory owned by repeater.
              > Please fix manually. Aborting.
              > failed!
              >
              > I am just learning BASH, so wasn't quite sure where to go from here. Does
              anyone have tips as to how I can get HTTPD working so that I can then use Vcon?
              >
              > Thanks,
              >
              > Craig, AE7I
              > Node 7062
              >

            Your message has been successfully submitted and would be delivered to recipients shortly.