Loading ...
Sorry, an error occurred while loading the content.
 

Re: Daylight Time Change

Expand Messages
  • Brayden Hulett
    Hi Dave, I tried reapplying the fix yesterday and have had no success. The script runs, but following a reboot the time does not change. My city is most
    Message 1 of 8 , Oct 18, 2012
      Hi Dave,

      I tried reapplying the fix yesterday and have had no success. The script runs, but following a reboot the time does not change.

      My city is most certainly there - Australia/Melbourne.

      Regards,

      Brayden

      --- In irlp-embedded@yahoogroups.com, "ve7ltd" <dcameron@...> wrote:
      >
      > Try to reapply the fix:
      >
      > http://groups.yahoo.com/group/irlp-embedded/message/232
      >
      > I assume the timezone you are trying to apply is available in the list when you use the timeconfig command?
      >
      > Try the steps in the message linked above.
      >
      > Dave Cameron
      >
      > --- In irlp-embedded@yahoogroups.com, "Brayden Hulett" <braydenhulett@> wrote:
      > >
      > > Hi All,
      > >
      > > Daylight savings has come in to effect here in Melbourne, Australia and my embedded node is still running behind. I have seen mention of a script on here that says it will fix this issue, but I've also read that all new nodes have the updated zoneinfo by default? I have attempted to force an update using set-time, but it still comes back with the non-dst time.
      > >
      > > Any help is appreciated. :)
      > >
      > > Regards,
      > >
      > > Brayden
      > >
      >
    • Brayden Hulett
      As an update - I reapplied it (twice now) and there is no change. On reboot, the time is still an hour behind and when the script finishes (but before
      Message 2 of 8 , Oct 23, 2012
        As an update - I reapplied it (twice now) and there is no change. On reboot, the time is still an hour behind and when the script finishes (but before flash_sync runs), I see 'timeout for ntp.ubc.ca'.

        Running /usr/sbin/set-time has no effect either.

        --- In irlp-embedded@yahoogroups.com, "ve7ltd" <dcameron@...> wrote:
        >
        > Try to reapply the fix:
        >
        > http://groups.yahoo.com/group/irlp-embedded/message/232
        >
        > I assume the timezone you are trying to apply is available in the list when you use the timeconfig command?
        >
        > Try the steps in the message linked above.
        >
        > Dave Cameron
        >
        > --- In irlp-embedded@yahoogroups.com, "Brayden Hulett" <braydenhulett@> wrote:
        > >
        > > Hi All,
        > >
        > > Daylight savings has come in to effect here in Melbourne, Australia and my embedded node is still running behind. I have seen mention of a script on here that says it will fix this issue, but I've also read that all new nodes have the updated zoneinfo by default? I have attempted to force an update using set-time, but it still comes back with the non-dst time.
        > >
        > > Any help is appreciated. :)
        > >
        > > Regards,
        > >
        > > Brayden
        > >
        >
      • David Cameron (IRLP)
        Okay, well there was a script change for the set-time script as well. But since it is a root script, it needs to be modified on the box by the root user. The
        Message 3 of 8 , Oct 24, 2012
          Okay, well there was a script change for the set-time script as well.
          But since it is a root script, it needs to be modified on the box by the
          root user.

          The ntp.ubc.ca was shut down (without my knowing), so not that script
          should use:

          rdate -s ntp.irlp.net

          (This at least I have control over).

          It could be that the timezone is correct, just that your time can not be
          updated because the set-time script is bad :)

          What is your node number - I will log in and have a look to see if I can
          figure out why this is happening.

          Dave Cameron

          On 23/10/2012 11:09 PM, Brayden Hulett wrote:
          > As an update - I reapplied it (twice now) and there is no change. On reboot, the time is still an hour behind and when the script finishes (but before flash_sync runs), I see 'timeout for ntp.ubc.ca'.
          >
          > Running /usr/sbin/set-time has no effect either.
          >
          > --- In irlp-embedded@yahoogroups.com, "ve7ltd" <dcameron@...> wrote:
          >>
          >> Try to reapply the fix:
          >>
          >> http://groups.yahoo.com/group/irlp-embedded/message/232
          >>
          >> I assume the timezone you are trying to apply is available in the list when you use the timeconfig command?
          >>
          >> Try the steps in the message linked above.
          >>
          >> Dave Cameron
          >>
          >> --- In irlp-embedded@yahoogroups.com, "Brayden Hulett" <braydenhulett@> wrote:
          >>>
          >>> Hi All,
          >>>
          >>> Daylight savings has come in to effect here in Melbourne, Australia and my embedded node is still running behind. I have seen mention of a script on here that says it will fix this issue, but I've also read that all new nodes have the updated zoneinfo by default? I have attempted to force an update using set-time, but it still comes back with the non-dst time.
          >>>
          >>> Any help is appreciated. :)
          >>>
          >>> Regards,
          >>>
          >>> Brayden
          >>>
          >>
          >
          >
          >
        • Brayden Hulett
          Hi Dave, This would be node 6789 - run by Craig Meddings VK3CRG. I appreciate the help! Regards, Brayden
          Message 4 of 8 , Oct 25, 2012
            Hi Dave,

            This would be node 6789 - run by Craig Meddings VK3CRG.

            I appreciate the help!

            Regards,

            Brayden

            --- In irlp-embedded@yahoogroups.com, "David Cameron (IRLP)" <dcameron@...> wrote:
            >
            > Okay, well there was a script change for the set-time script as well.
            > But since it is a root script, it needs to be modified on the box by the
            > root user.
            >
            > The ntp.ubc.ca was shut down (without my knowing), so not that script
            > should use:
            >
            > rdate -s ntp.irlp.net
            >
            > (This at least I have control over).
            >
            > It could be that the timezone is correct, just that your time can not be
            > updated because the set-time script is bad :)
            >
            > What is your node number - I will log in and have a look to see if I can
            > figure out why this is happening.
            >
            > Dave Cameron
            >
            > On 23/10/2012 11:09 PM, Brayden Hulett wrote:
            > > As an update - I reapplied it (twice now) and there is no change. On reboot, the time is still an hour behind and when the script finishes (but before flash_sync runs), I see 'timeout for ntp.ubc.ca'.
            > >
            > > Running /usr/sbin/set-time has no effect either.
            > >
            > > --- In irlp-embedded@yahoogroups.com, "ve7ltd" <dcameron@> wrote:
            > >>
            > >> Try to reapply the fix:
            > >>
            > >> http://groups.yahoo.com/group/irlp-embedded/message/232
            > >>
            > >> I assume the timezone you are trying to apply is available in the list when you use the timeconfig command?
            > >>
            > >> Try the steps in the message linked above.
            > >>
            > >> Dave Cameron
            > >>
            > >> --- In irlp-embedded@yahoogroups.com, "Brayden Hulett" <braydenhulett@> wrote:
            > >>>
            > >>> Hi All,
            > >>>
            > >>> Daylight savings has come in to effect here in Melbourne, Australia and my embedded node is still running behind. I have seen mention of a script on here that says it will fix this issue, but I've also read that all new nodes have the updated zoneinfo by default? I have attempted to force an update using set-time, but it still comes back with the non-dst time.
            > >>>
            > >>> Any help is appreciated. :)
            > >>>
            > >>> Regards,
            > >>>
            > >>> Brayden
            > >>>
            > >>
            > >
            > >
            > >
            >
          • ve7ltd
            Okay, I have updated the zoneinfo files that are pulled down by the fix-dst script. So if you are having trouble with your timezones, you can try to get this
            Message 5 of 8 , Oct 25, 2012
              Okay, I have updated the zoneinfo files that are pulled down by the fix-dst script.

              So if you are having trouble with your timezones, you can try to get this new version of the fix-dst script and zone files, and it should fix any problem. The files were updated on September 17th if this year.

              Here are the commands to run fix-dst

              log in as root
              cd /root
              wget ftp://ftp.irlp.net/fix-dst
              sh fix-dst

              It will download the new zones, and ask you to enter your timezone again.

              Happy updating!

              Dave Cameron
              VE7LTD

              --- In irlp-embedded@yahoogroups.com, "Brayden Hulett" <braydenhulett@...> wrote:
              >
              > Hi Dave,
              >
              > This would be node 6789 - run by Craig Meddings VK3CRG.
              >
              > I appreciate the help!
              >
              > Regards,
              >
              > Brayden
              >
              > --- In irlp-embedded@yahoogroups.com, "David Cameron (IRLP)" <dcameron@> wrote:
              > >
              > > Okay, well there was a script change for the set-time script as well.
              > > But since it is a root script, it needs to be modified on the box by the
              > > root user.
              > >
              > > The ntp.ubc.ca was shut down (without my knowing), so not that script
              > > should use:
              > >
              > > rdate -s ntp.irlp.net
              > >
              > > (This at least I have control over).
              > >
              > > It could be that the timezone is correct, just that your time can not be
              > > updated because the set-time script is bad :)
              > >
              > > What is your node number - I will log in and have a look to see if I can
              > > figure out why this is happening.
              > >
              > > Dave Cameron
              > >
              > > On 23/10/2012 11:09 PM, Brayden Hulett wrote:
              > > > As an update - I reapplied it (twice now) and there is no change. On reboot, the time is still an hour behind and when the script finishes (but before flash_sync runs), I see 'timeout for ntp.ubc.ca'.
              > > >
              > > > Running /usr/sbin/set-time has no effect either.
              > > >
              > > > --- In irlp-embedded@yahoogroups.com, "ve7ltd" <dcameron@> wrote:
              > > >>
              > > >> Try to reapply the fix:
              > > >>
              > > >> http://groups.yahoo.com/group/irlp-embedded/message/232
              > > >>
              > > >> I assume the timezone you are trying to apply is available in the list when you use the timeconfig command?
              > > >>
              > > >> Try the steps in the message linked above.
              > > >>
              > > >> Dave Cameron
              > > >>
              > > >> --- In irlp-embedded@yahoogroups.com, "Brayden Hulett" <braydenhulett@> wrote:
              > > >>>
              > > >>> Hi All,
              > > >>>
              > > >>> Daylight savings has come in to effect here in Melbourne, Australia and my embedded node is still running behind. I have seen mention of a script on here that says it will fix this issue, but I've also read that all new nodes have the updated zoneinfo by default? I have attempted to force an update using set-time, but it still comes back with the non-dst time.
              > > >>>
              > > >>> Any help is appreciated. :)
              > > >>>
              > > >>> Regards,
              > > >>>
              > > >>> Brayden
              > > >>>
              > > >>
              > > >
              > > >
              > > >
              > >
              >
            • Brayden Hulett
              Thanks Dave, That worked perfectly! Brayden
              Message 6 of 8 , Oct 26, 2012
                Thanks Dave,

                That worked perfectly!

                Brayden

                --- In irlp-embedded@yahoogroups.com, "ve7ltd" <dcameron@...> wrote:
                >
                > Okay, I have updated the zoneinfo files that are pulled down by the fix-dst script.
                >
                > So if you are having trouble with your timezones, you can try to get this new version of the fix-dst script and zone files, and it should fix any problem. The files were updated on September 17th if this year.
                >
                > Here are the commands to run fix-dst
                >
                > log in as root
                > cd /root
                > wget ftp://ftp.irlp.net/fix-dst
                > sh fix-dst
                >
                > It will download the new zones, and ask you to enter your timezone again.
                >
                > Happy updating!
                >
                > Dave Cameron
                > VE7LTD
                >
                > --- In irlp-embedded@yahoogroups.com, "Brayden Hulett" <braydenhulett@> wrote:
                > >
                > > Hi Dave,
                > >
                > > This would be node 6789 - run by Craig Meddings VK3CRG.
                > >
                > > I appreciate the help!
                > >
                > > Regards,
                > >
                > > Brayden
                > >
                > > --- In irlp-embedded@yahoogroups.com, "David Cameron (IRLP)" <dcameron@> wrote:
                > > >
                > > > Okay, well there was a script change for the set-time script as well.
                > > > But since it is a root script, it needs to be modified on the box by the
                > > > root user.
                > > >
                > > > The ntp.ubc.ca was shut down (without my knowing), so not that script
                > > > should use:
                > > >
                > > > rdate -s ntp.irlp.net
                > > >
                > > > (This at least I have control over).
                > > >
                > > > It could be that the timezone is correct, just that your time can not be
                > > > updated because the set-time script is bad :)
                > > >
                > > > What is your node number - I will log in and have a look to see if I can
                > > > figure out why this is happening.
                > > >
                > > > Dave Cameron
                > > >
                > > > On 23/10/2012 11:09 PM, Brayden Hulett wrote:
                > > > > As an update - I reapplied it (twice now) and there is no change. On reboot, the time is still an hour behind and when the script finishes (but before flash_sync runs), I see 'timeout for ntp.ubc.ca'.
                > > > >
                > > > > Running /usr/sbin/set-time has no effect either.
                > > > >
                > > > > --- In irlp-embedded@yahoogroups.com, "ve7ltd" <dcameron@> wrote:
                > > > >>
                > > > >> Try to reapply the fix:
                > > > >>
                > > > >> http://groups.yahoo.com/group/irlp-embedded/message/232
                > > > >>
                > > > >> I assume the timezone you are trying to apply is available in the list when you use the timeconfig command?
                > > > >>
                > > > >> Try the steps in the message linked above.
                > > > >>
                > > > >> Dave Cameron
                > > > >>
                > > > >> --- In irlp-embedded@yahoogroups.com, "Brayden Hulett" <braydenhulett@> wrote:
                > > > >>>
                > > > >>> Hi All,
                > > > >>>
                > > > >>> Daylight savings has come in to effect here in Melbourne, Australia and my embedded node is still running behind. I have seen mention of a script on here that says it will fix this issue, but I've also read that all new nodes have the updated zoneinfo by default? I have attempted to force an update using set-time, but it still comes back with the non-dst time.
                > > > >>>
                > > > >>> Any help is appreciated. :)
                > > > >>>
                > > > >>> Regards,
                > > > >>>
                > > > >>> Brayden
                > > > >>>
                > > > >>
                > > > >
                > > > >
                > > > >
                > > >
                > >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.