Loading ...
Sorry, an error occurred while loading the content.

time question

Expand Messages
  • Donald Jacob
    I have just noticed that on my node 3830 that the system time was off. I ran the command: /usr/sbin/set-time and get the error message: time out for ntp.ubc.ca
    Message 1 of 6 , Mar 10, 2010
    • 0 Attachment
      I have just noticed that on my node 3830 that the
      system time was off. I ran the command:
      /usr/sbin/set-time
      and get the error message:
      time out for ntp.ubc.ca

      Is there another time server to set the time?
      If so, how do I configure it?

      Thanks
      Don WB5EKU
    • James Nessen
      You can use the NTP pool servers instead. 0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org You can add them by modifying /etc/ntp.conf and looking
      Message 2 of 6 , Mar 11, 2010
      • 0 Attachment
        You can use the NTP pool servers instead.


        You can add them by modifying /etc/ntp.conf and looking for:

        server ntp.ubc.ca

        and replacing it with:


        (you don't have to use all 4 pools, but the option is there).

        The nice thing about the ntp pools is that they are made up of hundreds of machines, so you don't have to rely on a single time source.

        Hope that helps.

        Jim, K6JWN


        On Wed, Mar 10, 2010 at 8:59 PM, Donald Jacob <wb5eku@...> wrote:
         

        I have just noticed that on my node 3830 that the
        system time was off. I ran the command:
        /usr/sbin/set-time
        and get the error message:
        time out for ntp.ubc.ca

        Is there another time server to set the time?
        If so, how do I configure it?

        Thanks
        Don WB5EKU




        --
        Jim Nessen K6JWN
        Email: nessenj@... | Ph: 530.564.0039
        IRLP: Nodes 3598,7358 | Echolink: 83598 K6JWN-R

      • dcameron@irlp.net
        This is for an embedded machine, which only uses rdate periodically to update the time. I am pretty sure the ubc machine is still there, but you could just
        Message 3 of 6 , Mar 11, 2010
        • 0 Attachment
          This is for an embedded machine, which only uses rdate periodically to update the time.

          I am pretty sure the ubc machine is still there, but you could just change the set-time script to use the ntp pools instead.

          Don't forget to flash_sync when you are done.

          Dave Cameron

          --------------------------------------------------------
          David Cameron - VE7LTD
          IRLP System Designer - http://www.irlp.net


          From: James Nessen <nessenj@...>
          Date: Thu, 11 Mar 2010 08:04:02 -0800
          To: <irlp-embedded@yahoogroups.com>
          Subject: Re: [irlp-embedded] time question

           

          You can use the NTP pool servers instead.



          You can add them by modifying /etc/ntp.conf and looking for:

          server ntp.ubc.ca

          and replacing it with:


          (you don't have to use all 4 pools, but the option is there).

          The nice thing about the ntp pools is that they are made up of hundreds of machines, so you don't have to rely on a single time source.

          Hope that helps.

          Jim, K6JWN


          On Wed, Mar 10, 2010 at 8:59 PM, Donald Jacob <wb5eku@gmail. com> wrote:
           

          I have just noticed that on my node 3830 that the
          system time was off. I ran the command:
          /usr/sbin/set- time
          and get the error message:
          time out for ntp.ubc.ca

          Is there another time server to set the time?
          If so, how do I configure it?

          Thanks
          Don WB5EKU




          --
          Jim Nessen K6JWN
          Email: nessenj@jimsoffice. org | Ph: 530.564.0039
          IRLP: Nodes 3598,7358 | Echolink: 83598 K6JWN-R

        • James Nessen
          Ahh, I assumed that it used ntpd, thanks for the clarification :) Jim
          Message 4 of 6 , Mar 11, 2010
          • 0 Attachment
            Ahh, I assumed that it used ntpd, thanks for the clarification :)

            Jim

            On Thu, Mar 11, 2010 at 9:18 AM, <dcameron@...> wrote:
             

            This is for an embedded machine, which only uses rdate periodically to update the time.

            I am pretty sure the ubc machine is still there, but you could just change the set-time script to use the ntp pools instead.

            Don't forget to flash_sync when you are done.

            Dave Cameron


          • ve7ltd
            Unless the UBC machine has something to prevent outside IPs from obtaining the time data, it seems to be working fine for me here. There are literally hundreds
            Message 5 of 6 , Mar 15, 2010
            • 0 Attachment
              Unless the UBC machine has something to prevent outside IPs from obtaining the time data, it seems to be working fine for me here.

              There are literally hundreds of public NTP servers out there, and having super-accurate time is not a requirement of the IRLP.

              Dave Cameron
              VE7LTD

              --- In irlp-embedded@yahoogroups.com, dcameron@... wrote:
              >
              > This is for an embedded machine, which only uses rdate periodically to update the time.
              >
              > I am pretty sure the ubc machine is still there, but you could just change the set-time script to use the ntp pools instead.
              >
              > Don't forget to flash_sync when you are done.
              >
              > Dave Cameron
              > --------------------------------------------------------
              > David Cameron - VE7LTD
              > IRLP System Designer - http://www.irlp.net
              >
              > -----Original Message-----
              > From: James Nessen <nessenj@...>
              > Date: Thu, 11 Mar 2010 08:04:02
              > To: <irlp-embedded@yahoogroups.com>
              > Subject: Re: [irlp-embedded] time question
              >
              > You can use the NTP pool servers instead.
              >
              > 0.pool.ntp.org
              > 1.pool.ntp.org
              > 2.pool.ntp.org
              > 3.pool.ntp.org
              >
              > You can add them by modifying /etc/ntp.conf and looking for:
              >
              > server ntp.ubc.ca
              >
              > and replacing it with:
              >
              > server 0.pool.ntp.org
              > server 1.pool.ntp.org
              > server 2.pool.ntp.org
              > server 3.pool.ntp.org
              >
              > (you don't have to use all 4 pools, but the option is there).
              >
              > The nice thing about the ntp pools is that they are made up of hundreds of
              > machines, so you don't have to rely on a single time source.
              >
              > Hope that helps.
              >
              > Jim, K6JWN
              >
              >
              > On Wed, Mar 10, 2010 at 8:59 PM, Donald Jacob <wb5eku@...> wrote:
              >
              > >
              > >
              > > I have just noticed that on my node 3830 that the
              > > system time was off. I ran the command:
              > > /usr/sbin/set-time
              > > and get the error message:
              > > time out for ntp.ubc.ca
              > >
              > > Is there another time server to set the time?
              > > If so, how do I configure it?
              > >
              > > Thanks
              > > Don WB5EKU
              > >
              > >
              >
              >
              >
              > --
              > Jim Nessen K6JWN
              > Email: nessenj@... | Ph: 530.564.0039
              > IRLP: Nodes 3598,7358 | Echolink: 83598 K6JWN-R
              >
            • Donald Jacob
              Dave, Thanks for the reply, and Jim too. It seems that there is a larger problem. When I try to update the time manually, directly to any of the NTP servers, I
              Message 6 of 6 , Mar 15, 2010
              • 0 Attachment
                Dave,
                Thanks for the reply, and Jim too.
                It seems that there is a larger problem.
                When I try to update the time manually, directly to
                any of the NTP servers, I get the same timeout error message.
                Also, I have looked and looked in my embedded system and for
                the life of me I cannot find the set-time script. I'm probably
                looking right at it. but...

                I can set the time manually but not have it update.
                I have run the troubleshooting script and all is well!

                Don  WB5EKU
                Node 3830



                On Mon, Mar 15, 2010 at 12:53 PM, ve7ltd <dcameron@...> wrote:
                 

                Unless the UBC machine has something to prevent outside IPs from obtaining the time data, it seems to be working fine for me here.

                There are literally hundreds of public NTP servers out there, and having super-accurate time is not a requirement of the IRLP.

                Dave Cameron
                VE7LTD



                --- In irlp-embedded@yahoogroups.com, dcameron@... wrote:
                >
                > This is for an embedded machine, which only uses rdate periodically to update the time.
                >
                > I am pretty sure the ubc machine is still there, but you could just change the set-time script to use the ntp pools instead.
                >
                > Don't forget to flash_sync when you are done.
                >
                > Dave Cameron
                > --------------------------------------------------------
                > David Cameron - VE7LTD
                > IRLP System Designer - http://www.irlp.net
                >
                > -----Original Message-----
                > From: James Nessen <nessenj@...>
                > Date: Thu, 11 Mar 2010 08:04:02
                > To: <irlp-embedded@yahoogroups.com>
                > Subject: Re: [irlp-embedded] time question
                >
                > You can use the NTP pool servers instead.
                >
                > 0.pool.ntp.org
                > 1.pool.ntp.org
                > 2.pool.ntp.org
                > 3.pool.ntp.org
                >
                > You can add them by modifying /etc/ntp.conf and looking for:
                >
                > server ntp.ubc.ca
                >
                > and replacing it with:
                >
                > server 0.pool.ntp.org
                > server 1.pool.ntp.org
                > server 2.pool.ntp.org
                > server 3.pool.ntp.org
                >
                > (you don't have to use all 4 pools, but the option is there).
                >
                > The nice thing about the ntp pools is that they are made up of hundreds of
                > machines, so you don't have to rely on a single time source.
                >
                > Hope that helps.
                >
                > Jim, K6JWN
                >
                >
                > On Wed, Mar 10, 2010 at 8:59 PM, Donald Jacob <wb5eku@...> wrote:
                >
                > >
                > >
                > > I have just noticed that on my node 3830 that the
                > > system time was off. I ran the command:
                > > /usr/sbin/set-time
                > > and get the error message:
                > > time out for ntp.ubc.ca
                > >
                > > Is there another time server to set the time?
                > > If so, how do I configure it?
                > >
                > > Thanks
                > > Don WB5EKU
                > >
                > >
                >
                >
                >
                > --
                > Jim Nessen K6JWN
                > Email: nessenj@... | Ph: 530.564.0039

                > IRLP: Nodes 3598,7358 | Echolink: 83598 K6JWN-R
                >


              Your message has been successfully submitted and would be delivered to recipients shortly.