Loading ...
Sorry, an error occurred while loading the content.

IoDesktop on Mac OS X [HELP]

Expand Messages
  • Giovanni Giorgi
    Hi all, I have just started to look for the iolanguage. I am using Mac OS X Panther. I have succesful compiled the VM and the Server modules. I got stucked
    Message 1 of 5 , May 2, 2004
    View Source
    • 0 Attachment
      Hi all,
      I have just started to look for the iolanguage.
      I am using Mac OS X Panther.
      I have succesful compiled the VM and the Server modules.

      I got stucked compiling IoDesktop, because I cannot compile the Audio
      subsystem: the linker complaing about
      ld: Undefined symbols:
      _IoAudioInit

      So I tried to compile it:
      cd IoDesktop-2004-04-25/IoDesktop/Audio
      make
      I got a compilation error:

      gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../libmp3lame -I../include -I..
      -I/sw/include -I/sw/include/gtk-2.0 -I/Volumes/Dati/jj/src/boost_1_31_0
      -Wall -g -O2 -Dfull -Wall -Wstrict-prototypes -Winline -I. -I../../IoVM
      -I../../IoVM/base -Ibase -I../OpenGL -Ibase/portaudio/pa_common
      -Ibase/libsndfile/src -Ibase/lame/include -Ibase/libmad -fno-common -c
      `test -f brhist.c || echo './'`brhist.c
      In file included from brhist.c:25:
      ../config.h:67: warning: use of `long double' type; its size may change in
      a future release
      ../config.h:67: warning: (Long double usage is reported only once for each
      file.
      ../config.h:67: warning: To disable this warning, use -Wno-long-double.)
      brhist.c:206: error: parse error before numeric constant
      brhist.c:207: warning: function declaration isn't a prototype
      brhist.c: In function `brhist_disp_line':
      brhist.c:215: error: `br_hist_TOT' undeclared (first use in this function)
      brhist.c:215: error: (Each undeclared identifier is reported only once
      brhist.c:215: error: for each function it appears in.)
      brhist.c:216: error: `br_hist_LR' undeclared (first use in this function)
      brhist.c:221: error: `frames' undeclared (first use in this function)
      brhist.c:244: error: `i' undeclared (first use in this function)
      make[3]: *** [brhist.o] Error 1
      make[2]: *** [all-recursive] Error 1
      make[1]: *** [all] Error 2
      make: *** [all] Error 2
      I have tried to look at line 206 but I cannot understand where the error
      is.
      How can I compile IoDesktop without the Audio support?
      I am using:
      gcc (GCC) 3.3 20030304 (Apple Computer, Inc. build 1495)

      Thank you!

      --
      // Giovanni Giorgi
      // http://www.siforge.org
      //
    • Steve Dekorte
      ... Hi Giovanni, Did you run make configure first? -- Steve
      Message 2 of 5 , May 2, 2004
      View Source
      • 0 Attachment
        On May 2, 2004, at 2:59 AM, Giovanni Giorgi wrote:
        > I have just started to look for the iolanguage.
        > I am using Mac OS X Panther.
        > I have succesful compiled the VM and the Server modules.
        >
        > I got stucked compiling IoDesktop, because I cannot compile the Audio
        > subsystem: the linker complaing about
        > ld: Undefined symbols:
        > _IoAudioInit
        >
        > So I tried to compile it:
        > cd IoDesktop-2004-04-25/IoDesktop/Audio
        > make
        > I got a compilation error:
        >
        > gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../libmp3lame -I../include -I..
        > -I/sw/include -I/sw/include/gtk-2.0 -I/Volumes/Dati/jj/src/boost_1_31_0
        > -Wall -g -O2 -Dfull -Wall -Wstrict-prototypes -Winline -I.
        > -I../../IoVM
        > -I../../IoVM/base -Ibase -I../OpenGL -Ibase/portaudio/pa_common
        > -Ibase/libsndfile/src -Ibase/lame/include -Ibase/libmad -fno-common
        > -c
        > `test -f brhist.c || echo './'`brhist.c

        Hi Giovanni,

        Did you run "make configure" first?

        -- Steve
      • giorgi_g
        ... [...] ... Hi, I have ran ./configure --prefix=/opt/io and it seems to work fine. I should try to recompile it? Thank you!
        Message 3 of 5 , May 2, 2004
        View Source
        • 0 Attachment
          --- In iolanguage@yahoogroups.com, Steve Dekorte <steve@d...> wrote:
          [...]
          > Hi Giovanni,
          >
          > Did you run "make configure" first?

          Hi,
          I have ran
          ./configure --prefix=/opt/io

          and it seems to work fine.
          I'should try to recompile it?
          Thank you!
        • Steve Dekorte
          ... Where did you run that command? Did you run it before you compiled or after? -- Steve
          Message 4 of 5 , May 2, 2004
          View Source
          • 0 Attachment
            On May 2, 2004, at 10:53 AM, giorgi_g wrote:
            > I have ran
            > ./configure --prefix=/opt/io
            >
            > and it seems to work fine.
            > I'should try to recompile it?

            Where did you run that command?
            Did you run it before you compiled or after?

            -- Steve
          • Giovanni Giorgi
            I run configure before make (as usual :) The true problem is the compilation error: in the module IoDesktop-2004-04-25/IoDesktop/Audio I got an error on
            Message 5 of 5 , May 3, 2004
            View Source
            • 0 Attachment
              I run configure before make (as usual :)
              The true problem is the compilation error:
              in the module
              IoDesktop-2004-04-25/IoDesktop/Audio

              I got an error on
              brhist.c:206: error: parse error before numeric constant
              brhist.c:207: warning: function declaration isn't a prototype
              brhist.c: In function `brhist_disp_line':
              brhist.c:215: error: `br_hist_TOT' undeclared (first use in this function)
              brhist.c:215: error: (Each undeclared identifier is reported only once
              brhist.c:215: error: for each function it appears in.)
              brhist.c:216: error: `br_hist_LR' undeclared (first use in this function)
              brhist.c:221: error: `frames' undeclared (first use in this function)
              brhist.c:244: error: `i' undeclared (first use in this function)
              make[3]: *** [brhist.o] Error 1

              Can I compile IoDesktop without the Audio support?

              On Sun, 2 May 2004, Steve Dekorte wrote:

              >
              > On May 2, 2004, at 10:53 AM, giorgi_g wrote:
              > > I have ran
              > > ./configure --prefix=/opt/io
              > >
              > > and it seems to work fine.
              > > I'should try to recompile it?
              >
              > Where did you run that command?
              > Did you run it before you compiled or after?
              >
              > -- Steve
              >
              >
              >
              >
              >
              > Yahoo! Groups Links
              >
              >
              >
              >
              >

              --
              // Giovanni Giorgi
              // http://www.siforge.org
              //
            Your message has been successfully submitted and would be delivered to recipients shortly.