Loading ...
Sorry, an error occurred while loading the content.

Re: Help! - can not load into FLASH

Expand Messages
  • garthpaine
    I have followed this thread and tried everything outlined. as soon as I go into Boot mode the load and run buttons become greyed out. If I just start up
    Message 1 of 9 , May 1, 2007
    • 0 Attachment
      I have followed this thread and tried everything outlined. as soon
      as I go into Boot mode the load and run buttons become greyed out.

      If I just start up normally (not in boot mode) all buttons are
      available - if I then select FLASH and hit Load, the LCD reads LOAD,
      but the communication fails and the dialog box reads - Unable to Sync

      I can load into RAM just fine. I have had the Demo program in FLash
      before and had a Ping tester in Flash, which seems not to be there
      now.

      I did run the "Clear Config" option that comes up when in boot mode
      after setting the baud rate and then realoaded the VM.

      The Bot is an Intellibrain 2
      Model 02 Rev 01
      Ser 0100020034

      The rocking between stop/start etc as described in the support email
      does not work for me.

      Help please

      Thanks,

      Garth


      --- In intellibrain@yahoogroups.com, "RidgeSoft" <rs1@...> wrote:
      >
      >
      > To wrap up this disucssion...
      >
      > It's tricky to download a program to the IntelliBrain controller
      if it
      > has a program loaded in flash that is (1) set to run automatically
      and
      > (2) takes control of the COM1 port. Here's a proceedure to
      download to
      > the board when its in this state:
      >
      > 1. Uncheck "Run automatically" and set the load target to
      > FLASH. 2. Switch the power on. 3. Hold down STOP 4.
      Hold
      > down START 5. Release STOP 6. Release START – you can do 3-
      6
      > easily by rolling 1 finger from STOP to START.
      > At this point you should see "RoboJDE" on the LCD. 7. Hold
      > down START 8. Quickly click the load button then release the
      START
      > button. 9. If you get "Board not responding" click okay,
      > switch power off and go to step 2. 10. If you get the
      > "IntelliBrain Download" dialog power the board off. 11. Hold
      > down STOP. 12. Switch power on. 13. Release STOP. 14.
      Click
      > Okay.
      >
      > RidgeSoft Support
      >
      >
      > --- In intellibrain@yahoogroups.com, "Don" <DCFrench@> wrote:
      > >
      > > I downloaded a program to flash for the first time and now I
      can't
      > > download a new version of the program! RoboJDE never sees the
      > > Intellibrain (Load is grayed out). My program is set to run
      > > automatically and grabs COM1 right off the bat which, when I was
      > > running in RAM seemed to force me to power off and back on
      before it
      > > would allow Load. So, I tried holding down Start when powering
      up,
      > > and the LCD displays:
      > >
      > > RoboJDE v1.5 2r1
      > > Ready - Flash
      > >
      > > but Load is still grayed out. I then tried pressing Stop and the
      > > display showed:
      > >
      > > IntelliBrain 2
      > > Boot: 9.6K
      > >
      > > I see in the manual that this is how you set the baud rate that
      the
      > > Intellibrain uses to communicate with the host computer so I
      press
      > > Stop several time until it is the same as it is in the JDE, 115K.
      > > Then I press Start and what do you know, the Load icon is un-
      grayed.
      > > So I click it and it begins to download my new program. But only
      for
      > > a few seconds because my program starts running and seizes the
      COM1
      > > port and I get an error message in the JDE saying:
      > >
      > > Board not responding
      > >
      > > Finally, I try changing the baud rate on both the JDE and the
      > > Intellibrain to 9600 to give it a better chance to overwrite my
      > > program before it grabs COM1, but alas, that doesn't help.
      > >
      > > So, now I am stumped. Please, Ridgesoft, tell me what do I have
      to
      > > do to reprogram my Intellibrain, because the program that is in
      flash
      > > now is not what I want to use for the rest of time.
      > >
    • RidgeSoft
      Garth, The discussion on this thread only applies to the following narrow situation: 1. The program already in the FLASH takes control of the COM1 port - ie,
      Message 2 of 9 , May 1, 2007
      • 0 Attachment
        Garth,

        The discussion on this thread only applies to the following narrow
        situation:

        1. The program already in the FLASH takes control of the COM1 port - ie,
        calls IntelliBrain.getCom1().

        2. The program in FLASH was built with the "Run automatically" item in
        the project's properties set - ie, the program starts running when you
        turn the power switch on.

        You do not need to use the special procedure discussed on this thread
        unless both of these conditions are met. If your situation is not this
        case you should follow the normal FLASH loading procedure.

        1. Turn the robot on.
        2. Set the load target (on the tool bar) to FLASH.
        3. Click the download button.
        4. When prompted put the robot into FLASH download mode (power off, back
        on, press STOP). Don't do this step until prompted to do it.

        RidgeSoft Support




        --- In intellibrain@yahoogroups.com, "garthpaine" <ga.paine@...> wrote:
        >
        > I have followed this thread and tried everything outlined. as soon
        > as I go into Boot mode the load and run buttons become greyed out.
        >
        > If I just start up normally (not in boot mode) all buttons are
        > available - if I then select FLASH and hit Load, the LCD reads LOAD,
        > but the communication fails and the dialog box reads - Unable to Sync
        >
        > I can load into RAM just fine. I have had the Demo program in FLash
        > before and had a Ping tester in Flash, which seems not to be there
        > now.
        >
        > I did run the "Clear Config" option that comes up when in boot mode
        > after setting the baud rate and then realoaded the VM.
        >
        > The Bot is an Intellibrain 2
        > Model 02 Rev 01
        > Ser 0100020034
        >
        > The rocking between stop/start etc as described in the support email
        > does not work for me.
        >
        > Help please
        >
        > Thanks,
        >
        > Garth
        >
        >
        > --- In intellibrain@yahoogroups.com, "RidgeSoft" rs1@ wrote:
        > >
        > >
        > > To wrap up this disucssion...
        > >
        > > It's tricky to download a program to the IntelliBrain controller
        > if it
        > > has a program loaded in flash that is (1) set to run automatically
        > and
        > > (2) takes control of the COM1 port. Here's a proceedure to
        > download to
        > > the board when its in this state:
        > >
        > > 1. Uncheck "Run automatically" and set the load target to
        > > FLASH. 2. Switch the power on. 3. Hold down STOP 4.
        > Hold
        > > down START 5. Release STOP 6. Release START – you can do 3-
        > 6
        > > easily by rolling 1 finger from STOP to START.
        > > At this point you should see "RoboJDE" on the LCD. 7. Hold
        > > down START 8. Quickly click the load button then release the
        > START
        > > button. 9. If you get "Board not responding" click okay,
        > > switch power off and go to step 2. 10. If you get the
        > > "IntelliBrain Download" dialog power the board off. 11. Hold
        > > down STOP. 12. Switch power on. 13. Release STOP. 14.
        > Click
        > > Okay.
        > >
        > > RidgeSoft Support
        > >
        > >
        > > --- In intellibrain@yahoogroups.com, "Don" <DCFrench@> wrote:
        > > >
        > > > I downloaded a program to flash for the first time and now I
        > can't
        > > > download a new version of the program! RoboJDE never sees the
        > > > Intellibrain (Load is grayed out). My program is set to run
        > > > automatically and grabs COM1 right off the bat which, when I was
        > > > running in RAM seemed to force me to power off and back on
        > before it
        > > > would allow Load. So, I tried holding down Start when powering
        > up,
        > > > and the LCD displays:
        > > >
        > > > RoboJDE v1.5 2r1
        > > > Ready - Flash
        > > >
        > > > but Load is still grayed out. I then tried pressing Stop and the
        > > > display showed:
        > > >
        > > > IntelliBrain 2
        > > > Boot: 9.6K
        > > >
        > > > I see in the manual that this is how you set the baud rate that
        > the
        > > > Intellibrain uses to communicate with the host computer so I
        > press
        > > > Stop several time until it is the same as it is in the JDE, 115K.
        > > > Then I press Start and what do you know, the Load icon is un-
        > grayed.
        > > > So I click it and it begins to download my new program. But only
        > for
        > > > a few seconds because my program starts running and seizes the
        > COM1
        > > > port and I get an error message in the JDE saying:
        > > >
        > > > Board not responding
        > > >
        > > > Finally, I try changing the baud rate on both the JDE and the
        > > > Intellibrain to 9600 to give it a better chance to overwrite my
        > > > program before it grabs COM1, but alas, that doesn't help.
        > > >
        > > > So, now I am stumped. Please, Ridgesoft, tell me what do I have
        > to
        > > > do to reprogram my Intellibrain, because the program that is in
        > flash
        > > > now is not what I want to use for the rest of time.
        > > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.