Loading ...
Sorry, an error occurred while loading the content.

Re: [intellibrain] Re: Help!

Expand Messages
  • Don French
    Sorry, this does not work for me. Let me step you through exactly what happens. After step 6a, I do see the message: RoboJDE v1.2.2r1 Ready - Flash and the
    Message 1 of 9 , Feb 14, 2007
    • 0 Attachment
      Sorry, this does not work for me.  Let me step you through exactly what happens.
       
      After step 6a, I do see the message:
       
      RoboJDE v1.2.2r1
      Ready - Flash
       
      and the Load icon is ungrayed.  Immediately upon clicking the Load button, my program in flash executes, a Load progress dialog window in the JDE, and withing a fraction of a second,a "Board not responding" message displays on top of the Load window.  I ignore the Board not responding message and turn the Intellibrain off and back on while holding down the Stop button, I get:
       
      Intellibrain 2
      Boot: 115.2K
       
      which is the same baud rate I have set in the JDE.  So, I press Start and get:
       
      RoboJDE v1.2.2r1
      Ready - Flash
       
      again.  The Board not responding message is still showing in the JDE, on top of the Load progress dialog.  I click OK on the "Board not responding" message and my program in Flash runs and both the "Board not responding" dialog and the Load dialog disappear, the Load button is grayed and we are back where we were when we began.  The download does not proceed, the old program remains in flash, and I cannot change it.
       
      This is basically the program in Flash, or an abbreviated version of it up to the point that failure occurs:
       
       
      import com.ridgesoft.intellibrain .IntelliBrain;
      import com.ridgesoft.io.*;
      import java.io.*;
      import javax.comm.UnsupportedCommOper ationException;

      public class IntelliBrainSerialToController {


             static InputStream serialIn;
             static OutputStream serialOut;
        
             public static void main(String[] args) {

              static Display lcd = IntelliBrain.getcdDisplay();
              static SerialPort com1= IntelliBrain.getCom1();

                     try {
                             com1.setSerialP ortParams(9600,
                                             javax.comm.SerialPort.DATABITS _8,
                                             javax.comm.SerialPort.STOPBITS _1,
                                             javax.comm.SerialPort.PARITY _NONE);
                     } catch (UnsupportedCommOperationExcep tion e1) {
                     }


                     try {
                             serialIn = com1.getInputSt ream();
                             serialOut = com1.getOutputS tream();
                     } catch (IOException e) {
                     }
                     lcd.printString(0,"Hello world");
                     delay_ms(20000);  // pause
                      while(true);
      }
      private static void delay_ms(int val){
       
          long time = System.currentTimeMillis();
          while (System.currentTimeMIllis() < (time + val)){}
      }
      }
       
      One thing that I just noticed is that I change the serial port to 9600 baud in the code and the JDE downloads at 115K.  So I just tried changing both the JDE and the board to 9600 with no improvement.

      -- Don French
       
       
      ----- Original Message -----
      From: RidgeSoft
      Sent: Tuesday, February 13, 2007 8:30 PM
      Subject: [intellibrain] Re: Help!


      Don,

      I just loaded a board with a program that grabs COM1 and was set to
      automatically run. The previous test I tried was without the COM1
      twist. I am able to get a new program to load to flash and clear the
      autorun setting. The trick is to get the controller to display the
      RoboJDE message. When it is at this point it should communicate with
      the RoboJDE GUI on the host. The load button is greyed when the RoboJDE
      GUI isn't able to communicate with the RoboJDE virtual machine on the
      IntelliBrain controller.

      Hopefully inserting one step will get you going:

      6a. Hold the START button down and switch power on. You should see
      "RoboJDE" on the LCD and the load button should be ungreyed.

      7. Click the load button. The controller will reset and start running
      your program again. Ignore this and continue with step 8. Also, note
      the prompt suggests two ways of entering flash loading mode. Use the
      method in step 8, which is the one that will ensure your program doesn't
      get a chance to run.

      Hopefully this will get you going again. This worked for me.

      If you still have trouble it might be your program is transmitting
      characters that get the loader into a bad state. I think this is
      unlikely. If the above doesn't work for you, modify step 8 to: switch
      power off, hold down START, switch power on (should bring up RoboJDE
      prompt), then press STOP to get to the IntelliBrain prompt. If that
      doesn't work, start over and try holding the START button down while you
      do step 7.

      RidgeSoft Support

      --- In intellibrain@ yahoogroups. com, Don French <DCFrench@.. .> wrote:
      >
      > You must have missed a step because after step 4, the robot is off and
      never turned back on before step 8 when you say to turn it off. And the
      Load button (there is no Build and Load button) is grayed out for step
      6, of course. So, I tried just turning it back on after step 5, and it
      immediately ran the program in flash (the one that uses COM1) and the
      Load button remains grayed out. So, I tried turning the robot off and
      turning it back on while holding the Start button this time. This time
      the Load button is not grayed out, but when I clicked it, I got a
      Intellibrain Download dialog telling me to start the robot while holding
      the Stop button, which I did, followed by closing the dialog box. This
      brought me to Downloading. .. only there was no progress on the progress
      bar and after a short while, I got a Unable to Synchronize message.
      Sigh!
      >
      > I started over and I always get the same thing as before. The only way
      I can get a usable Load button is to power up the robot with the start
      button pressed, but when I begin downloading my program in Flash starts
      within a second or two and I get a Board not responding message. Double
      sigh!
      >
      > It appears that downloading an autostart program that uses the COM 1
      port into Flash is a fatal design flaw in the product. At least nothing
      I have tried allows me to change the program. Do you have any other
      ideas?
      >
      > -- Don French
      >
      >
      > ----- Original Message -----
      > From: RidgeSoft
      > To: intellibrain@ yahoogroups. com
      > Sent: Tuesday, February 13, 2007 9:50 AM
      > Subject: [intellibrain] Re: Help!
      >
      >
      >
      > Don,
      >
      > Try the following:
      >
      > 1. Turn the robot off and disconnect the serial cable.
      >
      > 2. Close and restart RoboJDE.
      >
      > 3. Adjust the baud rate of the robot to match the setting in RoboJDE
      by
      > holding the STOP button down while turning power on. Press the STOP
      > button until you see the baud rate you want, then press START.
      >
      > 4. Turn the robot off and reconnect the serial cable.
      >
      > 5. Uncheck run automatically in your project's properties.
      >
      > 6. Set the load target drop down to flash.
      >
      > 7. Click the build and load button.
      >
      > 8. When prompted, switch the power off, hold the STOP button down
      while
      > switching power back on. The display should show "IntelliBrain"
      > followed by "Boot: " and the baud rate you set. If it shows a
      different
      > baud rate or the red LED is blinking rapidly, repeat this step.
      >
      > 9. Click Okay. The program should load to flash.
      >
      > 10. When prompted, press START and click Okay.
      >
      > RidgeSoft Support
      >
      > --- In intellibrain@ yahoogroups. com, "Don" DCFrench@ wrote:
      > >
      > > I downloaded a program to flash for the first time and now I can't
      > > download a new version of the program! RoboJDE never sees the
      > > Intellibrain (Load is grayed out). My program is set to run
      > > automatically and grabs COM1 right off the bat which, when I was
      > > running in RAM seemed to force me to power off and back on before it
      > > would allow Load. So, I tried holding down Start when powering up,
      > > and the LCD displays:
      > >
      > > RoboJDE v1.5 2r1
      > > Ready - Flash
      > >
      > > but Load is still grayed out. I then tried pressing Stop and the
      > > display showed:
      > >
      > > IntelliBrain 2
      > > Boot: 9.6K
      > >
      > > I see in the manual that this is how you set the baud rate that the
      > > Intellibrain uses to communicate with the host computer so I press
      > > Stop several time until it is the same as it is in the JDE, 115K.
      > > Then I press Start and what do you know, the Load icon is un-grayed.
      > > So I click it and it begins to download my new program. But only for
      > > a few seconds because my program starts running and seizes the COM1
      > > port and I get an error message in the JDE saying:
      > >
      > > Board not responding
      > >
      > > Finally, I try changing the baud rate on both the JDE and the
      > > Intellibrain to 9600 to give it a better chance to overwrite my
      > > program before it grabs COM1, but alas, that doesn't help.
      > >
      > > So, now I am stumped. Please, Ridgesoft, tell me what do I have to
      > > do to reprogram my Intellibrain, because the program that is in
      flash
      > > now is not what I want to use for the rest of time.
      > >
      >

    • RidgeSoft
      Don, Your description makes it sound as though it is attempting to load to RAM, not flash. Please make sure you have set the load target to flash (step 6).
      Message 2 of 9 , Feb 14, 2007
      • 0 Attachment
        Don,

        Your description makes it sound as though it is attempting to load to
        RAM, not flash. Please make sure you have set the load target to flash
        (step 6). Do both steps 6 and 6a. The fact that it is going right to
        the download progress bar without the reset-the-board prompt dialog
        displaying indicates the load target is set to RAM.

        RidgeSoft Support


        --- In intellibrain@yahoogroups.com, Don French <DCFrench@...> wrote:
        >
        > Sorry, this does not work for me. Let me step you through exactly what
        happens.
        >
        > After step 6a, I do see the message:
        >
        > RoboJDE v1.2.2r1
        > Ready - Flash
        >
        > and the Load icon is ungrayed. Immediately upon clicking the Load
        button, my program in flash executes, a Load progress dialog window in
        the JDE, and withing a fraction of a second,a "Board not responding"
        message displays on top of the Load window. I ignore the Board not
        responding message and turn the Intellibrain off and back on while
        holding down the Stop button, I get:
        >
        > Intellibrain 2
        > Boot: 115.2K
        >
        > which is the same baud rate I have set in the JDE. So, I press Start
        and get:
        >
        > RoboJDE v1.2.2r1
        > Ready - Flash
        >
        > again. The Board not responding message is still showing in the JDE,
        on top of the Load progress dialog. I click OK on the "Board not
        responding" message and my program in Flash runs and both the "Board not
        responding" dialog and the Load dialog disappear, the Load button is
        grayed and we are back where we were when we began. The download does
        not proceed, the old program remains in flash, and I cannot change it.
        >
        > This is basically the program in Flash, or an abbreviated version of
        it up to the point that failure occurs:
        >
        >
        > import com.ridgesoft.intellibrain.IntelliBrain;
        > import com.ridgesoft.io.*;
        > import java.io.*;
        > import javax.comm.UnsupportedCommOperationException;
        >
        > public class IntelliBrainSerialToController {
        >
        >
        > static InputStream serialIn;
        > static OutputStream serialOut;
        >
        > public static void main(String[] args) {
        >
        > static Display lcd = IntelliBrain.getcdDisplay();
        > static SerialPort com1= IntelliBrain.getCom1();
        >
        > try {
        > com1.setSerialPortParams(9600,
        > javax.comm.SerialPort.DATABITS_8,
        > javax.comm.SerialPort.STOPBITS_1,
        > javax.comm.SerialPort.PARITY_NONE);
        > } catch (UnsupportedCommOperationException e1) {
        > }
        >
        >
        > try {
        > serialIn = com1.getInputStream();
        > serialOut = com1.getOutputStream();
        > } catch (IOException e) {
        > }
        > lcd.printString(0,"Hello world");
        > delay_ms(20000); // pause
        > while(true);
        > }
        > private static void delay_ms(int val){
        >
        > long time = System.currentTimeMillis();
        > while (System.currentTimeMIllis() < (time + val)){}
        > }
        > }
        >
        > One thing that I just noticed is that I change the serial port to 9600
        baud in the code and the JDE downloads at 115K. So I just tried changing
        both the JDE and the board to 9600 with no improvement.
        >
        > -- Don French
        >
        >
        > ----- Original Message -----
        > From: RidgeSoft
        > To: intellibrain@yahoogroups.com
        > Sent: Tuesday, February 13, 2007 8:30 PM
        > Subject: [intellibrain] Re: Help!
        >
        >
        >
        > Don,
        >
        > I just loaded a board with a program that grabs COM1 and was set to
        > automatically run. The previous test I tried was without the COM1
        > twist. I am able to get a new program to load to flash and clear the
        > autorun setting. The trick is to get the controller to display the
        > RoboJDE message. When it is at this point it should communicate with
        > the RoboJDE GUI on the host. The load button is greyed when the
        RoboJDE
        > GUI isn't able to communicate with the RoboJDE virtual machine on the
        > IntelliBrain controller.
        >
        > Hopefully inserting one step will get you going:
        >
        > 6a. Hold the START button down and switch power on. You should see
        > "RoboJDE" on the LCD and the load button should be ungreyed.
        >
        > 7. Click the load button. The controller will reset and start running
        > your program again. Ignore this and continue with step 8. Also, note
        > the prompt suggests two ways of entering flash loading mode. Use the
        > method in step 8, which is the one that will ensure your program
        doesn't
        > get a chance to run.
        >
        > Hopefully this will get you going again. This worked for me.
        >
        > If you still have trouble it might be your program is transmitting
        > characters that get the loader into a bad state. I think this is
        > unlikely. If the above doesn't work for you, modify step 8 to: switch
        > power off, hold down START, switch power on (should bring up RoboJDE
        > prompt), then press STOP to get to the IntelliBrain prompt. If that
        > doesn't work, start over and try holding the START button down while
        you
        > do step 7.
        >
        > RidgeSoft Support
        >
        > --- In intellibrain@yahoogroups.com, Don French DCFrench@ wrote:
        > >
        > > You must have missed a step because after step 4, the robot is off
        and
        > never turned back on before step 8 when you say to turn it off. And
        the
        > Load button (there is no Build and Load button) is grayed out for step
        > 6, of course. So, I tried just turning it back on after step 5, and it
        > immediately ran the program in flash (the one that uses COM1) and the
        > Load button remains grayed out. So, I tried turning the robot off and
        > turning it back on while holding the Start button this time. This time
        > the Load button is not grayed out, but when I clicked it, I got a
        > Intellibrain Download dialog telling me to start the robot while
        holding
        > the Stop button, which I did, followed by closing the dialog box. This
        > brought me to Downloading... only there was no progress on the
        progress
        > bar and after a short while, I got a Unable to Synchronize message.
        > Sigh!
        > >
        > > I started over and I always get the same thing as before. The only
        way
        > I can get a usable Load button is to power up the robot with the start
        > button pressed, but when I begin downloading my program in Flash
        starts
        > within a second or two and I get a Board not responding message.
        Double
        > sigh!
        > >
        > > It appears that downloading an autostart program that uses the COM 1
        > port into Flash is a fatal design flaw in the product. At least
        nothing
        > I have tried allows me to change the program. Do you have any other
        > ideas?
        > >
        > > -- Don French
        > >
        > >
        > > ----- Original Message -----
        > > From: RidgeSoft
        > > To: intellibrain@yahoogroups.com
        > > Sent: Tuesday, February 13, 2007 9:50 AM
        > > Subject: [intellibrain] Re: Help!
        > >
        > >
        > >
        > > Don,
        > >
        > > Try the following:
        > >
        > > 1. Turn the robot off and disconnect the serial cable.
        > >
        > > 2. Close and restart RoboJDE.
        > >
        > > 3. Adjust the baud rate of the robot to match the setting in RoboJDE
        > by
        > > holding the STOP button down while turning power on. Press the STOP
        > > button until you see the baud rate you want, then press START.
        > >
        > > 4. Turn the robot off and reconnect the serial cable.
        > >
        > > 5. Uncheck run automatically in your project's properties.
        > >
        > > 6. Set the load target drop down to flash.
        > >
        > > 7. Click the build and load button.
        > >
        > > 8. When prompted, switch the power off, hold the STOP button down
        > while
        > > switching power back on. The display should show "IntelliBrain"
        > > followed by "Boot: " and the baud rate you set. If it shows a
        > different
        > > baud rate or the red LED is blinking rapidly, repeat this step.
        > >
        > > 9. Click Okay. The program should load to flash.
        > >
        > > 10. When prompted, press START and click Okay.
        > >
        > > RidgeSoft Support
        > >
        > > --- In intellibrain@yahoogroups.com, "Don" DCFrench@ wrote:
        > > >
        > > > I downloaded a program to flash for the first time and now I can't
        > > > download a new version of the program! RoboJDE never sees the
        > > > Intellibrain (Load is grayed out). My program is set to run
        > > > automatically and grabs COM1 right off the bat which, when I was
        > > > running in RAM seemed to force me to power off and back on before
        it
        > > > would allow Load. So, I tried holding down Start when powering up,
        > > > and the LCD displays:
        > > >
        > > > RoboJDE v1.5 2r1
        > > > Ready - Flash
        > > >
        > > > but Load is still grayed out. I then tried pressing Stop and the
        > > > display showed:
        > > >
        > > > IntelliBrain 2
        > > > Boot: 9.6K
        > > >
        > > > I see in the manual that this is how you set the baud rate that
        the
        > > > Intellibrain uses to communicate with the host computer so I press
        > > > Stop several time until it is the same as it is in the JDE, 115K.
        > > > Then I press Start and what do you know, the Load icon is
        un-grayed.
        > > > So I click it and it begins to download my new program. But only
        for
        > > > a few seconds because my program starts running and seizes the
        COM1
        > > > port and I get an error message in the JDE saying:
        > > >
        > > > Board not responding
        > > >
        > > > Finally, I try changing the baud rate on both the JDE and the
        > > > Intellibrain to 9600 to give it a better chance to overwrite my
        > > > program before it grabs COM1, but alas, that doesn't help.
        > > >
        > > > So, now I am stumped. Please, Ridgesoft, tell me what do I have to
        > > > do to reprogram my Intellibrain, because the program that is in
        > flash
        > > > now is not what I want to use for the rest of time.
        > > >
        > >
        >
      • RidgeSoft
        To wrap up this disucssion... It s tricky to download a program to the IntelliBrain controller if it has a program loaded in flash that is (1) set to run
        Message 3 of 9 , Mar 15, 2007
        • 0 Attachment

          To wrap up this disucssion...

          It's tricky to download a program to the IntelliBrain controller if it has a program loaded in flash that is (1) set to run automatically and (2) takes control of the COM1 port.   Here's a proceedure to download to the board when its in this state:

          1. Uncheck "Run automatically" and set the load target to FLASH.
          2. Switch the power on.
          3. Hold down STOP
          4. Hold down START
          5. Release STOP
          6. Release START – you can do 3-6 easily by rolling 1 finger from STOP to START.
            At this point you should see "RoboJDE" on the LCD.
          7. Hold down START
          8. Quickly click the load button then release the START button.
          9. If you get "Board not responding" click okay, switch power off and go to step 2.
          10. If you get the "IntelliBrain Download" dialog power the board off.
          11. Hold down STOP.
          12. Switch power on.
          13. Release STOP.
          14. Click Okay.

          RidgeSoft Support


          --- In intellibrain@yahoogroups.com, "Don" <DCFrench@...> wrote:
          >
          > I downloaded a program to flash for the first time and now I can't
          > download a new version of the program! RoboJDE never sees the
          > Intellibrain (Load is grayed out). My program is set to run
          > automatically and grabs COM1 right off the bat which, when I was
          > running in RAM seemed to force me to power off and back on before it
          > would allow Load. So, I tried holding down Start when powering up,
          > and the LCD displays:
          >
          > RoboJDE v1.5 2r1
          > Ready - Flash
          >
          > but Load is still grayed out. I then tried pressing Stop and the
          > display showed:
          >
          > IntelliBrain 2
          > Boot: 9.6K
          >
          > I see in the manual that this is how you set the baud rate that the
          > Intellibrain uses to communicate with the host computer so I press
          > Stop several time until it is the same as it is in the JDE, 115K.
          > Then I press Start and what do you know, the Load icon is un-grayed.
          > So I click it and it begins to download my new program. But only for
          > a few seconds because my program starts running and seizes the COM1
          > port and I get an error message in the JDE saying:
          >
          > Board not responding
          >
          > Finally, I try changing the baud rate on both the JDE and the
          > Intellibrain to 9600 to give it a better chance to overwrite my
          > program before it grabs COM1, but alas, that doesn't help.
          >
          > So, now I am stumped. Please, Ridgesoft, tell me what do I have to
          > do to reprogram my Intellibrain, because the program that is in flash
          > now is not what I want to use for the rest of time.
          >

        • garthpaine
          I have followed this thread and tried everything outlined. as soon as I go into Boot mode the load and run buttons become greyed out. If I just start up
          Message 4 of 9 , May 1 4:27 AM
          • 0 Attachment
            I have followed this thread and tried everything outlined. as soon
            as I go into Boot mode the load and run buttons become greyed out.

            If I just start up normally (not in boot mode) all buttons are
            available - if I then select FLASH and hit Load, the LCD reads LOAD,
            but the communication fails and the dialog box reads - Unable to Sync

            I can load into RAM just fine. I have had the Demo program in FLash
            before and had a Ping tester in Flash, which seems not to be there
            now.

            I did run the "Clear Config" option that comes up when in boot mode
            after setting the baud rate and then realoaded the VM.

            The Bot is an Intellibrain 2
            Model 02 Rev 01
            Ser 0100020034

            The rocking between stop/start etc as described in the support email
            does not work for me.

            Help please

            Thanks,

            Garth


            --- In intellibrain@yahoogroups.com, "RidgeSoft" <rs1@...> wrote:
            >
            >
            > To wrap up this disucssion...
            >
            > It's tricky to download a program to the IntelliBrain controller
            if it
            > has a program loaded in flash that is (1) set to run automatically
            and
            > (2) takes control of the COM1 port. Here's a proceedure to
            download to
            > the board when its in this state:
            >
            > 1. Uncheck "Run automatically" and set the load target to
            > FLASH. 2. Switch the power on. 3. Hold down STOP 4.
            Hold
            > down START 5. Release STOP 6. Release START – you can do 3-
            6
            > easily by rolling 1 finger from STOP to START.
            > At this point you should see "RoboJDE" on the LCD. 7. Hold
            > down START 8. Quickly click the load button then release the
            START
            > button. 9. If you get "Board not responding" click okay,
            > switch power off and go to step 2. 10. If you get the
            > "IntelliBrain Download" dialog power the board off. 11. Hold
            > down STOP. 12. Switch power on. 13. Release STOP. 14.
            Click
            > Okay.
            >
            > RidgeSoft Support
            >
            >
            > --- In intellibrain@yahoogroups.com, "Don" <DCFrench@> wrote:
            > >
            > > I downloaded a program to flash for the first time and now I
            can't
            > > download a new version of the program! RoboJDE never sees the
            > > Intellibrain (Load is grayed out). My program is set to run
            > > automatically and grabs COM1 right off the bat which, when I was
            > > running in RAM seemed to force me to power off and back on
            before it
            > > would allow Load. So, I tried holding down Start when powering
            up,
            > > and the LCD displays:
            > >
            > > RoboJDE v1.5 2r1
            > > Ready - Flash
            > >
            > > but Load is still grayed out. I then tried pressing Stop and the
            > > display showed:
            > >
            > > IntelliBrain 2
            > > Boot: 9.6K
            > >
            > > I see in the manual that this is how you set the baud rate that
            the
            > > Intellibrain uses to communicate with the host computer so I
            press
            > > Stop several time until it is the same as it is in the JDE, 115K.
            > > Then I press Start and what do you know, the Load icon is un-
            grayed.
            > > So I click it and it begins to download my new program. But only
            for
            > > a few seconds because my program starts running and seizes the
            COM1
            > > port and I get an error message in the JDE saying:
            > >
            > > Board not responding
            > >
            > > Finally, I try changing the baud rate on both the JDE and the
            > > Intellibrain to 9600 to give it a better chance to overwrite my
            > > program before it grabs COM1, but alas, that doesn't help.
            > >
            > > So, now I am stumped. Please, Ridgesoft, tell me what do I have
            to
            > > do to reprogram my Intellibrain, because the program that is in
            flash
            > > now is not what I want to use for the rest of time.
            > >
          • RidgeSoft
            Garth, The discussion on this thread only applies to the following narrow situation: 1. The program already in the FLASH takes control of the COM1 port - ie,
            Message 5 of 9 , May 1 5:24 AM
            • 0 Attachment
              Garth,

              The discussion on this thread only applies to the following narrow
              situation:

              1. The program already in the FLASH takes control of the COM1 port - ie,
              calls IntelliBrain.getCom1().

              2. The program in FLASH was built with the "Run automatically" item in
              the project's properties set - ie, the program starts running when you
              turn the power switch on.

              You do not need to use the special procedure discussed on this thread
              unless both of these conditions are met. If your situation is not this
              case you should follow the normal FLASH loading procedure.

              1. Turn the robot on.
              2. Set the load target (on the tool bar) to FLASH.
              3. Click the download button.
              4. When prompted put the robot into FLASH download mode (power off, back
              on, press STOP). Don't do this step until prompted to do it.

              RidgeSoft Support




              --- In intellibrain@yahoogroups.com, "garthpaine" <ga.paine@...> wrote:
              >
              > I have followed this thread and tried everything outlined. as soon
              > as I go into Boot mode the load and run buttons become greyed out.
              >
              > If I just start up normally (not in boot mode) all buttons are
              > available - if I then select FLASH and hit Load, the LCD reads LOAD,
              > but the communication fails and the dialog box reads - Unable to Sync
              >
              > I can load into RAM just fine. I have had the Demo program in FLash
              > before and had a Ping tester in Flash, which seems not to be there
              > now.
              >
              > I did run the "Clear Config" option that comes up when in boot mode
              > after setting the baud rate and then realoaded the VM.
              >
              > The Bot is an Intellibrain 2
              > Model 02 Rev 01
              > Ser 0100020034
              >
              > The rocking between stop/start etc as described in the support email
              > does not work for me.
              >
              > Help please
              >
              > Thanks,
              >
              > Garth
              >
              >
              > --- In intellibrain@yahoogroups.com, "RidgeSoft" rs1@ wrote:
              > >
              > >
              > > To wrap up this disucssion...
              > >
              > > It's tricky to download a program to the IntelliBrain controller
              > if it
              > > has a program loaded in flash that is (1) set to run automatically
              > and
              > > (2) takes control of the COM1 port. Here's a proceedure to
              > download to
              > > the board when its in this state:
              > >
              > > 1. Uncheck "Run automatically" and set the load target to
              > > FLASH. 2. Switch the power on. 3. Hold down STOP 4.
              > Hold
              > > down START 5. Release STOP 6. Release START – you can do 3-
              > 6
              > > easily by rolling 1 finger from STOP to START.
              > > At this point you should see "RoboJDE" on the LCD. 7. Hold
              > > down START 8. Quickly click the load button then release the
              > START
              > > button. 9. If you get "Board not responding" click okay,
              > > switch power off and go to step 2. 10. If you get the
              > > "IntelliBrain Download" dialog power the board off. 11. Hold
              > > down STOP. 12. Switch power on. 13. Release STOP. 14.
              > Click
              > > Okay.
              > >
              > > RidgeSoft Support
              > >
              > >
              > > --- In intellibrain@yahoogroups.com, "Don" <DCFrench@> wrote:
              > > >
              > > > I downloaded a program to flash for the first time and now I
              > can't
              > > > download a new version of the program! RoboJDE never sees the
              > > > Intellibrain (Load is grayed out). My program is set to run
              > > > automatically and grabs COM1 right off the bat which, when I was
              > > > running in RAM seemed to force me to power off and back on
              > before it
              > > > would allow Load. So, I tried holding down Start when powering
              > up,
              > > > and the LCD displays:
              > > >
              > > > RoboJDE v1.5 2r1
              > > > Ready - Flash
              > > >
              > > > but Load is still grayed out. I then tried pressing Stop and the
              > > > display showed:
              > > >
              > > > IntelliBrain 2
              > > > Boot: 9.6K
              > > >
              > > > I see in the manual that this is how you set the baud rate that
              > the
              > > > Intellibrain uses to communicate with the host computer so I
              > press
              > > > Stop several time until it is the same as it is in the JDE, 115K.
              > > > Then I press Start and what do you know, the Load icon is un-
              > grayed.
              > > > So I click it and it begins to download my new program. But only
              > for
              > > > a few seconds because my program starts running and seizes the
              > COM1
              > > > port and I get an error message in the JDE saying:
              > > >
              > > > Board not responding
              > > >
              > > > Finally, I try changing the baud rate on both the JDE and the
              > > > Intellibrain to 9600 to give it a better chance to overwrite my
              > > > program before it grabs COM1, but alas, that doesn't help.
              > > >
              > > > So, now I am stumped. Please, Ridgesoft, tell me what do I have
              > to
              > > > do to reprogram my Intellibrain, because the program that is in
              > flash
              > > > now is not what I want to use for the rest of time.
              > > >
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.