Loading ...
Sorry, an error occurred while loading the content.
 

Re: unable to remote login

Expand Messages
  • joint_strike_force <joint_strike_force@y
    Hi, This should pretty much explain the situation.. bash-2.04# ps -ef | grep sshd root 1157 1 0 Jan03 ? 00:00:00 /usr/sbin/sshd bash-2.04#
    Message 1 of 9 , Jan 3, 2003
      Hi,

      This should pretty much explain the situation..

      bash-2.04# ps -ef | grep sshd
      root 1157 1 0 Jan03 ? 00:00:00 /usr/sbin/sshd

      bash-2.04# ipchains -L
      Chain input (policy ACCEPT):
      Chain forward (policy ACCEPT):
      Chain output (policy ACCEPT):

      bash-2.04# iptables -L
      iptables v1.1.1: can't initialize iptables table `filter': iptables
      who? (do you need to insmod?)
      Perhaps iptables or your kernel needs to be upgraded.

      bash-2.04# service sshd status
      sshd (pid 1157) is running...

      bash-2.04# ssh -l kmaddile sitescape
      The authenticity of host 'sitescape (127.0.0.1)' can't be
      established.
      RSA key fingerprint is
      78:cb:78:6d:fb:21:09:ed:8b:d0:13:ed:c8:31:a4:4b.
      Are you sure you want to continue connecting (yes/no)? yes
      Warning: Permanently added 'sitescape' (RSA) to the list of known
      hosts.
      kmaddile@sitescape's password:
      Permission denied, please try again.
      kmaddile@sitescape's password:
      Permission denied, please try again.
      kmaddile@sitescape's password:
      Permission denied (publickey,password,keyboard-interactive).
      bash-2.04#

      Thanks.






      --- In ilughyd@yahoogroups.com, phani@a... wrote:
      > ssh in the system itself and check it out If it is working fine
      Then
      > check the ipchains (i think u are using redhat 7.0 )
      >
      > If ssh is not working locally also acheck the ssh server conf file
      >
      >
      >
      > On Fri, 3 Jan 2003, joint_strike_force <joint_strike_force@y...>
      wrote:
      >
      > > Hi,
      > >    Thanks  Mr. Phani and Mr.Singh..
      > >    Telnet is now working but I am still not able use ssh.
      > >
      > >    I restarted sshd and checked with netstat. SSH is running on
      > > default 22 port and listening.
      > >
      > > Is there anything else i can try?
      > >
      > > Thanks.
      > >   
      > >   
      > >
      > >
      > > --- In ilughyd@yahoogroups.com, phani@a... wrote:
      > > > Check whether ur ssh server is on U are on RH so type
      > > > service sshd status
      > > > If it is not on start the service
      > > > If u wanna telnet to be on
      > > > chkconfig telnet on
      > > > service xinetd restart
      > > >
      > > >
      > > >
      > > > On Fri, 3 Jan 2003, joint_strike_force
      <joint_strike_force@y...>
      > > wrote:
      > > >
      > > > > Hey,
      > > > >
      > > > >     I recently got my hand on a new linux server (RH 7.0). I
      am
      > > > > unable to remote login using telnet or ssh.
      > > > >
      > > > > I have checked the following.
      > > > >
      > > > > 1. SSH daemon is listening on default port(tried with
      netstat)
      > > > > 2. No IP tables/IP chains
      > > > > 3. I am able to login from console
      > > > > 4. Server directly connected to internet (right now pretty
      > > insecure
      > > > > but will start building some walls soon)
      > > > > 5. oh.. also checked to c if hosts.deny file exists.. but it
      > > doesnt
      > > > > seem to.
      > > > >
      > > > > Am I missing something obvious??
      > > > >
      > > > > Thanks for any help in advance.
      > > > >
      > > > >
      > > > >
      > > > >
      > > > >
      > > > >
      > > > >
      > > > >
      > > > > Yahoo! Groups Sponsor
      > > > > ADVERTISEMENT
      > > > >
      > > > > -----------------------------------------------
      > > > >        Next Meeting 25th Jan 2003, 5PM
      > > > >           at Satyam Learning Center
      > > > >       Our Website: http://ilug-hyd.org.in
      > > > > -----------------------------------------------
      > > > >
      > > > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
      > > Service.
      > > > >
      > > >
      > > > --
      > >
      > >
      > > Yahoo! Groups Sponsor
      > > ADVERTISEMENT
      > >
      > > -----------------------------------------------
      > >        Next Meeting 25th Jan 2003, 5PM
      > >           at Satyam Learning Center
      > >       Our Website: http://ilug-hyd.org.in
      > > -----------------------------------------------
      > >
      > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
      Service.
      > >
      >
      > --
    • phani@aravaconsultancy.com
      Check out the auth in the /etc/ssh/sshd_config I think the problem is there in the file Might be the keys are enabled and u dont have the key check it out ...
      Message 2 of 9 , Jan 3, 2003
        Check out the auth in the /etc/ssh/sshd_config
        I think the problem is there in the file

        Might be the keys are enabled and u dont have the key check it out



        On Sat, 4 Jan 2003, joint_strike_force <joint_strike_force@...> wrote:

        > Hi,
        >
        > This should pretty much explain the situation..
        >
        > bash-2.04# ps -ef | grep sshd
        > root      1157     1  0 Jan03 ?        00:00:00 /usr/sbin/sshd
        >
        > bash-2.04# ipchains -L
        > Chain input (policy ACCEPT):
        > Chain forward (policy ACCEPT):
        > Chain output (policy ACCEPT):
        >
        > bash-2.04# iptables -L
        > iptables v1.1.1: can't initialize iptables table `filter': iptables
        > who? (do you need to insmod?)
        > Perhaps iptables or your kernel needs to be upgraded.
        >
        > bash-2.04# service sshd status
        > sshd (pid 1157) is running...
        >
        > bash-2.04# ssh -l kmaddile sitescape
        > The authenticity of host 'sitescape (127.0.0.1)' can't be
        > established.
        > RSA key fingerprint is
        > 78:cb:78:6d:fb:21:09:ed:8b:d0:13:ed:c8:31:a4:4b.
        > Are you sure you want to continue connecting (yes/no)? yes
        > Warning: Permanently added 'sitescape' (RSA) to the list of known
        > hosts.
        > kmaddile@sitescape's password:
        > Permission denied, please try again.
        > kmaddile@sitescape's password:
        > Permission denied, please try again.
        > kmaddile@sitescape's password:
        > Permission denied (publickey,password,keyboard-interactive).
        > bash-2.04#
        >
        > Thanks.
        >
        >
        >
        >
        >
        >
        > --- In ilughyd@yahoogroups.com, phani@a... wrote:
        > > ssh in the system itself and check it out If it  is working fine
        > Then
        > > check the ipchains (i think u are using redhat 7.0 )
        > >
        > > If ssh is not working locally also acheck the ssh server conf file
        > >
        > >
        > >
        > > On Fri, 3 Jan 2003, joint_strike_force <joint_strike_force@y...>
        > wrote:
        > >
        > > > Hi,
        > > >    Thanks  Mr. Phani and Mr.Singh..
        > > >    Telnet is now working but I am still not able use ssh.
        > > >
        > > >    I restarted sshd and checked with netstat. SSH is running on
        > > > default 22 port and listening.
        > > >
        > > > Is there anything else i can try?
        > > >
        > > > Thanks.
        > > >   
        > > >   
        > > >
        > > >
        > > > --- In ilughyd@yahoogroups.com, phani@a... wrote:
        > > > > Check whether ur ssh server is on U are on RH so type
        > > > > service sshd status
        > > > > If it is not on start the service
        > > > > If u wanna telnet to be on
        > > > > chkconfig telnet on
        > > > > service xinetd restart
        > > > >
        > > > >
        > > > >
        > > > > On Fri, 3 Jan 2003, joint_strike_force
        > <joint_strike_force@y...>
        > > > wrote:
        > > > >
        > > > > > Hey,
        > > > > >
        > > > > >     I recently got my hand on a new linux server (RH 7.0). I
        > am
        > > > > > unable to remote login using telnet or ssh.
        > > > > >
        > > > > > I have checked the following.
        > > > > >
        > > > > > 1. SSH daemon is listening on default port(tried with
        > netstat)
        > > > > > 2. No IP tables/IP chains
        > > > > > 3. I am able to login from console
        > > > > > 4. Server directly connected to internet (right now pretty
        > > > insecure
        > > > > > but will start building some walls soon)
        > > > > > 5. oh.. also checked to c if hosts.deny file exists.. but it
        > > > doesnt
        > > > > > seem to.
        > > > > >
        > > > > > Am I missing something obvious??
        > > > > >
        > > > > > Thanks for any help in advance.
        > > > > >
        > > > > >
        > > > > >
        > > > > >
        > > > > >
        > > > > >
        > > > > >
        > > > > >
        > > > > > Yahoo! Groups Sponsor
        > > > > > ADVERTISEMENT
        > > > > >
        > > > > > -----------------------------------------------
        > > > > >        Next Meeting 25th Jan 2003, 5PM
        > > > > >           at Satyam Learning Center
        > > > > >       Our Website: http://ilug-hyd.org.in
        > > > > > -----------------------------------------------
        > > > > >
        > > > > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
        > > > Service.
        > > > > >
        > > > >
        > > > > --
        > > >
        > > >
        > > > Yahoo! Groups Sponsor
        > > > ADVERTISEMENT
        > > >
        > > > -----------------------------------------------
        > > >        Next Meeting 25th Jan 2003, 5PM
        > > >           at Satyam Learning Center
        > > >       Our Website: http://ilug-hyd.org.in
        > > > -----------------------------------------------
        > > >
        > > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
        > Service.
        > > >
        > >
        > > --
        >
        >
        > Yahoo! Groups Sponsor
        > ADVERTISEMENT
        >
        > -----------------------------------------------
        >        Next Meeting 25th Jan 2003, 5PM
        >           at Satyam Learning Center
        >       Our Website: http://ilug-hyd.org.in
        > -----------------------------------------------
        >
        > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        >

        --
      • joint_strike_force <joint_strike_force@y
        Didnt quite understand what you said. I have included the sshd_config file. Could you please tell me if there is anything wrong with it. Thank you for your
        Message 3 of 9 , Jan 4, 2003
          Didnt quite understand what you said. I have included the
          sshd_config file. Could you please tell me if there is anything
          wrong with it.

          Thank you for your help.

          -----------------------

          # This is ssh client systemwide configuration file. This file
          provides
          # defaults for users, and the values can be changed in per-user
          configuration
          # files or on the command line.

          # Configuration data is parsed as follows:
          # 1. command line options
          # 2. user-specific file
          # 3. system-wide file
          # Any configuration value is only changed the first time it is set.
          # Thus, host-specific definitions should be at the beginning of the
          # configuration file, and defaults at the end.

          # Site-wide defaults for various options

          # Host *
          # ForwardAgent yes
          # ForwardX11 yes
          # RhostsAuthentication yes
          # RhostsRSAAuthentication yes
          # RSAAuthentication yes
          # PasswordAuthentication yes
          # FallBackToRsh no
          # UseRsh no
          # BatchMode no
          # CheckHostIP yes
          # StrictHostKeyChecking no
          # IdentityFile ~/.ssh/identity
          # Port 22
          # Protocol 2,1
          # Cipher 3des
          # EscapeChar ~

          # Be paranoid by default
          Host *
          ForwardAgent no
          ForwardX11 yes
          FallBackToRsh no
          Protocol 2,1
          -----------------------------------

          --- In ilughyd@yahoogroups.com, phani@a... wrote:
          > Check out the auth in the /etc/ssh/sshd_config
          > I think the problem is there in the file
          >
          > Might be the keys are enabled and u dont have the key check it out
          >
          >
          >
          > On Sat, 4 Jan 2003, joint_strike_force <joint_strike_force@y...>
          wrote:
          >
          > > Hi,
          > >
          > > This should pretty much explain the situation..
          > >
          > > bash-2.04# ps -ef | grep sshd
          > > root      1157     1  0 Jan03 ?        00:00:00 /usr/sbin/sshd
          > >
          > > bash-2.04# ipchains -L
          > > Chain input (policy ACCEPT):
          > > Chain forward (policy ACCEPT):
          > > Chain output (policy ACCEPT):
          > >
          > > bash-2.04# iptables -L
          > > iptables v1.1.1: can't initialize iptables table `filter':
          iptables
          > > who? (do you need to insmod?)
          > > Perhaps iptables or your kernel needs to be upgraded.
          > >
          > > bash-2.04# service sshd status
          > > sshd (pid 1157) is running...
          > >
          > > bash-2.04# ssh -l kmaddile sitescape
          > > The authenticity of host 'sitescape (127.0.0.1)' can't be
          > > established.
          > > RSA key fingerprint is
          > > 78:cb:78:6d:fb:21:09:ed:8b:d0:13:ed:c8:31:a4:4b.
          > > Are you sure you want to continue connecting (yes/no)? yes
          > > Warning: Permanently added 'sitescape' (RSA) to the list of known
          > > hosts.
          > > kmaddile@sitescape's password:
          > > Permission denied, please try again.
          > > kmaddile@sitescape's password:
          > > Permission denied, please try again.
          > > kmaddile@sitescape's password:
          > > Permission denied (publickey,password,keyboard-interactive).
          > > bash-2.04#
          > >
          > > Thanks.
          > >
          > >
          > >
          > >
          > >
          > >
          > > --- In ilughyd@yahoogroups.com, phani@a... wrote:
          > > > ssh in the system itself and check it out If it  is working
          fine
          > > Then
          > > > check the ipchains (i think u are using redhat 7.0 )
          > > >
          > > > If ssh is not working locally also acheck the ssh server conf
          file
          > > >
          > > >
          > > >
          > > > On Fri, 3 Jan 2003, joint_strike_force
          <joint_strike_force@y...>
          > > wrote:
          > > >
          > > > > Hi,
          > > > >    Thanks  Mr. Phani and Mr.Singh..
          > > > >    Telnet is now working but I am still not able use ssh.
          > > > >
          > > > >    I restarted sshd and checked with netstat. SSH is running
          on
          > > > > default 22 port and listening.
          > > > >
          > > > > Is there anything else i can try?
          > > > >
          > > > > Thanks.
          > > > >   
          > > > >   
          > > > >
          > > > >
          > > > > --- In ilughyd@yahoogroups.com, phani@a... wrote:
          > > > > > Check whether ur ssh server is on U are on RH so type
          > > > > > service sshd status
          > > > > > If it is not on start the service
          > > > > > If u wanna telnet to be on
          > > > > > chkconfig telnet on
          > > > > > service xinetd restart
          > > > > >
          > > > > >
          > > > > >
          > > > > > On Fri, 3 Jan 2003, joint_strike_force
          > > <joint_strike_force@y...>
          > > > > wrote:
          > > > > >
          > > > > > > Hey,
          > > > > > >
          > > > > > >     I recently got my hand on a new linux server (RH
          7.0). I
          > > am
          > > > > > > unable to remote login using telnet or ssh.
          > > > > > >
          > > > > > > I have checked the following.
          > > > > > >
          > > > > > > 1. SSH daemon is listening on default port(tried with
          > > netstat)
          > > > > > > 2. No IP tables/IP chains
          > > > > > > 3. I am able to login from console
          > > > > > > 4. Server directly connected to internet (right now
          pretty
          > > > > insecure
          > > > > > > but will start building some walls soon)
          > > > > > > 5. oh.. also checked to c if hosts.deny file exists..
          but it
          > > > > doesnt
          > > > > > > seem to.
          > > > > > >
          > > > > > > Am I missing something obvious??
          > > > > > >
          > > > > > > Thanks for any help in advance.
          > > > > > >
          > > > > > >
          > > > > > >
          > > > > > >
          > > > > > >
          > > > > > >
          > > > > > >
          > > > > > >
          > > > > > > Yahoo! Groups Sponsor
          > > > > > > ADVERTISEMENT
          > > > > > >
          > > > > > > -----------------------------------------------
          > > > > > >        Next Meeting 25th Jan 2003, 5PM
          > > > > > >           at Satyam Learning Center
          > > > > > >       Our Website: http://ilug-hyd.org.in
          > > > > > > -----------------------------------------------
          > > > > > >
          > > > > > > Your use of Yahoo! Groups is subject to the Yahoo! Terms
          of
          > > > > Service.
          > > > > > >
          > > > > >
          > > > > > --
          > > > >
          > > > >
          > > > > Yahoo! Groups Sponsor
          > > > > ADVERTISEMENT
          > > > >
          > > > > -----------------------------------------------
          > > > >        Next Meeting 25th Jan 2003, 5PM
          > > > >           at Satyam Learning Center
          > > > >       Our Website: http://ilug-hyd.org.in
          > > > > -----------------------------------------------
          > > > >
          > > > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          > > Service.
          > > > >
          > > >
          > > > --
          > >
          > >
          > > Yahoo! Groups Sponsor
          > > ADVERTISEMENT
          > >
          > > -----------------------------------------------
          > >        Next Meeting 25th Jan 2003, 5PM
          > >           at Satyam Learning Center
          > >       Our Website: http://ilug-hyd.org.in
          > > -----------------------------------------------
          > >
          > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          Service.
          > >
          >
          > --
        • Raghuram Vijapurapu
          ... I think all you would require to do is disable the firewall first and then give it a try, if this is working fine, then its a boom for you! I supp ose that
          Message 4 of 9 , Jan 4, 2003
            joint_strike_force wrote:

            >Didnt quite understand what you said. I have included the
            >sshd_config file. Could you please tell me if there is anything
            >wrong with it.
            >
            >Thank you for your help.
            >
            >
            >

            I think all you would require to do is disable the firewall first and
            then give it a try, if this is working fine, then its a boom for you!

            I supp'ose that the firewall is restricting access to the port. A better
            way to give it a try is to telnet to the port from outside and check it out.

            Ram.

            >-----------------------
            >
            ># This is ssh client systemwide configuration file. This file
            >provides
            ># defaults for users, and the values can be changed in per-user
            >configuration
            ># files or on the command line.
            >
            ># Configuration data is parsed as follows:
            ># 1. command line options
            ># 2. user-specific file
            ># 3. system-wide file
            ># Any configuration value is only changed the first time it is set.
            ># Thus, host-specific definitions should be at the beginning of the
            ># configuration file, and defaults at the end.
            >
            ># Site-wide defaults for various options
            >
            ># Host *
            ># ForwardAgent yes
            ># ForwardX11 yes
            ># RhostsAuthentication yes
            ># RhostsRSAAuthentication yes
            ># RSAAuthentication yes
            ># PasswordAuthentication yes
            ># FallBackToRsh no
            ># UseRsh no
            ># BatchMode no
            ># CheckHostIP yes
            ># StrictHostKeyChecking no
            ># IdentityFile ~/.ssh/identity
            ># Port 22
            ># Protocol 2,1
            ># Cipher 3des
            ># EscapeChar ~
            >
            ># Be paranoid by default
            >Host *
            > ForwardAgent no
            > ForwardX11 yes
            > FallBackToRsh no
            > Protocol 2,1
            >-----------------------------------
            >
            >--- In ilughyd@yahoogroups.com, phani@a... wrote:
            >
            >
            >>Check out the auth in the /etc/ssh/sshd_config
            >>I think the problem is there in the file
            >>
            >>Might be the keys are enabled and u dont have the key check it out
            >>
            >>
            >>
            >>On Sat, 4 Jan 2003, joint_strike_force <joint_strike_force@y...>
            >>
            >>
            >wrote:
            >
            >
            >>>Hi,
            >>>
            >>>This should pretty much explain the situation..
            >>>
            >>>bash-2.04# ps -ef | grep sshd
            >>>root 1157 1 0 Jan03 ? 00:00:00 /usr/sbin/sshd
            >>>
            >>>bash-2.04# ipchains -L
            >>>Chain input (policy ACCEPT):
            >>>Chain forward (policy ACCEPT):
            >>>Chain output (policy ACCEPT):
            >>>
            >>>bash-2.04# iptables -L
            >>>iptables v1.1.1: can't initialize iptables table `filter':
            >>>
            >>>
            >iptables
            >
            >
            >>>who? (do you need to insmod?)
            >>>Perhaps iptables or your kernel needs to be upgraded.
            >>>
            >>>bash-2.04# service sshd status
            >>>sshd (pid 1157) is running...
            >>>
            >>>bash-2.04# ssh -l kmaddile sitescape
            >>>The authenticity of host 'sitescape (127.0.0.1)' can't be
            >>>established.
            >>>RSA key fingerprint is
            >>>78:cb:78:6d:fb:21:09:ed:8b:d0:13:ed:c8:31:a4:4b.
            >>>Are you sure you want to continue connecting (yes/no)? yes
            >>>Warning: Permanently added 'sitescape' (RSA) to the list of known
            >>>hosts.
            >>>kmaddile@sitescape's password:
            >>>Permission denied, please try again.
            >>>kmaddile@sitescape's password:
            >>>Permission denied, please try again.
            >>>kmaddile@sitescape's password:
            >>>Permission denied (publickey,password,keyboard-interactive).
            >>>bash-2.04#
            >>>
            >>>Thanks.
            >>>
            >>>
            >>>
            >>>
            >>>
            >>>
            >>>--- In ilughyd@yahoogroups.com, phani@a... wrote:
            >>>
            >>>
            >>>>ssh in the system itself and check it out If it is working
            >>>>
            >>>>
            >fine
            >
            >
            >>>Then
            >>>
            >>>
            >>>>check the ipchains (i think u are using redhat 7.0 )
            >>>>
            >>>>If ssh is not working locally also acheck the ssh server conf
            >>>>
            >>>>
            >file
            >
            >
            >>>>
            >>>>On Fri, 3 Jan 2003, joint_strike_force
            >>>>
            >>>>
            ><joint_strike_force@y...>
            >
            >
            >>>wrote:
            >>>
            >>>
            >>>>>Hi,
            >>>>> Thanks Mr. Phani and Mr.Singh..
            >>>>> Telnet is now working but I am still not able use ssh.
            >>>>>
            >>>>> I restarted sshd and checked with netstat. SSH is running
            >>>>>
            >>>>>
            >on
            >
            >
            >>>>>default 22 port and listening.
            >>>>>
            >>>>>Is there anything else i can try?
            >>>>>
            >>>>>Thanks.
            >>>>>
            >>>>>
            >>>>>
            >>>>>
            >>>>>--- In ilughyd@yahoogroups.com, phani@a... wrote:
            >>>>>
            >>>>>
            >>>>>>Check whether ur ssh server is on U are on RH so type
            >>>>>>service sshd status
            >>>>>>If it is not on start the service
            >>>>>>If u wanna telnet to be on
            >>>>>>chkconfig telnet on
            >>>>>>service xinetd restart
            >>>>>>
            >>>>>>
            >>>>>>
            >>>>>>On Fri, 3 Jan 2003, joint_strike_force
            >>>>>>
            >>>>>>
            >>><joint_strike_force@y...>
            >>>
            >>>
            >>>>>wrote:
            >>>>>
            >>>>>
            >>>>>>>Hey,
            >>>>>>>
            >>>>>>> I recently got my hand on a new linux server (RH
            >>>>>>>
            >>>>>>>
            >7.0). I
            >
            >
            >>>am
            >>>
            >>>
            >>>>>>>unable to remote login using telnet or ssh.
            >>>>>>>
            >>>>>>>I have checked the following.
            >>>>>>>
            >>>>>>>1. SSH daemon is listening on default port(tried with
            >>>>>>>
            >>>>>>>
            >>>netstat)
            >>>
            >>>
            >>>>>>>2. No IP tables/IP chains
            >>>>>>>3. I am able to login from console
            >>>>>>>4. Server directly connected to internet (right now
            >>>>>>>
            >>>>>>>
            >pretty
            >
            >
            >>>>>insecure
            >>>>>
            >>>>>
            >>>>>>>but will start building some walls soon)
            >>>>>>>5. oh.. also checked to c if hosts.deny file exists..
            >>>>>>>
            >>>>>>>
            >but it
            >
            >
            >>>>>doesnt
            >>>>>
            >>>>>
            >>>>>>>seem to.
            >>>>>>>
            >>>>>>>Am I missing something obvious??
            >>>>>>>
            >>>>>>>Thanks for any help in advance.
            >>>>>>>
            >>>>>>>



            [Non-text portions of this message have been removed]
          • joint_strike_force <joint_strike_force@y
            ... and ... you! ... better ... check it out. ... Hi, I dont know what I m doing wrong but I am just unable to make ssh work. = IP address of my machine
            Message 5 of 9 , Jan 7, 2003
              >
              > I think all you would require to do is disable the firewall first
              and
              > then give it a try, if this is working fine, then its a boom for
              you!
              >
              > I supp'ose that the firewall is restricting access to the port. A
              better
              > way to give it a try is to telnet to the port from outside and
              check it out.
              >
              > Ram.
              >

              Hi,

              I dont know what I'm doing wrong but I am just unable to make ssh
              work.
              <ip> = IP address of my machine

              osf1> telnet <ip> 22
              Trying <ip>...
              Connected to <ip>.
              Escape character is '^]'.
              SSH-1.99-OpenSSH_3.5p1

              Does'nt this mean there is no firewall running. Moreover telnet is
              working.

              $ rpm -qa | grep ssh
              openssh-askpass-2.1.1p4-1
              openssh-server-2.1.1p4-1
              openssh-clients-2.1.1p4-1
              openssh-askpass-gnome-2.1.1p4-1
              openssh-2.1.1p4-1


              bash-2.04# ipchains -L
              Chain input (policy ACCEPT):
              Chain forward (policy ACCEPT):
              Chain output (policy ACCEPT):

              bash-2.04# iptables -L
              iptables v1.1.1: can't initialize iptables table `filter': iptables
              who? (do you need to insmod?)
              Perhaps iptables or your kernel needs to be upgraded.
              bash-2.04#


              Do you think reinstalling is a better option?????



              Thank you.


              > >-----------------------
              > >
              > ># This is ssh client systemwide configuration file. This file
              > >provides
              > ># defaults for users, and the values can be changed in per-user
              > >configuration
              > ># files or on the command line.
              > >
              > ># Configuration data is parsed as follows:
              > ># 1. command line options
              > ># 2. user-specific file
              > ># 3. system-wide file
              > ># Any configuration value is only changed the first time it is set.
              > ># Thus, host-specific definitions should be at the beginning of the
              > ># configuration file, and defaults at the end.
              > >
              > ># Site-wide defaults for various options
              > >
              > ># Host *
              > ># ForwardAgent yes
              > ># ForwardX11 yes
              > ># RhostsAuthentication yes
              > ># RhostsRSAAuthentication yes
              > ># RSAAuthentication yes
              > ># PasswordAuthentication yes
              > ># FallBackToRsh no
              > ># UseRsh no
              > ># BatchMode no
              > ># CheckHostIP yes
              > ># StrictHostKeyChecking no
              > ># IdentityFile ~/.ssh/identity
              > ># Port 22
              > ># Protocol 2,1
              > ># Cipher 3des
              > ># EscapeChar ~
              > >
              > ># Be paranoid by default
              > >Host *
              > > ForwardAgent no
              > > ForwardX11 yes
              > > FallBackToRsh no
              > > Protocol 2,1
              > >-----------------------------------
              > >
              > >--- In ilughyd@yahoogroups.com, phani@a... wrote:
              > >
              > >
              > >>Check out the auth in the /etc/ssh/sshd_config
              > >>I think the problem is there in the file
              > >>
              > >>Might be the keys are enabled and u dont have the key check it out
              > >>
              > >>
              > >>
              > >>On Sat, 4 Jan 2003, joint_strike_force <joint_strike_force@y...>
              > >>
              > >>
              > >wrote:
              > >
              > >
              > >>>Hi,
              > >>>
              > >>>This should pretty much explain the situation..
              > >>>
              > >>>bash-2.04# ps -ef | grep sshd
              > >>>root 1157 1 0 Jan03 ? 00:00:00 /usr/sbin/sshd
              > >>>
              > >>>bash-2.04# ipchains -L
              > >>>Chain input (policy ACCEPT):
              > >>>Chain forward (policy ACCEPT):
              > >>>Chain output (policy ACCEPT):
              > >>>
              > >>>bash-2.04# iptables -L
              > >>>iptables v1.1.1: can't initialize iptables table `filter':
              > >>>
              > >>>
              > >iptables
              > >
              > >
              > >>>who? (do you need to insmod?)
              > >>>Perhaps iptables or your kernel needs to be upgraded.
              > >>>
              > >>>bash-2.04# service sshd status
              > >>>sshd (pid 1157) is running...
              > >>>
              > >>>bash-2.04# ssh -l kmaddile sitescape
              > >>>The authenticity of host 'sitescape (127.0.0.1)' can't be
              > >>>established.
              > >>>RSA key fingerprint is
              > >>>78:cb:78:6d:fb:21:09:ed:8b:d0:13:ed:c8:31:a4:4b.
              > >>>Are you sure you want to continue connecting (yes/no)? yes
              > >>>Warning: Permanently added 'sitescape' (RSA) to the list of known
              > >>>hosts.
              > >>>kmaddile@sitescape's password:
              > >>>Permission denied, please try again.
              > >>>kmaddile@sitescape's password:
              > >>>Permission denied, please try again.
              > >>>kmaddile@sitescape's password:
              > >>>Permission denied (publickey,password,keyboard-interactive).
              > >>>bash-2.04#
              > >>>
              > >>>Thanks.
              > >>>
              > >>>
              > >>>
              > >>>
              > >>>
              > >>>
              > >>>--- In ilughyd@yahoogroups.com, phani@a... wrote:
              > >>>
              > >>>
              > >>>>ssh in the system itself and check it out If it is working
              > >>>>
              > >>>>
              > >fine
              > >
              > >
              > >>>Then
              > >>>
              > >>>
              > >>>>check the ipchains (i think u are using redhat 7.0 )
              > >>>>
              > >>>>If ssh is not working locally also acheck the ssh server conf
              > >>>>
              > >>>>
              > >file
              > >
              > >
              > >>>>
              > >>>>On Fri, 3 Jan 2003, joint_strike_force
              > >>>>
              > >>>>
              > ><joint_strike_force@y...>
              > >
              > >
              > >>>wrote:
              > >>>
              > >>>
              > >>>>>Hi,
              > >>>>> Thanks Mr. Phani and Mr.Singh..
              > >>>>> Telnet is now working but I am still not able use ssh.
              > >>>>>
              > >>>>> I restarted sshd and checked with netstat. SSH is running
              > >>>>>
              > >>>>>
              > >on
              > >
              > >
              > >>>>>default 22 port and listening.
              > >>>>>
              > >>>>>Is there anything else i can try?
              > >>>>>
              > >>>>>Thanks.
              > >>>>>
              > >>>>>
              > >>>>>
              > >>>>>
              > >>>>>--- In ilughyd@yahoogroups.com, phani@a... wrote:
              > >>>>>
              > >>>>>
              > >>>>>>Check whether ur ssh server is on U are on RH so type
              > >>>>>>service sshd status
              > >>>>>>If it is not on start the service
              > >>>>>>If u wanna telnet to be on
              > >>>>>>chkconfig telnet on
              > >>>>>>service xinetd restart
              > >>>>>>
              > >>>>>>
              > >>>>>>
              > >>>>>>On Fri, 3 Jan 2003, joint_strike_force
              > >>>>>>
              > >>>>>>
              > >>><joint_strike_force@y...>
              > >>>
              > >>>
              > >>>>>wrote:
              > >>>>>
              > >>>>>
              > >>>>>>>Hey,
              > >>>>>>>
              > >>>>>>> I recently got my hand on a new linux server (RH
              > >>>>>>>
              > >>>>>>>
              > >7.0). I
              > >
              > >
              > >>>am
              > >>>
              > >>>
              > >>>>>>>unable to remote login using telnet or ssh.
              > >>>>>>>
              > >>>>>>>I have checked the following.
              > >>>>>>>
              > >>>>>>>1. SSH daemon is listening on default port(tried with
              > >>>>>>>
              > >>>>>>>
              > >>>netstat)
              > >>>
              > >>>
              > >>>>>>>2. No IP tables/IP chains
              > >>>>>>>3. I am able to login from console
              > >>>>>>>4. Server directly connected to internet (right now
              > >>>>>>>
              > >>>>>>>
              > >pretty
              > >
              > >
              > >>>>>insecure
              > >>>>>
              > >>>>>
              > >>>>>>>but will start building some walls soon)
              > >>>>>>>5. oh.. also checked to c if hosts.deny file exists..
              > >>>>>>>
              > >>>>>>>
              > >but it
              > >
              > >
              > >>>>>doesnt
              > >>>>>
              > >>>>>
              > >>>>>>>seem to.
              > >>>>>>>
              > >>>>>>>Am I missing something obvious??
              > >>>>>>>
              > >>>>>>>Thanks for any help in advance.
              > >>>>>>>
              > >>>>>>>
              >
              >
              >
              > [Non-text portions of this message have been removed]
            Your message has been successfully submitted and would be delivered to recipients shortly.