Loading ...
Sorry, an error occurred while loading the content.
 

multi-access to X?

Expand Messages
  • V S Ashoka
    If I su to another user (or even root) form an X-terminal and then run an X-based program (like netscape, nedit etc.) from his shell, it refuses with a message
    Message 1 of 3 , Apr 1, 2001
      If I su to another user (or even root) form an X-terminal and then run an
      X-based program (like netscape, nedit etc.) from his shell, it refuses
      with a message

      Xlib: connection to ":0.0" refused by server
      Xlib: Invalid MIT-MAGIC-COOKIE-1 key

      I had this prob. with RH 6.1 but not with SuSe 6.4. The settings with SuSE
      7.1 has again gone to this refusal mode. I couldn't find the settings
      where I can shut this off. Any ideas?

      I need a :0.0 connection for another user who does a su when I am
      logged on.

      Ashok
    • Y. Giridhar Appaji Nag
      Hi, If the remote machine on which you want to run the x-client is remote.tifr.res.in then add it to the allowed host list of the local machine (say
      Message 2 of 3 , Apr 1, 2001
        Hi,

        If the remote machine on which you want to run the x-client is
        remote.tifr.res.in then add it to the allowed host list of the local
        machine (say local.tifr.res.in) and the DISPLAY variable in the su'ed
        shell on the remote machine must be set to local.tifr.res.in:0.0

        someone@remote$ su - vsashok
        Password:
        vsashok@remote$ netscape
        Xlib: connection to ":0.0" refused by server
        Xlib: Invalid MIT-MAGIC-COOKIE-1 key

        vsashok@local$ xhost +remote.tifr.res.in
        remote.tifr.res.in added to host list

        vsashok@remote$ export DISPLAY=local.tifr.res.in:0.0
        vsashok@remote$ netscape

        This way, any XClient on remote can connect to your local display
        (and capture events etc.) but if you want restircted access then
        check out man xauth

        -rgds,
        Giridhar

        =====
        Y. Giridhar Appaji Nag I hate quotations,
        yganag[at]yahoo[dot]com tell me what you know
        http://want.to.know/really? -Ralph W. Emerson

        __________________________________________________
        Do You Yahoo!?
        Get email at your own domain with Yahoo! Mail.
        http://personal.mail.yahoo.com/?.refer=text
      • Sekhar vs
        hi ashoke, Thats because X is locked by the user who starts it first. To start X apps as another user u need to do 2 things: 1. xhost + issue the above cmd as
        Message 3 of 3 , Apr 1, 2001
          hi ashoke,

          Thats because X is locked by the user who starts it
          first.

          To start X apps as another user u need to do 2 things:

          1. xhost +
          issue the above cmd as the user starting the X

          2. export DISPLAY=localhost:0.0
          issue the above cmd after logging in as other user
          using su

          Then starting any x app (like netscape, nedit
          etc.)works like a charm.

          Good luck,

          -sekhar

          >
          > Message: 3
          > Date: Sun, 1 Apr 2001 14:50:06 +0530 (IST)
          > From: V S Ashoka <vsashok@...>
          > Subject: multi-access to X?
          >
          >
          > If I su to another user (or even root) form an
          > X-terminal and then run an
          > X-based program (like netscape, nedit etc.) from his
          > shell, it refuses
          > with a message
          >
          > Xlib: connection to ":0.0" refused by server
          > Xlib: Invalid MIT-MAGIC-COOKIE-1 key
          >
          > I had this prob. with RH 6.1 but not with SuSe 6.4.
          > The settings with SuSE
          > 7.1 has again gone to this refusal mode. I couldn't
          > find the settings
          > where I can shut this off. Any ideas?
          >
          > I need a :0.0 connection for another user who does
          > a su when I am
          > logged on.
          >
          > Ashok
          >
          >
          >
          >
          ________________________________________________________________________
          >
          ________________________________________________________________________
          >
          >
          >
          > Your use of Yahoo! Groups is subject to
          > http://docs.yahoo.com/info/terms/
          >
          >


          __________________________________________________
          Do You Yahoo!?
          Get email at your own domain with Yahoo! Mail.
          http://personal.mail.yahoo.com/?.refer=text
        Your message has been successfully submitted and would be delivered to recipients shortly.