Loading ...
Sorry, an error occurred while loading the content.
 

Re: TFTP Problem

Expand Messages
  • Raghuram Vijapurapu
    ... 1700 series router. I want to copy the IOS image from the router to the Linux server using tftp. I enabled the tftp service in the Linux server by editing
    Message 1 of 8 , Oct 4, 2004
      --- In ilughyd@yahoogroups.com, Anandh G <anandhglinux@y...> wrote:
      > I am having a Redhat Linux 9 connected to the internet using a Cisco
      1700 series router. I want to copy the IOS image from the router to
      the Linux server using tftp. I enabled the tftp service in the Linux
      server by editing the tftp file in /etc/xinetd.d and then set the
      disable to no and then restarted the xinetd service. but when i put
      nmap localhost I don't find the tftp server running. Also the router
      is not able to reach the tftp server in the linux server. but when I
      did this thing for telnet service and restarted the xinetd service it
      is running.
      >
      > How do I start the tftp service in my linux.

      Can you please send the configuration file you are using? This might
      help up better to help you out!

      Ram.

      > Plz reply
      >
      >
      > Regards,
      > AnandhG
    • Anandh G
      What configuration file you want ? ... 1700 series router. I want to copy the IOS image from the router to the Linux server using tftp. I enabled the tftp
      Message 2 of 8 , Oct 4, 2004
        What configuration file you want ?

        Raghuram Vijapurapu <ram@...> wrote:
        --- In ilughyd@yahoogroups.com, Anandh G <anandhglinux@y...> wrote:
        > I am having a Redhat Linux 9 connected to the internet using a Cisco
        1700 series router. I want to copy the IOS image from the router to
        the Linux server using tftp. I enabled the tftp service in the Linux
        server by editing the tftp file in /etc/xinetd.d and then set the
        disable to no and then restarted the xinetd service. but when i put
        nmap localhost I don't find the tftp server running. Also the router
        is not able to reach the tftp server in the linux server. but when I
        did this thing for telnet service and restarted the xinetd service it
        is running.
        >
        > How do I start the tftp service in my linux.

        Can you please send the configuration file you are using? This might
        help up better to help you out!

        Ram.



        Regards,
        AnandhG

        ---------------------------------
        Do you Yahoo!?
        Yahoo! Mail - 50x more storage than other providers!

        [Non-text portions of this message have been removed]
      • Binand Sethumadhavan
        On Mon, 4 Oct 2004 23:11:46 -0700 (PDT), Anandh G ... Not configuration info exactly, but how about posting the logs when you restart xinetd? Binand
        Message 3 of 8 , Oct 4, 2004
          On Mon, 4 Oct 2004 23:11:46 -0700 (PDT), Anandh G
          <anandhglinux@...> wrote:
          >
          > What configuration file you want ?

          Not configuration info exactly, but how about posting the logs when
          you restart xinetd?

          Binand
        • Anandh G
          I restarted xinetd service and the /var/log/message is shown as below ********************************************** Oct 5 18:08:19 cbe xinetd[22820]: xinetd
          Message 4 of 8 , Oct 5, 2004
            I restarted xinetd service and the /var/log/message is shown as below
            **********************************************
            Oct 5 18:08:19 cbe xinetd[22820]: xinetd Version 2002.03.28 started with libwrap options compiled in.
            Oct 5 18:08:19 cbe xinetd[22820]: Started working: 1 available service
            Oct 5 18:08:21 cbe xinetd: xinetd startup succeeded
            **********************************************
            On Mon, 4 Oct 2004 23:11:46 -0700 (PDT), Anandh G
            <anandhglinux@...> wrote:
            >
            > What configuration file you want ?

            Not configuration info exactly, but how about posting the logs when
            you restart xinetd?




            Regards,
            AnandhG

            ---------------------------------
            Do you Yahoo!?
            New and Improved Yahoo! Mail - 100MB free storage!

            [Non-text portions of this message have been removed]
          • Binand Sethumadhavan
            On Mon, 4 Oct 2004 00:21:50 -0700 (PDT), Anandh G ... Sigh. tftp is a UDP service. Nmap by default scans only TCP ports. How about running nmap as nmap -sU
            Message 5 of 8 , Oct 5, 2004
              On Mon, 4 Oct 2004 00:21:50 -0700 (PDT), Anandh G
              <anandhglinux@...> wrote:
              > I want to copy the IOS image from the router to the Linux server using tftp. I enabled the tftp service in the Linux server by editing the tftp file in /etc/xinetd.d and then set the disable to no and then restarted the xinetd service. but when i put nmap localhost I don't find the tftp server running.

              Sigh. tftp is a UDP service. Nmap by default scans only TCP ports. How
              about running nmap as nmap -sU localhost?

              > Also the router is not able to reach the tftp server in the linux server. but when I did this thing for telnet service and restarted the xinetd service it is running.

              Firewall? Did you check ipchains/iptables? Can you post the output
              from the router of the command:

              copy running-config tftp:

              Binand
            • Anandh G
              I tried to use nmap using the -sU and got the following result. # nmap -sU localhost Starting nmap V. 2.54BETA31 ( www.insecure.org/nmap/ ) (The 1456 ports
              Message 6 of 8 , Oct 5, 2004
                I tried to use nmap using the -sU and got the following result.
                # nmap -sU localhost
                Starting nmap V. 2.54BETA31 ( www.insecure.org/nmap/ )
                (The 1456 ports scanned but not shown below are in state: closed)
                Port State Service
                53/udp open domain
                610/udp open npmp-local
                1024/udp open unknown

                Also when I tried from the router, it says the tftp server is not reachable, but I am able to ping to the linux server.
                Binand Sethumadhavan <binand@...> wrote:
                On Mon, 4 Oct 2004 00:21:50 -0700 (PDT), Anandh G
                <anandhglinux@...> wrote:
                > I want to copy the IOS image from the router to the Linux server using tftp. I enabled the tftp service in the Linux server by editing the tftp file in /etc/xinetd.d and then set the disable to no and then restarted the xinetd service. but when i put nmap localhost I don't find the tftp server running.

                Sigh. tftp is a UDP service. Nmap by default scans only TCP ports. How
                about running nmap as nmap -sU localhost?

                > Also the router is not able to reach the tftp server in the linux server. but when I did this thing for telnet service and restarted the xinetd service it is running.

                Firewall? Did you check ipchains/iptables? Can you post the output
                from the router of the command:

                copy running-config tftp:

                Binand

                Regards,
                AnandhG

                ---------------------------------
                Do you Yahoo!?
                Take Yahoo! Mail with you! Get it on your mobile phone.

                [Non-text portions of this message have been removed]
              • Ram Vijapurapu
                Can you turn off the firewall and check? Ram. On Tue, 5 Oct 2004 21:49:40 -0700 (PDT), Anandh G ... -- Ram Vijapurapu rvijapurapu at gmail dot com
                Message 7 of 8 , Oct 6, 2004
                  Can you turn off the firewall and check?

                  Ram.


                  On Tue, 5 Oct 2004 21:49:40 -0700 (PDT), Anandh G
                  <anandhglinux@...> wrote:
                  >
                  > I tried to use nmap using the -sU and got the following result.
                  > # nmap -sU localhost
                  > Starting nmap V. 2.54BETA31 ( www.insecure.org/nmap/ )
                  > (The 1456 ports scanned but not shown below are in state: closed)
                  > Port State Service
                  > 53/udp open domain
                  > 610/udp open npmp-local
                  > 1024/udp open unknown
                  >
                  > Also when I tried from the router, it says the tftp server is not reachable, but I am able to ping to the linux server.
                  > Binand Sethumadhavan <binand@...> wrote:
                  > On Mon, 4 Oct 2004 00:21:50 -0700 (PDT), Anandh G
                  > <anandhglinux@...> wrote:
                  > > I want to copy the IOS image from the router to the Linux server using tftp. I enabled the tftp service in the Linux server by editing the tftp file in /etc/xinetd.d and then set the disable to no and then restarted the xinetd service. but when i put nmap localhost I don't find the tftp server running.
                  >
                  > Sigh. tftp is a UDP service. Nmap by default scans only TCP ports. How
                  > about running nmap as nmap -sU localhost?
                  >
                  > > Also the router is not able to reach the tftp server in the linux server. but when I did this thing for telnet service and restarted the xinetd service it is running.
                  >
                  > Firewall? Did you check ipchains/iptables? Can you post the output
                  > from the router of the command:
                  >
                  > copy running-config tftp:
                  >
                  > Binand
                  >
                  > Regards,
                  > AnandhG
                  >
                  > ---------------------------------
                  > Do you Yahoo!?
                  > Take Yahoo! Mail with you! Get it on your mobile phone.
                  >
                  >
                  >
                  > [Non-text portions of this message have been removed]
                  >
                  >
                  > -----------------------------------------------
                  > Next Meeting as on our Website: http://ilug-hyd.org.in
                  > -----------------------------------------------
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >


                  --
                  Ram Vijapurapu
                  rvijapurapu at gmail dot com
                Your message has been successfully submitted and would be delivered to recipients shortly.