Loading ...
Sorry, an error occurred while loading the content.

Re: [id-ruby] Install gem install rails error, mohon pencerahan!

Expand Messages
  • Karuna Murti
    Sebisa mungkin jangan install dari package. Kalau mau system wide install dari source ke /usr/local. Kalau untuk development biasa pakai rvm saja.
    Message 1 of 5 , Jan 26, 2013
    • 0 Attachment
      Sebisa mungkin jangan install dari package. Kalau mau system wide install
      dari source ke /usr/local.
      Kalau untuk development biasa pakai rvm saja. http://rvm.io


      On Sat, Jan 26, 2013 at 2:57 PM, Leo Laksmana <beol@...> wrote:

      > **
      >
      >
      > Lupa-lupa inget nih tapi kayaknya belom install ruby-devel library tuh.
      > Pake stock ruby yah? Yg default installation-nya Centos?
      >
      >
      > On Saturday, January 26, 2013, Hari wrote:
      >
      > > Dear teman2,
      > > lagi mencoba install rails di Centos,
      > > gem install rails -V, muncul error spt dibawah ini:
      > > /usr/lib64/ruby/gems/1.8/gems/json-1.7.6/tests/test_json.rb
      > > Building native extensions. This could take a while...
      > > ERROR: Error installing rails:
      > > ERROR: Failed to build gem native extension.
      > >
      > > /usr/bin/ruby extconf.rb
      > > mkmf.rb can't find header files for ruby at /usr/lib/ruby/ruby.h
      > >
      > >
      > > Gem files will remain installed in
      > > /usr/lib64/ruby/gems/1.8/gems/json-1.7.6 for inspection.
      > > Results logged to
      > >
      > /usr/lib64/ruby/gems/1.8/gems/json-1.7.6/ext/json/ext/generator/gem_make.out
      > >
      > > Mohon pencerahan!
      > >
      > > Terima kasih sebelumnya
      > >
      > >
      > >
      > >
      > >
      > >
      > > ------------------------------------
      >
      > >
      > > ID-Ruby
      > > Berdiskusi dan belajar bersama Bahasa Pemrograman Ruby, termasuk segala
      > > varian Ruby (JRuby, Rubinius, IronRuby, XRuby), dan program yang dibuat
      > > dengan Ruby (Ruby on Rails, JRuby on Rails, Merb)
      > >
      > > http://rubyurl.com/Q8DD
      > > http://news.gmane.org/gmane.comp.lang.ruby.region.indonesia
      > >
      > >
      > >
      > >
      > >
      >
      > --
      > --
      > http://twitter.com/beol
      >
      > [Non-text portions of this message have been removed]
      >
      >
      >


      [Non-text portions of this message have been removed]
    • Rafeequl
      Kalau masih fresh install, Coba install pakai rbenv aja, biar sekalian diinstalin libyml dll ... [Non-text portions of this message have been removed]
      Message 2 of 5 , Jan 26, 2013
      • 0 Attachment
        Kalau masih fresh install, Coba install pakai rbenv aja, biar sekalian diinstalin libyml dll

        On 26 Jan 2013, at 14:13, "Hari" <h4r1purnomo@...> wrote:

        > Dear teman2,
        > lagi mencoba install rails di Centos,
        > gem install rails -V, muncul error spt dibawah ini:
        > /usr/lib64/ruby/gems/1.8/gems/json-1.7.6/tests/test_json.rb
        > Building native extensions. This could take a while...
        > ERROR: Error installing rails:
        > ERROR: Failed to build gem native extension.
        >
        > /usr/bin/ruby extconf.rb
        > mkmf.rb can't find header files for ruby at /usr/lib/ruby/ruby.h
        >
        > Gem files will remain installed in /usr/lib64/ruby/gems/1.8/gems/json-1.7.6 for inspection.
        > Results logged to /usr/lib64/ruby/gems/1.8/gems/json-1.7.6/ext/json/ext/generator/gem_make.out
        >
        > Mohon pencerahan!
        >
        > Terima kasih sebelumnya
        >
        >


        [Non-text portions of this message have been removed]
      • Leo Laksmana
        Kalo gak install JRuby 1.7 dengan JRE 7. ... -- -- http://twitter.com/beol [Non-text portions of this message have been removed]
        Message 3 of 5 , Jan 26, 2013
        • 0 Attachment
          Kalo gak install JRuby 1.7 dengan JRE 7.

          On Saturday, January 26, 2013, Karuna Murti wrote:

          > Sebisa mungkin jangan install dari package. Kalau mau system wide install
          > dari source ke /usr/local.
          > Kalau untuk development biasa pakai rvm saja. http://rvm.io
          >
          >
          > On Sat, Jan 26, 2013 at 2:57 PM, Leo Laksmana <beol@...<javascript:;>>
          > wrote:
          >
          > > **
          > >
          > >
          > > Lupa-lupa inget nih tapi kayaknya belom install ruby-devel library tuh.
          > > Pake stock ruby yah? Yg default installation-nya Centos?
          > >
          > >
          > > On Saturday, January 26, 2013, Hari wrote:
          > >
          > > > Dear teman2,
          > > > lagi mencoba install rails di Centos,
          > > > gem install rails -V, muncul error spt dibawah ini:
          > > > /usr/lib64/ruby/gems/1.8/gems/json-1.7.6/tests/test_json.rb
          > > > Building native extensions. This could take a while...
          > > > ERROR: Error installing rails:
          > > > ERROR: Failed to build gem native extension.
          > > >
          > > > /usr/bin/ruby extconf.rb
          > > > mkmf.rb can't find header files for ruby at /usr/lib/ruby/ruby.h
          > > >
          > > >
          > > > Gem files will remain installed in
          > > > /usr/lib64/ruby/gems/1.8/gems/json-1.7.6 for inspection.
          > > > Results logged to
          > > >
          > >
          > /usr/lib64/ruby/gems/1.8/gems/json-1.7.6/ext/json/ext/generator/gem_make.out
          > > >
          > > > Mohon pencerahan!
          > > >
          > > > Terima kasih sebelumnya
          > > >
          > > >
          > > >
          > > >
          > > >
          > > >
          > > > ------------------------------------
          > >
          > > >
          > > > ID-Ruby
          > > > Berdiskusi dan belajar bersama Bahasa Pemrograman Ruby, termasuk segala
          > > > varian Ruby (JRuby, Rubinius, IronRuby, XRuby), dan program yang dibuat
          > > > dengan Ruby (Ruby on Rails, JRuby on Rails, Merb)
          > > >
          > > > http://rubyurl.com/Q8DD
          > > > http://news.gmane.org/gmane.comp.lang.ruby.region.indonesia
          > > >
          > > >
          > > >
          > > >
          > > >
          > >
          > > --
          > > --
          > > http://twitter.com/beol
          > >
          > > [Non-text portions of this message have been removed]
          > >
          > >
          > >
          >
          >
          >
          > ------------------------------------
          >
          > ID-Ruby
          > Berdiskusi dan belajar bersama Bahasa Pemrograman Ruby, termasuk segala
          > varian Ruby (JRuby, Rubinius, IronRuby, XRuby), dan program yang dibuat
          > dengan Ruby (Ruby on Rails, JRuby on Rails, Merb)
          >
          > http://rubyurl.com/Q8DD
          > http://news.gmane.org/gmane.comp.lang.ruby.region.indonesia
          >
          >
          >
          >
          >

          --
          --
          http://twitter.com/beol


          [Non-text portions of this message have been removed]
        Your message has been successfully submitted and would be delivered to recipients shortly.