Loading ...
Sorry, an error occurred while loading the content.

Install Ruby - Rails - Redmine

Expand Messages
  • Fikri Ms
    Hello All, Maaf nih, saya pemula di dunia ruby. Tertarik dengan Redmine http://www.redmine.org/ utk project management. Saya belum pernah sama sekali
    Message 1 of 7 , Jan 4, 2011
    • 0 Attachment
      Hello All,

      Maaf nih, saya pemula di dunia ruby. Tertarik dengan Redmine
      http://www.redmine.org/ utk project management. Saya belum pernah sama
      sekali mengenal dunia ruby. Saya mencoba install di Server
      Ubuntu 10.10, dg cara :
      1. Install Ruby, berhubung di situs resminya sdh ada ruby1.9.1 maka
      saya langsung aja pakai :
      sudo apt-get install ruby1.9.1-full
      2. Saat mau install Rails, nengok ke situsnya :
      We recommend Ruby 1.8.7 or Ruby 1.9.2 for use with Rails. Ruby 1.8.6
      and earlier are not supported, neither is version 1.9.1.
      Waduuh .. ternyata 1.9.1 gak support Rails ??
      3. Berdasarkan requirement redmine
      http://www.redmine.org/projects/redmine/wiki/RedmineInstall disebutkan
      bhw : Ruby yg disupport ternyata 1.8.x

      Jadi Frustasi duluan nih ... Ada nggak langkah2 praktis Instalasi :
      Ruby - Rails - Redmine ??

      Thx

      --
      Best regards,
      Fikri mailto:fikri.ms@...
    • michael_23_27
      Hello Fikri, Sorry my bahasa isn t good enough to reply in it, so English it is. For redmine need to use ruby 1.8.7 and rails 2.3.5. Don t install ruby through
      Message 2 of 7 , Jan 16, 2011
      • 0 Attachment
        Hello Fikri,

        Sorry my bahasa isn't good enough to reply in it, so English it is.

        For redmine need to use ruby 1.8.7 and rails 2.3.5.

        Don't install ruby through system package managers. Instead use RVM (http://rvm.beginrescueend.com/) to manage multiple versions of Ruby on one system.

        Start by installing RVM and read the documentation on their site. If you have any questions, feel free to post them to the group and I am sure others and I will be able to help you along the way.

        Kind regards,

        Michael Smith
        http://treecode.com

        --- In id-ruby@yahoogroups.com, Fikri Ms <fikri.ms@...> wrote:
        >
        > Hello All,
        >
        > Maaf nih, saya pemula di dunia ruby. Tertarik dengan Redmine
        > http://www.redmine.org/ utk project management. Saya belum pernah sama
        > sekali mengenal dunia ruby. Saya mencoba install di Server
        > Ubuntu 10.10, dg cara :
        > 1. Install Ruby, berhubung di situs resminya sdh ada ruby1.9.1 maka
        > saya langsung aja pakai :
        > sudo apt-get install ruby1.9.1-full
        > 2. Saat mau install Rails, nengok ke situsnya :
        > We recommend Ruby 1.8.7 or Ruby 1.9.2 for use with Rails. Ruby 1.8.6
        > and earlier are not supported, neither is version 1.9.1.
        > Waduuh .. ternyata 1.9.1 gak support Rails ??
        > 3. Berdasarkan requirement redmine
        > http://www.redmine.org/projects/redmine/wiki/RedmineInstall disebutkan
        > bhw : Ruby yg disupport ternyata 1.8.x
        >
        > Jadi Frustasi duluan nih ... Ada nggak langkah2 praktis Instalasi :
        > Ruby - Rails - Redmine ??
        >
        > Thx
        >
        > --
        > Best regards,
        > Fikri mailto:fikri.ms@...
        >
      • gozali@gmail.com
        Kalo install ruby-full aja dikasih 1.8.7 bukannya bro? Klo nggak bisa download source nya + compile sendiri aja yg 1.8.7 atau yg 1.9.2 Sent from my mobile
        Message 3 of 7 , Jan 16, 2011
        • 0 Attachment
          Kalo install ruby-full aja dikasih 1.8.7 bukannya bro? Klo nggak bisa download source nya + compile sendiri aja yg 1.8.7 atau yg 1.9.2


          Sent from my mobile device

          -----Original Message-----
          From: Fikri Ms <fikri.ms@...>
          Sender: id-ruby@yahoogroups.com
          Date: Wed, 5 Jan 2011 14:44:33
          To: <id-ruby@yahoogroups.com>
          Reply-To: id-ruby@yahoogroups.com
          Subject: [id-ruby] Install Ruby - Rails - Redmine

          Hello All,

          Maaf nih, saya pemula di dunia ruby. Tertarik dengan Redmine
          http://www.redmine.org/ utk project management. Saya belum pernah sama
          sekali mengenal dunia ruby. Saya mencoba install di Server
          Ubuntu 10.10, dg cara :
          1. Install Ruby, berhubung di situs resminya sdh ada ruby1.9.1 maka
          saya langsung aja pakai :
          sudo apt-get install ruby1.9.1-full
          2. Saat mau install Rails, nengok ke situsnya :
          We recommend Ruby 1.8.7 or Ruby 1.9.2 for use with Rails. Ruby 1.8.6
          and earlier are not supported, neither is version 1.9.1.
          Waduuh .. ternyata 1.9.1 gak support Rails ??
          3. Berdasarkan requirement redmine
          http://www.redmine.org/projects/redmine/wiki/RedmineInstall disebutkan
          bhw : Ruby yg disupport ternyata 1.8.x

          Jadi Frustasi duluan nih ... Ada nggak langkah2 praktis Instalasi :
          Ruby - Rails - Redmine ??

          Thx

          --
          Best regards,
          Fikri mailto:fikri.ms@...




          ------------------------------------

          ID-Ruby
          Berdiskusi dan belajar bersama Bahasa Pemrograman Ruby, termasuk segala varian Ruby (JRuby, Rubinius, IronRuby, XRuby), dan program yang dibuat dengan Ruby (Ruby on Rails, JRuby on Rails, Merb)

          http://rubyurl.com/Q8DD
          http://news.gmane.org/gmane.comp.lang.ruby.region.indonesia
        • michael_23_27
          Hi Ahmad ;) Yes, that s exactly what RVM does, it downloads and installs from source and at the same time allows you to quickly switch between versions. And it
          Message 4 of 7 , Jan 16, 2011
          • 0 Attachment
            Hi Ahmad ;)

            Yes, that's exactly what RVM does, it downloads and installs from source and at the same time allows you to quickly switch between versions. And it keeps gems separated between different ruby versions.

            --- In id-ruby@yahoogroups.com, gozali@... wrote:
            >
            > Kalo install ruby-full aja dikasih 1.8.7 bukannya bro? Klo nggak bisa download source nya + compile sendiri aja yg 1.8.7 atau yg 1.9.2
            >
            >
            > Sent from my mobile device
            >
            > -----Original Message-----
            > From: Fikri Ms <fikri.ms@...>
            > Sender: id-ruby@yahoogroups.com
            > Date: Wed, 5 Jan 2011 14:44:33
            > To: <id-ruby@yahoogroups.com>
            > Reply-To: id-ruby@yahoogroups.com
            > Subject: [id-ruby] Install Ruby - Rails - Redmine
            >
            > Hello All,
            >
            > Maaf nih, saya pemula di dunia ruby. Tertarik dengan Redmine
            > http://www.redmine.org/ utk project management. Saya belum pernah sama
            > sekali mengenal dunia ruby. Saya mencoba install di Server
            > Ubuntu 10.10, dg cara :
            > 1. Install Ruby, berhubung di situs resminya sdh ada ruby1.9.1 maka
            > saya langsung aja pakai :
            > sudo apt-get install ruby1.9.1-full
            > 2. Saat mau install Rails, nengok ke situsnya :
            > We recommend Ruby 1.8.7 or Ruby 1.9.2 for use with Rails. Ruby 1.8.6
            > and earlier are not supported, neither is version 1.9.1.
            > Waduuh .. ternyata 1.9.1 gak support Rails ??
            > 3. Berdasarkan requirement redmine
            > http://www.redmine.org/projects/redmine/wiki/RedmineInstall disebutkan
            > bhw : Ruby yg disupport ternyata 1.8.x
            >
            > Jadi Frustasi duluan nih ... Ada nggak langkah2 praktis Instalasi :
            > Ruby - Rails - Redmine ??
            >
            > Thx
            >
            > --
            > Best regards,
            > Fikri mailto:fikri.ms@...
            >
            >
            >
            >
            > ------------------------------------
            >
            > ID-Ruby
            > Berdiskusi dan belajar bersama Bahasa Pemrograman Ruby, termasuk segala varian Ruby (JRuby, Rubinius, IronRuby, XRuby), dan program yang dibuat dengan Ruby (Ruby on Rails, JRuby on Rails, Merb)
            >
            > http://rubyurl.com/Q8DD
            > http://news.gmane.org/gmane.comp.lang.ruby.region.indonesia
            >
          • saputra.didiet
            Halo mas Fikri.. Udah pernah coba ikuti step yang disini http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_in_Ubuntu ?? sepertinya cukup ok
            Message 5 of 7 , Jan 16, 2011
            • 0 Attachment
              Halo mas Fikri..
              Udah pernah coba ikuti step yang disini http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_in_Ubuntu ??
              sepertinya cukup ok tu mas step2nya..
              aku sendiri udah pernah coba yang installation step di windows, pake apache + mongrel, dan sukses instalasinya..


              Best Regards,
              Aditya Saputra
              smartechnusa.co.id

              --- In id-ruby@yahoogroups.com, Fikri Ms <fikri.ms@...> wrote:
              >
              > Hello All,
              >
              > Maaf nih, saya pemula di dunia ruby. Tertarik dengan Redmine
              > http://www.redmine.org/ utk project management. Saya belum pernah sama
              > sekali mengenal dunia ruby. Saya mencoba install di Server
              > Ubuntu 10.10, dg cara :
              > 1. Install Ruby, berhubung di situs resminya sdh ada ruby1.9.1 maka
              > saya langsung aja pakai :
              > sudo apt-get install ruby1.9.1-full
              > 2. Saat mau install Rails, nengok ke situsnya :
              > We recommend Ruby 1.8.7 or Ruby 1.9.2 for use with Rails. Ruby 1.8.6
              > and earlier are not supported, neither is version 1.9.1.
              > Waduuh .. ternyata 1.9.1 gak support Rails ??
              > 3. Berdasarkan requirement redmine
              > http://www.redmine.org/projects/redmine/wiki/RedmineInstall disebutkan
              > bhw : Ruby yg disupport ternyata 1.8.x
              >
              > Jadi Frustasi duluan nih ... Ada nggak langkah2 praktis Instalasi :
              > Ruby - Rails - Redmine ??
              >
              > Thx
              >
              > --
              > Best regards,
              > Fikri mailto:fikri.ms@...
              >
            • hendra kusuma
              Atau langkah yang paling praktis, basmi aja ruby yang 1.9.1 dan install 1.8.7 Saya sendiri masih bertahan di 1.8.7 karena beberapa gem belum di port ke 1.9.x
              Message 6 of 7 , Jan 16, 2011
              • 0 Attachment
                Atau langkah yang paling praktis, basmi aja ruby yang 1.9.1 dan install
                1.8.7
                Saya sendiri masih bertahan di 1.8.7 karena beberapa gem belum di port ke
                1.9.x
                toh bedanya ga terlalu besar, apalagi kalau cuma untuk keperluan belajar

                2011/1/16 michael_23_27 <michael.shmitty@...>

                >
                >
                > Hi Ahmad ;)
                >
                > Yes, that's exactly what RVM does, it downloads and installs from source
                > and at the same time allows you to quickly switch between versions. And it
                > keeps gems separated between different ruby versions.
                >
                >
                > --- In id-ruby@yahoogroups.com <id-ruby%40yahoogroups.com>, gozali@...
                > wrote:
                > >
                > > Kalo install ruby-full aja dikasih 1.8.7 bukannya bro? Klo nggak bisa
                > download source nya + compile sendiri aja yg 1.8.7 atau yg 1.9.2
                > >
                > >
                > > Sent from my mobile device
                > >
                > > -----Original Message-----
                > > From: Fikri Ms <fikri.ms@...>
                > > Sender: id-ruby@yahoogroups.com <id-ruby%40yahoogroups.com>
                > > Date: Wed, 5 Jan 2011 14:44:33
                > > To: <id-ruby@yahoogroups.com <id-ruby%40yahoogroups.com>>
                > > Reply-To: id-ruby@yahoogroups.com <id-ruby%40yahoogroups.com>
                > > Subject: [id-ruby] Install Ruby - Rails - Redmine
                > >
                > > Hello All,
                > >
                > > Maaf nih, saya pemula di dunia ruby. Tertarik dengan Redmine
                > > http://www.redmine.org/ utk project management. Saya belum pernah sama
                > > sekali mengenal dunia ruby. Saya mencoba install di Server
                > > Ubuntu 10.10, dg cara :
                > > 1. Install Ruby, berhubung di situs resminya sdh ada ruby1.9.1 maka
                > > saya langsung aja pakai :
                > > sudo apt-get install ruby1.9.1-full
                > > 2. Saat mau install Rails, nengok ke situsnya :
                > > We recommend Ruby 1.8.7 or Ruby 1.9.2 for use with Rails. Ruby 1.8.6
                > > and earlier are not supported, neither is version 1.9.1.
                > > Waduuh .. ternyata 1.9.1 gak support Rails ??
                > > 3. Berdasarkan requirement redmine
                > > http://www.redmine.org/projects/redmine/wiki/RedmineInstall disebutkan
                > > bhw : Ruby yg disupport ternyata 1.8.x
                > >
                > > Jadi Frustasi duluan nih ... Ada nggak langkah2 praktis Instalasi :
                > > Ruby - Rails - Redmine ??
                > >
                > > Thx
                > >
                > > --
                > > Best regards,
                > > Fikri mailto:fikri.ms@...
                > >
                > >
                > >
                > >
                > > ------------------------------------
                >
                > >
                > > ID-Ruby
                > > Berdiskusi dan belajar bersama Bahasa Pemrograman Ruby, termasuk segala
                > varian Ruby (JRuby, Rubinius, IronRuby, XRuby), dan program yang dibuat
                > dengan Ruby (Ruby on Rails, JRuby on Rails, Merb)
                > >
                > > http://rubyurl.com/Q8DD
                > > http://news.gmane.org/gmane.comp.lang.ruby.region.indonesia
                > >
                >
                >
                >



                --
                Suka linux?
                Kunjungi blog saya http://penguinroad.blogspot.com


                [Non-text portions of this message have been removed]
              • syaiful sabril
                kebetulan saya juga udah nyobain Redmine, tapi pake RVM buat setting Ruby SDK dan gemsnya. http://rvm.beginrescueend.com/ di RVM saya install 1.8.7 dan 1.9.2
                Message 7 of 7 , Jan 23, 2011
                • 0 Attachment
                  kebetulan saya juga udah nyobain Redmine, tapi pake RVM buat setting Ruby SDK
                  dan gemsnya.

                  http://rvm.beginrescueend.com/

                  di RVM saya install 1.8.7 dan 1.9.2

                  > rvm list
                  => ruby-1.8.7-p302 [x86_64]
                  ruby-1.9.2-p0 [x86_64]

                  setelah install RVM dan Redmine, add Ruby SDK yang ada di ~/.rvm
                  berikutnya Redmine akan menginstall gems yang diperlukan



                  ________________________________
                  From: Fikri Ms <fikri.ms@...>
                  To: id-ruby@yahoogroups.com
                  Sent: Wed, January 5, 2011 2:44:33 PM
                  Subject: [id-ruby] Install Ruby - Rails - Redmine

                  Hello All,

                  Maaf nih, saya pemula di dunia ruby. Tertarik dengan Redmine
                  http://www.redmine.org/ utk project management. Saya belum pernah sama
                  sekali mengenal dunia ruby. Saya mencoba install di Server
                  Ubuntu 10.10, dg cara :
                  1. Install Ruby, berhubung di situs resminya sdh ada ruby1.9.1 maka
                  saya langsung aja pakai :
                  sudo apt-get install ruby1.9.1-full
                  2. Saat mau install Rails, nengok ke situsnya :
                  We recommend Ruby 1.8.7 or Ruby 1.9.2 for use with Rails. Ruby 1.8.6
                  and earlier are not supported, neither is version 1.9.1.
                  Waduuh .. ternyata 1.9.1 gak support Rails ??
                  3. Berdasarkan requirement redmine
                  http://www.redmine.org/projects/redmine/wiki/RedmineInstall disebutkan
                  bhw : Ruby yg disupport ternyata 1.8.x

                  Jadi Frustasi duluan nih ... Ada nggak langkah2 praktis Instalasi :
                  Ruby - Rails - Redmine ??

                  Thx

                  --
                  Best regards,
                  Fikri mailto:fikri.ms@...




                  ------------------------------------

                  ID-Ruby
                  Berdiskusi dan belajar bersama Bahasa Pemrograman Ruby, termasuk segala varian
                  Ruby (JRuby, Rubinius, IronRuby, XRuby), dan program yang dibuat dengan Ruby
                  (Ruby on Rails, JRuby on Rails, Merb)

                  http://rubyurl.com/Q8DD
                  http://news.gmane.org/gmane.comp.lang.ruby.region.indonesia







                  [Non-text portions of this message have been removed]
                Your message has been successfully submitted and would be delivered to recipients shortly.