Loading ...
Sorry, an error occurred while loading the content.

[id-ruby] [ASK] Error saat menjalankan aplikasi ruby 1.9.1

Expand Messages
  • Robin
    Salam teman2 pengguna Ruby di Indonesia, Saya baru saja menginstall Ruby versi 1.9.1 pada platform Win32. Kemudian saya menginstall rubygems1.3.5 dengan
    Message 1 of 4 , Dec 22, 2009
    • 0 Attachment
      Salam teman2 pengguna Ruby di Indonesia,

      Saya baru saja menginstall Ruby versi 1.9.1 pada platform Win32. Kemudian saya menginstall rubygems1.3.5 dengan menggunakan perintah "ruby setup.rb" dan setelah itu menginstall rails dan mongrel dengan perintah "gem install". Setelah semuanya selesai, saya menggunakan IDE Netbeans untuk membuat RailsApplication. Ketika saya coba jalankan di NetBeans, terjadi error dengan pesan sebagai berikut:

      => Booting WEBrick
      => Rails 2.3.5 application starting on http://0.0.0.0:3000
      C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:117:in `<module:TextUtils>': invalid multibyte character (ArgumentError)
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:110:in `<module:TMail>'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:53:in `<top (required)>'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/interface.rb:36:in `<top (required)>'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/mail.rb:34:in `<top (required)>'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail.rb:2:in `<top (required)>'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail.rb:13:in `<top (required)>'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer.rb:62:in `<top (required)>'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:268:in `block in require_frameworks'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:268:in `each'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:268:in `require_frameworks'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:134:in `process'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:113:in `run'
      from D:/Coding/RailsApplication1/config/environment.rb:9:in `<top (required)>'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
      from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/commands/server.rb:84:in `<top (required)>'
      from script/server:3:in `require'
      from script/server:3:in `<main>'


      Kemudian saya mencoba menggunakan cara lain untuk start application Rails saya dengan cara membuka command prompt dan melakukan "ruby script/server", dan muncul pesan error seperti ini :

      "This application has failed to start because msvcrt-ruby18.dll was not found. Re-installing the application may fix this problem"

      Setelah diklik "OK", muncul pesan error yang sama dengan yang terjadi pada NetBeans. Sepertinya gem masih mendetek versi ruby yang lama (1.8), padahal ruby yang saya install sekarang adalah versi (1.9). Apakah ada yang pernah mengalami kejadian yang sama dengan saya ? Solusinya bagaimana ?

      Terima kasih.

      Robin





      [Non-text portions of this message have been removed]
    • Iqbal Farabi
      Salam. Saya kebetulan pernah mengalami masalah serupa. Sepengetahuan saya, persoalannya adalah karena Ruby berusaha mencari file msvcrt-ruby18.dll tersebut,
      Message 2 of 4 , Dec 24, 2009
      • 0 Attachment
        Salam.

        Saya kebetulan pernah mengalami masalah serupa. Sepengetahuan saya,
        persoalannya adalah karena Ruby berusaha mencari file msvcrt-ruby18.dll
        tersebut, dan ternyata tidak ditemukan karena file tersebut ada pada
        instalasi Ruby 1.8. Waktu itu saya akhirnya memutuskan untuk kembali ke Ruby
        versi 1.8.x saja.

        Sebenarnya yang saya usulkan tadi tidak solutif (tidak menyelesaikan masalah
        dengan Ruby 1.9, tapi menghindarinya), tapi kalau memang ingin jalan pintas,
        monggo. Saya pernah mencoba googling tentang masalah Ruby 1.9 ini, dan tidak
        menemukan hasil yang memuaskan. Barangkali teman-teman lain di milis ini ada
        yang punya solusinya. Cheers. :D

        2009/12/22 Robin <robinchsz@...>

        >
        >
        > Salam teman2 pengguna Ruby di Indonesia,
        >
        > Saya baru saja menginstall Ruby versi 1.9.1 pada platform Win32. Kemudian
        > saya menginstall rubygems1.3.5 dengan menggunakan perintah "ruby setup.rb"
        > dan setelah itu menginstall rails dan mongrel dengan perintah "gem install".
        > Setelah semuanya selesai, saya menggunakan IDE Netbeans untuk membuat
        > RailsApplication. Ketika saya coba jalankan di NetBeans, terjadi error
        > dengan pesan sebagai berikut:
        >
        > => Booting WEBrick
        > => Rails 2.3.5 application starting on http://0.0.0.0:3000
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:117:in
        > `<module:TextUtils>': invalid multibyte character (ArgumentError)
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:110:in
        > `<module:TMail>'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:53:in
        > `<top (required)>'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `block in require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
        > `new_constants_in'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/interface.rb:36:in
        > `<top (required)>'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `block in require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
        > `new_constants_in'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail/mail.rb:34:in
        > `<top (required)>'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `block in require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
        > `new_constants_in'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail-1.2.3/tmail.rb:2:in
        > `<top (required)>'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `block in require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
        > `new_constants_in'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer/vendor/tmail.rb:13:in
        > `<top (required)>'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `block in require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
        > `new_constants_in'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/action_mailer.rb:62:in
        > `<top (required)>'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `block in require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
        > `new_constants_in'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:268:in
        > `block in require_frameworks'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:268:in
        > `each'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:268:in
        > `require_frameworks'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:134:in
        > `process'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:113:in
        > `run'
        > from D:/Coding/RailsApplication1/config/environment.rb:9:in `<top
        > (required)>'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `block in require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
        > `new_constants_in'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
        > `require'
        > from
        > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/commands/server.rb:84:in
        > `<top (required)>'
        > from script/server:3:in `require'
        > from script/server:3:in `<main>'
        >
        > Kemudian saya mencoba menggunakan cara lain untuk start application Rails
        > saya dengan cara membuka command prompt dan melakukan "ruby script/server",
        > dan muncul pesan error seperti ini :
        >
        > "This application has failed to start because msvcrt-ruby18.dll was not
        > found. Re-installing the application may fix this problem"
        >
        > Setelah diklik "OK", muncul pesan error yang sama dengan yang terjadi pada
        > NetBeans. Sepertinya gem masih mendetek versi ruby yang lama (1.8), padahal
        > ruby yang saya install sekarang adalah versi (1.9). Apakah ada yang pernah
        > mengalami kejadian yang sama dengan saya ? Solusinya bagaimana ?
        >
        > Terima kasih.
        >
        > Robin
        >
        > [Non-text portions of this message have been removed]
        >
        >
        >



        --
        Iqbal Farabi
        www.starqle.com
        iqbal@...
        farabi.iqbal@...


        [Non-text portions of this message have been removed]
      • Achmad Gozali
        http://www.learnaholic.me/2009/06/18/installing-ruby-1-9-1-rails-and-mysql-ruby-2-8-1-on-windows-7-rc-and-mysql-5-0/ In starting of server I got error again
        Message 3 of 4 , Dec 24, 2009
        • 0 Attachment
          http://www.learnaholic.me/2009/06/18/installing-ruby-1-9-1-rails-and-mysql-ruby-2-8-1-on-windows-7-rc-and-mysql-5-0/

          "In starting of server I got error again missing msvcrt-ruby18.dll,
          but on click OK server is started and everything works perfectly."

          dia bilang setelah klik OK jalan normal tuh om :)

          coba install rails versi 2.3.2 kayak dia,

          saya sendiri pake 1.9.1 tapi bukan di Windows, jalan nggak ada masalah

          --Gozali


          On Dec 24, 2009, at 4:02 PM, Iqbal Farabi wrote:

          > Salam.
          >
          > Saya kebetulan pernah mengalami masalah serupa. Sepengetahuan saya,
          > persoalannya adalah karena Ruby berusaha mencari file msvcrt-
          > ruby18.dll
          > tersebut, dan ternyata tidak ditemukan karena file tersebut ada pada
          > instalasi Ruby 1.8. Waktu itu saya akhirnya memutuskan untuk kembali
          > ke Ruby
          > versi 1.8.x saja.
          >
          > Sebenarnya yang saya usulkan tadi tidak solutif (tidak menyelesaikan
          > masalah
          > dengan Ruby 1.9, tapi menghindarinya), tapi kalau memang ingin jalan
          > pintas,
          > monggo. Saya pernah mencoba googling tentang masalah Ruby 1.9 ini,
          > dan tidak
          > menemukan hasil yang memuaskan. Barangkali teman-teman lain di milis
          > ini ada
          > yang punya solusinya. Cheers. :D
          >
          > 2009/12/22 Robin <robinchsz@...>
          >
          > >
          > >
          > > Salam teman2 pengguna Ruby di Indonesia,
          > >
          > > Saya baru saja menginstall Ruby versi 1.9.1 pada platform Win32.
          > Kemudian
          > > saya menginstall rubygems1.3.5 dengan menggunakan perintah "ruby
          > setup.rb"
          > > dan setelah itu menginstall rails dan mongrel dengan perintah "gem
          > install".
          > > Setelah semuanya selesai, saya menggunakan IDE Netbeans untuk
          > membuat
          > > RailsApplication. Ketika saya coba jalankan di NetBeans, terjadi
          > error
          > > dengan pesan sebagai berikut:
          > >
          > > => Booting WEBrick
          > > => Rails 2.3.5 application starting on http://0.0.0.0:3000
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
          > action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:117:in
          > > `<module:TextUtils>': invalid multibyte character (ArgumentError)
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
          > action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:110:in
          > > `<module:TMail>'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
          > action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:53:in
          > > `<top (required)>'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `block in require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:521:in
          > > `new_constants_in'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
          > action_mailer/vendor/tmail-1.2.3/tmail/interface.rb:36:in
          > > `<top (required)>'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `block in require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:521:in
          > > `new_constants_in'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
          > action_mailer/vendor/tmail-1.2.3/tmail/mail.rb:34:in
          > > `<top (required)>'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `block in require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:521:in
          > > `new_constants_in'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
          > action_mailer/vendor/tmail-1.2.3/tmail.rb:2:in
          > > `<top (required)>'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `block in require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:521:in
          > > `new_constants_in'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
          > action_mailer/vendor/tmail.rb:13:in
          > > `<top (required)>'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `block in require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:521:in
          > > `new_constants_in'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
          > action_mailer.rb:62:in
          > > `<top (required)>'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `block in require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:521:in
          > > `new_constants_in'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
          > 268:in
          > > `block in require_frameworks'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
          > 268:in
          > > `each'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
          > 268:in
          > > `require_frameworks'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
          > 134:in
          > > `process'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
          > 113:in
          > > `run'
          > > from D:/Coding/RailsApplication1/config/environment.rb:9:in `<top
          > > (required)>'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `block in require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:521:in
          > > `new_constants_in'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
          > active_support/dependencies.rb:156:in
          > > `require'
          > > from
          > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/commands/
          > server.rb:84:in
          > > `<top (required)>'
          > > from script/server:3:in `require'
          > > from script/server:3:in `<main>'
          > >
          > > Kemudian saya mencoba menggunakan cara lain untuk start
          > application Rails
          > > saya dengan cara membuka command prompt dan melakukan "ruby script/
          > server",
          > > dan muncul pesan error seperti ini :
          > >
          > > "This application has failed to start because msvcrt-ruby18.dll
          > was not
          > > found. Re-installing the application may fix this problem"
          > >
          > > Setelah diklik "OK", muncul pesan error yang sama dengan yang
          > terjadi pada
          > > NetBeans. Sepertinya gem masih mendetek versi ruby yang lama
          > (1.8), padahal
          > > ruby yang saya install sekarang adalah versi (1.9). Apakah ada
          > yang pernah
          > > mengalami kejadian yang sama dengan saya ? Solusinya bagaimana ?
          > >
          > > Terima kasih.
          > >
          > > Robin
          > >
          > > [Non-text portions of this message have been removed]
          > >
          > >
          > >
          >
          > --
          > Iqbal Farabi
          > www.starqle.com
          > iqbal@...
          > farabi.iqbal@...
          >
          > [Non-text portions of this message have been removed]
          >
          >
          >



          [Non-text portions of this message have been removed]
        • Robin
          Terima kasih atas infonya bro, tetapi saya sudah agak males untuk mencoba karena tetap tidak bisa. Akhirnya saya pakai ubuntu dan ruby versi 1.8 dan berjalan
          Message 4 of 4 , Dec 24, 2009
          • 0 Attachment
            Terima kasih atas infonya bro, tetapi saya sudah agak males untuk mencoba karena tetap tidak bisa. Akhirnya saya pakai ubuntu dan ruby versi 1.8 dan berjalan dengan baik. Lain kali saya akan coba sarannya. Kalau rekan2 yang lain punya solusi alternatif boleh dipost di milis juga.

            Regards,

            Robin




            ________________________________
            From: Achmad Gozali <gozali@...>
            To: id-ruby@yahoogroups.com
            Sent: Thu, December 24, 2009 6:23:21 PM
            Subject: Re: [id-ruby] [ASK] Error saat menjalankan aplikasi ruby 1.9.1

            http://www.learnaholic.me/2009/06/18/installing-ruby-1-9-1-rails-and-mysql-ruby-2-8-1-on-windows-7-rc-and-mysql-5-0/

            "In starting of server I got error again missing msvcrt-ruby18.dll,
            but on click OK server is started and everything works perfectly."

            dia bilang setelah klik OK jalan normal tuh om :)

            coba install rails versi 2.3.2 kayak dia,

            saya sendiri pake 1.9.1 tapi bukan di Windows, jalan nggak ada masalah

            --Gozali


            On Dec 24, 2009, at 4:02 PM, Iqbal Farabi wrote:

            > Salam.
            >
            > Saya kebetulan pernah mengalami masalah serupa. Sepengetahuan saya,
            > persoalannya adalah karena Ruby berusaha mencari file msvcrt-
            > ruby18.dll
            > tersebut, dan ternyata tidak ditemukan karena file tersebut ada pada
            > instalasi Ruby 1.8. Waktu itu saya akhirnya memutuskan untuk kembali
            > ke Ruby
            > versi 1.8.x saja.
            >
            > Sebenarnya yang saya usulkan tadi tidak solutif (tidak menyelesaikan
            > masalah
            > dengan Ruby 1.9, tapi menghindarinya), tapi kalau memang ingin jalan
            > pintas,
            > monggo. Saya pernah mencoba googling tentang masalah Ruby 1.9 ini,
            > dan tidak
            > menemukan hasil yang memuaskan. Barangkali teman-teman lain di milis
            > ini ada
            > yang punya solusinya. Cheers. :D
            >
            > 2009/12/22 Robin <robinchsz@...>
            >
            > >
            > >
            > > Salam teman2 pengguna Ruby di Indonesia,
            > >
            > > Saya baru saja menginstall Ruby versi 1.9.1 pada platform Win32.
            > Kemudian
            > > saya menginstall rubygems1.3.5 dengan menggunakan perintah "ruby
            > setup.rb"
            > > dan setelah itu menginstall rails dan mongrel dengan perintah "gem
            > install".
            > > Setelah semuanya selesai, saya menggunakan IDE Netbeans untuk
            > membuat
            > > RailsApplication. Ketika saya coba jalankan di NetBeans, terjadi
            > error
            > > dengan pesan sebagai berikut:
            > >
            > > => Booting WEBrick
            > > => Rails 2.3.5 application starting on http://0.0.0.0:3000
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
            > action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:117:in
            > > `<module:TextUtils>': invalid multibyte character (ArgumentError)
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
            > action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:110:in
            > > `<module:TMail>'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
            > action_mailer/vendor/tmail-1.2.3/tmail/utils.rb:53:in
            > > `<top (required)>'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `block in require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:521:in
            > > `new_constants_in'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
            > action_mailer/vendor/tmail-1.2.3/tmail/interface.rb:36:in
            > > `<top (required)>'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `block in require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:521:in
            > > `new_constants_in'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
            > action_mailer/vendor/tmail-1.2.3/tmail/mail.rb:34:in
            > > `<top (required)>'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `block in require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:521:in
            > > `new_constants_in'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
            > action_mailer/vendor/tmail-1.2.3/tmail.rb:2:in
            > > `<top (required)>'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `block in require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:521:in
            > > `new_constants_in'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
            > action_mailer/vendor/tmail.rb:13:in
            > > `<top (required)>'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `block in require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:521:in
            > > `new_constants_in'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionmailer-2.3.5/lib/
            > action_mailer.rb:62:in
            > > `<top (required)>'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `block in require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:521:in
            > > `new_constants_in'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
            > 268:in
            > > `block in require_frameworks'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
            > 268:in
            > > `each'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
            > 268:in
            > > `require_frameworks'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
            > 134:in
            > > `process'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
            > 113:in
            > > `run'
            > > from D:/Coding/RailsApplication1/config/environment.rb:9:in `<top
            > > (required)>'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `block in require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:521:in
            > > `new_constants_in'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/
            > active_support/dependencies.rb:156:in
            > > `require'
            > > from
            > > C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/commands/
            > server.rb:84:in
            > > `<top (required)>'
            > > from script/server:3:in `require'
            > > from script/server:3:in `<main>'
            > >
            > > Kemudian saya mencoba menggunakan cara lain untuk start
            > application Rails
            > > saya dengan cara membuka command prompt dan melakukan "ruby script/
            > server",
            > > dan muncul pesan error seperti ini :
            > >
            > > "This application has failed to start because msvcrt-ruby18.dll
            > was not
            > > found. Re-installing the application may fix this problem"
            > >
            > > Setelah diklik "OK", muncul pesan error yang sama dengan yang
            > terjadi pada
            > > NetBeans. Sepertinya gem masih mendetek versi ruby yang lama
            > (1.8), padahal
            > > ruby yang saya install sekarang adalah versi (1.9). Apakah ada
            > yang pernah
            > > mengalami kejadian yang sama dengan saya ? Solusinya bagaimana ?
            > >
            > > Terima kasih.
            > >
            > > Robin
            > >
            > > [Non-text portions of this message have been removed]
            > >
            > >
            > >
            >
            > --
            > Iqbal Farabi
            > www.starqle.com
            > iqbal@...
            > farabi.iqbal@...
            >
            > [Non-text portions of this message have been removed]
            >
            >
            >



            [Non-text portions of this message have been removed]



            ------------------------------------

            ID-Ruby
            Berdiskusi dan belajar bersama Bahasa Pemrograman Ruby, termasuk segala varian Ruby (JRuby, Rubinius, IronRuby, XRuby), dan program yang dibuat dengan Ruby (Ruby on Rails, JRuby on Rails, Merb)

            http://rubyurl.com/Q8DD
            http://news.gmane.org/gmane.comp.lang.ruby.region.indonesia







            [Non-text portions of this message have been removed]
          Your message has been successfully submitted and would be delivered to recipients shortly.