Loading ...
Sorry, an error occurred while loading the content.

Re: [Electronica] Hi

Expand Messages
  • Sal Aiello (UK)
    Hi Bernhix, To keep things simple, I ve reduced the circuit to not include hysteresis. I ve uploaded a schematic in Photos under the folder Sal s Stuff . The
    Message 1 of 3 , Dec 7, 2006
    • 0 Attachment
      Hi Bernhix,

      To keep things simple, I've reduced the circuit to not include
      hysteresis. I've uploaded a schematic in Photos under the
      folder 'Sal's Stuff'. The circuit is literally the LM393, +5V supply
      to the comparator and two pots, one 1Mohm for the -ve reference
      input and a 10K for the +ve input, all connected to ground. The
      output of the comparator has a 2K pull-up resistor. I've tabulated
      the results with varying reference voltages and corresponding input
      voltages that start to switch the comparator output to 'high' ( more
      or less +5V):

      Ref (-ve) Input (+ve)
      0.5V 0.55V
      1.0V 1.20V
      1.5V 1.85V
      2.0V 2.5V
      2.5V 3.10V

      I've also replaced the 1M pot with a lower value 1K pot as has been
      suggested by those more expert in electronics than myself and also
      changed the comparator for another one in the small chance that it
      was faulty, but I still get exactly the same results as above. The
      point at which the input starts to switch the output seems to be
      proportional to the reference voltage, increasing as the reference
      voltage increases. The circuit is practically the same as the many
      examples on the internet but it just doesn't seem to behave in the
      way that they say, i.e. to switch around the reference voltage! I
      can normally work things out for myself even if it means spending
      days trying to get a particular component to work, but this one has
      me totally baffled! ;o) Another thing that may shed some light is
      the fact that I have made the same circuit with a LM311N voltage
      comparator and I get more or less the same behaviour...

      Thanks,
      Salvatore

      --- In home_electronics@yahoogroups.com, Bernie Fernandez
      <bernie_a_fernandez@...> wrote:
      >
      > Hi,
      >
      > I had used an LM393 of my project before but the supply I had
      used was 12V and I never try this with 5V but I think there is no
      problem with as long as the supply is with in it parameter based on
      datasheet. If you can post your circuit is better so I could help
      you out. You need to place a pull up resistor on its output(lm393)
      because this device is an open collector. Do not test your circuit
      using breadboard, this is based on my experience, that comparator
      circuit will not work properly using breadboard connection.
      >
      > Regards,
      > Bernhix
      >
      > "Sal Aiello (UK)" <saiello@...> wrote:
      > Hi All, I've got a small project on the go and need some
      advice. It
      > concerns the use of voltage comparators, in particular the LM311
      and
      > LM393. I've got a breadboarded ( plywood and cup screws!! ) test
      setup
      > and I've managed to get both comparators to work including some
      > hysteresis, but I am still having a problem in understanding why
      they
      > won't switch around the reference voltage. The comparators are set
      up
      > with single supply, +5V from a 7805 regulator and 0V ground. The
      > reference voltage is to +ve input at 2.5V with about 0.1V
      hysteresis.
      > I vary the input voltage to the -ve input using a cermet
      > potentiometer. I expected the comparators to switch around 2.5V (
      > allowing for hysteresis), but I am finding that it will only
      switch a
      > full 0.5V below this value at around 2V. What am I doing wrong?
      Any
      > help much appreciated.
      >
      > Thanks,
      > Salvatore.
      >
      >
      >
      >
      >
      >
      > ---------------------------------
      > Want to start your own business? Learn how on Yahoo! Small
      Business.
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.