Loading ...
Sorry, an error occurred while loading the content.

API Method calls

Expand Messages
  • kmustatea
    Dear GovTrack, I m having some trouble with some of the API methods. This seems to be a successful call:
    Message 1 of 6 , Aug 6, 2012
    View Source
    • 0 Attachment
      Dear GovTrack,

      I'm having some trouble with some of the API methods.

      This seems to be a successful call:
      http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20

      However this is not:
      http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20&bill_type=house_bill

      So filtering results by bill_type does not seem to work as expected. The trouble seems to be with any parameters which do not have a * or ** next to them in the API documentation. Is a different format required for these parameters? Or are they just not available yet through the API?

      Many thanks for any clarification you can provide.
    • Josh Tauberer
      Hi, The backend is probably missing the conversion from the string constant to the proper numeric constant used in the database. I ll take a look. - Josh
      Message 2 of 6 , Aug 7, 2012
      View Source
      • 0 Attachment
        Hi,

        The backend is probably missing the conversion from the string constant
        to the proper numeric constant used in the database. I'll take a look.

        - Josh Tauberer (@JoshData)

        http://razor.occams.info

        On 08/06/2012 12:27 PM, kmustatea wrote:
        > Dear GovTrack,
        >
        > I'm having some trouble with some of the API methods.
        >
        > This seems to be a successful call:
        > http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20
        >
        > However this is not:
        > http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20&bill_type=house_bill
        >
        > So filtering results by bill_type does not seem to work as expected. The trouble seems to be with any parameters which do not have a * or ** next to them in the API documentation. Is a different format required for these parameters? Or are they just not available yet through the API?
        >
        > Many thanks for any clarification you can provide.
        >
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
      • kmustatea
        Do you have an idea of how long it might take to fix this?
        Message 3 of 6 , Aug 31, 2012
        View Source
        • 0 Attachment
          Do you have an idea of how long it might take to fix this?

          --- In govtrack@yahoogroups.com, Josh Tauberer <tauberer@...> wrote:
          >
          > Hi,
          >
          > The backend is probably missing the conversion from the string constant
          > to the proper numeric constant used in the database. I'll take a look.
          >
          > - Josh Tauberer (@JoshData)
          >
          > http://razor.occams.info
          >
          > On 08/06/2012 12:27 PM, kmustatea wrote:
          > > Dear GovTrack,
          > >
          > > I'm having some trouble with some of the API methods.
          > >
          > > This seems to be a successful call:
          > > http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20
          > >
          > > However this is not:
          > > http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20&bill_type=house_bill
          > >
          > > So filtering results by bill_type does not seem to work as expected. The trouble seems to be with any parameters which do not have a * or ** next to them in the API documentation. Is a different format required for these parameters? Or are they just not available yet through the API?
          > >
          > > Many thanks for any clarification you can provide.
          > >
          > >
          > >
          > > ------------------------------------
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          >
        • Josh Tauberer
          Try now. Sorry I lost track of this issue. - Josh Tauberer (@JoshData) http://razor.occams.info
          Message 4 of 6 , Aug 31, 2012
          View Source
          • 0 Attachment
            Try now. Sorry I lost track of this issue.

            - Josh Tauberer (@JoshData)

            http://razor.occams.info

            On 08/31/2012 11:05 AM, kmustatea wrote:
            > Do you have an idea of how long it might take to fix this?
            >
            > --- In govtrack@yahoogroups.com, Josh Tauberer <tauberer@...> wrote:
            >> Hi,
            >>
            >> The backend is probably missing the conversion from the string constant
            >> to the proper numeric constant used in the database. I'll take a look.
            >>
            >> - Josh Tauberer (@JoshData)
            >>
            >> http://razor.occams.info
            >>
            >> On 08/06/2012 12:27 PM, kmustatea wrote:
            >>> Dear GovTrack,
            >>>
            >>> I'm having some trouble with some of the API methods.
            >>>
            >>> This seems to be a successful call:
            >>> http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20
            >>>
            >>> However this is not:
            >>> http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20&bill_type=house_bill
            >>>
            >>> So filtering results by bill_type does not seem to work as expected. The trouble seems to be with any parameters which do not have a * or ** next to them in the API documentation. Is a different format required for these parameters? Or are they just not available yet through the API?
            >>>
            >>> Many thanks for any clarification you can provide.
            >>>
            >>>
            >>>
            >>> ------------------------------------
            >>>
            >>> Yahoo! Groups Links
            >>>
            >>>
            >>>
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
          • kmustatea
            This call doesn t seem to work (it s one of the examples given in the documentation). The problem is with the Option parameter, I think.
            Message 5 of 6 , Sep 5, 2012
            View Source
            • 0 Attachment
              This call doesn't seem to work (it's one of the examples given in the documentation). The problem is with the Option parameter, I think.

              http://www.govtrack.us/api/v1/vote_voter/?person=400222&option=0&limit=1000&order_by=created

              --- In govtrack@yahoogroups.com, Josh Tauberer <tauberer@...> wrote:
              >
              > Try now. Sorry I lost track of this issue.
              >
              > - Josh Tauberer (@JoshData)
              >
              > http://razor.occams.info
              >
              > On 08/31/2012 11:05 AM, kmustatea wrote:
              > > Do you have an idea of how long it might take to fix this?
              > >
              > > --- In govtrack@yahoogroups.com, Josh Tauberer <tauberer@> wrote:
              > >> Hi,
              > >>
              > >> The backend is probably missing the conversion from the string constant
              > >> to the proper numeric constant used in the database. I'll take a look.
              > >>
              > >> - Josh Tauberer (@JoshData)
              > >>
              > >> http://razor.occams.info
              > >>
              > >> On 08/06/2012 12:27 PM, kmustatea wrote:
              > >>> Dear GovTrack,
              > >>>
              > >>> I'm having some trouble with some of the API methods.
              > >>>
              > >>> This seems to be a successful call:
              > >>> http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20
              > >>>
              > >>> However this is not:
              > >>> http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20&bill_type=house_bill
              > >>>
              > >>> So filtering results by bill_type does not seem to work as expected. The trouble seems to be with any parameters which do not have a * or ** next to them in the API documentation. Is a different format required for these parameters? Or are they just not available yet through the API?
              > >>>
              > >>> Many thanks for any clarification you can provide.
              > >>>
              > >>>
              > >>>
              > >>> ------------------------------------
              > >>>
              > >>> Yahoo! Groups Links
              > >>>
              > >>>
              > >>>
              > >
              > >
              > >
              > > ------------------------------------
              > >
              > > Yahoo! Groups Links
              > >
              > >
              > >
              >
            • Josh Tauberer
              Thanks. The last fix broke that parameter (internally it is a complicated mapping to a different database column). Should be working now. - Josh Tauberer
              Message 6 of 6 , Sep 5, 2012
              View Source
              • 0 Attachment
                Thanks. The last fix broke that parameter (internally it is a
                complicated mapping to a different database column).

                Should be working now.

                - Josh Tauberer (@JoshData)

                http://razor.occams.info

                On 09/05/2012 10:07 AM, kmustatea wrote:
                > This call doesn't seem to work (it's one of the examples given in the documentation). The problem is with the Option parameter, I think.
                >
                > http://www.govtrack.us/api/v1/vote_voter/?person=400222&option=0&limit=1000&order_by=created
                >
                > --- In govtrack@yahoogroups.com, Josh Tauberer <tauberer@...> wrote:
                >> Try now. Sorry I lost track of this issue.
                >>
                >> - Josh Tauberer (@JoshData)
                >>
                >> http://razor.occams.info
                >>
                >> On 08/31/2012 11:05 AM, kmustatea wrote:
                >>> Do you have an idea of how long it might take to fix this?
                >>>
                >>> --- In govtrack@yahoogroups.com, Josh Tauberer <tauberer@> wrote:
                >>>> Hi,
                >>>>
                >>>> The backend is probably missing the conversion from the string constant
                >>>> to the proper numeric constant used in the database. I'll take a look.
                >>>>
                >>>> - Josh Tauberer (@JoshData)
                >>>>
                >>>> http://razor.occams.info
                >>>>
                >>>> On 08/06/2012 12:27 PM, kmustatea wrote:
                >>>>> Dear GovTrack,
                >>>>>
                >>>>> I'm having some trouble with some of the API methods.
                >>>>>
                >>>>> This seems to be a successful call:
                >>>>> http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20
                >>>>>
                >>>>> However this is not:
                >>>>> http://www.govtrack.us/api/v1/bill/?congress=112&order_by=-current_status_date&offset=20&bill_type=house_bill
                >>>>>
                >>>>> So filtering results by bill_type does not seem to work as expected. The trouble seems to be with any parameters which do not have a * or ** next to them in the API documentation. Is a different format required for these parameters? Or are they just not available yet through the API?
                >>>>>
                >>>>> Many thanks for any clarification you can provide.
                >>>>>
                >>>>>
                >>>>>
                >>>>> ------------------------------------
                >>>>>
                >>>>> Yahoo! Groups Links
                >>>>>
                >>>>>
                >>>>>
                >>>
                >>>
                >>> ------------------------------------
                >>>
                >>> Yahoo! Groups Links
                >>>
                >>>
                >>>
                >
                >
                > ------------------------------------
                >
                > Yahoo! Groups Links
                >
                >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.