Loading ...
Sorry, an error occurred while loading the content.

hebrew in Gnome and KDE

Expand Messages
  • meir michanie
    My configuration: RH 7.2 kernel 2.4.9 Ximian KDE 2.2.2/1 (I am not sure) hi there, while trying to set up hebrew support on KDE, it works but after I restart
    Message 1 of 2 , Mar 31, 2002
    • 0 Attachment
      My configuration:
      RH 7.2
      kernel 2.4.9
      Ximian
      KDE 2.2.2/1 (I am not sure)


      hi there, while trying to set up hebrew support on KDE, it works but after I
      restart the X server I can not open the terminal, the control panel, etc, so
      I run
      rm -rf .kde*
      and then It works but back in US.

      on Gnome, it seems that I am missing something.
      I have hebrew fonts installed,
      running xmodmap /usr/share/xmodmap/xmodmap.il
      and then gfontsel
      I can type hebrew letters
      but
      back in the terminal I get other encoding, no hebrew.
      In gedit when ever I tried to choose the iso8859-8 it is unselectable.
      I am using Ximian.
      another wierd thing is when using the international keyboard applet, i can
      not choose the iso8859-8 even do I can from the xfontsel.
      I heard that Diego wrote a hebrew how to, url?
      thanks.





      _________________________________________________________________
      Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.
    • Diego Iastrubni
      meir michanie , I could not send this message directly, my guess is that actcom is fucked up somewehere, since it s the 2nd mail
      Message 2 of 2 , Apr 2, 2002
      • 0 Attachment
        "meir michanie" <meirmichanie@...>, I could not send this message
        directly, my guess is that actcom is fucked up somewehere, since it's the 2nd
        mail which does not arrive.

        hi,

        the url was posted, here it is again.
        http://dgi_il.tripod.com/linux/hebrew-howto.tar.gz

        hopefull it will help you, but I doubt it, since you apparently did what I
        have written. my how-to concentrates more on kde, and some specific programs,
        and is rather big (~800kb) since it contains a few pictures, my guess is that
        it would look great printed some day. hope you have konqueror/mozilla, since
        it is logical hebrew.

        kde2 has a bug in which you set hebrew and kde does not load. I mean you can
        see unicode hebrew, but when setting the locale to iso8859-8 it dies.
        (control centre/look and feel/chaset). Deleting the kde configuration files,
        it will default again to iso8859-1 and loading OK, but you probably know this
        by now. Try d/l kde3 this weekend, I have been bug hunt since alpha, and it's
        great. (currently got back to 2.2. since I used a windows program to access
        ext2 and letting it kill my linux partition). very recommended.

        as for gnome:
        edit /etc/sysconfig/i18n, to include hebrew, and then gnome will input hebrew.
        LC_CTYPE=he_IL biditext gedit
        is your friend, let me know how it works. I am having problem with this one
        (seeing backwards bla bla bla...), xchat works fine though. install elmar
        fonts since they have good monospaced hebrew fonts.

        -diego
        --
        Abbott's Admonitions:
        (1) If you have to ask, you're not entitled to know.
        (2) If you don't like the answer, you shouldn't have asked the question.
        -- Charles Abbot, dean, University of Virginia

        On Sunday 31 March 2002 19:00, meir michanie wrote:
        > My configuration:
        > RH 7.2
        > kernel 2.4.9
        > Ximian
        > KDE 2.2.2/1 (I am not sure)
        >
        >
        > hi there, while trying to set up hebrew support on KDE, it works but after
        > I restart the X server I can not open the terminal, the control panel, etc,
        > so I run
        > rm -rf .kde*
        > and then It works but back in US.
        >
        > on Gnome, it seems that I am missing something.
        > I have hebrew fonts installed,
        > running xmodmap /usr/share/xmodmap/xmodmap.il
        > and then gfontsel
        > I can type hebrew letters
        > but
        > back in the terminal I get other encoding, no hebrew.
        > In gedit when ever I tried to choose the iso8859-8 it is unselectable.
        > I am using Ximian.
        > another wierd thing is when using the international keyboard applet, i can
        > not choose the iso8859-8 even do I can from the xfontsel.
        > I heard that Diego wrote a hebrew how to, url?
        > thanks.
      Your message has been successfully submitted and would be delivered to recipients shortly.