Loading ...
Sorry, an error occurred while loading the content.

KDE, Galeon & Hebrew

Expand Messages
  • Nigel Ridley
    Why can I type Hebrew into forms/boxes in Galeon but not using any text editor or word processor in KDE? - I just get lots of ???????????? instead of Hebrew
    Message 1 of 9 , Mar 1, 2002
    • 0 Attachment
      Why can I type Hebrew into forms/boxes in Galeon but not using any text
      editor or word processor in KDE? - I just get lots of ???????????? instead
      of Hebrew letters (I have a Hebrew keyboard and have configured KDE
      [2.2.2] to use it - switching between the US and Israeli flags on the
      right of the KDE panel). Will KDE 3 support Hebrew better?
      I really would like to be able to encourage others on my kibbutz to try
      Linux but without real support for Hebrew it's difficult.

      Nigel.
      Kibbutz Ramat Hakovesh
    • Tzafrir Cohen
      ... Do you have the same problem with mozilla? What versions of Galeon and of Mozilla do you have? Older versions of mozilla (
      Message 2 of 9 , Mar 1, 2002
      • 0 Attachment
        On Fri, 1 Mar 2002, Nigel Ridley wrote:

        > Why can I type Hebrew into forms/boxes in Galeon but not using any text
        > editor or word processor in KDE? - I just get lots of ???????????? instead
        > of Hebrew letters (I have a Hebrew keyboard and have configured KDE
        > [2.2.2] to use it - switching between the US and Israeli flags on the
        > right of the KDE panel). Will KDE 3 support Hebrew better?

        Do you have the same problem with mozilla?

        What versions of Galeon and of Mozilla do you have?

        Older versions of mozilla (<= 0.9.1 IIRC) had a similar problem. I'm not
        sure if it should have affected galeon. I believe that forms and such are
        not handled by gecko (the part of mozilla that galeon uses: the HTML
        renderer)

        This also may be an issue of keyboard mapping that is layers that are
        lower than KDE. See:

        http://www.iglu.org.il/faq/cache/85.html

        (the test with xev)

        --
        Tzafrir Cohen
        mailto:tzafrir@...
        http://www.technion.ac.il/~tzafrir
      • Nigel Ridley
        On Fri, 1 Mar 2002 23:02:14 +0200 (IST) ... text editor or word processor in KDE? - I just get lots of ???????????? instead of Hebrew letters (I have a
        Message 3 of 9 , Mar 1, 2002
        • 0 Attachment
          On Fri, 1 Mar 2002 23:02:14 +0200 (IST)
          Tzafrir Cohen <tzafrir@...> wrote:

          > On Fri, 1 Mar 2002, Nigel Ridley wrote:
          >
          > > Why can I type Hebrew into forms/boxes in Galeon but not using any
          text> > editor or word processor in KDE? - I just get lots of ????????????
          instead> > of Hebrew letters (I have a Hebrew keyboard and have configured
          KDE> > [2.2.2] to use it - switching between the US and Israeli flags on
          the> > right of the KDE panel). Will KDE 3 support Hebrew better?
          >
          > Do you have the same problem with mozilla?
          >
          > What versions of Galeon and of Mozilla do you have?
          >
          > Older versions of mozilla (<= 0.9.1 IIRC) had a similar problem. I'm not
          > sure if it should have affected galeon. I believe that forms and such
          are> not handled by gecko (the part of mozilla that galeon uses: the HTML
          > renderer)
          >
          > This also may be an issue of keyboard mapping that is layers that are
          > lower than KDE. See:
          >
          > http://www.iglu.org.il/faq/cache/85.html
          >
          > (the test with xev)
          >
          > --
          > Tzafrir Cohen
          > mailto:tzafrir@...
          > http://www.technion.ac.il/~tzafrir
          >


          Sorry, perhaps I should have been clearer:
          Now that I can type Hebrew into Galeon (I'm not sure about Mozilla - and
          it doesn't really matter for me), I want to be able to type Hebrew into a
          text editor such as Kate or KWord but I just get the ?????????????
          everytime. The question is "how come it works in Galeon but not in Kate or
          KWord?"

          > This also may be an issue of keyboard mapping that is layers that are
          > lower than KDE. See:
          >
          > http://www.iglu.org.il/faq/cache/85.html
          >
          > (the test with xev)

          I read the above before I wrote to the list but if I can type Hebrew OK
          into Galeon then the keyboard mapping is OK - no?

          I am running Mandrake 8.1 with Galeon 1.0.2 - Mozilla/5.0 (X11; U; Linux
          i686; en-US; rv:0.9.7) Gecko/20011221

          Nigel
        • Gil Elad
          look at http://iglu.org.il/faq/cache/143.html Gil Elad
          Message 4 of 9 , Mar 2, 2002
          • 0 Attachment
            look at http://iglu.org.il/faq/cache/143.html

            Gil Elad

            Nigel Ridley wrote:
            > Why can I type Hebrew into forms/boxes in Galeon but not using any text
            > editor or word processor in KDE? - I just get lots of ???????????? instead
            > of Hebrew letters (I have a Hebrew keyboard and have configured KDE
            > [2.2.2] to use it - switching between the US and Israeli flags on the
            > right of the KDE panel). Will KDE 3 support Hebrew better?
            > I really would like to be able to encourage others on my kibbutz to try
            > Linux but without real support for Hebrew it's difficult.
            >
            > Nigel.
            > Kibbutz Ramat Hakovesh
          • Nigel Ridley
            On Sat, 02 Mar 2002 12:00:29 +0200 ... text editor or word processor in KDE? - I just get lots of ???????????? instead of Hebrew letters (I have a Hebrew
            Message 5 of 9 , Mar 2, 2002
            • 0 Attachment
              On Sat, 02 Mar 2002 12:00:29 +0200
              Gil Elad <gilelad@...> wrote:

              > look at http://iglu.org.il/faq/cache/143.html
              >
              > Gil Elad
              >
              > Nigel Ridley wrote:
              > > Why can I type Hebrew into forms/boxes in Galeon but not using any
              text> > editor or word processor in KDE? - I just get lots of ????????????
              instead> > of Hebrew letters (I have a Hebrew keyboard and have configured
              KDE> > [2.2.2] to use it - switching between the US and Israeli flags on
              the> > right of the KDE panel). Will KDE 3 support Hebrew better?
              > > I really would like to be able to encourage others on my kibbutz to
              try> > Linux but without real support for Hebrew it's difficult.
              > >
              > > Nigel.
              > > Kibbutz Ramat Hakovesh
              >
              >
              > Yahoo! Groups Sponsor
              > ADVERTISEMENT
              >
              >
              >
              > To unsubscribe from this group, send an email to:
              > gnubies-il-unsubscribe@egroups.com
              >
              >
              >
              > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

              Thanks, I now understand that it is best to upgrade to QT version 2.3

              Nigel.
            • Nigel Ridley
              On Sat, 02 Mar 2002 12:00:29 +0200 ... text editor or word processor in KDE? - I just get lots of ???????????? instead of Hebrew letters (I have a Hebrew
              Message 6 of 9 , Mar 2, 2002
              • 0 Attachment
                On Sat, 02 Mar 2002 12:00:29 +0200
                Gil Elad <gilelad@...> wrote:

                > look at http://iglu.org.il/faq/cache/143.html
                >
                > Gil Elad
                >
                > Nigel Ridley wrote:
                > > Why can I type Hebrew into forms/boxes in Galeon but not using any
                text> > editor or word processor in KDE? - I just get lots of ????????????
                instead> > of Hebrew letters (I have a Hebrew keyboard and have configured
                KDE> > [2.2.2] to use it - switching between the US and Israeli flags on
                the> > right of the KDE panel). Will KDE 3 support Hebrew better?
                > > I really would like to be able to encourage others on my kibbutz to
                try> > Linux but without real support for Hebrew it's difficult.
                > >
                > > Nigel.
                > > Kibbutz Ramat Hakovesh

                OK. I already have QT 2.3.1 and still have ????? when I try to type
                Hebrew. I changed to ISO-8859-8, through KDE's *Control
                Center*>Personalization>Country & Language, but it messed up the fonts and
                when I logged out and then back in again I kept getting the KDE crash
                window with the following:

                (no debugging symbols found)...[New Thread 1024 (LWP 2241)]
                0x40e3a4f9 in wait4 () from /lib/libc.so.6
                #0 0x40e3a4f9 in wait4 () from /lib/libc.so.6
                #1 0x40eb8098 in __check_rhosts_file () from /lib/libc.so.6
                #2 0x405f3c6e in KCrash::defaultCrashHandler () from
                /usr/lib/libkdecore.so.3#3 0x40d4b847 in _IO_2_1_stderr_ () from
                /usr/lib/libstdc++-libc6.2-2.so.3

                I also couldn't get back into *Control Center*>Personalization>Country &
                Language as it crashed every time that I clicked on the *Country &
                Language* section. I eventually edited my
                /home/nigel/.kde/share/config/kdeglobals file and managed to get it back
                to (nearly) the way it was - the fonts on the KDE Panel are, I think, AD
                Mono, and horrible! I have yet to figure out how to change them :-(

                Anyway, if someone could post a copy of (the relevant part of)
                .kde/share/config/kdeglobals file it would help me to get Hebrew working
                propely. Here is mine:

                [Locale]
                Charset=iso8859-1
                Country=il
                Language=C

                [PanelIcons]
                Size=16

                [Paths]
                Trash=/home/nigel/Desktop/Trash/

                [WM]
                activeFont=helvetica,12,5,0,75,0
                activeFontCharset=default

                I did try Language=he but it didn't seem to change anything.

                Nigel.
              • Tzafrir Cohen
                ... Change this to ISO-10646-1 If you can t local the control interface, try editing .kde/share/config/.kdeglobals What I currently have, but I don t use KDE
                Message 7 of 9 , Mar 2, 2002
                • 0 Attachment
                  On Sat, 2 Mar 2002, Nigel Ridley wrote:

                  > On Sat, 02 Mar 2002 12:00:29 +0200
                  > Gil Elad <gilelad@...> wrote:
                  >
                  > > look athttp://iglu.org.il/faq/cache/143.html
                  > >
                  > > Gil Elad
                  > >
                  > > Nigel Ridley wrote:
                  > > > Why can I type Hebrew into forms/boxes in Galeon but not using any
                  > text> > editor or word processor in KDE? - I just get lots of ????????????
                  > instead> > of Hebrew letters (I have a Hebrew keyboard and have configured
                  > KDE> > [2.2.2] to use it - switching between the US and Israeli flags on
                  > the> > right of the KDE panel). Will KDE3 support Hebrew better?
                  > > > I really would like to be able to encourage others on my kibbutz to
                  > try> > Linux but without real support for Hebrew it's difficult.
                  > > >
                  > > > Nigel.
                  > > > Kibbutz Ramat Hakovesh
                  >
                  > OK. I already have QT 2.3.1 and still have????? when I try to type
                  > Hebrew. I changed to ISO-8859-8, through KDE's *Control

                  Change this to ISO-10646-1

                  If you can't local the control interface, try editing
                  .kde/share/config/.kdeglobals

                  What I currently have, but I don't use KDE on this machine:

                  [Locale]
                  Charset=iso10646-1
                  Country=il
                  Language=C

                  (I believe I set Langage="C" either to have translation set from the
                  environment LC settings or not to use translation at all. Those would give
                  a different effect in my case)

                  > Center*>Personalization>Country & Language, but it messed up the fonts and
                  > when I logged out and then back in again I kept getting the KDE crash
                  > window with the following:

                  Expected. Is this not in the FAQ, BTW?

                  >
                  > [WM]
                  > activeFont=helvetica,12,5,0,75,0
                  > activeFontCharset=default

                  Actually, there are "Font" options apread all over that directory, but the
                  global fonts setting are saved in $HOME/.kderc

                  The following is from the .kderc of the same computer. It is set to give
                  fonts that are avilable generaly anywhere (assuming you have a fairly
                  recent XFree):

                  [General]
                  StandardFont=fixed,12,5,22,0,0
                  activeFont=fixed,14,5,22,50,0
                  fixed=fixed,12,5,22,2,0
                  font=fixed,13,5,22,0,0
                  menuFont=fixed,13,5,22,0,0
                  toolBarFont=fixed,13,5,22,0,0

                  I figure you should use Arial for everything except the fixed font, and
                  Courier New for the fixed font. I believe that '22' in the line above
                  means 'iso-10646-1' in some internal QT or KDE enumaration. But I never
                  checked this.

                  >
                  > I did try Language=he but it didn't seem to change anything.

                  --
                  Tzafrir Cohen
                  mailto:tzafrir@...
                  http://www.technion.ac.il/~tzafrir
                • Nigel Ridley
                  On Sat, 2 Mar 2002 19:01:49 +0200 (IST) ... ???????????? instead of Hebrew letters (I have a Hebrew keyboard and have configured KDE [2.2.2] to use
                  Message 8 of 9 , Mar 2, 2002
                  • 0 Attachment
                    On Sat, 2 Mar 2002 19:01:49 +0200 (IST)
                    Tzafrir Cohen <tzafrir@...> wrote:

                    > On Sat, 2 Mar 2002, Nigel Ridley wrote:
                    >
                    > > On Sat, 02 Mar 2002 12:00:29 +0200
                    > > Gil Elad <gilelad@...> wrote:
                    > >
                    > > > look athttp://iglu.org.il/faq/cache/143.html
                    > > >
                    > > > Gil Elad
                    > > >
                    > > > Nigel Ridley wrote:
                    > > > > Why can I type Hebrew into forms/boxes in Galeon but not using any
                    > > text> > editor or word processor in KDE? - I just get lots of
                    ????????????> > instead> > of Hebrew letters (I have a Hebrew keyboard and
                    have configured> > KDE> > [2.2.2] to use it - switching between the US and
                    Israeli flags on> > the> > right of the KDE panel). Will KDE3 support
                    Hebrew better?> > > > I really would like to be able to encourage others
                    on my kibbutz to> > try> > Linux but without real support for Hebrew it's
                    difficult.> > > >
                    > > > > Nigel.
                    > > > > Kibbutz Ramat Hakovesh
                    > >
                    > > OK. I already have QT 2.3.1 and still have????? when I try to type
                    > > Hebrew. I changed to ISO-8859-8, through KDE's *Control
                    >
                    > Change this to ISO-10646-1
                    >
                    > If you can't local the control interface, try editing
                    > .kde/share/config/.kdeglobals
                    >
                    > What I currently have, but I don't use KDE on this machine:
                    >
                    > [Locale]
                    > Charset=iso10646-1
                    > Country=il
                    > Language=C
                    >
                    > (I believe I set Langage="C" either to have translation set from the
                    > environment LC settings or not to use translation at all. Those would
                    give> a different effect in my case)
                    >
                    > > Center*>Personalization>Country & Language, but it messed up the fonts
                    and> > when I logged out and then back in again I kept getting the KDE
                    crash> > window with the following:
                    >
                    > Expected. Is this not in the FAQ, BTW?
                    >
                    > >
                    > > [WM]
                    > > activeFont=helvetica,12,5,0,75,0
                    > > activeFontCharset=default
                    >
                    > Actually, there are "Font" options apread all over that directory, but
                    the> global fonts setting are saved in $HOME/.kderc
                    >
                    > The following is from the .kderc of the same computer. It is set to give
                    > fonts that are avilable generaly anywhere (assuming you have a fairly
                    > recent XFree):
                    >
                    > [General]
                    > StandardFont=fixed,12,5,22,0,0
                    > activeFont=fixed,14,5,22,50,0
                    > fixed=fixed,12,5,22,2,0
                    > font=fixed,13,5,22,0,0
                    > menuFont=fixed,13,5,22,0,0
                    > toolBarFont=fixed,13,5,22,0,0
                    >
                    > I figure you should use Arial for everything except the fixed font, and
                    > Courier New for the fixed font. I believe that '22' in the line above
                    > means 'iso-10646-1' in some internal QT or KDE enumaration. But I never
                    > checked this.
                    >
                    > >
                    > > I did try Language=he but it didn't seem to change anything.
                    >
                    > --
                    > Tzafrir Cohen
                    > mailto:tzafrir@...
                    > http://www.technion.ac.il/~tzafrir

                    I tried what you suggested with the iso-10646-1 but I don't have Arial
                    fonts and the ISO-8859-8, along with all the Hebrew fonts, has dissapeared
                    from the font list under KDE's Control Center!? Now I don't have Hebrew
                    typing ability in Galeon anymore - nothing - not even gibberish. I'll keep
                    trying though ..........

                    Nigel.
                  • Tzafrir Cohen
                    ... You should have misc-fixed of charsets iso-8859-8 and iso-10646-1 . It is generally readable enough (At least if you don t try to resize it, and stick to
                    Message 9 of 9 , Mar 2, 2002
                    • 0 Attachment
                      On Sat, 2 Mar 2002, Nigel Ridley wrote:

                      > I tried what you suggested with the iso-10646-1 but I don't have Arial
                      > fonts and the ISO-8859-8, along with all the Hebrew fonts, has dissapeared
                      > from the font list under KDE's Control Center!? Now I don't have Hebrew
                      > typing ability in Galeon anymore - nothing - not even gibberish. I'll keep
                      > trying though ..........

                      You should have misc-fixed of charsets iso-8859-8 and iso-10646-1 . It is
                      generally readable enough (At least if you don't try to resize it, and
                      stick to the point sizes of 12 or 13)

                      Under KDE you should generally use iso-10646-1 .

                      You should seperate keyboard mapping from fonts. Those are two separate
                      issues.

                      Note that galeon shares almost no configuration with KDE.

                      I would also recommend not to use kxkb, as it is badly designed (and thus
                      its keyboard switching may be slow) and use standard Xkd switching (as
                      recommended in the IGLU FAQ.

                      --
                      Tzafrir Cohen
                      mailto:tzafrir@...
                      http://www.technion.ac.il/~tzafrir
                    Your message has been successfully submitted and would be delivered to recipients shortly.