Loading ...
Sorry, an error occurred while loading the content.

Re: Fw: [gnubies-il] Re: what went wrong on my pppd? [or what is /etc/pam.d/system-auth]

Expand Messages
  • Adi Schwartz
    hello Tzafrir thank you very much for giving time to help me. im running R.H 6.2 yes i know its an old dist but is the latest version dist that i have. the
    Message 1 of 3 , Jul 31, 2001
    • 0 Attachment
      hello Tzafrir
      thank you very much for giving time to help me.

      im running R.H 6.2 yes i know its an old dist but is the latest version dist
      that i have.

      the updated packet is from R.H`s site and the latest ppp version there is
      2.3
      as for your memory, i think you are right, version 2.4 does need ppp>=2.4
      but i cant find that version.

      the funny thing is that i used to be able to log into the internet with
      kernel 2.4
      but now i cant do this any more even with version 2.4

      adi.
      ----- Original Message -----
      From: Tzafrir Cohen <tzafrir@...>
      To: gnubies <gnubies-il@yahoogroups.com>
      Sent: Monday, July 30, 2001 9:53 PM
      Subject: Re: Fw: [gnubies-il] Re: what went wrong on my pppd? [or what is
      /etc/pam.d/system-auth]


      > On Mon, 30 Jul 2001, Adi Schwartz wrote:
      >
      > > well
      > > ive tried it out but with no use i still cant log on to the internet.
      > > i thought maybe it was another reason ..
      > > maybe my ppp is not updated
      > >
      > > i think that the latest packet is ppp-2.3.11-7 when ive tried to install
      it
      > > i got this Error!!
      > >
      > > [root@localhost Linux]# rpm -U ppp-2.3.11-7.i386.rpm
      > > error: failed dependencies:
      > > /etc/pam.d/system-auth is needed by ppp-2.3.11-7
      > >
      > > Does any one knows what system-auth is??
      >
      > PAM stands for Pluggable Authentication Modules. It is a library that
      > controls the way users are authnenticated by variuss programs (e.g: if you
      > ever wanted a passwrd-less user for gdm - you can easily achive it using
      > pam configs)
      >
      > The system-auth package gives /etc/pam.d/system-auth . It is a pam config
      > file that is "included" by the default PAM configs (at least with
      > mandrake, beginning with version 7.1, I believe).
      >
      > So you are either installing newer packages from the updates directory (in
      > this case, you should also install the "pam" package from there) or you're
      > trying to install a package from a newer version of your distro, which
      > generally may not work easily, and is not recomended (if there are better
      > alternatives).
      >
      > Where is this package from?
      >
      > What distribution do you use?
      >
      > >
      > > Im adding too the file that ive add last time to inspire the bright idea
      > > that will Help me Get it Right This Time
      > >
      > > ==============================================
      > > Jul 28 17:33:37 localhost pppd[1671]: pppd 2.3.11 started by root, uid 0
      > > Jul 28 17:33:37 localhost pppd[1671]: ioctl(TIOCSETD): Invalid
      argument(22)
      > > Jul 28 17:33:37 localhost pppd[1671]: Exit.
      > >
      > > [root@localhost /root]# pppstats
      > > pppstats: nonexistent interface 'ppp0' specified
      >
      > Also I seem to recall that kernel 2.4 requires pppd version >= 2.4 (I
      > believe that the version number matching is pure coincinnce, though).
      >
      > Although you say that you have connected previously with 2.4.0 . What
      > version of ppp have you used then?
      >
      > > > > ive compiled a new kernel with ppp support.
      > > > > the old kernel which i had compiled had worked just fine and could
      > > > > get on the internet without a problem .but now i cant seem to get it
      > > > > work right!!
      > > > > the old kernel was 2.4.0.
      > > > > the new oneis 2.4.5 ive even tried to compile the 2.4.0 again but
      > > > > with no use.
      >
      > --
      > Tzafrir Cohen
      > mailto:tzafrir@...
      > http://www.technion.ac.il/~tzafrir
      >
      >
      >
      > To unsubscribe from this group, send an email to:
      > gnubies-il-unsubscribe@egroups.com
      >
      >
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.