Loading ...
Sorry, an error occurred while loading the content.
 

Re: [gnubies-il] Hebrew keyboard

Expand Messages
  • Shlomi Fish
    Hi Chaim, On Thu, 22 Sep 2011 21:51:44 +0300 ... that s because files with a leading period ( . ) are considered hidden. ... OK, I should note that generally
    Message 1 of 7 , Sep 23 12:04 AM
      Hi Chaim,

      On Thu, 22 Sep 2011 21:51:44 +0300
      Chaim Seymour <chaim.seymour@...> wrote:

      > Hi all
      >
      > Many thanks to Shlomi. I still seem to need your collective wisdom.
      >
      > I set up the file: .Xkbmap. I took the content from the editor by
      > cut/paste. I don't see the file in my file-cabinet,

      that's because files with a leading period (".") are considered hidden.

      > but the xterminal
      > reads it when I give a 'more' command.
      >

      OK, I should note that generally the "less" command is superior to more and you
      should use it instead. To exit it press "q".

      > I installed SBL Hebrew and can see it in the list of fonts within Open
      > Office.
      >
      > However, I still don't have Hebrew printing in Open Office, Xterminal,
      > Chrome or Evolution.

      Do you mean Hebrew "typing" (הקלדה) rather than Hebrew "printing" (הדפסה)? If
      so, you should try restarting your X session for the ".Xkbmap" file to take
      effect.

      You can apply such a file immediately by saying:

      $ setxkbmap $(cat .Xkbmap)

      But this won't test that it is a permanent change.

      Regards,

      Shlomi Fish

      >
      > I must be doing something wrong. Does anybody have any ideas?
      >
      > Chaim
      >
      > On ה', 2011-09-22 at 12:38 +0300, Shlomi Fish wrote:
      > > Hi Chaim,
      > >
      > > On Thu, 22 Sep 2011 09:14:55 -0000
      > > "chaim.seymour" <chaim.seymour@...> wrote:
      > >
      > > > Hi
      > > >
      > > > I am a super-gnuby. I am learning as I go along.
      > > >
      > > > So far I succeed in installing the Fedora 15 with Hebrew support. I can read Hebrew and all my menus are in Hebrew but I can't write Hebrew.
      > > >
      > > > I tried a search and found all the answers were KDE. The Fedora uses Gnome 3. Can anybody help me with a simple answer how to solve the Hebrew writing problem?
      > > >
      > >
      > > Try putting this line in a text file called .Xkbmap (note the "." and the
      > > capital "X") in your home directory:
      > >
      > > «
      > > -option compose:ralt,grp:switch,grp:alt_shift_toggle,grp_led:scroll
      > > -variant ,lyx us,il »
      > >
      > > Then you'll be able to type LeftAlt+LeftShift to switch to Hebrew.
      > >
      > > For more information, see my tip here:
      > >
      > > http://permalink.gmane.org/gmane.linux.region.israel/43351
      > >
      > > Regards,
      > >
      > > Shlomi Fish
      > >
      > >
      >
      >
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >



      --
      -----------------------------------------------------------------
      Shlomi Fish http://www.shlomifish.org/
      Apple Inc. is Evil - http://www.shlomifish.org/open-source/anti/apple/

      If Botticelli were alive today, he’d be working for Vogue.
      http://en.wikiquote.org/wiki/Peter_Ustinov

      Please reply to list if it's a mailing list post - http://shlom.in/reply .
    • Chaim Seymour
      Hi I followed your advice to see if the file works. The cat command reproduced the file, but I still don t have Hebrew. I assume that I am doing something
      Message 2 of 7 , Sep 23 7:01 AM
        Hi

        I followed your advice to see if the file works. The 'cat' command reproduced the file, but I still don't have Hebrew.

        I assume that I am doing something stupid and the whole thing is something minor.

        I tried the Google virtual keyboard and it works beautifully. The pity is that it can't be used on other applications

        shabbat shalom

        Chaim

        On 23 September 2011 10:04, Shlomi Fish <shlomif@...> wrote:
         

        Hi Chaim,



        On Thu, 22 Sep 2011 21:51:44 +0300
        Chaim Seymour <chaim.seymour@...> wrote:

        > Hi all
        >
        > Many thanks to Shlomi. I still seem to need your collective wisdom.
        >
        > I set up the file: .Xkbmap. I took the content from the editor by
        > cut/paste. I don't see the file in my file-cabinet,

        that's because files with a leading period (".") are considered hidden.


        > but the xterminal
        > reads it when I give a 'more' command.
        >

        OK, I should note that generally the "less" command is superior to more and you
        should use it instead. To exit it press "q".


        > I installed SBL Hebrew and can see it in the list of fonts within Open
        > Office.
        >
        > However, I still don't have Hebrew printing in Open Office, Xterminal,
        > Chrome or Evolution.

        Do you mean Hebrew "typing" (הקלדה) rather than Hebrew "printing" (הדפסה)? If
        so, you should try restarting your X session for the ".Xkbmap" file to take
        effect.

        You can apply such a file immediately by saying:

        $ setxkbmap $(cat .Xkbmap)

        But this won't test that it is a permanent change.

        Regards,

        Shlomi Fish

        >
        > I must be doing something wrong. Does anybody have any ideas?
        >
        > Chaim
        >
        > On ה', 2011-09-22 at 12:38 +0300, Shlomi Fish wrote:
        > > Hi Chaim,
        > >
        > > On Thu, 22 Sep 2011 09:14:55 -0000
        > > "chaim.seymour" <chaim.seymour@...> wrote:
        > >
        > > > Hi
        > > >
        > > > I am a super-gnuby. I am learning as I go along.
        > > >
        > > > So far I succeed in installing the Fedora 15 with Hebrew support. I can read Hebrew and all my menus are in Hebrew but I can't write Hebrew.
        > > >
        > > > I tried a search and found all the answers were KDE. The Fedora uses Gnome 3. Can anybody help me with a simple answer how to solve the Hebrew writing problem?
        > > >
        > >
        > > Try putting this line in a text file called .Xkbmap (note the "." and the
        > > capital "X") in your home directory:
        > >
        > > «
        > > -option compose:ralt,grp:switch,grp:alt_shift_toggle,grp_led:scroll
        > > -variant ,lyx us,il »
        > >
        > > Then you'll be able to type LeftAlt+LeftShift to switch to Hebrew.
        > >
        > > For more information, see my tip here:
        > >
        > > http://permalink.gmane.org/gmane.linux.region.israel/43351
        > >
        > > Regards,
        > >
        > > Shlomi Fish
        > >
        > >
        >
        >
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >

        --
        ----------------------------------------------------------
        Shlomi Fish http://www.shlomifish.org/
        Apple Inc. is Evil - http://www.shlomifish.org/open-source/anti/apple/

        If Botticelli were alive today, he’d be working for Vogue.
        http://en.wikiquote.org/wiki/Peter_Ustinov


        Please reply to list if it's a mailing list post - http://shlom.in/reply .




        --
        Chaim Seymour
        David Elazar 8
        Givat Shemuel 54032
        Israel
        tel: 972-3-5320560
      • Shlomi Fish
        Hi Chaim, On Fri, 23 Sep 2011 17:01:59 +0300 ... Does this command work for the current session (in a terminal)? setxkbmap $(cat .Xkbmap) ... Shabbath Shalom
        Message 3 of 7 , Sep 23 7:35 AM
          Hi Chaim,

          On Fri, 23 Sep 2011 17:01:59 +0300
          Chaim Seymour <chaim.seymour@...> wrote:

          > Hi
          >
          > I followed your advice to see if the file works. The 'cat' command
          > reproduced the file, but I still don't have Hebrew.
          >

          Does this command work for the current session (in a terminal)?

          setxkbmap $(cat .Xkbmap)

          > I assume that I am doing something stupid and the whole thing is something
          > minor.
          >
          > I tried the Google virtual keyboard and it works beautifully. The pity is
          > that it can't be used on other applications
          >
          > shabbat shalom
          >

          Shabbath Shalom and Shanah Tovah.

          Regards,

          Shlomi Fish

          > Chaim
          >


          --
          -----------------------------------------------------------------
          Shlomi Fish http://www.shlomifish.org/
          "Star Trek: We, the Living Dead" - http://shlom.in/st-wtld

          There is no IGLU Cabal! Home‐made Cabals eventually superseded the power and
          influence of the original IGLU Cabal, which was considered a cutting edge
          development at its time.

          Please reply to list if it's a mailing list post - http://shlom.in/reply .
        • Chaim Seymour
          שלום רב העברית היא תוצאה של פקודה: setxkbmap -option compose:ralt,grp:switch,grp:alt_shift_toggle,grp_led:scroll -variant ,lyx
          Message 4 of 7 , Sep 24 12:21 PM
            שלום רב

            העברית היא תוצאה של פקודה:

             setxkbmap -option compose:ralt,grp:switch,grp:alt_shift_toggle,grp_led:scroll  -variant ,lyx us,il

            בשורה  אחת. עד כאן טוב

            בברכת שנה טובה

            חיים

            On 23 September 2011 17:35, Shlomi Fish <shlomif@...> wrote:
             

            Hi Chaim,

            On Fri, 23 Sep 2011 17:01:59 +0300


            Chaim Seymour <chaim.seymour@...> wrote:

            > Hi
            >
            > I followed your advice to see if the file works. The 'cat' command
            > reproduced the file, but I still don't have Hebrew.
            >

            Does this command work for the current session (in a terminal)?

            setxkbmap $(cat .Xkbmap)


            > I assume that I am doing something stupid and the whole thing is something
            > minor.
            >
            > I tried the Google virtual keyboard and it works beautifully. The pity is
            > that it can't be used on other applications
            >
            > shabbat shalom
            >

            Shabbath Shalom and Shanah Tovah.

            Regards,

            Shlomi Fish

            > Chaim

            >

            --
            ----------------------------------------------------------
            Shlomi Fish http://www.shlomifish.org/
            "Star Trek: We, the Living Dead" - http://shlom.in/st-wtld

            There is no IGLU Cabal! Home‐made Cabals eventually superseded the power and
            influence of the original IGLU Cabal, which was considered a cutting edge
            development at its time.


            Please reply to list if it's a mailing list post - http://shlom.in/reply .




            --
            Chaim Seymour
            David Elazar 8
            Givat Shemuel 54032
            Israel
            tel: 972-3-5320560
          Your message has been successfully submitted and would be delivered to recipients shortly.