Loading ...
Sorry, an error occurred while loading the content.

Re: [gnubies-il] Re: Mounting problem - size difference and storage "black holes"

Expand Messages
  • Hagai Hadad
    David, Did you try to use the Gnome Partition Editor (gparted) in Ubuntu? I ran it and from what I saw, I think you should do the following: 1. Completely
    Message 1 of 4 , Jun 30, 2009
      Did you try to use the "Gnome Partition Editor" (gparted) in Ubuntu?
      I ran it and from what I saw, I think you should do the following:
      1. Completely delete this partition (it will shown as unformatted area in the partition table).
      2. Format it to "ext3" (I don't know if there is also an option of "quick format" which means the format only affects the partition table, but if there is, don't!!! use it).
      3. Pray ...


      Hope this helps


      On Tue, Jun 30, 2009 at 8:42 PM, baum_j <baum_j@...> wrote:


      A. Thanks for the info.

      B. It seems as if you're right on the spot.
      From the moment I set the fs to be vfat,
      I get the following fsck message, on each boot:

      ===FSCK LOG BEGIN===
      sck 1.41.3 (12-Oct-2008)
      fsck.ext3: Bad magic number in super-block while trying to open /dev/sda2
      The superblock could not be read or does not describe a correct ext2
      filesystem. If the device is valid and it really contains an ext2
      filesystem (and not swap or ufs or something else), then the superblock
      is corrupt, and you might try running e2fsck with an alternate superblock:
      e2fsck -b 8193 <device>

      fsck died with exit status 8
      ===FSCK LOG END===

      What should I do then: I generally wish for it to be an ext3 fs.
      How can I format it to the correct type?

      --- In gnubies-il@yahoogroups.com, Hagai Hadad <kopolov@...> wrote:
      > I have 2 comments:
      > 1. The current most up to date Ubuntu version is 9.04 (for the past 2
      > months) - code name "Jaunty Jackalope".
      > You can also use "ext4" as a file system.
      > 2. When you mounted those 10G partition, did you specifically marked them to
      > be deleted (formatted) before?
      > My guess is that the partition table is "not clean" somehow (residues in
      > those 10G).
      > Hagai
      > On Sat, Jun 27, 2009 at 7:34 PM, David <baum_j@...> wrote:
      > > [Attachment(s) <#12222a3318d89931_TopText> from David included below]
      > >
      > > Dear gnubsilers, hello again.
      > > I need some advice, regarding a mount problem.
      > >
      > > I am using a 2 year old Toshiba Satellite laptop - and it mostly functions
      > > greatly.
      > > I run an Ubuntu 8.10 (the latest as far as I know) with a 2.6.27-14-generic
      > > Kernel version (again, latest).
      > >
      > > The reason I mentioned having a laptop is the space issue. Having a laptop
      > > with only(?) 80 Gigs mean that storage is a critical issue.
      > > "Historically" this computer came with MS Shitsta installed on it.
      > > When I installed Ubuntu, I initially reserved a 10G partition not be
      > > touched by GParted. Can't remember why...
      > >
      > > Now I want this precious HD real-estate, accounting for some 15% of my
      > > total storage.
      > >
      > > So I went to GParted, and chose the "ext3" option on this partition
      > > /dev/sda2.
      > > I then updated my 'fstab' file accordingly adding the following line:
      > > /dev/sda2 /mnt/data ext3 defaults 0 2
      > >
      > > Following boots, it seems to work well. The problem I have is about a
      > > storage "black hole" regarding this partition.
      > > When the partition is mounted as ext3 (like now) df says it has 155M of
      > > occupied space.
      > > When I 'ls -l' the mount-point, there's nothing there.
      > > In the meanwhile, GParted says that the partition is over 320M occupied.
      > > Now I'm not petty - but 300M is some room for storage, and so are 150M; But
      > > most of all I'm buffeled.
      > > I'm uncertain as to what's going on.
      > > Further more, if I use GParted to format the partition to 'fat32', both df
      > > and GParted agree - that nothing is taken up - or so I understand.
      > >
      > > What's going on. What should I do?
      > > P.S. I ran fsck on this partition - it is OK.
      > >
      > > (I attached screen outputs showing this blackhole issue)
      > > ×"ו×" David
      > >
      > >
      > >
      > --
      > Hagai Hadad

      Hagai Hadad
    Your message has been successfully submitted and would be delivered to recipients shortly.