Loading ...
Sorry, an error occurred while loading the content.

Three problems

Expand Messages
  • Errol Sapir
    Hi All I have almost completely moved over to Linux on my home computer. At work I have no choice but to use Windows. These are functions that I haven t been
    Message 1 of 13 , May 9 10:27 PM
    • 0 Attachment
      Hi All
      I have almost completely moved over to Linux on my home computer. At work I 
      have no choice but to use Windows. These are functions that I haven't been 
      able to get to work in Linux YET!!!
      Introduction: I use Kubuntu as my OS as FOR ME it is the most user friendly 
      both in English AND Hebrew.
      1. Hebrew works perfectly except that I cannot change languages with alt/shift 
      - only by clicking on the language icon will the language (and direction of 
      typing) change. 
      2. As you know Israel's official sites are Explorer built - banks, government 
      institutions etc. How can I get Firefox to read these sites. In Windows there 
      was a plugin called IEtab which did the job.
      2. I use a Canon i865 printer. Drivers for this are nowhere to be found.
      ANY help with these problems will be appreciated. 
      Yes I have posted some of these problems on the Kubuntu forum but with not many answers that helped.
      TIA
      Errol
    • Oded Arbel
      ... Which version of Kubuntu do you use ? here s how to get KDE to behave like windows: - right click the language icon and choose configure. - select the
      Message 2 of 13 , May 10 3:13 AM
      • 0 Attachment
        On Wednesday, 10 בMay 2006 08:27, Errol Sapir wrote:
        > Introduction: I use Kubuntu as my OS

        > 1. Hebrew works perfectly except that I cannot change languages with
        > alt/shift - only by clicking on the language icon will the language
        > (and direction of typing) change.

        Which version of Kubuntu do you use ? here's how to get KDE to behave
        like windows:
        - right click the language icon and choose configure.
        - select the "israeli" item in the right panel
        - check "include latin layout" at the bottom (which is just a confusing
        term - it should say "include latin group")
        - switch to the right most tab: "Xkb options"
        - check "reset old options"
        - check "Group shift/lock behavior"->"alt+shift changes group".
        - I also find it useful to check "Use keyboard LED to show alternative
        group"->"ScrollLock LED".
        - click "OK".
        now, when the language indicator shows "IL", you can switch between
        latin text input and hebrew text input by hitting alt+shift. When the
        indicator shows "US" you can only type latin. You can set the IL layout
        to be the default (i.e. - first to be active when you log in), but do
        note that for the IL layout the hebrew text input is always first, so
        if you type a lot of english you'd probably find it annoying.
        You might also like to play with the options in the "Switching options"
        tab which allows you to have KDE "remember" the current keyboard layout
        setting for each application or window, so that if you type hebrew in
        one application and english in another, simply switching between the
        applications automatically switches the keyboard layout.

        The explanation is that X have a distinction between "keyboard
        layouts" - which is how your keyboard looks, and "keyboard groups"
        which is what groups of characters your keyboard generates. So, in our
        example you can either have a US layout which means a keyboard as sold
        in the united states - QWERTY with only latin input, or an Israeli
        layout which means a keyboard as sold in Israel - QWERTY with markings
        for hebrew as well as latin on the character keys. The Israeli layout
        can then generates two different groups of characters - latin and
        hebrew. By default, setting a keyboard's layout as Israeli in the
        configuration tells KDE that this keyboard only have hebrew characters,
        and no latin characters, and you are forced to switch layouts (which is
        hard and requires reconfiguring the X server on the fly using the KDE
        language applet), instead of simply changing groups. This is a bug in
        KDE.

        > 2. As you know Israel's official sites are Explorer built - banks,
        > government institutions etc. How can I get Firefox to read these
        > sites. In Windows there was a plugin called IEtab which did the job.

        IETab doesn't let firefox view "explorer only" sites - instead it just
        loads internet explorer inside the firefox shell, so you are actually
        using internet explorer, it just a looks a bit like firefox (also,
        there goes your extra security out of the window. make sure to use
        IETab only with sites that you are absolutely sure are safe).

        Its possible to install Internet Explorer using the "wine" program on
        your system (detailed instructions can be found on the web. I recommend
        using one of the scripts that do this automatically for you), and I
        heard at least one account of someone getting IETab extension working
        on Linux by loading a "wined" internet explorer. But that can be very
        difficult and probably not worth it. I suggest one of three
        alternatives:

        A. install Internet Explorer using wine and one of the aforementioned
        scripts, and use it for the web sites that require it.
        B. Install a "user-agent" switching extension for firefox which allows
        firefox to masquerade itself as internet explorer for certain sites -
        for sites that work reasonably well with firefox and only employ
        browser detection to drive away linux users (which is most sites), this
        would work nicely.
        C. Use Konqueror - it has the "user-agent" masquerading feature
        built-in, and it also behaves more like Internet Explorer (from the web
        site perspective), so that sites that don't work with firefox using
        option B, might well work with Konqueror.

        > 2. I use a Canon i865 printer. Drivers for this are nowhere to be
        > found.

        Don't you mean "3" ?
        I've read here http://www.qbik.ch/usb/devices/showdev.php?id=3368 that
        it will work when installing the canon drivers from
        ftp://download.canon.jp/pub/driver/bj/linux/ . Get the RPM packages for
        version 2.4 and install them using "alien". Then you should be able to
        set the KDE printing wizard to print to the printer using one of the BJ
        drivers - don't know which for sure - try a few items that look
        relevant, and it doesn't work email me again.

        --
        Oded

        ::..
        Reasons to Run Away 8-"When the DM just watched a LOT of horror/monster
        movies"
      • errol
        Thanks Oded for all the explanations.I ll relate to each problem under your question. ... Which version of Kubuntu do you use ? At the moment Breezy but am
        Message 3 of 13 , May 10 5:47 AM
        • 0 Attachment
          Thanks Oded for all the explanations.I'll relate to each problem under your
          question.


          > Introduction: I use Kubuntu as my OS
          >
          > 1. Hebrew works perfectly except that I cannot change languages with
          > alt/shift - only by clicking on the language icon will the language
          > (and direction of typing) change.

          Which version of Kubuntu do you use ?
          At the moment Breezy but am waiting for the Dapper release.



          > 2. As you know Israel's official sites are Explorer built - banks,
          > government institutions etc. How can I get Firefox to read these
          > sites. In Windows there was a plugin called IEtab which did the job.

          . I suggest one of three
          alternatives:

          A. install Internet Explorer using wine and one of the aforementioned
          scripts, and use it for the web sites that require it.
          This is the only alternative I haven't tried. Will do so when I've read enough
          about it.

          B. Install a "user-agent" switching extension for firefox which allows
          firefox to masquerade itself as internet explorer for certain sites -
          for sites that work reasonably well with firefox and only employ
          browser detection to drive away linux users (which is most sites), this
          would work nicely.
          Tried it but couldn't get the IE to "behave"' with the site.

          C. Use Konqueror - it has the "user-agent" masquerading feature
          built-in, and it also behaves more like Internet Explorer (from the web
          site perspective), so that sites that don't work with firefox using
          option B, might well work with Konqueror.
          I had difficulty setting it up. I need to try again

          > 2. I use a Canon i865 printer. Drivers for this are nowhere to be
          > found.
          Don't you mean "3" ?

          No I mean i865. It is what Canon call a "Photo Printer". In my house there is
          another computer running Windows and I can "network" print through that I
          guess but I really wanted to connect this to my Kubuntu OS.
          Thanks again for advice.
          Errol
        • errol
          ... This command is greyed out so I can t do anything with it. After completing all the other instructions, it still doesn t use alt/shift (or anything else
          Message 4 of 13 , May 10 6:25 AM
          • 0 Attachment
            > - right click the language icon and choose configure.
            > - select the "israeli" item in the right panel
            > - check "include latin layout" at the bottom (which is just a confusing
            > term - it should say "include latin group")

            This command is "greyed out" so I can't do anything with it. After completing
            all the other instructions, it still doesn't use alt/shift (or anything else
            to toggle).

            > - switch to the right most tab: "Xkb options"
            > - check "reset old options"
            > - check "Group shift/lock behavior"->"alt+shift changes group".
            > - I also find it useful to check "Use keyboard LED to show alternative
            > group"->"ScrollLock LED".
            > - click "OK".
          • Oded Arbel
            ... Make sure to select the israeli item on the right panel. if there isn t an israeli item on the right panel, then pick it in the left panel and add it
            Message 5 of 13 , May 10 7:10 AM
            • 0 Attachment
              On Wednesday, 10 בMay 2006 16:25, errol wrote:
              > > - right click the language icon and choose configure.
              > > - select the "israeli" item in the right panel
              > > - check "include latin layout" at the bottom (which is just a
              > > confusing term - it should say "include latin group")
              >
              > This command is "greyed out" so I can't do anything with it. After
              > completing all the other instructions, it still doesn't use alt/shift
              > (or anything else to toggle).

              Make sure to select the "israeli" item on the right panel. if there
              isn't an "israeli" item on the right panel, then pick it in the left
              panel and add it to the right, then make sure to select it on the right
              panel.
              After that the checkbox should be available.

              --
              Oded

              ::..
              Wallace: "Why do you help me?"
              Isabelle: "Because of the way you are looking at me now."
              -- from "Braveheart"

              --
              Oded

              ::..
              If at first you don't succeed, redefine success.
            • errol
              ... It is in the right panel, together with US English. Maybe it should be alone in the panel? Errol
              Message 6 of 13 , May 10 7:25 AM
              • 0 Attachment
                On Wednesday 10 May 2006 17:10, Oded Arbel wrote:
                > On Wednesday, 10 בMay 2006 16:25, errol wrote:
                > > > - right click the language icon and choose configure.
                > > > - select the "israeli" item in the right panel
                > > > - check "include latin layout" at the bottom (which is just a
                > > > confusing term - it should say "include latin group")
                > >
                > > This command is "greyed out" so I can't do anything with it. After
                > > completing all the other instructions, it still doesn't use alt/shift
                > > (or anything else to toggle).
                >
                > Make sure to select the "israeli" item on the right panel. if there
                > isn't an "israeli" item on the right panel, then pick it in the left
                > panel and add it to the right, then make sure to select it on the right
                > panel.
                > After that the checkbox should be available.
                >
                It is in the right panel, together with US English. Maybe it should be alone
                in the panel?
                Errol

                > --
                > Oded
                >
              • Oded Arbel
                ... Not IE - Firefox. If you use user-agent spoofing and the site doesn t behave properly, open an Evangelism bug on the Mozilla bugzilla. Look in
                Message 7 of 13 , May 10 7:29 AM
                • 0 Attachment
                  On Wednesday, 10 בMay 2006 15:47, errol wrote:
                  > B. Install a "user-agent" switching extension for firefox which
                  > allows firefox to masquerade itself as internet explorer for certain
                  > sites - for sites that work reasonably well with firefox and only
                  > employ browser detection to drive away linux users (which is most
                  > sites), this would work nicely.


                  > Tried it but couldn't get the IE to "behave"' with the site.

                  Not IE - Firefox. If you use user-agent spoofing and the site doesn't
                  behave properly, open an "Evangelism" bug on the Mozilla bugzilla. Look
                  in mozilla.org.il for instructions.

                  > C. Use Konqueror - it has the "user-agent" masquerading feature
                  > built-in, and it also behaves more like Internet Explorer (from the
                  > web site perspective), so that sites that don't work with firefox
                  > using option B, might well work with Konqueror.

                  > I had difficulty setting it up. I need to try again

                  its simple - make sure you have the "kdeaddons" package installed. Now
                  when you go to a web site, under the "tools" menu should be an
                  option "change browser identification". After choosing the required
                  identification, make sure to also enable "apply for the entire site".


                  >
                  > > 2. I use a Canon i865 printer. Drivers for this are nowhere to be
                  > > found.
                  >
                  > Don't you mean "3" ?
                  >
                  > No I mean i865.

                  It was a joke about you having 3 questions and numbering them 1, 2 and
                  2.


                  --
                  Oded

                  ::..
                  Famous Last Words 051-"They need a twenty to hit me, I'm invincible"
                • Oded Arbel
                  ... No, just make sure to select it (so there s a blue rectangle around israeli ). When that happens the checkbox should be available. -- Oded ... People are
                  Message 8 of 13 , May 10 7:31 AM
                  • 0 Attachment
                    On Wednesday, 10 �‘May 2006 17:25, errol wrote:
                    > On Wednesday 10 May 2006 17:10, Oded Arbel wrote:
                    > > On Wednesday, 10 ן�½�‘May 2006 16:25, errol wrote:
                    > > > > - right click the language icon and choose configure.
                    > > > > - select the "israeli" item in the right panel
                    > > > > - check "include latin layout" at the bottom (which is just a
                    > > > > confusing term - it should say "include latin group")
                    > > >
                    > > > This command is "greyed out" so I can't do anything with it.
                    > > > After completing all the other instructions, it still doesn't use
                    > > > alt/shift (or anything else to toggle).
                    > >
                    > > Make sure to select the "israeli" item on the right panel. if there
                    > > isn't an "israeli" item on the right panel, then pick it in the
                    > > left panel and add it to the right, then make sure to select it on
                    > > the right panel.
                    > > After that the checkbox should be available.
                    >
                    > It is in the right panel, together with US English. Maybe it should
                    > be alone in the panel?
                    > Errol

                    No, just make sure to select it (so there's a blue rectangle
                    around "israeli"). When that happens the checkbox should be available.

                    --
                    Oded

                    ::..
                    People are like clouds all unique...

                    --
                    Oded

                    ::..
                    Sometimes when reading Goethe I have the paralyzing suspicion that he is
                    trying to be funny.
                    -- Guy Davenport
                  • errol
                    ... Mmmm I thought you meant i386. Too much pressure I reckon:) Errol
                    Message 9 of 13 , May 10 7:36 AM
                    • 0 Attachment
                      > > > 2. I use a Canon i865 printer. Drivers for this are nowhere to be
                      > > > found.
                      > >
                      > > Don't you mean "3" ?
                      > >
                      > > No I mean i865.
                      >
                      > It was a joke about you having 3 questions and numbering them 1, 2 and
                      > 2.
                      >
                      Mmmm I thought you meant i386. Too much pressure I reckon:)
                      Errol
                    • errol
                      ... Nope, Nothing I do makes the command un-grey . I even tried restarting my computer. Errol
                      Message 10 of 13 , May 10 7:37 AM
                      • 0 Attachment
                        On Wednesday 10 May 2006 17:31, Oded Arbel wrote:
                        > On Wednesday, 10 �‘May 2006 17:25, errol wrote:
                        > > On Wednesday 10 May 2006 17:10, Oded Arbel wrote:
                        > > > On Wednesday, 10 ן�½�‘May 2006 16:25, errol wrote:
                        > > > > > - right click the language icon and choose configure.
                        > > > > > - select the "israeli" item in the right panel
                        > > > > > - check "include latin layout" at the bottom (which is just a
                        > > > > > confusing term - it should say "include latin group")
                        > > > >
                        > > > > This command is "greyed out" so I can't do anything with it.
                        > > > > After completing all the other instructions, it still doesn't use
                        > > > > alt/shift (or anything else to toggle).
                        > > >
                        > > > Make sure to select the "israeli" item on the right panel. if there
                        > > > isn't an "israeli" item on the right panel, then pick it in the
                        > > > left panel and add it to the right, then make sure to select it on
                        > > > the right panel.
                        > > > After that the checkbox should be available.
                        > >
                        > > It is in the right panel, together with US English. Maybe it should
                        > > be alone in the panel?
                        > > Errol
                        >
                        > No, just make sure to select it (so there's a blue rectangle
                        > around "israeli"). When that happens the checkbox should be available.
                        >
                        Nope, Nothing I do makes the command "un-grey". I even tried restarting my
                        computer.
                        Errol
                      • Oded Arbel
                        ... Restarting is bad! bad, bad windows user ! kidding ;-) As a general rule, restarting a Linux computer would not solve any problem - its more likely to
                        Message 11 of 13 , May 10 8:36 AM
                        • 0 Attachment
                          On Wednesday, 10 בMay 2006 17:37, errol wrote:
                          > > > It is in the right panel, together with US English. Maybe it
                          > > > should be alone in the panel?
                          > > > Errol
                          > >
                          > > No, just make sure to select it (so there's a blue rectangle
                          > > around "israeli"). When that happens the checkbox should be
                          > > available.
                          >
                          > Nope, Nothing I do makes the command "un-grey". I even tried
                          > restarting my computer.

                          Restarting is bad! bad, bad windows user !

                          kidding ;-)

                          As a general rule, restarting a Linux computer would not solve any
                          problem - its more likely to cause them. If there is one thing that
                          Linux beats Windows in, is consistency - if its broken, it will
                          continue to be broken and no amount of restarts will change that.

                          Can you please attach a screen capture of the keyboard layout
                          configuration dialog, with the "israeli" layout selected and
                          the "include latin" checkbox grayed out ?

                          --
                          Oded

                          ::..
                          "I'm not a god, I was misquoted."
                          -- Lister in "Red Dwarf"
                        • errol
                          Thanks for all the efforts to help BUT I haven t succeeded with ANY of the solutions to any of the problems. Am now thinking of waiting for the Dapper version
                          Message 12 of 13 , May 14 8:28 PM
                          • 0 Attachment
                            Thanks for all the efforts to help BUT I haven't succeeded with ANY of the
                            solutions to any of the problems. Am now thinking of waiting for the Dapper
                            version of Kubuntu, re-installing after formating. I'll keep my Home
                            directory in order not to lose data. Is that enough or should I do other
                            things before such a drastic move?

                            Errol


                            On Wednesday 10 May 2006 13:13, Oded Arbel wrote:
                            > On Wednesday, 10 בMay 2006 08:27, Errol Sapir wrote:
                            > > Introduction: I use Kubuntu as my OS
                            > >
                            > > 1. Hebrew works perfectly except that I cannot change languages with
                            > > alt/shift - only by clicking on the language icon will the language
                            > > (and direction of typing) change.
                            >
                            > Which version of Kubuntu do you use ? here's how to get KDE to behave
                            > like windows:
                            > - right click the language icon and choose configure.
                            > - select the "israeli" item in the right panel
                            > - check "include latin layout" at the bottom (which is just a confusing
                            > term - it should say "include latin group")
                            > - switch to the right most tab: "Xkb options"
                            > - check "reset old options"
                            > - check "Group shift/lock behavior"->"alt+shift changes group".
                            > - I also find it useful to check "Use keyboard LED to show alternative
                            > group"->"ScrollLock LED".
                            > - click "OK".
                            > now, when the language indicator shows "IL", you can switch between
                            > latin text input and hebrew text input by hitting alt+shift. When the
                            > indicator shows "US" you can only type latin. You can set the IL layout
                            > to be the default (i.e. - first to be active when you log in), but do
                            > note that for the IL layout the hebrew text input is always first, so
                            > if you type a lot of english you'd probably find it annoying.
                            > You might also like to play with the options in the "Switching options"
                            > tab which allows you to have KDE "remember" the current keyboard layout
                            > setting for each application or window, so that if you type hebrew in
                            > one application and english in another, simply switching between the
                            > applications automatically switches the keyboard layout.
                            >
                            > The explanation is that X have a distinction between "keyboard
                            > layouts" - which is how your keyboard looks, and "keyboard groups"
                            > which is what groups of characters your keyboard generates. So, in our
                            > example you can either have a US layout which means a keyboard as sold
                            > in the united states - QWERTY with only latin input, or an Israeli
                            > layout which means a keyboard as sold in Israel - QWERTY with markings
                            > for hebrew as well as latin on the character keys. The Israeli layout
                            > can then generates two different groups of characters - latin and
                            > hebrew. By default, setting a keyboard's layout as Israeli in the
                            > configuration tells KDE that this keyboard only have hebrew characters,
                            > and no latin characters, and you are forced to switch layouts (which is
                            > hard and requires reconfiguring the X server on the fly using the KDE
                            > language applet), instead of simply changing groups. This is a bug in
                            > KDE.
                            >
                            > > 2. As you know Israel's official sites are Explorer built - banks,
                            > > government institutions etc. How can I get Firefox to read these
                            > > sites. In Windows there was a plugin called IEtab which did the job.
                            >
                            > IETab doesn't let firefox view "explorer only" sites - instead it just
                            > loads internet explorer inside the firefox shell, so you are actually
                            > using internet explorer, it just a looks a bit like firefox (also,
                            > there goes your extra security out of the window. make sure to use
                            > IETab only with sites that you are absolutely sure are safe).
                            >
                            > Its possible to install Internet Explorer using the "wine" program on
                            > your system (detailed instructions can be found on the web. I recommend
                            > using one of the scripts that do this automatically for you), and I
                            > heard at least one account of someone getting IETab extension working
                            > on Linux by loading a "wined" internet explorer. But that can be very
                            > difficult and probably not worth it. I suggest one of three
                            > alternatives:
                            >
                            > A. install Internet Explorer using wine and one of the aforementioned
                            > scripts, and use it for the web sites that require it.
                            > B. Install a "user-agent" switching extension for firefox which allows
                            > firefox to masquerade itself as internet explorer for certain sites -
                            > for sites that work reasonably well with firefox and only employ
                            > browser detection to drive away linux users (which is most sites), this
                            > would work nicely.
                            > C. Use Konqueror - it has the "user-agent" masquerading feature
                            > built-in, and it also behaves more like Internet Explorer (from the web
                            > site perspective), so that sites that don't work with firefox using
                            > option B, might well work with Konqueror.
                            >
                            > > 2. I use a Canon i865 printer. Drivers for this are nowhere to be
                            > > found.
                            >
                            > Don't you mean "3" ?
                            > I've read here http://www.qbik.ch/usb/devices/showdev.php?id=3368 that
                            > it will work when installing the canon drivers from
                            > ftp://download.canon.jp/pub/driver/bj/linux/ . Get the RPM packages for
                            > version 2.4 and install them using "alien". Then you should be able to
                            > set the KDE printing wizard to print to the printer using one of the BJ
                            > drivers - don't know which for sure - try a few items that look
                            > relevant, and it doesn't work email me again.
                            >
                            > --
                            > Oded
                            >
                            > ::..
                            >
                            > Reasons to Run Away 8-"When the DM just watched a LOT of horror/monster
                            > movies"
                            >
                            >
                            >
                            >
                            > Yahoo! Groups Links
                            >
                            >
                            >
                            >
                            >
                            >
                            >
                            > ###########################################################################
                            >########## This Mail Was Scanned by 012.net AntiVirus Service1- Powered by
                            > TrendMicro Interscan
                          • Oded Arbel
                            ... If your home directory is under a different partition, then you shouldn t have any problems - make sure not to format it. Otherwise, you d need to back it
                            Message 13 of 13 , May 15 4:37 AM
                            • 0 Attachment
                              On Mon, 2006-05-15 at 06:28 +0300, errol wrote:
                              Thanks for all the efforts to help BUT I haven't succeeded with ANY of the 
                              solutions to any of the problems. Am now thinking of waiting for the Dapper 
                              version of Kubuntu, re-installing after formating. I'll keep my Home 
                              directory in order not to lose data. Is that enough or should I do other 
                              things before such a drastic move?
                              

                              If your home directory is under a different partition, then you shouldn't have any problems - make sure not to format it. Otherwise, you'd need to back it up and restore it later, as kubuntu will need to format the entire partition (including your home) before installing.

                              Alternatively, you might want to try doing a simple apt upgrade.

                            Your message has been successfully submitted and would be delivered to recipients shortly.