Loading ...
Sorry, an error occurred while loading the content.

Re: [gnubies-il] Re: Hebrew and KDE problem

Expand Messages
  • Nigel Ridley
    ... Yes you re right - I read the man pages and corrected the fstab. ... It s actually on the other box so I can t give a copy and paste but here is the
    Message 1 of 11 , Oct 7, 2005
    • 0 Attachment
      Tzafrir Cohen wrote:
      > On Thu, Oct 06, 2005 at 10:03:09PM +0300, Nigel Ridley wrote:
      >
      >>Nigel Ridley wrote:
      >>
      >>>Shimon Lebowitz wrote:
      >>>
      >>>
      >>>>Did you mount the filesystem with utf8 in the fstab?
      >>>>I needed that before I could see Hebrew file names.
      >>>>
      >>>>Shana tova,
      >>>>Shimon
      >>>>
      >>>
      >>>
      >>>I have now mounted the file system as utf8:
      >>>/dev/hda5 /home reiserfs utf8,auto 0 2
      >>
      >>Oops - should read as:
      >>/dev/hda5 /home reiserfs utf8 defaults,auto 0 2
      >
      >
      > Reiserfs , ext2, ext3, xfs and generally "unix file systes" (with the
      > exception of jfs, that has os/2 roots) don't have a character set in the
      > file system. The name of a file is simply a string and does not have any
      > character set attached to it. Therefore no character set mount option is
      > needed and is recognized.
      >
      > Thus both fstab lines above are incorrect: the first one has an
      > incorrect option to reiserfs, whereas the secon is not even in the right
      > syntax.

      Yes you're right - I read the man pages and corrected the fstab.

      >
      > If you start a terminal by just running the command 'xterm' and run in
      > it the command 'locale', what is the output?

      It's actually on the other box so I can't give a 'copy and paste' but
      here is the first couple of lines:
      LANG=C
      LC_TYPE = "C"

      all the other entries also end in C.

      >
      >
      >>>but I still can't get KDE to show a new folder written in Hebrew - still
      >>>the ?????'s.
      >
      >
      > KDE not using a UTF-8 locale? We'll see that from the test above.

      I did do a 'dpkg-reconfigure locales' and added both the Hebrew entries
      as well as utf8 (US) and then chose utf8 (US) as the default locale.

      I did find something that sounds useful:
      http://article.gmane.org/gmane.linux.region.israel.ivrix.discuss/1062
      where it mentions a package named 'hebrew-meta-pack'
      [quote]
      All That a Hebrew user need to do is:
      "apt-get/urpmi/yum install hebrew-meta-pack", and his
      box will be Hebrew enabled.

      This are the packages i made (they are in the libhdate
      reposatory), this packages are for Ubuntu 5.04.

      a. hul-hebrew-console
      it installes:
      language-pack-he, language-support-he, hspell,
      libhdate0, bidiv

      b. hul-hebrew-gnome
      it installes:
      hul-hebrew-console, hdate-applet, hspell-gui,
      sendsms-gui, culmus

      hul-math
      it installes:
      octave, gnuplot, maxima, wxmaxima, ivritex

      hul-devel
      it installes GNU autotools, gnome-devel, and some
      devel librarys and programs including library for use
      of the Hebrew calendar.

      All the user or CDD(*)/LiveCD maker have to do is:
      sudo apt-get install hul-hebrew-gnome

      (*)CDD (Custom Debian Distribution)
      [quote]

      Are you familiar with it?

      Blessings,

      Nigel
      >
      >
      >>>>>I have recently installed Kanotix (Debian based) - using KDE 3.4.1 - and
      >>>>>set up an account for my daughter.
      >
      >
      > Knoppix is quite different from Debian in the locales definitions, BTW.
      > I don't know where Kanotix stands.
      >
      >
      >>>>>She wants a Hebrew environment; so I installed (via apt) the Hebrew KDE
      >>>>>language pack and culmus (fonts), set up her KDE to use Hebrew and
      >>>>>everything looks good - she can type in Hebrew, read Hebrew --
      >>>>>BUT, she cannot save a file, or create a new directory, using Hebrew -
      >>>>>the name just appears as a load of ???????'s.
      >>>>>
      >>>>>Where and what do I have to do to enable file names to be in Hebrew?
      >
      >


      --
      It's not a problem -- it's a learning opportunity.
      --

      I AM Bible Studies and Resources
      http://www.i-amfaithweb.net

      Messianic E-Cards.com
      http://www.messianicecards.com

      OliveRoot Ministries
      http://www.oliveroot.net

      PrayingForIsrael.net
      http://www.prayingforisrael.net
    • Tzafrir Cohen
      ... Right. I hope this should fix most things. Can you re-login? Is the output of locale affected? ... Nice, but kind of an overkill. -- Tzafrir Cohen
      Message 2 of 11 , Oct 7, 2005
      • 0 Attachment
        On Fri, Oct 07, 2005 at 06:49:53PM +0300, Nigel Ridley wrote:
        > Tzafrir Cohen wrote:
        > > On Thu, Oct 06, 2005 at 10:03:09PM +0300, Nigel Ridley wrote:
        > >
        > >>Nigel Ridley wrote:
        > >>
        > >>>Shimon Lebowitz wrote:
        > >>>
        > >>>
        > >>>>Did you mount the filesystem with utf8 in the fstab?
        > >>>>I needed that before I could see Hebrew file names.
        > >>>>
        > >>>>Shana tova,
        > >>>>Shimon
        > >>>>
        > >>>
        > >>>
        > >>>I have now mounted the file system as utf8:
        > >>>/dev/hda5 /home reiserfs utf8,auto 0 2
        > >>
        > >>Oops - should read as:
        > >>/dev/hda5 /home reiserfs utf8 defaults,auto 0 2
        > >
        > >
        > > Reiserfs , ext2, ext3, xfs and generally "unix file systes" (with the
        > > exception of jfs, that has os/2 roots) don't have a character set in the
        > > file system. The name of a file is simply a string and does not have any
        > > character set attached to it. Therefore no character set mount option is
        > > needed and is recognized.
        > >
        > > Thus both fstab lines above are incorrect: the first one has an
        > > incorrect option to reiserfs, whereas the secon is not even in the right
        > > syntax.
        >
        > Yes you're right - I read the man pages and corrected the fstab.
        >
        > >
        > > If you start a terminal by just running the command 'xterm' and run in
        > > it the command 'locale', what is the output?
        >
        > It's actually on the other box so I can't give a 'copy and paste' but
        > here is the first couple of lines:
        > LANG=C
        > LC_TYPE = "C"
        >
        > all the other entries also end in C.
        >
        > >
        > >
        > >>>but I still can't get KDE to show a new folder written in Hebrew - still
        > >>>the ?????'s.
        > >
        > >
        > > KDE not using a UTF-8 locale? We'll see that from the test above.
        >
        > I did do a 'dpkg-reconfigure locales' and added both the Hebrew entries
        > as well as utf8 (US) and then chose utf8 (US) as the default locale.

        Right. I hope this should fix most things. Can you re-login? Is the
        output of 'locale' affected?

        >
        > I did find something that sounds useful:
        > http://article.gmane.org/gmane.linux.region.israel.ivrix.discuss/1062
        > where it mentions a package named 'hebrew-meta-pack'
        > [quote]
        > All That a Hebrew user need to do is:
        > "apt-get/urpmi/yum install hebrew-meta-pack", and his
        > box will be Hebrew enabled.

        Nice, but kind of an overkill.

        --
        Tzafrir Cohen | tzafrir@... | VIM is
        http://tzafrir.org.il | | a Mutt's
        tzafrir@... | | best
        ICQ# 16849755 | | friend
      • Nigel Ridley
        ... [snip] ... [snip] ... Yes I can re-login; no the output of locale still gives C and I still get the same ??????????? s I even tried resetting the
        Message 3 of 11 , Oct 8, 2005
        • 0 Attachment
          Tzafrir Cohen wrote:
          > On Fri, Oct 07, 2005 at 06:49:53PM +0300, Nigel Ridley wrote:
          >
          >>Tzafrir Cohen wrote:
          >>

          [snip]

          >>>If you start a terminal by just running the command 'xterm' and run in
          >>>it the command 'locale', what is the output?
          >>
          >>It's actually on the other box so I can't give a 'copy and paste' but
          >>here is the first couple of lines:
          >>LANG=C
          >>LC_TYPE = "C"
          >>
          >>all the other entries also end in C.
          >>
          >>
          >>>

          [snip]

          >>>KDE not using a UTF-8 locale? We'll see that from the test above.
          >>
          >>I did do a 'dpkg-reconfigure locales' and added both the Hebrew entries
          >>as well as utf8 (US) and then chose utf8 (US) as the default locale.
          >
          >
          > Right. I hope this should fix most things. Can you re-login? Is the
          > output of 'locale' affected?

          Yes I can re-login; no the output of 'locale' still gives 'C' and I
          still get the same ???????????'s

          I even tried resetting the locale (using dpkg) to Hebrew utf8 - but same
          as above.

          The strange thing is that on another box we have Libranet which uses the
          default GDM and there is an option for language type. If I choose Hebrew
          everything works great!
          What do the GDM scripts change?

          >
          >
          >>I did find something that sounds useful:
          >>http://article.gmane.org/gmane.linux.region.israel.ivrix.discuss/1062
          >>where it mentions a package named 'hebrew-meta-pack'
          >>[quote]
          >>All That a Hebrew user need to do is:
          >>"apt-get/urpmi/yum install hebrew-meta-pack", and his
          >>box will be Hebrew enabled.
          >
          >
          > Nice, but kind of an overkill.
          >

          I might just try it - as a last resort :-)

          Blessings,

          Nigel

          --
          It's not a problem -- it's a learning opportunity.
          --

          I AM Bible Studies and Resources
          http://www.i-amfaithweb.net

          Messianic E-Cards.com
          http://www.messianicecards.com

          OliveRoot Ministries
          http://www.oliveroot.net

          PrayingForIsrael.net
          http://www.prayingforisrael.net
        • Tzafrir Cohen
          ... They explicitly set the locale environment variables. -- Tzafrir Cohen | tzafrir@jbr.cohens.org.il | VIM is http://tzafrir.org.il |
          Message 4 of 11 , Oct 8, 2005
          • 0 Attachment
            On Sat, Oct 08, 2005 at 10:04:53AM +0300, Nigel Ridley wrote:
            > Tzafrir Cohen wrote:
            > > On Fri, Oct 07, 2005 at 06:49:53PM +0300, Nigel Ridley wrote:
            > >
            > >>Tzafrir Cohen wrote:
            > >>
            >
            > [snip]
            >
            > >>>If you start a terminal by just running the command 'xterm' and run in
            > >>>it the command 'locale', what is the output?
            > >>
            > >>It's actually on the other box so I can't give a 'copy and paste' but
            > >>here is the first couple of lines:
            > >>LANG=C
            > >>LC_TYPE = "C"
            > >>
            > >>all the other entries also end in C.
            > >>
            > >>
            > >>>
            >
            > [snip]
            >
            > >>>KDE not using a UTF-8 locale? We'll see that from the test above.
            > >>
            > >>I did do a 'dpkg-reconfigure locales' and added both the Hebrew entries
            > >>as well as utf8 (US) and then chose utf8 (US) as the default locale.
            > >
            > >
            > > Right. I hope this should fix most things. Can you re-login? Is the
            > > output of 'locale' affected?
            >
            > Yes I can re-login; no the output of 'locale' still gives 'C' and I
            > still get the same ???????????'s
            >
            > I even tried resetting the locale (using dpkg) to Hebrew utf8 - but same
            > as above.
            >
            > The strange thing is that on another box we have Libranet which uses the
            > default GDM and there is an option for language type. If I choose Hebrew
            > everything works great!
            > What do the GDM scripts change?

            They explicitly set the locale environment variables.

            --
            Tzafrir Cohen | tzafrir@... | VIM is
            http://tzafrir.org.il | | a Mutt's
            tzafrir@... | | best
            ICQ# 16849755 | | friend
          • Nigel Ridley
            ... So, since I have set the locale environment variables, via dpkg-reconfigure locales , to Hebrew utf8, why can t I get Hebrew file names? Actually, on the
            Message 5 of 11 , Oct 8, 2005
            • 0 Attachment
              Tzafrir Cohen wrote:
              > On Sat, Oct 08, 2005 at 10:04:53AM +0300, Nigel Ridley wrote:
              >
              >>Tzafrir Cohen wrote:
              >>
              >>>On Fri, Oct 07, 2005 at 06:49:53PM +0300, Nigel Ridley wrote:
              >>>
              >>>
              >>>>Tzafrir Cohen wrote:
              >>>>
              >>
              >>[snip]
              >>
              >>
              >>>>>If you start a terminal by just running the command 'xterm' and run in
              >>>>>it the command 'locale', what is the output?
              >>>>
              >>>>It's actually on the other box so I can't give a 'copy and paste' but
              >>>>here is the first couple of lines:
              >>>>LANG=C
              >>>>LC_TYPE = "C"
              >>>>
              >>>>all the other entries also end in C.
              >>>>
              >>>>
              >>>>
              >>[snip]
              >>
              >>
              >>>>>KDE not using a UTF-8 locale? We'll see that from the test above.
              >>>>
              >>>>I did do a 'dpkg-reconfigure locales' and added both the Hebrew entries
              >>>>as well as utf8 (US) and then chose utf8 (US) as the default locale.
              >>>
              >>>
              >>>Right. I hope this should fix most things. Can you re-login? Is the
              >>>output of 'locale' affected?
              >>
              >>Yes I can re-login; no the output of 'locale' still gives 'C' and I
              >>still get the same ???????????'s
              >>
              >>I even tried resetting the locale (using dpkg) to Hebrew utf8 - but same
              >>as above.
              >>
              >>The strange thing is that on another box we have Libranet which uses the
              >>default GDM and there is an option for language type. If I choose Hebrew
              >>everything works great!
              >>What do the GDM scripts change?
              >
              >
              > They explicitly set the locale environment variables.
              >

              So, since I have set the locale environment variables, via
              'dpkg-reconfigure locales', to Hebrew utf8, why can't I get Hebrew file
              names?

              Actually, on the desktop there are Hebrew file names - for the Trash and
              Home folders; but I can't create new ones (with Hebrew names).

              Another strange thing is that in the KDE Control Center the window title
              is in ??????'s but if I click on 'Appearance and Themes' > 'Fonts'
              (Gofanim in the [all] Hebrew menus), then 'Gofanim' (in Hebrew) appears
              in the window title next to a load of ?????'s (which is meant to be
              'Control Center' in Hebrew).

              Perhaps it is a Kanotix bug? or should I ask on the KDE mailing list?

              Blessings,

              Nigel

              --
              It's not a problem -- it's a learning opportunity.
              --

              I AM Bible Studies and Resources
              http://www.i-amfaithweb.net

              Messianic E-Cards.com
              http://www.messianicecards.com

              OliveRoot Ministries
              http://www.oliveroot.net

              PrayingForIsrael.net
              http://www.prayingforisrael.net
            Your message has been successfully submitted and would be delivered to recipients shortly.