Loading ...
Sorry, an error occurred while loading the content.

vocalized Hebrew in firefox and openoffice

Expand Messages
  • Mathias Weyland
    Hi I am Matt from Switzerland. I m not a linux newbie, but I have the feeling that my question is so trivial that I don t want to bother the other list.
    Message 1 of 5 , Oct 2, 2005
    • 0 Attachment
      Hi

      I am Matt from Switzerland. I'm not a linux newbie, but I have the feeling
      that my question is so trivial that I don't want to bother the other list.
      Unfortunately, reading Hebrew in Switzerland is not a common thing,
      especially not with linux, so I don't know who I could ask. Furthermore, I
      couldn't find any useful information for my problem on the net, all I found
      was either outdated or in Ivrit.

      I would like to be able to read websites containing vocalized Hebrew in
      firefox and write such text in the openoffice writer (version 1.1 or 2beta).

      I managed to set up X11 with a proper keyboard layout, so basically writing
      Hebrew works. But the 'dots' (like dagesh, vowels ect.) are always displayed
      _left_ of the consonant. I made a screenshot of this page [1] which is
      available at [2] to show what I mean.

      I tried both debian sarge and unstable with the same result, and everyone I
      asked could confirm this strange behaviour of the programs. I tried several
      fonts: Arial, Monospace and even some fonts of the culmus package which are
      specially designed for Hebrew. If I copy the text from firefox to the c&p
      buffer and paste it in xchat, I get proper rendering.

      I would be very very glad if anyone could explain what I have to do to get
      proper rendering of vocalized Hebrew in openoffice and firefox.

      Best regards

      Mathias Weyland

      [1] http://www.anastesontai.com/b-vocalisee/voc-en.asp
      [2] http://www.lugs.ch/~hal/broken_hebrew.jpg
    • Tzafrir Cohen
      ... IIRC this should be fixed by using pango rendering in gecko. Anybody with a more practical answer? ... The culmus fonts have vowels. GTK/gnome programs use
      Message 2 of 5 , Oct 2, 2005
      • 0 Attachment
        On Mon, Oct 03, 2005 at 12:56:56AM +0200, Mathias Weyland wrote:
        > Hi
        >
        > I am Matt from Switzerland. I'm not a linux newbie, but I have the feeling
        > that my question is so trivial that I don't want to bother the other list.
        > Unfortunately, reading Hebrew in Switzerland is not a common thing,
        > especially not with linux, so I don't know who I could ask. Furthermore, I
        > couldn't find any useful information for my problem on the net, all I found
        > was either outdated or in Ivrit.
        >
        > I would like to be able to read websites containing vocalized Hebrew in
        > firefox and write such text in the openoffice writer (version 1.1 or 2beta).
        >
        > I managed to set up X11 with a proper keyboard layout, so basically writing
        > Hebrew works. But the 'dots' (like dagesh, vowels ect.) are always displayed
        > _left_ of the consonant. I made a screenshot of this page [1] which is
        > available at [2] to show what I mean.

        IIRC this should be fixed by using pango rendering in gecko.

        Anybody with a more practical answer?

        >
        > I tried both debian sarge and unstable with the same result, and everyone I
        > asked could confirm this strange behaviour of the programs. I tried several
        > fonts: Arial, Monospace and even some fonts of the culmus package which are
        > specially designed for Hebrew. If I copy the text from firefox to the c&p
        > buffer and paste it in xchat, I get proper rendering.

        The culmus fonts have vowels.

        GTK/gnome programs use Pango as part of gtk. KDE/QT programs use QT's
        rendering. OpenOffice has independent rendering for that.

        >
        > I would be very very glad if anyone could explain what I have to do to get
        > proper rendering of vocalized Hebrew in openoffice and firefox.
        >
        > Best regards
        >
        > Mathias Weyland
        >
        > [1] http://www.anastesontai.com/b-vocalisee/voc-en.asp
        > [2] http://www.lugs.ch/~hal/broken_hebrew.jpg
        >
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >

        --
        Tzafrir Cohen | tzafrir@... | VIM is
        http://tzafrir.org.il | | a Mutt's
        tzafrir@... | | best
        ICQ# 16849755 | | friend
      • gblaisepublic
        ... Hebrew in ... or 2beta). ... basically writing ... displayed ... which is ... everyone I ... tried several ... which are ... the c&p ... do to get ... Not
        Message 3 of 5 , Oct 3, 2005
        • 0 Attachment
          --- In gnubies-il@yahoogroups.com, Mathias Weyland <mathias@w...>
          wrote:
          > Hi
          >
          > I am Matt from Switzerland.

          > I would like to be able to read websites containing vocalized
          Hebrew in
          > firefox and write such text in the openoffice writer (version 1.1
          or 2beta).
          >
          > I managed to set up X11 with a proper keyboard layout, so
          basically writing
          > Hebrew works. But the 'dots' (like dagesh, vowels ect.) are always
          displayed
          > _left_ of the consonant. I made a screenshot of this page [1]
          which is
          > available at [2] to show what I mean.
          >
          > I tried both debian sarge and unstable with the same result, and
          everyone I
          > asked could confirm this strange behaviour of the programs. I
          tried several
          > fonts: Arial, Monospace and even some fonts of the culmus package
          which are
          > specially designed for Hebrew. If I copy the text from firefox to
          the c&p
          > buffer and paste it in xchat, I get proper rendering.
          >
          > I would be very very glad if anyone could explain what I have to
          do to get
          > proper rendering of vocalized Hebrew in openoffice and firefox.
          >
          > Best regards
          >
          > Mathias Weyland
          >
          > [1] http://www.anastesontai.com/b-vocalisee/voc-en.asp
          > [2] http://www.lugs.ch/~hal/broken_hebrew.jpg

          Not sure if this will help your situation, but a fantastic Hebrew
          font (which even includes cantillation marks) is SBL's font.
          You can download the font and a keyboard map free at

          http://www.sbl-site.org/Resources/default.aspx

          I haven't yet tried in on my Linux system, but it works great on my
          Windoze box.

          Gerald
        • Mathias Weyland
          ... Hi I ve tried that font. The result is better, but it still doesen t look like it should. [0] I did some additional googling and found [1]. I tried the
          Message 4 of 5 , Oct 4, 2005
          • 0 Attachment
            On Tue, Oct 04, 2005 at 02:43:45AM -0000, gblaisepublic wrote:

            > Not sure if this will help your situation, but a fantastic Hebrew
            > font (which even includes cantillation marks) is SBL's font.
            > You can download the font and a keyboard map free at

            Hi

            I've tried that font. The result is better, but it still doesen't look like
            it should. [0]

            I did some additional googling and found [1]. I tried the patch for pango,
            the pango packages available on that site and the experimental version of
            pange where the problem should be fixed. But no success :(. Bug #21 looks
            exactly like my problem, though.

            Furthermore, I tried the patched version of mozilla firefox. Same result :(.
            I really don't know what to do. Is anyone able to see dagesh and nikud
            correctly? If yes, could that person tell me about his distribution and
            special settings he/she made? I'll try to track down the problem then.

            Best regards and thank you for your support

            Mathias Weyland

            [0] http://www.lugs.ch/~hal/broken_hebrew2.jpg
            [1] http://blacksapphire.com/firefox-rtl/
          • Oded Arbel
            ... I don t have any problems seeing nikud (diacritics) in the site whose screenshot you provided, with Mozilla Firefox 1.0.6:
            Message 5 of 5 , Oct 5, 2005
            • 0 Attachment
              On Tuesday, 4 בOctober 2005 21:14, Mathias Weyland wrote:
              > Is anyone able to see
              > dagesh and nikud correctly? If yes, could that person tell me about
              > his distribution and special settings he/she made? I'll try to track
              > down the problem then.

              I don't have any problems seeing nikud (diacritics) in the site whose
              screenshot you provided, with Mozilla Firefox 1.0.6:
              http://www.geek.co.il/screenshots/hebrew-bible-ok.png
              Konqueror from KDE 3.4.2 shows the same page without any problems as
              well although the characters are a little more blocky.

              I'm using Mandriva 2006 RC1 without any modifications whatsoever. I
              believe Mandriva 10.2 would work the same.

              --
              Oded

              ::..
              One man's theology is another man's belly laugh.
            Your message has been successfully submitted and would be delivered to recipients shortly.