Loading ...
Sorry, an error occurred while loading the content.

Re: [gnubies-il] changing the keyboard language

Expand Messages
  • Offer Kaye
    ... Hi Uri, I tried following the instructions, but the Include Latin Layout options stays grayed out and can t be selected. Help? -- Offer Kaye
    Message 1 of 6 , Jan 20, 2005
    • 0 Attachment
      On Thu, 20 Jan 2005 00:53:05 -0500, Uri Sharf wrote:
      >
      > Hi offer,
      > see some examples here:
      >
      > KDE
      > http://linmagazine.co.il/book/view/4328

      Hi Uri,
      I tried following the instructions, but the "Include Latin Layout"
      options stays grayed out and can't be selected. Help?

      --
      Offer Kaye
    • David Raviv
      Hi Offer, I had the same problem. Here is how I ve solved it: Under configure your desktop go to accessibility then keyboard layout. In the active layouts
      Message 2 of 6 , Jan 22, 2005
      • 0 Attachment
        Hi Offer,

        I had the same problem.
        Here is how I've solved it:

        Under "configure your desktop" go to accessibility then keyboard layout.
        In the active layouts select only "Israel (il)". Now select the line
        you just added, and tick the "Include latine layout" check box bellow.

        Now you will not have the language indication on the screen. You can
        go to Xkb tab and select the option to have an indication led on the
        keyboard.

        I would prefer to have the indication on the screen as well, but this
        is the only way I managed to use the keybord to switch between the
        languages.

        Hope I helped...

        David.



        On Thu, 20 Jan 2005 16:41:37 -0500, Offer Kaye <offer.kaye@...> wrote:
        >
        > On Thu, 20 Jan 2005 00:53:05 -0500, Uri Sharf wrote:
        > >
        > > Hi offer,
        > > see some examples here:
        > >
        > > KDE
        > > http://linmagazine.co.il/book/view/4328
        >
        > Hi Uri,
        > I tried following the instructions, but the "Include Latin Layout"
        > options stays grayed out and can't be selected. Help?
        >
        > --
        > Offer Kaye
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >


        --
        _________________________
        David Raviv
        T +972 3 6702255
        M +972 52 8543929
        F +972 3 6702255
        Email: david.raviv@...
      • Offer Kaye
        ... As I answered Uri, the Include Latin Layout option stays grayed-out no matter what I do and can t be selected. Any idea why that is? ... Fraid not, but
        Message 3 of 6 , Jan 22, 2005
        • 0 Attachment
          On Sat, 22 Jan 2005 21:16:54 +0200, David Raviv wrote:
          >
          > Under "configure your desktop" go to accessibility then keyboard layout.
          > In the active layouts select only "Israel (il)". Now select the line
          > you just added, and tick the "Include latine layout" check box bellow.
          >

          As I answered Uri, the "Include Latin Layout" option stays grayed-out
          no matter what I do and can't be selected. Any idea why that is?

          >
          > Hope I helped...
          >

          'Fraid not, but thanks for trying.

          --
          Offer Kaye
        • Moshe Kaminsky
          Hi, ... I don t know how to do it with KDE, but I can say how I did it for X. First, you need to find the X configuration file. It is called either xorg.conf
          Message 4 of 6 , Jan 22, 2005
          • 0 Attachment
            Hi,

            * Offer Kaye <offer.kaye@...> [19/01/05 22:56]:
            >
            > Hi,
            > I'm using KDE 3.2.3 on Mepis Linux (a Debian derivitive) and would
            > like to sometimes switch my keyboard between English and Hebrew.
            > I've manged to setup KDE to show a little flag that I can click on to
            > change the language, but I would also like to be able to do it using
            > the ALT+SHIFT keys, like in Windows.
            > Is there a way to set this up?

            I don't know how to do it with KDE, but I can say how I did it for X.
            First, you need to find the X configuration file. It is called either
            xorg.conf or XF86Config (depending on the X implementation you have),
            and is placed usually in /etc/X11. In this file, look for a section
            "InputDevice" for the keyboard. It should contain a line like

            Identifier "Keyboard1"

            Inside it, look for lines of the form

            Option "XkbLayout" "..."
            Option "XkbOptions" "..."

            For the XkbLayout, make sure it contains us and il, for english and
            hebrew. For XkbOptions, add the string grp:alt_shift_toggle (the options
            are separated with commas). If these lines don't exist, add them. That
            should be it.

            There are some other useful options to put. There is a good
            documentation which comes with the X installation. On my system it's in

            /usr/lib/X11/xkb/README.config

            (and /etc/X11/xkb is a link to that directory)

            HTH,

            Moshe
            >
            > Thanks in advance,
            > --
            > Offer Kaye
            >
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >

            --
            I love deadlines. I like the whooshing sound they make as they fly by.
            -- Douglas Adams

            Moshe Kaminsky <kaminsky@...>
            Home: 08-9456841
          Your message has been successfully submitted and would be delivered to recipients shortly.