Loading ...
Sorry, an error occurred while loading the content.

fedora 2 & OOhebrew

Expand Messages
  • Errol & Estelle Sapir
    I have been trying to write Hebrew in OO. Many people have been helping me on the OO forum. I ll describe briefly the problem and then ask for help. I am able
    Message 1 of 4 , Jul 24 3:12 AM
    • 0 Attachment
      I have been trying to write Hebrew in OO. Many people have been helping
      me on the OO forum. I'll describe briefly the problem and then ask for
      help. I am able to write Hebrew ANYWHERE in Fedora except in any of the
      open office programs. There when trying to write Hebrew I get gibberish.
      English is written OK.
      The final bit of help over a period of time came from Yitzchak Gale. I
      am grateful to him, Shoshannah Forbes, Tzafrir Cohen who were the main
      helpers who set me on the right track. After realizing that the problem
      is now a Fedora core 2 one, I am turning to this forum for what I hope
      is the end of a search for the way to write Hebrew in Open Office. I'll
      paste some the final transaction between me and Yitchak & hopefully my
      problem will become clear!





      >
      > Well, I have not used KDE that much, but
      > I'll give it a try. If this doesn't work,
      > I'm afraid someone else who knows KDE better
      > will have to step in. Here goes:
      >
      > 1. Right-click the OOo icon on the panel.
      > 2. Select Properties.
      > 3. Select the Execute tab.
      > 4. Modify the text in the Command field as follows:
      >
      > Leave all of the existing text. Before the existing
      > text add the following new text:
      >
      > /bin/env LC_CTYPE=en_US.UTF-8
      >
      > Make sure that there is a space after the new text
      > to separate it from the existing text.
      >
      > 5. Click OK.
      >
      > I hope that will do it. Test it out. Reboot and test it
      > again. Does it work? Is it permanent?
      >
      > -Yitzchak

      Where do I type the line you wrote?
      When right clicking "properties" on any of the icons in the taskbar I
      don't get any tab or box with "execute". I get three tabs at the top
      "general", "permissions" & "application". I don't see anywhere to modify
      text! I'm sure I'm missing something here.

      Errol

      Basically my question to this forum is the same as I asked Yitzchak. I
      was able to write Hebrew if I started wirter (or calc etc.) with the
      following command

      LC_CTYPE=C oowriter &

      That worked and hence Yitzchak's above suggestion which I cannot implement.
      Help Please!!

      TIA
      Errol
    • usharf@linmagazine.co.il
      What you are describing here is not really needed. I have the same setup like you, and I don t need to go through this. My default system locale is en_US.UTF-8
      Message 2 of 4 , Aug 16, 2004
      • 0 Attachment
        What you are describing here is not really needed. I have the same setup like
        you, and I don't need to go through this. My default system locale is
        en_US.UTF-8 and I don't have problems typing Hebrew in OOo's applications. It
        could help if you check what you have in: /etc/sysconfig/i18n.

        Uri

        > Where do I type the line you wrote?
        > When right clicking "properties" on any of the icons in the taskbar I
        > don't get any tab or box with "execute". I get three tabs at the top
        > "general", "permissions" & "application". I don't see anywhere to modify
        > text! I'm sure I'm missing something here.

        Errol

        Basically my question to this forum is the same as I asked Yitzchak. I
        was able to write Hebrew if I started wirter (or calc etc.) with the
        following command

        LC_CTYPE=C oowriter &

        That worked and hence Yitzchak's above suggestion which I cannot implement.
        Help Please!!
      • Errol & Estelle Sapir
        Uri Thanks for your interest in solving to open office problem I had with writing Hebrew. I managed to solve the problem and reported my solution on the 00o
        Message 3 of 4 , Aug 17, 2004
        • 0 Attachment
          Uri
          Thanks for your interest in solving to open office problem I had with
          writing Hebrew. I managed to solve the problem and reported my solution
          on the 00o forum. I am reprinting it here for this forum.
          Here is my solution which works for me!
          Errol

          I'm not sure that what I'm about to describe is the best or correct way
          of writing Hebrew in Open Office programs an Fedora core 2. It is the
          way I got to write Hebrew using OO after MANY unsuccessful attempts. For
          the sake of this article I am reconstructing from memory and trying to
          put into logical order what was three or four weeks of trial and error.

          Hopefully this will help others with the same problem.
          The problem was that I could write Hebrew anywhere in Linux, EXCEPT in
          Open Office.
          I want to thank all members of the Ooo-H & gnubies-il forums who aided
          me in solving the problem. I want to thank three people in particular,
          at the risk of forgetting others (to them I apologize). Thanks to
          Shoshannah Fobes who started me on the right track, to Tzafrir Cohen who
          plodded on with advice when it seemed (to me) that I was getting nowhere
          and to Yatzchak Gale who put the final piece in the puzzle.

          Background and clarifications
          I installed Fedora core 2 as a textual setup. For some reason the CD's
          on my computer wouldn't do a graphical installation. I don't think this
          had any effect on what came later, because after installation everything
          worked OK.
          I installed the complete installation – i.e. all the packages that came
          on the 4 CD's.
          I did the English installation and added Hebrew as another language to
          be installed.
          The OO installation that came with Fedora worked OK without Hebrew. In
          my many attempts to solve the Hebrew problem, I also installed
          Linux-Culmus from the www.linux.org.il site. BOTH versions of Linux
          reacted in the same way to Hebrew writing.
          I am using the KDE format but had the same problems when in Gnome.
          The first step was to go to the site
          http://easylinux.jokie.net/hebrew.html It is a site written in Hebrew
          and offers many ways of setting up Linux to work with Hebrew. I applied
          the setup for the parameters which I wanted. I wanted English interface
          with Hebrew possibilities. I have translated the stages I used from that
          site.

          Stages I went through.
          1.Define the keyboard so that ALT/SHIFT toggles between English and Hebrew.
          i. Open the Terminal by pressing the Start menu button>system
          tools>terminal.
          ii. In the terminal type "su" (without the quotes) to get root and then
          your root password.
          Iii. Now type:
          kate /home/user/.Xkbmap
          The word “user” is replaced by your user name.
          iv. Then type:
          -option grp:alt_shift_toggle,grp:switch,grp_led:scroll us,il
          note the “-” sign that starts the string.
          v. Save the file.

          2.Define Hebrew in the system (but keeping English interface).
          i. As root in the terminal type:
          kate /etc/sysconfig/i18n
          ii. Change whatever is written in the file that appears to: (keep the
          quotes, upper and lower-case)
          LC_CTYPE="he_IL"
          LANG="en_US.UTF-8"
          SUPPORTED="en_US.UTF-8:en_US:en:he_IL.UTF-8:he_IL:he:he_IL.ISO-8859-

          8:hebrew:he_IL.UTF-8"
          (Note: from SUPPORTED to the last quote should all be on one line)
          SYSFONT="latarcyrheb-sun16"
          iii. Save the file.

          3.Defining the directories and files to support Hebrew names.
          i. As root in the terminal type:
          kate /etc/fstab
          ii.The next command is placed in the fourth column (after the word
          "defaults")
          defaults,iocharset=iso8859-8,codepage=862
          As you will see when opening this file, there are many lines one could
          write the above string on.
          As a relative newbie to Linux I'm not sure exactly on which line is the
          correct one. I tried several places and at the moment it is in the same
          line as "/sys". That could be the wrong place! Input anyone?

          4.The final problem and it's solution (at least for me).

          After doing all of the above my problems really became confusing to me.

          I was able to write Hebrew anywhere in Fedora – in terminal, in any
          place that text could be written! The ONLY place Hebrew would not type
          was in any of the Open Office programs. Here is where Yitzchak Gale gave
          me the push I needed.
          i. After much corresponding on the forum he asked me to type:
          LC_CTYPE=C oowriter &
          at the shell prompt. This command opened the oowriter with the ability
          to write Hebrew. Eureka!!

          ii. Now the problem became how to make this permanent i.e. so that
          whenever one opens the OO the ability to write in Hebrew would be
          possible. My workaround enables me to open any of the OO programs and
          write Hebrew and use different Hebrew fonts etc. It seems the every
          version of Linux sees the OO files in a different way. I'll try and explain.
          Yitzchak suggested to me the following:
          1.Right-click the OOo icon on the panel.
          2. Select Properties.
          3. Select the Execute tab.
          4. Modify the text in the Command field as follows:
          i. Leave all of the existing text. Before the existing
          text add the following new text:

          /bin/env LC_CTYPE=en_US.UTF-8

          ii. Make sure that there is a space after the new text
          to separate it from the existing text.

          5.Click OK.

          When trying the above that I found no “execute” tab inproperties of OO
          programs.
          In Fedora core 2 when pressing on properties on any of the OO progams,
          the properties box comes up with three tabs - “general”, “permissions” &
          “application”. When opening the application tab, there arevarious text
          boxes. In the one called “command” is written the name ofthe OO program
          - “oowriter”, “oocalc” or “ooimprress”. BEFORE those names I added the
          original command given to me by Yitzchak and then a space before the
          name of the program. So the command box under the application tab now reads:
          LC_CTYPE=C oowriter
          I repeated this for each of the OO programs and am happy to say that I
          can now write Hebrew in ALL of the OO programs. So the other two
          programs also have a new line in the command:
          LC_CTYPE=C ooimpress
          and
          LC_CTYPE=C oocalc

          I hope these instructions are clear and will be only too willing to
          clarify anything. It is essential to keep all upper and lower –case
          letters as typed here.

          Errol

          usharf@... wrote:

          > What you are describing here is not really needed. I have the same setup
          > like
          > you, and I don't need to go through this. My default system locale is
          > en_US.UTF-8 and I don't have problems typing Hebrew in OOo's
          > applications. It
          > could help if you check what you have in: /etc/sysconfig/i18n.
          >
          > Uri
          >
          > > Where do I type the line you wrote?
          > > When right clicking "properties" on any of the icons in the taskbar I
          > > don't get any tab or box with "execute". I get three tabs at the top
          > > "general", "permissions" & "application". I don't see anywhere to modify
          > > text! I'm sure I'm missing something here.
          >
          > Errol
          >
          > Basically my question to this forum is the same as I asked Yitzchak. I
          > was able to write Hebrew if I started wirter (or calc etc.) with the
          > following command
          >
          > LC_CTYPE=C oowriter &
          >
          > That worked and hence Yitzchak's above suggestion which I cannot implement.
          > Help Please!!
          >
          > *Yahoo! Groups Sponsor*
          > ADVERTISEMENT
          > click here
          > <http://us.ard.yahoo.com/SIG=1291jhrk6/M=298184.5285298.6392945.3001176/D=groups/S=1705006580:HM/EXP=1092850930/A=2164331/R=0/SIG=11eaelai9/*http://www.netflix.com/Default?mqso=60183351>
          >
          >
          > ------------------------------------------------------------------------
          > *Yahoo! Groups Links*
          >
          > * To visit your group on the web, go to:
          > http://groups.yahoo.com/group/gnubies-il/
          >
          > * To unsubscribe from this group, send an email to:
          > gnubies-il-unsubscribe@yahoogroups.com
          > <mailto:gnubies-il-unsubscribe@yahoogroups.com?subject=Unsubscribe>
          >
          > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          > Service <http://docs.yahoo.com/info/terms/>.
          >
          >
          >
          > ------------------------------------------------------------------------
          >
          > #####################################################################################
          > This Mail Was Scanned by 012.net Anti Virus Service - Powered by TrendMicro Interscan
        • Uri Sharf
          Thank you Errol, that makes sense and a good reference for others as well. Uri
          Message 4 of 4 , Aug 18, 2004
          • 0 Attachment
            Thank you Errol, that makes sense and a good reference for others as well.

            Uri
          Your message has been successfully submitted and would be delivered to recipients shortly.