Loading ...
Sorry, an error occurred while loading the content.
 

Configure minicom to work as terminal

Expand Messages
  • iandahf
    I need to connect my Linux machine to a windows machine with hyperterminal - (porpose is to establish the session through the serial port by intention) What
    Message 1 of 2 , Apr 29, 2004
      I need to connect my Linux machine to a windows machine with hyperterminal - (porpose is to
      establish the session through the serial port by intention)

      What specific settings I need in order that Minicom will recognize the Serial port and
      send/receive the dat through him ? all the settings from the Minicom menu are set and
      correct, but the Minicom says "Offline"

      When redirecting some output to the serial port I do get the output in my Windows
      Hyperterminal.

      Thanks,


      Hazanis
    • Tzafrir Cohen
      ... minicom serves the same function of hyper-terminal on windows: a terminal for serial-line connection. I don t understand why you wish to configure it
      Message 2 of 2 , Apr 30, 2004
        On Thu, Apr 29, 2004 at 02:03:27PM -0000, iandahf wrote:
        > I need to connect my Linux machine to a windows machine with
        > hyperterminal - (porpose is to establish the session through the
        > serial port by intention)
        >
        > What specific settings I need in order that Minicom will recognize the
        > Serial port and send/receive the dat through him ? all the settings
        > from the Minicom menu are set and correct, but the Minicom says
        > "Offline"

        minicom serves the same function of hyper-terminal on windows: a
        terminal for serial-line connection. I don't understand why you wish to
        configure it (unless this is in a different linux machine).

        >
        > When redirecting some output to the serial port I do get the output
        > in my Windows Hyperterminal.

        Basically you need a getty process (e.g: mgetty) to listen on the serial
        line.

        /etc/inttab of my current distro (debian/stable) contains the following
        remme-out lines:

        #T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
        #T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

        See if your distro already has such lines. If so: unrem them (remove the
        '#' marks) and then run 'telinit q' to tell the init process to reread
        /etc/inittab .

        Alternatively: you may want a headless station with a serial terimnal as
        a console. In that case I believe you need to either config lilo for that
        (does grub support bootting with a serail console?) . It may be even
        better if you bios support a serail terminal, because this will also
        allow you to see bios boot messages in the remote terminal.

        --
        Tzafrir Cohen +---------------------------+
        http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
        mailto:tzafrir@... +---------------------------+
      Your message has been successfully submitted and would be delivered to recipients shortly.