Loading ...
Sorry, an error occurred while loading the content.

Re: [gnubies-il] Re: Problam with the FSTAB file , i cant mount my HD

Expand Messages
  • Itamar Ravid
    On Fri, 26 Dec 2003 02:09:56 -0000 ... It should look something like this: /dev/hda1 /mnt/disk vfat iocharset=utf8,codepage=862 0 0 Those should all be in
    Message 1 of 6 , Dec 27, 2003
    • 0 Attachment
      On Fri, 26 Dec 2003 02:09:56 -0000
      "sorer_17" <sorer_17@...> wrote:

      > --- In gnubies-il@yahoogroups.com, Tzafrir Cohen <tzafrir@t...> wrote:
      > > On Thu, Dec 25, 2003 at 10:43:41PM -0000, sorer_17 wrote:
      > > > i use this command in th FSTAB file :
      > > > /dev/hda1 /mnt/disk vfat -o
      > > > iocharset=utf8,codepage=862
      > > >
      > > > but its aint working , somone can help me please
      > > >
      > >
      > > remove the "-o"
      > >
      > > /dev/hda1 /mnt/disk vfat iocharset=utf8,codepage=862
      > >
      > > --
      > > Tzafrir Cohen +---------------------------+
      > > http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
      > > mailto:tzafrir@t... +---------------------------+
      >
      >
      > its still not working
      >
      >
      > To unsubscribe from this group, send an email to:
      > gnubies-il-unsubscribe@egroups.com
      >
      >
      >
      > Yahoo! Groups Links
      >
      > To visit your group on the web, go to:
      > http://groups.yahoo.com/group/gnubies-il/
      >
      > To unsubscribe from this group, send an email to:
      > gnubies-il-unsubscribe@yahoogroups.com
      >
      > Your use of Yahoo! Groups is subject to:
      > http://docs.yahoo.com/info/terms/
      >
      >
      It should look something like this:

      /dev/hda1 /mnt/disk vfat iocharset=utf8,codepage=862 \ 0 0

      Those should all be in one line. Check out your other lines in the fstab- this one should follow the same structure.
    • Tzafrir Cohen
      ... it is not working is not very helpful. some extra details? Does it give the same error message? ... Actually: /dev/hda1 /mnt/disk vfat
      Message 2 of 6 , Dec 27, 2003
      • 0 Attachment
        On Sat, Dec 27, 2003 at 01:43:58PM +0200, Itamar Ravid wrote:
        > On Fri, 26 Dec 2003 02:09:56 -0000
        > "sorer_17" <sorer_17@...> wrote:
        >
        > > --- In gnubies-il@yahoogroups.com, Tzafrir Cohen <tzafrir@t...> wrote:
        > > > On Thu, Dec 25, 2003 at 10:43:41PM -0000, sorer_17 wrote:
        > > > > i use this command in th FSTAB file :
        > > > > /dev/hda1 /mnt/disk vfat -o
        > > > > iocharset=utf8,codepage=862
        > > > >
        > > > > but its aint working , somone can help me please
        > > > >
        > > >
        > > > remove the "-o"
        > > >
        > > > /dev/hda1 /mnt/disk vfat iocharset=utf8,codepage=862
        > >
        > > its still not working

        "it is not working" is not very helpful. some extra details? Does it
        give the same error message?

        > >
        > >
        > It should look something like this:
        >
        > /dev/hda1 /mnt/disk vfat iocharset=utf8,codepage=862 \ 0 0

        Actually:

        /dev/hda1 /mnt/disk vfat iocharset=utf8,codepage=862 0 0

        (the '\' was removed). My line above was missing the two zeros in the
        end.

        If that does not work please send the output of the following commands:

        mount
        fdisk -l /dev/hda

        You need to be root for the last command

        --
        Tzafrir Cohen +---------------------------+
        http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
        mailto:tzafrir@... +---------------------------+
      • Neil Magedman
        ... 1) You say it isn t working. What exactly isn t working? Is it failing to mount? If so, what s the error message? Does it work when you mount it by
        Message 3 of 6 , Dec 27, 2003
        • 0 Attachment
          > > > > i use this command in th FSTAB file :
          > > > > /dev/hda1 /mnt/disk vfat -o
          > > > > iocharset=utf8,codepage=862
          > > > >
          > > > > but its aint working , somone can help me please
          > > >
          > > > remove the "-o"
          > > >
          > > > /dev/hda1 /mnt/disk vfat
          > > > iocharset=utf8,codepage=862
          > >
          > > its still not working
          > >
          > It should look something like this:
          >
          > /dev/hda1 /mnt/disk vfat iocharset=utf8,codepage=862 \ 0 0
          >
          > Those should all be in one line. Check out your other lines in the
          > fstab- this one should follow the same structure.
          >

          1) You say it isn't working. What exactly isn't working? Is it failing
          to mount? If so, what's the error message? Does it work when you
          mount it by hand? (i.e.
          # mount -t vfat -o iocharset=utf8,codepage=862 /dev/hda1 /mnt/disk
          ) Be descriptive with the problem.

          2) Do you have the codepage file installed? Run
          $ locate nls_cp862.o
          It should turn up something like
          /lib/modules/2.4.22-1-686/kernel/fs/nls/nls_cp862.o
          Do the same thing for utf8 support:
          $ locate nls_utf8
          /lib/modules/2.4.22-1-686/kernel/fs/nls/nls_utf8.o
          Make sure the kernel you are running ($ uname -r) is among the files
          listed by locate.

          3) BTW, don't worry about the "0 0" in etc/fstab. It's assumed. And I
          don't believe you can use '\' in /etc/fstab to break lines. (A quick
          test says No)

          4) I noticed in mount(8) there's also an option 'utf8' separate from
          iocharset=utf8. Experiment with that.

          --Noach
        Your message has been successfully submitted and would be delivered to recipients shortly.