Loading ...
Sorry, an error occurred while loading the content.

using Hebrew with icewm

Expand Messages
  • Nigel Ridley
    Hi, I just started using icewm and can t figure out how to be able to type in Hebrew (KDE was a no brainer) -- any pointers welcome -- even reading the fine
    Message 1 of 15 , Dec 5, 2003
    • 0 Attachment
      Hi,

      I just started using icewm and can't figure out how to be able to type
      in Hebrew (KDE was a no brainer) -- any pointers welcome -- even reading
      the fine manual:-)

      Blessings,

      Nigel Ridley

      --
      It's not a problem -- it's a learning opportunity.
      --

      I AM Bible Studies and Resources
      http://www.i-amfaithweb.net

      Messianic E-Cards.com
      http://www.messianicecards.com

      OliveRoot Ministries
      http://www.oliveroot.net
    • Tzafrir Cohen
      ... Keyboard settings are handled by X. KDE only offers a interface for configuring it. That interface often does more harm than use, I might add.
      Message 2 of 15 , Dec 5, 2003
      • 0 Attachment
        On Fri, Dec 05, 2003 at 08:35:12PM +0200, Nigel Ridley wrote:
        > Hi,
        >
        > I just started using icewm and can't figure out how to be able to type
        > in Hebrew (KDE was a no brainer) -- any pointers welcome -- even reading
        > the fine manual:-)

        Keyboard settings are handled by X. KDE only offers a interface for
        configuring it. That interface often does more harm than use, I might
        add.

        http://iglu.org.il/faq/cache/86.html

        If you need any more details: what is your distro?

        --
        Tzafrir Cohen +---------------------------+
        http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
        mailto:tzafrir@... +---------------------------+
      • Nigel Ridley
        On Fri, 5 Dec 2003 21:59:51 +0200 ... I am using Libranet 2.8 (Debian based) dist-upgraded using sarge this last week, with a few apps from sid (icewm is from
        Message 3 of 15 , Dec 5, 2003
        • 0 Attachment
          On Fri, 5 Dec 2003 21:59:51 +0200
          Tzafrir Cohen <tzafrir@...> wrote:

          > On Fri, Dec 05, 2003 at 08:35:12PM +0200, Nigel Ridley wrote:
          > > Hi,
          > >
          > > I just started using icewm and can't figure out how to be able to
          > > type in Hebrew (KDE was a no brainer) -- any pointers welcome --
          > > even reading the fine manual:-)
          >
          > Keyboard settings are handled by X. KDE only offers a interface for
          > configuring it. That interface often does more harm than use, I might
          > add.
          >
          > http://iglu.org.il/faq/cache/86.html
          >
          > If you need any more details: what is your distro?
          >
          > --
          > Tzafrir Cohen +---------------------------+
          > http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
          > mailto:tzafrir@... +---------------------------+
          >
          > ------------------------ Yahoo! Groups Sponsor
          > ---------------------~--> Buy Ink Cartridges or Refill Kits for your
          > HP, Epson, Canon or Lexmark Printer at MyInks.com. Free s/h on orders
          > $50 or more to the US & Canada.
          > http://www.c1tracking.com/l.asp?cid=5511
          > http://us.click.yahoo.com/mOAaAA/3exGAA/qnsNAA/0XFolB/TM
          > ---------------------------------------------------------------------
          > ~->
          >
          > To unsubscribe from this group, send an email to:
          > gnubies-il-unsubscribe@egroups.com
          >
          >
          >
          > Your use of Yahoo! Groups is subject to
          > http://docs.yahoo.com/info/terms/
          >

          I am using Libranet 2.8 (Debian based) dist-upgraded using sarge this
          last week, with a few apps from sid (icewm is from sarge).
          XFree 4.3.0 but without xkb (not even in sid).
          Is xkb necessary or can I follow the instructions
          (from http://iglu.org.il/faq/cache/86.html) for XFree 4.0 -- 4.21?

          Blessings,

          Nigel

          --
          It's not a problem -- it's a learning opportunity.
          --

          I AM Bible Studies and Resources
          http://www.i-amfaithweb.net

          Messianic E-Cards.com
          http://www.messianicecards.com

          OliveRoot Ministries
          http://www.oliveroot.net
        • Tzafrir Cohen
          ... What do you mean without xkb ? ... You have XFree 4.3, and thus you should use the first section (XFree 4.3). -- Tzafrir Cohen
          Message 4 of 15 , Dec 6, 2003
          • 0 Attachment
            On Sat, Dec 06, 2003 at 07:59:34AM +0200, Nigel Ridley wrote:
            > On Fri, 5 Dec 2003 21:59:51 +0200
            > Tzafrir Cohen <tzafrir@...> wrote:
            >
            > > On Fri, Dec 05, 2003 at 08:35:12PM +0200, Nigel Ridley wrote:
            > > > Hi,
            > > >
            > > > I just started using icewm and can't figure out how to be able to
            > > > type in Hebrew (KDE was a no brainer) -- any pointers welcome --
            > > > even reading the fine manual:-)
            > >
            > > Keyboard settings are handled by X. KDE only offers a interface for
            > > configuring it. That interface often does more harm than use, I might
            > > add.
            > >
            > > http://iglu.org.il/faq/cache/86.html
            > >
            > > If you need any more details: what is your distro?
            >
            > I am using Libranet 2.8 (Debian based) dist-upgraded using sarge this
            > last week, with a few apps from sid (icewm is from sarge).
            > XFree 4.3.0 but without xkb (not even in sid).

            What do you mean "without xkb"?

            > Is xkb necessary or can I follow the instructions
            > (from http://iglu.org.il/faq/cache/86.html) for XFree 4.0 -- 4.21?

            You have XFree 4.3, and thus you should use the first section (XFree
            4.3).

            --
            Tzafrir Cohen +---------------------------+
            http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
            mailto:tzafrir@... +---------------------------+
          • Leibovich
            ... It s Extremely simple and straightfoward - you can t, Icewm doesn t use a toolkit that supports Hebrew.
            Message 5 of 15 , Dec 6, 2003
            • 0 Attachment
              On Friday 05 December 2003 06:35 pm, Nigel Ridley wrote:
              > Hi,
              >
              > I just started using icewm and can't figure out how to be able to type
              > in Hebrew (KDE was a no brainer) -- any pointers welcome -- even reading
              > the fine manual:-)
              It's Extremely simple and straightfoward - you can't, Icewm doesn't use a
              toolkit that supports Hebrew.
              >
              > Blessings,
              >
              > Nigel Ridley
            • Tzafrir Cohen
              ... Sure you can. Keyboard support is not related to the window manager. It is a feature of the X server. You can set up IceWM to show unicode fonts, and then
              Message 6 of 15 , Dec 6, 2003
              • 0 Attachment
                On Sat, Dec 06, 2003 at 10:49:28PM +0000, Leibovich wrote:
                > On Friday 05 December 2003 06:35 pm, Nigel Ridley wrote:
                > > Hi,
                > >
                > > I just started using icewm and can't figure out how to be able to type
                > > in Hebrew (KDE was a no brainer) -- any pointers welcome -- even reading
                > > the fine manual:-)
                > It's Extremely simple and straightfoward - you can't, Icewm doesn't use a
                > toolkit that supports Hebrew.

                Sure you can. Keyboard support is not related to the window manager. It
                is a feature of the X server. You can set up IceWM to show unicode
                fonts, and then it will show Hebrew, but reversed.

                Note that the only Hebrew texts in IceWM are short texts , of one line.
                This means that adding bidi support into it shouldn't be a big deal:
                just filter everything through fribidi.

                --
                Tzafrir Cohen +---------------------------+
                http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
                mailto:tzafrir@... +---------------------------+
              • Nigel Ridley
                On Sat, 06 Dec 2003 22:49:28 +0000 ... So can you recommend a lightweight wm than does use Hebrew. Blessings, Nigel -- It s not a problem -- it s a learning
                Message 7 of 15 , Dec 6, 2003
                • 0 Attachment
                  On Sat, 06 Dec 2003 22:49:28 +0000
                  Leibovich <meh@...> wrote:

                  > On Friday 05 December 2003 06:35 pm, Nigel Ridley wrote:
                  > > Hi,
                  > >
                  > > I just started using icewm and can't figure out how to be able to
                  > > type in Hebrew (KDE was a no brainer) -- any pointers welcome --
                  > > even reading the fine manual:-)
                  > It's Extremely simple and straightfoward - you can't, Icewm doesn't
                  > use a toolkit that supports Hebrew.
                  > >
                  > > Blessings,
                  > >
                  > > Nigel Ridley
                  >
                  >

                  So can you recommend a lightweight wm than does use Hebrew.

                  Blessings,

                  Nigel

                  --
                  It's not a problem -- it's a learning opportunity.
                  --

                  I AM Bible Studies and Resources
                  http://www.i-amfaithweb.net

                  Messianic E-Cards.com
                  http://www.messianicecards.com

                  OliveRoot Ministries
                  http://www.oliveroot.net
                • Tzafrir Cohen
                  ... I use IceWM, and the lack of bidi support doesn t bother much. Anyway, of the lighter-wight WMs, ther is XFCE, and also recent development branch of fvwm
                  Message 8 of 15 , Dec 6, 2003
                  • 0 Attachment
                    On Sun, Dec 07, 2003 at 06:25:05AM +0200, Nigel Ridley wrote:
                    > On Sat, 06 Dec 2003 22:49:28 +0000
                    > Leibovich <meh@...> wrote:
                    >
                    > > On Friday 05 December 2003 06:35 pm, Nigel Ridley wrote:
                    > > > Hi,
                    > > >
                    > > > I just started using icewm and can't figure out how to be able to
                    > > > type in Hebrew (KDE was a no brainer) -- any pointers welcome --
                    > > > even reading the fine manual:-)
                    > > It's Extremely simple and straightfoward - you can't, Icewm doesn't
                    > > use a toolkit that supports Hebrew.
                    > > >
                    > > > Blessings,
                    > > >
                    > > > Nigel Ridley
                    > >
                    > >
                    >
                    > So can you recommend a lightweight wm than does use Hebrew.

                    I use IceWM, and the lack of bidi support doesn't bother much.

                    Anyway, of the lighter-wight WMs, ther is XFCE, and also recent
                    development branch of fvwm (2.5.x . Try fvwm-themes, for something which
                    looks resonable without much messing)

                    --
                    Tzafrir Cohen +---------------------------+
                    http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
                    mailto:tzafrir@... +---------------------------+
                  • Nigel Ridley
                    On Sun, 7 Dec 2003 08:40:35 +0200 ... Yes, I suppose that since most Hebrew *work* would be done in apps such as AbiWord or OpenOffice, then it doesn t really
                    Message 9 of 15 , Dec 7, 2003
                    • 0 Attachment
                      On Sun, 7 Dec 2003 08:40:35 +0200
                      Tzafrir Cohen <tzafrir@...> wrote:

                      > On Sun, Dec 07, 2003 at 06:25:05AM +0200, Nigel Ridley wrote:
                      > > On Sat, 06 Dec 2003 22:49:28 +0000
                      > > Leibovich <meh@...> wrote:
                      > >
                      > > > On Friday 05 December 2003 06:35 pm, Nigel Ridley wrote:
                      > > > > Hi,
                      > > > >
                      > > > > I just started using icewm and can't figure out how to be able
                      > > > > to type in Hebrew (KDE was a no brainer) -- any pointers welcome
                      > > > > -- even reading the fine manual:-)
                      > > > It's Extremely simple and straightfoward - you can't, Icewm
                      > > > doesn't use a toolkit that supports Hebrew.
                      > > > >
                      > > > > Blessings,
                      > > > >
                      > > > > Nigel Ridley
                      > > >
                      > > >
                      > >
                      > > So can you recommend a lightweight wm than does use Hebrew.
                      >
                      > I use IceWM, and the lack of bidi support doesn't bother much.
                      >
                      > Anyway, of the lighter-wight WMs, ther is XFCE, and also recent
                      > development branch of fvwm (2.5.x . Try fvwm-themes, for something
                      > which looks resonable without much messing)
                      >
                      > --
                      > Tzafrir Cohen +---------------------------+
                      > http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
                      > mailto:tzafrir@... +---------------------------+
                      >

                      > To unsubscribe from this group, send an email to:
                      > gnubies-il-unsubscribe@egroups.com
                      >
                      >
                      >
                      > Your use of Yahoo! Groups is subject to
                      > http://docs.yahoo.com/info/terms/
                      >

                      Yes, I suppose that since most Hebrew *work* would be done in apps such
                      as AbiWord or OpenOffice, then it doesn't really matter about the wm.

                      BTW, I am using Libranet 2.8 (Debian based) dist-upgraded using sarge
                      this last week, with a few apps from sid (icewm is from sarge).
                      XFree 4.3.0 but without xkb (not even in sid).

                      Is xkb necessary or can I follow the instructions
                      (from http://iglu.org.il/faq/cache/86.html) for XFree 4.0 -- 4.21?

                      Blessings,

                      Nigel

                      --
                      It's not a problem -- it's a learning opportunity.
                      --

                      I AM Bible Studies and Resources
                      http://www.i-amfaithweb.net

                      Messianic E-Cards.com
                      http://www.messianicecards.com

                      OliveRoot Ministries
                      http://www.oliveroot.net
                    • Kfir Lavi
                      ... Hi, I m using ICEwm and i can write in hebrew. Add this lines to your /etc/X11/XF86Config Option XkbLayout us,il Option XkbOptions
                      Message 10 of 15 , Dec 9, 2003
                      • 0 Attachment
                        Nigel Ridley wrote:

                        >Hi,
                        >
                        >I just started using icewm and can't figure out how to be able to type
                        >in Hebrew (KDE was a no brainer) -- any pointers welcome -- even reading
                        >the fine manual:-)
                        >
                        >Blessings,
                        >
                        >Nigel Ridley
                        >
                        >
                        >
                        Hi,
                        I'm using ICEwm and i can write in hebrew.
                        Add this lines to your /etc/X11/XF86Config

                        Option "XkbLayout" "us,il"
                        Option "XkbOptions"
                        "grp:switch,grp:shift_toggle,grp_led:scroll"

                        in the keyboard section.
                        Then you will be able to move from english to hebrew with pressing on
                        two shifts.
                        If you just want a temporary hebrew or english press alt and write.

                        Regards,
                        Kfir Lavi
                      • Nigel Ridley
                        On Wed, 10 Dec 2003 08:23:26 +0200 ... Thanks, I don t have xkb installed (there are no debs) however I could probably d/l a tarball and install that. Would it
                        Message 11 of 15 , Dec 9, 2003
                        • 0 Attachment
                          On Wed, 10 Dec 2003 08:23:26 +0200
                          Kfir Lavi <kfirlavi@...> wrote:

                          > Nigel Ridley wrote:
                          >
                          > >Hi,
                          > >
                          > >I just started using icewm and can't figure out how to be able to
                          > >type in Hebrew (KDE was a no brainer) -- any pointers welcome -- even
                          > >reading the fine manual:-)
                          > >
                          > >Blessings,
                          > >
                          > >Nigel Ridley
                          > >
                          > >
                          > >
                          > Hi,
                          > I'm using ICEwm and i can write in hebrew.
                          > Add this lines to your /etc/X11/XF86Config
                          >
                          > Option "XkbLayout" "us,il"
                          > Option "XkbOptions"
                          > "grp:switch,grp:shift_toggle,grp_led:scroll"
                          >
                          > in the keyboard section.
                          > Then you will be able to move from english to hebrew with pressing on
                          > two shifts.
                          > If you just want a temporary hebrew or english press alt and write.
                          >
                          > Regards,
                          > Kfir Lavi
                          >
                          >
                          > ------------------------ Yahoo! Groups Sponsor
                          > ---------------------~--> Buy Ink Cartridges or Refill Kits for your
                          > HP, Epson, Canon or Lexmark Printer at MyInks.com. Free s/h on orders
                          > $50 or more to the US & Canada.
                          > http://www.c1tracking.com/l.asp?cid=5511
                          > http://us.click.yahoo.com/mOAaAA/3exGAA/qnsNAA/0XFolB/TM
                          > ---------------------------------------------------------------------
                          > ~->
                          >
                          > To unsubscribe from this group, send an email to:
                          > gnubies-il-unsubscribe@egroups.com
                          >
                          >
                          >
                          > Your use of Yahoo! Groups is subject to
                          > http://docs.yahoo.com/info/terms/
                          >

                          Thanks, I don't have xkb installed (there are no debs) however I could
                          probably d/l a tarball and install that.

                          Would it be possible to follow the instructions
                          (from http://iglu.org.il/faq/cache/86.html) for XFree 4.0 -- 4.21 (I
                          actually have 4.3.0 but no xkb at the moment)?

                          Blessings,

                          Nigel

                          P.S. icewm is fun -- I just spent some time yesterday editing my
                          .icewm/menu and .icewm/toolbar -- now I have things the way I want :-)

                          --
                          It's not a problem -- it's a learning opportunity.
                          --

                          I AM Bible Studies and Resources
                          http://www.i-amfaithweb.net

                          Messianic E-Cards.com
                          http://www.messianicecards.com

                          OliveRoot Ministries
                          http://www.oliveroot.net
                        • Nigel Ridley
                          On Sat, 6 Dec 2003 13:30:15 +0200 ... snip ... Well according to http://iglu.org.il/faq/cache/86.html: (Debian still doesn t have it, even not in unstable) I
                          Message 12 of 15 , Dec 13, 2003
                          • 0 Attachment
                            On Sat, 6 Dec 2003 13:30:15 +0200
                            Tzafrir Cohen <tzafrir@...> wrote:

                            > On Sat, Dec 06, 2003 at 07:59:34AM +0200, Nigel Ridley wrote:
                            > > On Fri, 5 Dec 2003 21:59:51 +0200
                            > > Tzafrir Cohen <tzafrir@...> wrote:
                            > >
                            > > > On Fri, Dec 05, 2003 at 08:35:12PM +0200, Nigel Ridley wrote:
                            snip
                            > > > Keyboard settings are handled by X. KDE only offers a interface
                            > > > for configuring it. That interface often does more harm than use,
                            > > > I might add.
                            > > >
                            > > > http://iglu.org.il/faq/cache/86.html
                            > > >
                            > > > If you need any more details: what is your distro?
                            > >
                            > > I am using Libranet 2.8 (Debian based) dist-upgraded using sarge
                            > > this last week, with a few apps from sid (icewm is from sarge).
                            > > XFree 4.3.0 but without xkb (not even in sid).
                            >
                            > What do you mean "without xkb"?

                            Well according to http://iglu.org.il/faq/cache/86.html:
                            "(Debian still doesn't have it, even not in unstable)"

                            I did check in sid and sarge but couldn't find it; BUT, in checking
                            /etc/X11 I found a dir for xkb. I then checked my XF86Config-4 and lo
                            and behold I have the necessary entries.
                            So, a quick edit and I now have a Hebrew keyboard with the press of alt
                            shift (yes I know but my daughter is already used to it).

                            Since I am running Libranet 2.8, and have xkb (I don't know about stock
                            Debian) perhaps you could add that info to
                            http://iglu.org.il/faq/cache/86.html.

                            >
                            > > Is xkb necessary or can I follow the instructions
                            > > (from http://iglu.org.il/faq/cache/86.html) for XFree 4.0 -- 4.21?
                            >
                            > You have XFree 4.3, and thus you should use the first section (XFree
                            > 4.3).

                            Yes I do and sorted xkb out (see above).

                            >
                            > --
                            > Tzafrir Cohen +---------------------------+
                            > http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
                            > mailto:tzafrir@... +---------------------------+
                            >
                            snip
                            >
                            > To unsubscribe from this group, send an email to:
                            > gnubies-il-unsubscribe@egroups.com
                            >
                            >
                            >
                            > Your use of Yahoo! Groups is subject to
                            > http://docs.yahoo.com/info/terms/
                            >

                            Thanks for the help and encouragement :-)

                            Blessings,

                            Nigel

                            --
                            It's not a problem -- it's a learning opportunity.
                            --

                            I AM Bible Studies and Resources
                            http://www.i-amfaithweb.net

                            Messianic E-Cards.com
                            http://www.messianicecards.com

                            OliveRoot Ministries
                            http://www.oliveroot.net
                          • Nigel Ridley
                            On Wed, 10 Dec 2003 08:23:26 +0200 Kfir Lavi wrote: snip ... OK. Got it working now -- thanks :-) Blessings, Nigel -- It s not a
                            Message 13 of 15 , Dec 13, 2003
                            • 0 Attachment
                              On Wed, 10 Dec 2003 08:23:26 +0200
                              Kfir Lavi <kfirlavi@...> wrote:

                              snip
                              > Hi,
                              > I'm using ICEwm and i can write in hebrew.
                              > Add this lines to your /etc/X11/XF86Config
                              >
                              > Option "XkbLayout" "us,il"
                              > Option "XkbOptions"
                              > "grp:switch,grp:shift_toggle,grp_led:scroll"
                              >
                              > in the keyboard section.
                              > Then you will be able to move from english to hebrew with pressing on
                              > two shifts.
                              > If you just want a temporary hebrew or english press alt and write.
                              >
                              > Regards,
                              > Kfir Lavi
                              >
                              >

                              >
                              > To unsubscribe from this group, send an email to:
                              > gnubies-il-unsubscribe@egroups.com
                              >
                              >
                              >
                              > Your use of Yahoo! Groups is subject to
                              > http://docs.yahoo.com/info/terms/
                              >

                              OK. Got it working now -- thanks :-)

                              Blessings,

                              Nigel

                              --
                              It's not a problem -- it's a learning opportunity.
                              --

                              I AM Bible Studies and Resources
                              http://www.i-amfaithweb.net

                              Messianic E-Cards.com
                              http://www.messianicecards.com

                              OliveRoot Ministries
                              http://www.oliveroot.net
                            • Tzafrir Cohen
                              ... This refers to XFree 4.3 If you read a bit onwards you ll see references to XFree 4.0-4.21 . Since both my home and my work systems are XFree 4.21 I can
                              Message 14 of 15 , Dec 14, 2003
                              • 0 Attachment
                                On Sat, Dec 13, 2003 at 08:57:55PM +0200, Nigel Ridley wrote:
                                > On Sat, 6 Dec 2003 13:30:15 +0200
                                > Tzafrir Cohen <tzafrir@...> wrote:
                                >
                                > > On Sat, Dec 06, 2003 at 07:59:34AM +0200, Nigel Ridley wrote:
                                > > > On Fri, 5 Dec 2003 21:59:51 +0200
                                > > > Tzafrir Cohen <tzafrir@...> wrote:
                                > > >
                                > > > > On Fri, Dec 05, 2003 at 08:35:12PM +0200, Nigel Ridley wrote:
                                > snip
                                > > > > Keyboard settings are handled by X. KDE only offers a interface
                                > > > > for configuring it. That interface often does more harm than use,
                                > > > > I might add.
                                > > > >
                                > > > > http://iglu.org.il/faq/cache/86.html
                                > > > >
                                > > > > If you need any more details: what is your distro?
                                > > >
                                > > > I am using Libranet 2.8 (Debian based) dist-upgraded using sarge
                                > > > this last week, with a few apps from sid (icewm is from sarge).
                                > > > XFree 4.3.0 but without xkb (not even in sid).
                                > >
                                > > What do you mean "without xkb"?
                                >
                                > Well according to http://iglu.org.il/faq/cache/86.html:
                                > "(Debian still doesn't have it, even not in unstable)"

                                This refers to XFree 4.3

                                If you read a bit onwards you'll see references to XFree 4.0-4.21 .
                                Since both my home and my work systems are XFree 4.21 I can attest that
                                it has decent Hebrew keyboard support. At least if all you need is dual
                                English-Hebrew.

                                >
                                > I did check in sid and sarge but couldn't find it; BUT, in checking
                                > /etc/X11 I found a dir for xkb. I then checked my XF86Config-4 and lo
                                > and behold I have the necessary entries.

                                XKB is an extention of the X11 protocol. It has been implemented by
                                XFree for quite a while. Many programs can help you configure it, but
                                you basically need nothing more than what already comes with XFree.

                                > So, a quick edit and I now have a Hebrew keyboard with the press of alt
                                > shift (yes I know but my daughter is already used to it).
                                >
                                > Since I am running Libranet 2.8, and have xkb (I don't know about stock
                                > Debian) perhaps you could add that info to
                                > http://iglu.org.il/faq/cache/86.html.

                                It seems to have XFree 4.3. Probably based on the experimental packages
                                or something similar. Take a look at http://apt-get.org for some
                                alternative (though non-standard) software sources for Debian.

                                --
                                Tzafrir Cohen +---------------------------+
                                http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
                                mailto:tzafrir@... +---------------------------+
                              • Nigel Ridley
                                On Sun, 14 Dec 2003 14:07:05 +0200 ... snip ... Yes I know and this is the version that comes with Libranet (Debian based distro) -- so I do have xkb with a
                                Message 15 of 15 , Dec 14, 2003
                                • 0 Attachment
                                  On Sun, 14 Dec 2003 14:07:05 +0200
                                  Tzafrir Cohen <tzafrir@...> wrote:

                                  > On Sat, Dec 13, 2003 at 08:57:55PM +0200, Nigel Ridley wrote:
                                  > > On Sat, 6 Dec 2003 13:30:15 +0200
                                  > > Tzafrir Cohen <tzafrir@...> wrote:
                                  snip
                                  > > >
                                  > > > What do you mean "without xkb"?
                                  > >
                                  > > Well according to http://iglu.org.il/faq/cache/86.html:
                                  > > "(Debian still doesn't have it, even not in unstable)"
                                  >
                                  > This refers to XFree 4.3

                                  Yes I know and this is the version that comes with Libranet (Debian
                                  based distro) -- so I do have xkb with a default install of Libranet
                                  2.8.

                                  >
                                  > If you read a bit onwards you'll see references to XFree 4.0-4.21 .
                                  > Since both my home and my work systems are XFree 4.21 I can attest
                                  > that it has decent Hebrew keyboard support. At least if all you need
                                  > is dual English-Hebrew.
                                  >
                                  > >
                                  > > I did check in sid and sarge but couldn't find it; BUT, in checking
                                  > > /etc/X11 I found a dir for xkb. I then checked my XF86Config-4 and
                                  > > lo and behold I have the necessary entries.
                                  >
                                  > XKB is an extention of the X11 protocol. It has been implemented by
                                  > XFree for quite a while. Many programs can help you configure it, but
                                  > you basically need nothing more than what already comes with XFree.
                                  >
                                  > > So, a quick edit and I now have a Hebrew keyboard with the press of
                                  > > alt shift (yes I know but my daughter is already used to it).
                                  > >
                                  > > Since I am running Libranet 2.8, and have xkb (I don't know about
                                  > > stock Debian) perhaps you could add that info to
                                  > > http://iglu.org.il/faq/cache/86.html.
                                  >
                                  > It seems to have XFree 4.3. Probably based on the experimental
                                  > packages or something similar. Take a look at http://apt-get.org for
                                  > some alternative (though non-standard) software sources for Debian.

                                  Yes Libranet, from 2.8, tracks mainly sarge but also has packages that
                                  were not even in sid when it was released -- quite a bleeding edge
                                  Debian distro; BTW, have you tried it yet?

                                  Yes I know about http://apt-get.org :-)

                                  >
                                  > --
                                  > Tzafrir Cohen +---------------------------+
                                  > http://www.technion.ac.il/~tzafrir/ |vim is a mutt's best friend|
                                  > mailto:tzafrir@... +---------------------------+
                                  >

                                  >
                                  > To unsubscribe from this group, send an email to:
                                  > gnubies-il-unsubscribe@egroups.com
                                  >
                                  >
                                  >
                                  > Your use of Yahoo! Groups is subject to
                                  > http://docs.yahoo.com/info/terms/
                                  >

                                  Thanks again though :-)

                                  Blessings,

                                  Nigel

                                  --
                                  It's not a problem -- it's a learning opportunity.
                                  --

                                  I AM Bible Studies and Resources
                                  http://www.i-amfaithweb.net

                                  Messianic E-Cards.com
                                  http://www.messianicecards.com

                                  OliveRoot Ministries
                                  http://www.oliveroot.net
                                Your message has been successfully submitted and would be delivered to recipients shortly.