Loading ...
Sorry, an error occurred while loading the content.

configuring a CD-writer

Expand Messages
  • Tsahee Zidenberg
    System: intel celeron, MDK 9.2 - of which I don t know enough to make it not-standard HW added: LG Combo drive (CD/DVD read, CD R/W) Already working: CD read
    Message 1 of 7 , Sep 11, 2003
    View Source
    • 0 Attachment
      System: intel celeron, MDK 9.2 - of which I don't know enough to make it not-standard

      HW added: LG Combo drive (CD/DVD read, CD R/W)

      Already working: CD read access via /dev/cdrom0, mounting fine, etc. DVD access via /dev/dvd, which is a soft link to /dev/cdrom0 (I saw somebody doing it while googling for HW compatibility, which should be fine)

      RPMs installed: basicly, I got up to installing xcdroast, including all it's dependencies and perhaps some more (cdrecord, cdda2wav, cdparanoia...)

      problem:
      **********************************************
      [root@localhost tsahee]# cdrecord -scanbus
      Cdrecord 1.11a32 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
      cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
      cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
      [root@localhost tsahee]# ls -l /dev/pg*
      ls: /dev/pg*: No such file or directory
      ***********************************************

      There is no /dev/pg*.

      My main attempts:
      * I tried creating symlinks pg0->sg0 or pg0->cdrom0, didn't work.
      * I went according to the CD-Writing HOWTO. I ran the following commands that appear there:

      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      test `whoami` = 'root' || echo "You must be root to execute the commands."
      cd /dev/
      umask -S u=rwx,g=rwx,o-rwx
      [ -f loop0 ] \
          || ./MAKEDEV loop \
          || for i in 0 1 2 3 4 5 6 7; do mknod loop$i b 7 $i; done
      [ -f sg0 -o -f sga ] \
          || ./MAKEDEV sg \
          || for i in 0 1 2 3 4 5 6 7; do mknod sg$i  c 21 $i; done
      


      result:
      loop? files already exsisted, so if I understand correctly they were'nt touched
      sg? files were created. I'm not sure that was a good thing. I later found out I have no /dev/MAKEDEV, so that command did nothing except for saying there is no such command.
      I tried running it again with MAKEDEV instead of ./MAKEDEV (actually, it's /sbin/MAKEDEV). This time it did nothing, becase the sg? files already existed. I tried renaming the sg? files, but it wouldn't let me (yes I was root, I think the files were in use, some how). I was too scared to try harm the sg? files any more.


      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      another command set that appears on the HOWTO is this:

      test `whoami` = 'root' || echo "You must be root to execute the commands."
      cdrecord -scanbus > /dev/null
      if ! (pidof kerneld || test -f "/proc/sys/kernel/modprobe"); then
          echo "Neither kerneld nor kmod are running to automatically load modules".
      fi
      report_no_autoload() {
          echo "Ensure the module $1 is loaded automatically next time."
      }
      if test ! -f "/proc/scsi/scsi"; then
          report_no_autoload scsi_mod  &&  insmod scsi_mod
      fi
      if ! grep "^........ sg_" /proc/ksyms > /dev/null; then
          report_no_autoload sg  &&  insmod sg
      fi
      if ! grep "^........ sr_" /proc/ksyms > /dev/null; then
          report_no_autoload sr_mod  &&  insmod sr_mod
      fi
      if ! grep "^........ loop_" /proc/ksyms > /dev/null; then
          report_no_autoload loop  &&  insmod loop
      fi
      if ! grep iso9660 /proc/filesystems > /dev/null; then
          report_no_autoload iso9660  &&  insmod iso9660
      fi
      echo "The following is only needed for IDE/ATAPI CD-writers."
      if ! grep ide-scsi /proc/ide/drivers > /dev/null; then
          report_no_autoload ide-scsi  &&  insmod ide-scsi
      fi
      cdrecord -scanbus

      ide-scsi is not autoloaded on my sysem, but loads fine when requested to do so. However, I do get:

      "
      Ensure the module iso9660 is loaded automatically next time.
      insmod: iso9660: no module by that name found
      "
      every time I run those commands.
      Other tests on this set report no errors, cdrecord returns with the above-memsioned results.

      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Notes:

      On the Mandrake Control Center, Under Hardware list, listed under "CD/DVD burners" -> "/dev/hdc"
      (it is the only entry under burners) I have:

      Model:
      Vendor:
      Bus: ide
      capacity: burner DVD
      Channel: secondary
      New devfs device: ide/host0/bus1/target0/lun0/cd
      Old device file: /dev/hdc
      Media class: cdrom
      and indeed :

      [root@localhost tsahee]# ls -l /dev/cdroms/cdrom0
      lr-xr-xr-x    1 root     root           33 Jan  1  1970 /dev/cdroms/cdrom0 -> ../ide/host0/bus1/target0/lun0/cd


      I wrote down any information that seemed relevant. If you can help, I'd appreciate it. If you need any more information, of course, just tell me what it is that you want to know.

    • Diego Iastrubni
      why did not the installed set it up properly? put in kernel parameters hdb=ide-scsi if you use a 2.4 kernel. Also update the programs, now the cdrw will be
      Message 2 of 7 , Sep 11, 2003
      View Source
      • 0 Attachment
        'why did not the installed set it up properly?

        put in kernel parameters "hdb=ide-scsi" if you use a 2.4 kernel. Also update
        the programs, now the cdrw will be /dev/scd0.

        about 2.6 kernel, you should use a new cdrecord which i don't know if it's
        included in mdk9.2 (which was not distributed yet, since it's not finished
        and there fore your question should be replied with a "WAIT FOR THE FINAL AND
        TEST IT OR RTFM" answer by me).


        ביום חמישי, 11 בספטמבר 2003, 15:31, Tsahee Zidenberg כתב:
        > System: intel celeron, MDK 9.2 - of which I don't know enough to make it
        > not-standard
        >
        > HW added: LG Combo drive (CD/DVD read, CD R/W)
        >
        > Already working: CD read access via /dev/cdrom0, mounting fine, etc. DVD
        > access via /dev/dvd, which is a soft link to /dev/cdrom0 (I saw somebody
        > doing it while googling for HW compatibility, which should be fine)
        >
        > RPMs installed: basicly, I got up to installing xcdroast, including all
        > it's dependencies and perhaps some more (cdrecord, cdda2wav, cdparanoia...)
        >
        > problem:
        > **********************************************
        > [root@localhost tsahee]# cdrecord -scanbus
        > Cdrecord 1.11a32 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg
        > Schilling cdrecord: No such file or directory. Cannot open '/dev/pg*'.
        > Cannot open SCSI driver. cdrecord: For possible targets try 'cdrecord
        > -scanbus'. Make sure you are root. [root@localhost tsahee]# ls -l /dev/pg*
        > ls: /dev/pg*: No such file or directory
        > ***********************************************
        >
        > There is no /dev/pg*.
        >
        > My main attempts:
        > * I tried creating symlinks pg0->sg0 or pg0->cdrom0, didn't work.
        > * I went according to the CD-Writing HOWTO. I ran the following commands
        > that appear there:
        >
        > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        >
        > test `whoami` = 'root' || echo "You must be root to execute the commands."
        > cd /dev/
        > umask -S u=rwx,g=rwx,o-rwx
        > [ -f loop0 ] \
        >
        > || ./MAKEDEV loop \
        > || for i in 0 1 2 3 4 5 6 7; do mknod loop$i b 7 $i; done
        >
        > [ -f sg0 -o -f sga ] \
        >
        > || ./MAKEDEV sg \
        > || for i in 0 1 2 3 4 5 6 7; do mknod sg$i c 21 $i; done
        >
        > result:
        > loop? files already exsisted, so if I understand correctly they were'nt
        > touched sg? files were created. I'm not sure that was a good thing. I later
        > found out I have no /dev/MAKEDEV, so that command did nothing except for
        > saying there is no such command. I tried running it again with MAKEDEV
        > instead of ./MAKEDEV (actually, it's /sbin/MAKEDEV). This time it did
        > nothing, becase the sg? files already existed. I tried renaming the sg?
        > files, but it wouldn't let me (yes I was root, I think the files were in
        > use, some how). I was too scared to try harm the sg? files any more.
        >
        >
        > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        > another command set that appears on the HOWTO is this:
        >
        >
        > test `whoami` = 'root' || echo "You must be root to execute the commands."
        > cdrecord -scanbus > /dev/null
        > if ! (pidof kerneld || test -f "/proc/sys/kernel/modprobe"); then
        > echo "Neither kerneld nor kmod are running to automatically load
        > modules". fi
        > report_no_autoload() {
        > echo "Ensure the module $1 is loaded automatically next time."
        > }
        > if test ! -f "/proc/scsi/scsi"; then
        > report_no_autoload scsi_mod && insmod scsi_mod
        > fi
        > if ! grep "^........ sg_" /proc/ksyms > /dev/null; then
        > report_no_autoload sg && insmod sg
        > fi
        > if ! grep "^........ sr_" /proc/ksyms > /dev/null; then
        > report_no_autoload sr_mod && insmod sr_mod
        > fi
        > if ! grep "^........ loop_" /proc/ksyms > /dev/null; then
        > report_no_autoload loop && insmod loop
        > fi
        > if ! grep iso9660 /proc/filesystems > /dev/null; then
        > report_no_autoload iso9660 && insmod iso9660
        > fi
        > echo "The following is only needed for IDE/ATAPI CD-writers."
        > if ! grep ide-scsi /proc/ide/drivers > /dev/null; then
        > report_no_autoload ide-scsi && insmod ide-scsi
        > fi
        > cdrecord -scanbus
        >
        > ide-scsi is not autoloaded on my sysem, but loads fine when requested to
        > do so. However, I do get:
        >
        > "
        > Ensure the module iso9660 is loaded automatically next time.
        > insmod: iso9660: no module by that name found
        > "
        > every time I run those commands.
        > Other tests on this set report no errors, cdrecord returns with the
        > above-memsioned results.
        >
        > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        >
        > Notes:
        >
        > On the Mandrake Control Center, Under Hardware list, listed under "CD/DVD
        > burners" -> "/dev/hdc" (it is the only entry under burners) I have:
        >
        >
        > Model:
        > Vendor:
        > Bus: ide
        > capacity: burner DVD
        > Channel: secondary
        > New devfs device: ide/host0/bus1/target0/lun0/cd
        > Old device file: /dev/hdc
        > Media class: cdrom
        >
        > and indeed :
        >
        > [root@localhost tsahee]# ls -l /dev/cdroms/cdrom0
        > lr-xr-xr-x 1 root root 33 Jan 1 1970 /dev/cdroms/cdrom0
        > -> ../ide/host0/bus1/target0/lun0/cd
        >
        >
        > I wrote down any information that seemed relevant. If you can help, I'd
        > appreciate it. If you need any more information, of course, just tell me
        > what it is that you want to know.
        >
        >
        >
        >
        > Yahoo! Groups Sponsor
        >
        >
        >
        > ADVERTISEMENT
        >
        >
        >
        >
        >
        >
        > To unsubscribe from this group, send an email to:
        > gnubies-il-unsubscribe@egroups.com
        >
        >
        >
        > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

        --

        - diego
        ________________________________________
        / Linus: I guess it's wrong always to be \
        | worrying about tomorrow. Maybe we |
        | should think only about today. Charlie |
        | Brown: No, that's giving up. I'm still |
        \ hoping that yesterday will get better. /
        ----------------------------------------
        \ ^__^
        \ (xx)\_______
        (__)\ )\/\
        U ||----w |
        || ||

        Please avoid sending me Word or PowerPoint attachments.
        See http://www.fsf.org/philosophy/no-word-attachments.html
      • Tsahee Zidenberg
        woops. it s MDK9.0 sorry. my bad Diego Iastrubni wrote: why did not the installed set it up properly? put in kernel parameters hdb=ide-scsi if you use a 2.4
        Message 3 of 7 , Sep 12, 2003
        View Source
        • 0 Attachment
          woops. it's MDK9.0 sorry. my bad

          Diego Iastrubni wrote:
          'why did not the installed set it up properly?
          
          put in kernel parameters "hdb=ide-scsi" if you use a 2.4 kernel. Also update 
          the programs, now the cdrw will be /dev/scd0.
          
          about 2.6 kernel, you should use a new cdrecord which i don't know if it's 
          included in mdk9.2 (which was not distributed yet, since it's not finished 
          and there fore your question should be replied with a "WAIT FOR THE FINAL AND 
          TEST IT OR RTFM" answer by me).
          
          
          ביום חמישי, 11 בספטמבר 2003, 15:31, Tsahee Zidenberg כתב:
            
           System: intel celeron, MDK 9.2 - of which I don't know enough to make it
          not-standard
          
           HW added: LG Combo drive (CD/DVD read, CD R/W)
          
           Already working: CD read access via /dev/cdrom0, mounting fine, etc. DVD
          access via /dev/dvd, which is a soft link to /dev/cdrom0 (I saw somebody
          doing it while googling for HW compatibility, which should be fine)
          
           RPMs installed: basicly, I got up to installing xcdroast, including all
          it's dependencies and perhaps some more (cdrecord, cdda2wav, cdparanoia...)
          
           problem:
           **********************************************
           [root@localhost tsahee]# cdrecord -scanbus
           Cdrecord 1.11a32 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg
          Schilling cdrecord: No such file or directory. Cannot open '/dev/pg*'.
          Cannot open SCSI driver. cdrecord: For possible targets try 'cdrecord
          -scanbus'. Make sure you are root. [root@localhost tsahee]# ls -l /dev/pg*
           ls: /dev/pg*: No such file or directory
           ***********************************************
          
           There is no /dev/pg*.
          
           My main attempts:
           * I tried creating symlinks pg0->sg0 or pg0->cdrom0, didn't work.
           * I went according to the CD-Writing HOWTO. I ran the following commands
          that appear there:
          
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          
          test `whoami` = 'root' || echo "You must be root to execute the commands."
          cd /dev/
          umask -S u=rwx,g=rwx,o-rwx
          [ -f loop0 ] \
          
              || ./MAKEDEV loop \
              || for i in 0 1 2 3 4 5 6 7; do mknod loop$i b 7 $i; done
          
          [ -f sg0 -o -f sga ] \
          
              || ./MAKEDEV sg \
              || for i in 0 1 2 3 4 5 6 7; do mknod sg$i  c 21 $i; done
          
           result:
           loop? files already exsisted, so if I understand correctly they were'nt
          touched sg? files were created. I'm not sure that was a good thing. I later
          found out I have no /dev/MAKEDEV, so that command did nothing except for
          saying there is no such command. I tried running it again with MAKEDEV
          instead of ./MAKEDEV (actually, it's /sbin/MAKEDEV). This time it did
          nothing, becase the sg? files already existed. I tried renaming the sg?
          files, but it wouldn't let me (yes I was root, I think the files were in
          use, some how). I was too scared to try harm the sg? files any more.
          
          
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
           another command set that appears on the HOWTO is this:
          
          
          test `whoami` = 'root' || echo "You must be root to execute the commands."
          cdrecord -scanbus > /dev/null
          if ! (pidof kerneld || test -f "/proc/sys/kernel/modprobe"); then
              echo "Neither kerneld nor kmod are running to automatically load
          modules". fi
          report_no_autoload() {
              echo "Ensure the module $1 is loaded automatically next time."
          }
          if test ! -f "/proc/scsi/scsi"; then
              report_no_autoload scsi_mod  &&  insmod scsi_mod
          fi
          if ! grep "^........ sg_" /proc/ksyms > /dev/null; then
              report_no_autoload sg  &&  insmod sg
          fi
          if ! grep "^........ sr_" /proc/ksyms > /dev/null; then
              report_no_autoload sr_mod  &&  insmod sr_mod
          fi
          if ! grep "^........ loop_" /proc/ksyms > /dev/null; then
              report_no_autoload loop  &&  insmod loop
          fi
          if ! grep iso9660 /proc/filesystems > /dev/null; then
              report_no_autoload iso9660  &&  insmod iso9660
          fi
          echo "The following is only needed for IDE/ATAPI CD-writers."
          if ! grep ide-scsi /proc/ide/drivers > /dev/null; then
              report_no_autoload ide-scsi  &&  insmod ide-scsi
          fi
          cdrecord -scanbus
          
           ide-scsi is not autoloaded on my sysem, but loads fine when requested to
          do so. However, I do get:
          
           "
           Ensure the module iso9660 is loaded automatically next time.
           insmod: iso9660: no module by that name found
           "
           every time I run those commands.
           Other tests on this set report no errors, cdrecord returns with the
          above-memsioned results.
          
           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          
           Notes:
          
           On the Mandrake Control Center, Under Hardware list, listed under "CD/DVD
          burners" -> "/dev/hdc" (it is the only entry under burners) I have:
          
          
          Model:
           Vendor:
           Bus: ide
           capacity: burner DVD
           Channel: secondary
           New devfs device: ide/host0/bus1/target0/lun0/cd
           Old device file: /dev/hdc
           Media class: cdrom
          
          and indeed :
          
           [root@localhost tsahee]# ls -l /dev/cdroms/cdrom0
           lr-xr-xr-x    1 root     root           33 Jan  1  1970 /dev/cdroms/cdrom0
          -> ../ide/host0/bus1/target0/lun0/cd
          
          
           I wrote down any information that seemed relevant. If you can help, I'd
          appreciate it. If you need any more information, of course, just tell me
          what it is that you want to know.
          
          
          
          
          Yahoo! Groups Sponsor
          
          
          
          ADVERTISEMENT
          
          
          
          
          
          
           To unsubscribe from this group, send an email to:
           gnubies-il-unsubscribe@egroups.com
          
          
          
           Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
              
            
        • Tsahee Zidenberg
          First of all, once more, I m sorry, I m on MDK9.0 my bad. I added hdc=ide-scsi to lilo.conf. So now when I run insmod I get a nice message: Using
          Message 4 of 7 , Sep 18, 2003
          View Source
          • 0 Attachment
            First of all, once more, I'm sorry, I'm on MDK9.0 my bad.

            I added "hdc=ide-scsi" to lilo.conf. So now when I run insmod I get a
            nice message: "Using
            /lib/modules/2.4.19-16mdk/kernel/drivers/scsi/ide-scsi.o.gz", which
            seems alright I guess.

            Main problem remains:
            *******************************************************
            [root@localhost dev]# cdrecord -scanbus
            Cdrecord 1.11a32 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg
            Schilling
            cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open
            SCSI driver.
            cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
            are root.
            ********************************************************
            (He's not lying I really have no /dev/pg*)

            Problems when trying to fix it, going according to the the CD-WRITING-HOWTO:
            (HOWTO can be found here: http://www.tldp.org/HOWTO/CD-Writing-HOWTO-2.html)

            problem 1:
            ****************************************************
            [root@localhost dev]# [ -f sg0 -o -f sga ] \
            > || MAKEDEV sg \
            > || for i in 0 1 2 3 4 5 6 7; do mknod sg$i c 21 $i; done
            MAKEDEV: error making /dev/sg0: Operation not permitted
            ****************************************************
            (no sg* files exsist before the operation. sg0-7 and "sg0-" are
            created. I use MAKEDEV instead of ./MAKEDEV that's on the HOWTO,
            because I have no MAKEDEV inside /dev/)

            problem 2:
            ****************************************************
            [root@localhost dev]# insmod iso9660
            insmod: iso9660: no module by that name found
            ****************************************************

            also, no /dev/scd0 was created.

            any help would really be appreciated.

            Diego Iastrubni wrote:

            >'why did not the installed set it up properly?
            >
            >put in kernel parameters "hdb=ide-scsi" if you use a 2.4 kernel. Also update
            >the programs, now the cdrw will be /dev/scd0.
            >
            >about 2.6 kernel, you should use a new cdrecord which i don't know if it's
            >included in mdk9.2 (which was not distributed yet, since it's not finished
            >and there fore your question should be replied with a "WAIT FOR THE FINAL AND
            >TEST IT OR RTFM" answer by me).
            >
            >
            >
          • Tsahee Zidenberg
            Some stuff changed since last mail, I ve read all the how-to s I could put my hands on, and rebooted my computer a few dozens of times to find a few dozens of
            Message 5 of 7 , Sep 20, 2003
            View Source
            • 0 Attachment
              Some stuff changed since last mail, I've read all the how-to's I could put my hands on, and rebooted my computer a few dozens of times to find a few dozens of wrong solutions (well, not dozens, but you get the point). So here's current status:

              System: MDK9.0 rather standard ( I don't know enough to make it otherwise)

              Added HW:   
              *****************
                  ide1: BM-DMA at 0xe008-0xe00f, BIOS settings: hdc:DMA, hdd:DMA
              hdc: HL-DT-ST RW/DVD GCC-4480B, ATAPI CD/DVD-ROM drive
              ****************
              (It's LG. Should be compatible. I read somewhere about a guy having no problem using LG's combo on MDK9.0) I had no cd-writer installed before that.

              Problem is:
              ****************
              [root@localhost dev]# cdrecord -scanbus
              Cdrecord 1.11a32 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
              cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
              cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
              ****************

              The cause, as much as I can determin: IDE-SCSI does not find my drive.  /dev/scsi dir is empty.

              Lilo.conf entry:
              ****************
              image=/boot/vmlinuz
                      label=linux
                      root=/dev/hda5
                      initrd=/boot/initrd.img
                      append="quiet hdc=ide-scsi devfs=mount"
                      vga=788
                      read-only
              *************

              modules.conf:
              ***************
              [root@localhost dev]# cat /etc/modules.conf
                                 #not related:
              probeall usb-interface usb-uhci
              above snd-cmipci snd-pcm-oss
              alias sound-slot-0 snd-cmipci
              alias /dev/nvidia*   nvidia
                                 #here start the additions for the CD/W:
              options ide-cd ignore=hdc            # tell the ide-cd module to ignore hdc
              alias scd0 sr_mod                    # load sr_mod upon access of scd0
              pre-install sg     modprobe ide-scsi # load ide-scsi before sg
              pre-install sr_mod modprobe ide-scsi # load ide-scsi before sr_mod
              pre-install ide-scsi modprobe ide-cd # load ide-cd   before ide-scsi
              ****************

              /etc/modules is empty (besides comments).

              There is a series of tests that appear on the CD_WRITING_HOWTO. To pass all those tests I have to
                  > manually "insmod loop"
                  > access my other cd-rom drive (to automaticly load the iso9660 filesystem). for example "ls /mnt/cdrom"
              Then, If I run that series, I get no errors, except for the cdrecord of course. The tests are:

              *****************
              test `whoami` = 'root' || echo "You must be root to execute the commands."
              cdrecord -scanbus > /dev/null
              if ! (pidof kerneld || test -f "/proc/sys/kernel/modprobe"); then
                  echo "Neither kerneld nor kmod are running to automatically load modules".
              fi
              report_no_autoload() {
                  echo "Ensure the module $1 is loaded automatically next time."
              }
              if test ! -f "/proc/scsi/scsi"; then
                  report_no_autoload scsi_mod  &&  insmod scsi_mod
              fi
              if ! grep "^........ sg_" /proc/ksyms > /dev/null; then
                  report_no_autoload sg  &&  insmod sg
              fi
              if ! grep "^........ sr_" /proc/ksyms > /dev/null; then
                  report_no_autoload sr_mod  &&  insmod sr_mod
              fi
              if ! grep "^........ loop_" /proc/ksyms > /dev/null; then
                  report_no_autoload loop  &&  insmod loop
              fi
              if ! grep iso9660 /proc/filesystems > /dev/null; then
                  report_no_autoload iso9660  &&  insmod iso9660
              fi
              echo "The following is only needed for IDE/ATAPI CD-writers."
              if ! grep ide-scsi /proc/ide/drivers > /dev/null; then
                  report_no_autoload ide-scsi  &&  insmod ide-scsi
              fi
              cdrecord -scanbus
              ****************************

              When I don't use the line "options ide-cd ignore=hdc", I have CD/DVD read access, through
              ****************
              [root@localhost dev]# ls -l hdc
              lr-xr-xr-x    1 root     root           30 Sep 20 13:28 hdc -> ide/host0/bus1/target0/lun0/cd
              ****************
              When that line is active, I have no /dev/hdc file.

              please help

              BTW:
              Discovering a certain wrong solution, I mannaged to get this:
              *****************
              [root@localhost dev]# ls -l scsi/host0/bus0/target0/lun0/
              total 0
              crw-rw----    1 tsahee   cdwriter  21,   0 Jan  1  1970 generic
              *****************
              , which was recognized as a floppy on cdrecord -scanbus and that's it. I have then tried adding ide-scsi to the /dev/modules file, and it was gone (nothing under /dev/scsi). I couldn't get it back since. I have no idea what that means.
            • Diego Iastrubni
              which kernel do you use? ... -- diego, 24 Elul 5763 Please avoid sending me Word or PowerPoint attachments. See
              Message 6 of 7 , Sep 20, 2003
              View Source
              • 0 Attachment
                which kernel do you use?

                בשבת, 20 בספטמבר 2003, 19:14, נכתב על ידי Tsahee Zidenberg:
                > Some stuff changed since last mail, I've read all the how-to's I could put
                > my hands on, and rebooted my computer a few dozens of times to find a few
                > dozens of wrong solutions (well, not dozens, but you get the point). So
                > here's current status:
                >
                > System: MDK9.0 rather standard ( I don't know enough to make it otherwise)
                >
                > Added HW: � �
                > *****************
                > � � � ide1: BM-DMA at 0xe008-0xe00f, BIOS settings: hdc:DMA, hdd:DMA
                > hdc: HL-DT-ST RW/DVD GCC-4480B, ATAPI CD/DVD-ROM drive
                > ****************
                > (It's LG. Should be compatible. I read somewhere about a guy having no
                > problem using LG's combo on MDK9.0) I had no cd-writer installed before
                > that.
                >
                > Problem is:
                > ****************
                > [root@localhost dev]# cdrecord -scanbus
                > Cdrecord 1.11a32 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 J�¶rg
                > Schilling cdrecord: No such file or directory. Cannot open '/dev/pg*'.
                > Cannot open SCSI driver. cdrecord: For possible targets try 'cdrecord
                > -scanbus'. Make sure you are root. ****************
                >
                > The cause, as much as I can determin: IDE-SCSI does not find my drive.�
                > /dev/scsi dir is empty.
                >
                > Lilo.conf entry:
                > ****************
                > image=/boot/vmlinuz
                > � � � � � � � label=linux
                > � � � � � � � root=/dev/hda5
                > � � � � � � � initrd=/boot/initrd.img
                > � � � � � � � append="quiet hdc=ide-scsi devfs=mount"
                > � � � � � � � vga=788
                > � � � � � � � read-only
                > *************
                >
                > modules.conf:
                > ***************
                > [root@localhost dev]# cat /etc/modules.conf
                > � � � � � � � � � � � � � #not related:
                > probeall usb-interface usb-uhci
                > above snd-cmipci snd-pcm-oss
                > alias sound-slot-0 snd-cmipci
                > alias /dev/nvidia*� � nvidia
                > � � � � � � � � � � � � � #here start the additions for the CD/W:
                > options ide-cd ignore=hdc � � � � � � � � � � # tell the ide-cd module to
                > ignore hdc alias scd0 sr_mod� � � � � � � � � � � � � � � � � � � # load
                > sr_mod upon access of scd0 pre-install sg� � � � modprobe ide-scsi # load
                > ide-scsi before sg pre-install sr_mod modprobe ide-scsi # load ide-scsi
                > before sr_mod pre-install ide-scsi modprobe ide-cd # load ide-cd� � before
                > ide-scsi ****************
                >
                > /etc/modules is empty (besides comments).
                >
                > There is a series of tests that appear on the CD_WRITING_HOWTO. To pass
                > all those tests I have to � � � > manually "insmod loop"
                > � � � > access my other cd-rom drive (to automaticly load the iso9660
                > filesystem). for example "ls /mnt/cdrom" Then, If I run that series, I get
                > no errors, except for the cdrecord of course. The tests are:
                >
                > *****************
                > test `whoami` = 'root' || echo "You must be root to execute the commands."
                > cdrecord -scanbus > /dev/null
                > if ! (pidof kerneld || test -f "/proc/sys/kernel/modprobe"); then
                > � � � echo "Neither kerneld nor kmod are running to automatically load
                > modules". fi
                > report_no_autoload() {
                > � � � echo "Ensure the module $1 is loaded automatically next time."
                > }
                > if test ! -f "/proc/scsi/scsi"; then
                > � � � report_no_autoload scsi_mod� &&� insmod scsi_mod
                > fi
                > if ! grep "^........ sg_" /proc/ksyms > /dev/null; then
                > � � � report_no_autoload sg� &&� insmod sg
                > fi
                > if ! grep "^........ sr_" /proc/ksyms > /dev/null; then
                > � � � report_no_autoload sr_mod� &&� insmod sr_mod
                > fi
                > if ! grep "^........ loop_" /proc/ksyms > /dev/null; then
                > � � � report_no_autoload loop� &&� insmod loop
                > fi
                > if ! grep iso9660 /proc/filesystems > /dev/null; then
                > � � � report_no_autoload iso9660� &&� insmod iso9660
                > fi
                > echo "The following is only needed for IDE/ATAPI CD-writers."
                > if ! grep ide-scsi /proc/ide/drivers > /dev/null; then
                > � � � report_no_autoload ide-scsi� &&� insmod ide-scsi
                > fi
                > cdrecord -scanbus
                > ****************************
                >
                > When I don't use the line "options ide-cd ignore=hdc", I have CD/DVD read
                > access, through ****************
                > [root@localhost dev]# ls -l hdc
                > lr-xr-xr-x� � � 1 root� � � � root� � � � � � � � � � 30 Sep 20 13:28
                > hdc -> ide/host0/bus1/target0/lun0/cd ****************
                > When that line is active, I have no /dev/hdc file.
                >
                > please help
                >
                > BTW:
                > Discovering a certain wrong solution, I mannaged to get this:
                > *****************
                > [root@localhost dev]# ls -l scsi/host0/bus0/target0/lun0/
                > total 0
                > crw-rw----� � � 1 tsahee� � cdwriter� 21,� � 0 Jan� 1� 1970 generic
                > *****************
                > , which was recognized as a floppy on cdrecord -scanbus and that's it. I
                > have then tried adding ide-scsi to the /dev/modules file, and it was gone
                > (nothing under /dev/scsi). I couldn't get it back since. I have no idea
                > what that means.
                >
                >
                >
                > Yahoo! Groups Sponsor
                >
                >
                >
                > ADVERTISEMENT
                >
                >
                >
                >
                >
                >
                > To unsubscribe from this group, send an email to:
                > gnubies-il-unsubscribe@egroups.com
                >
                >
                >
                > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

                --

                diego, 24 Elul 5763

                Please avoid sending me Word or PowerPoint attachments.
                See http://www.fsf.org/philosophy/no-word-attachments.html
              • Tsahee Zidenberg
                Linux version 2.4.19-16mdk ( quintela@bi.mandrakesoft.com ) (gcc version 3.2 (Mandrake Linux 9.0 3.2-1mdk)) Diego Iastrubni wrote: which kernel do you use?
                Message 7 of 7 , Sep 21, 2003
                View Source
                • 0 Attachment
                  "Linux version 2.4.19-16mdk (quintela@...) (gcc version 3.2 (Mandrake Linux 9.0 3.2-1mdk))"

                  Diego Iastrubni wrote:
                  which kernel do you use?
                  
                  בשבת, 20 בספטמבר 2003, 19:14, נכתב על ידי Tsahee Zidenberg:
                    
                   Some stuff changed since last mail, I've read all the how-to's I could put
                  my hands on, and rebooted my computer a few dozens of times to find a few
                  dozens of wrong solutions (well, not dozens, but you get the point). So
                  here's current status:
                  
                   System: MDK9.0 rather standard ( I don't know enough to make it otherwise)
                  
                   Added HW: � � 
                   *****************
                   � � �  ide1: BM-DMA at 0xe008-0xe00f, BIOS settings: hdc:DMA, hdd:DMA
                   hdc: HL-DT-ST RW/DVD GCC-4480B, ATAPI CD/DVD-ROM drive
                   ****************
                   (It's LG. Should be compatible. I read somewhere about a guy having no
                  problem using LG's combo on MDK9.0) I had no cd-writer installed before
                  that.
                  
                   Problem is:
                   ****************
                   [root@localhost dev]# cdrecord -scanbus
                   Cdrecord 1.11a32 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 J�¶rg
                  Schilling cdrecord: No such file or directory. Cannot open '/dev/pg*'.
                  Cannot open SCSI driver. cdrecord: For possible targets try 'cdrecord
                  -scanbus'. Make sure you are root. ****************
                  
                   The cause, as much as I can determin: IDE-SCSI does not find my drive.� 
                  /dev/scsi dir is empty.
                  
                   Lilo.conf entry:
                   ****************
                   image=/boot/vmlinuz
                   � � � � � � �  label=linux
                   � � � � � � �  root=/dev/hda5
                   � � � � � � �  initrd=/boot/initrd.img
                   � � � � � � �  append="quiet hdc=ide-scsi devfs=mount"
                   � � � � � � �  vga=788
                   � � � � � � �  read-only
                   *************
                  
                   modules.conf:
                   ***************
                   [root@localhost dev]# cat /etc/modules.conf
                   � � �  � �  � �  � �  � �  � �  #not related:
                   probeall usb-interface usb-uhci
                   above snd-cmipci snd-pcm-oss
                   alias sound-slot-0 snd-cmipci
                   alias /dev/nvidia*� �  nvidia
                   � � �  � �  � �  � �  � �  � �  #here start the additions for the CD/W:
                   options ide-cd ignore=hdc � � � � � � � � � �  # tell the ide-cd module to
                  ignore hdc alias scd0 sr_mod� � � � � � � � � � � � � � � � � � �  # load
                  sr_mod upon access of scd0 pre-install sg� � � �  modprobe ide-scsi # load
                  ide-scsi before sg pre-install sr_mod modprobe ide-scsi # load ide-scsi
                  before sr_mod pre-install ide-scsi modprobe ide-cd # load ide-cd� �  before
                  ide-scsi ****************
                  
                   /etc/modules is empty (besides comments).
                  
                   There is a series of tests that appear on the CD_WRITING_HOWTO. To pass
                  all those tests I have to � � �  > manually "insmod loop"
                   � � �  > access my other cd-rom drive (to automaticly load the iso9660
                  filesystem). for example "ls /mnt/cdrom" Then, If I run that series, I get
                  no errors, except for the cdrecord of course. The tests are:
                  
                   *****************
                   test `whoami` = 'root' || echo "You must be root to execute the commands."
                   cdrecord -scanbus > /dev/null
                   if ! (pidof kerneld || test -f "/proc/sys/kernel/modprobe"); then
                   � � �  echo "Neither kerneld nor kmod are running to automatically load
                  modules". fi
                   report_no_autoload() {
                   � � �  echo "Ensure the module $1 is loaded automatically next time."
                   }
                   if test ! -f "/proc/scsi/scsi"; then
                   � � �  report_no_autoload scsi_mod�  &&�  insmod scsi_mod
                   fi
                   if ! grep "^........ sg_" /proc/ksyms > /dev/null; then
                   � � �  report_no_autoload sg�  &&�  insmod sg
                   fi
                   if ! grep "^........ sr_" /proc/ksyms > /dev/null; then
                   � � �  report_no_autoload sr_mod�  &&�  insmod sr_mod
                   fi
                   if ! grep "^........ loop_" /proc/ksyms > /dev/null; then
                   � � �  report_no_autoload loop�  &&�  insmod loop
                   fi
                   if ! grep iso9660 /proc/filesystems > /dev/null; then
                   � � �  report_no_autoload iso9660�  &&�  insmod iso9660
                   fi
                   echo "The following is only needed for IDE/ATAPI CD-writers."
                   if ! grep ide-scsi /proc/ide/drivers > /dev/null; then
                   � � �  report_no_autoload ide-scsi�  &&�  insmod ide-scsi
                   fi
                   cdrecord -scanbus
                   ****************************
                  
                   When I don't use the line "options ide-cd ignore=hdc", I have CD/DVD read
                  access, through ****************
                   [root@localhost dev]# ls -l hdc
                   lr-xr-xr-x� � �  1 root� � � �  root� � � � � � � � � �  30 Sep 20 13:28
                  hdc -> ide/host0/bus1/target0/lun0/cd ****************
                   When that line is active, I have no /dev/hdc file.
                  
                   please help
                  
                   BTW:
                   Discovering a certain wrong solution, I mannaged to get this:
                   *****************
                   [root@localhost dev]# ls -l scsi/host0/bus0/target0/lun0/
                   total 0
                   crw-rw----� � �  1 tsahee� �  cdwriter�  21,� �  0 Jan�  1�  1970 generic
                   *****************
                   , which was recognized as a floppy on cdrecord -scanbus and that's it. I
                  have then tried adding ide-scsi to the /dev/modules file, and it was gone
                  (nothing under /dev/scsi). I couldn't get it back since. I have no idea
                  what that means.
                  
                  
                  
                  Yahoo! Groups Sponsor
                  
                  
                  
                  ADVERTISEMENT
                  
                  
                  
                  
                  
                  
                   To unsubscribe from this group, send an email to:
                   gnubies-il-unsubscribe@egroups.com
                  
                  
                  
                   Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
                      
                    
                Your message has been successfully submitted and would be delivered to recipients shortly.