Loading ...
Sorry, an error occurred while loading the content.
 

Toggling xkeyboard layout

Expand Messages
  • David Howard
    Hi to all. I ve almost never needed to *write* Hebrew in Linux, though I do read a fair amount on the web. Consequently, I ve never before tried messing with
    Message 1 of 3 , Jun 8, 2003
      Hi to all.

      I've almost never needed to *write* Hebrew in Linux, though I do read a
      fair amount on the web. Consequently, I've never before tried messing
      with RTL layout. I've just apt-got the OOo 1.1beta2, enabled CTL, and
      now have two questions.

      The first is almost certainly a dumb question, but how do I toggle
      xkeyboard layout between Hebrew and English? It's no problem in KDE
      (3.1.1), with a button on the tray, but I rarely use KDE - mostly
      xfce3). I'd like to do it with a keyboard toggle (alt-shift?). Google
      searches for various combinations of "change", "switch", "toggle",
      "Hebrew", "layout(s)", "Linux" have produced nothing useful.

      I did find (and now can't remember where) a readme file which suggested
      the following addition to XF86Config-4:

      Option "XkbLayout" "us,cz,il,ru"
      Option "XKbOptions" "grp:alt_shift_toggle"

      So I added these lines, logged out, even rebooted(!), but no luck. An
      xfce button (a la KDE would be ideal, but I'll happily RTF any M, or
      welcome any CLI command or (preferably) keyboard toggle.

      The second question concerns worksheet alignment in calc. Writer seems
      to work well. In KDE, toggling to RTL with the toolbar button switches
      alignment, ruler direction, cursor position and input. In calc, however,
      worksheet layout remains LTR even after toggling - i.e., row numbers
      remain at left, and the column headers go LTR. This makes an unholy mess
      when opening Hebrew .xls files in Calc. Is this a bug, and if so, is
      there any workaround?

      Cheers, David.

      --
      David Howard
      dhoward@...
      Evolution 1.2.3 in Libranet 2.8
    • Yosef Leibovich
      General reference: http://www.iglu.org.il/faq/cache/56.html specifical Xkb: http://www.iglu.org.il/faq/cache/86.html
      Message 2 of 3 , Jun 8, 2003
        General reference: http://www.iglu.org.il/faq/cache/56.html
        specifical Xkb: http://www.iglu.org.il/faq/cache/86.html

        David Howard wrote:

        >Hi to all.
        >
        >I've almost never needed to *write* Hebrew in Linux, though I do read a
        >fair amount on the web. Consequently, I've never before tried messing
        >with RTL layout. I've just apt-got the OOo 1.1beta2, enabled CTL, and
        >now have two questions.
        >
        >The first is almost certainly a dumb question, but how do I toggle
        >xkeyboard layout between Hebrew and English? It's no problem in KDE
        >(3.1.1), with a button on the tray, but I rarely use KDE - mostly
        >xfce3). I'd like to do it with a keyboard toggle (alt-shift?). Google
        >searches for various combinations of "change", "switch", "toggle",
        >"Hebrew", "layout(s)", "Linux" have produced nothing useful.
        >
        >I did find (and now can't remember where) a readme file which suggested
        >the following addition to XF86Config-4:
        >
        >Option "XkbLayout" "us,cz,il,ru"
        >Option "XKbOptions" "grp:alt_shift_toggle"
        >
        >So I added these lines, logged out, even rebooted(!), but no luck. An
        >xfce button (a la KDE would be ideal, but I'll happily RTF any M, or
        >welcome any CLI command or (preferably) keyboard toggle.
        >
        >The second question concerns worksheet alignment in calc. Writer seems
        >to work well. In KDE, toggling to RTL with the toolbar button switches
        >alignment, ruler direction, cursor position and input. In calc, however,
        >worksheet layout remains LTR even after toggling - i.e., row numbers
        >remain at left, and the column headers go LTR. This makes an unholy mess
        >when opening Hebrew .xls files in Calc. Is this a bug, and if so, is
        >there any workaround?
        >
        >Cheers, David.
        >
        >
        >
      • andy_m
        ... To David: The answer for your 1st.question is this : http://jem.ascender.com/eitan Regarding the 2nd.question.As far as I noticed is nothing to do with
        Message 3 of 3 , Jun 9, 2003
          David Howard wrote:

          >Hi to all.
          >
          >I've almost never needed to *write* Hebrew in Linux, though I do read a
          >fair amount on the web. Consequently, I've never before tried messing
          >with RTL layout. I've just apt-got the OOo 1.1beta2, enabled CTL, and
          >now have two questions.
          >
          >The first is almost certainly a dumb question, but how do I toggle
          >xkeyboard layout between Hebrew and English? It's no problem in KDE
          >(3.1.1), with a button on the tray, but I rarely use KDE - mostly
          >xfce3). I'd like to do it with a keyboard toggle (alt-shift?). Google
          >searches for various combinations of "change", "switch", "toggle",
          >"Hebrew", "layout(s)", "Linux" have produced nothing useful.
          >
          >I did find (and now can't remember where) a readme file which suggested
          >the following addition to XF86Config-4:
          >
          >Option "XkbLayout" "us,cz,il,ru"
          >Option "XKbOptions" "grp:alt_shift_toggle"
          >
          >So I added these lines, logged out, even rebooted(!), but no luck. An
          >xfce button (a la KDE would be ideal, but I'll happily RTF any M, or
          >welcome any CLI command or (preferably) keyboard toggle.
          >
          >The second question concerns worksheet alignment in calc. Writer seems
          >to work well. In KDE, toggling to RTL with the toolbar button switches
          >alignment, ruler direction, cursor position and input. In calc, however,
          >worksheet layout remains LTR even after toggling - i.e., row numbers
          >remain at left, and the column headers go LTR. This makes an unholy mess
          >when opening Hebrew .xls files in Calc. Is this a bug, and if so, is
          >there any workaround?
          >
          >Cheers, David.
          >
          >
          >
          To David:

          The answer for your 1st.question is this : http://jem.ascender.com/eitan

          Regarding the 2nd.question.As far as I noticed is nothing to do with
          it.OO 1.1 beta2 hasn't a complete support for converted .xls files.I
          don't know if you ever seen how hebrew MS Office look alike.The
          interface is different meaning,for example,that the "File" is in right
          side of the screen,etc,etc.Lately israeli Finance Ministry announced
          that probably will support the "hebrew-ization" project with IBM in
          order to give a full hebrew support on their product.Let's see!Take a
          look at that (in case you know hebrew :-) ) :
          http://www.ynet.co.il/articles/0,7340,L-2152857,00.html

          Regards,
        Your message has been successfully submitted and would be delivered to recipients shortly.