Loading ...
Sorry, an error occurred while loading the content.

Re: [gnubies-il] Hebrew vfat/fat32 mounting

Expand Messages
  • meh
    http://www.iglu.org.il/faq/cache/76.html: What about hebrew filenames in a FAT partition? Is there really such thing? As far as I understand most windows
    Message 1 of 5 , Mar 10, 2003
    • 0 Attachment
      http://www.iglu.org.il/faq/cache/76.html:
      What about hebrew filenames in a FAT partition? Is there really such thing?

      As far as I understand most windows versions store filenames in some
      unicode format.

      How can I use those filenames?

      Try this:

      mount -t vfat -o iocharset=iso8859-8,codepage=862 /dev/hda1 /dosc

      or whatever... of course u can also add the iocharset,codepage options
      to your fstab.

      - Gaven (Gadi) Cohen
      meh wrote:

      >How can I mount a vfat/fat32 partition with hebrew file names on, when
      >mounting it hebrew appears as question marks (even within kde3.1
      >konsole!) and the most irritating part - cp'ing it or any other action
      >returns 'bad parameter ?????' where the question marks are the file/dir.
      >name.
      >What should I do?
      >
      >
      >
      >
      >To unsubscribe from this group, send an email to:
      >gnubies-il-unsubscribe@egroups.com
      >
      >
      >
      >Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >
      >
      >
      >
    • Leibovich Yosef
      ... Ermm but AFAIK win32 doesn t use this charset in vfat - shouldn t it distrupt your letters (like displaying an HTML with the wrong charset?
      Message 2 of 5 , Mar 11, 2003
      • 0 Attachment
        Tzafrir Cohen wrote:

        >On Tue, Mar 11, 2003 at 09:25:39AM +0200, meh wrote:
        >
        >
        >>>How can I mount a vfat/fat32 partition with hebrew file names on, when
        >>>mounting it hebrew appears as question marks (even within kde3.1
        >>>konsole!) and the most irritating part - cp'ing it or any other action
        >>>returns 'bad parameter ?????' where the question marks are the file/dir.
        >>>name.
        >>>What should I do?
        >>>
        >>>
        >>http://www.iglu.org.il/faq/cache/76.html:
        >>What about hebrew filenames in a FAT partition? Is there really such thing?
        >>
        >>As far as I understand most windows versions store filenames in some
        >>unicode format.
        >>
        >>How can I use those filenames?
        >>
        >>Try this:
        >>
        >>mount -t vfat -o iocharset=iso8859-8,codepage=862 /dev/hda1 /dosc
        >>
        >>
        >
        >Or simply:
        >
        > mount -t vfat -o utf8 /dev/hda1 /dosc
        >
        Ermm but AFAIK win32 doesn't use this charset in vfat - shouldn't it
        distrupt your letters (like displaying an HTML with the wrong charset?

        >
        >The Right Way
        >
        >Then Hebrew should be displayed in konsole, as well as in other
        >unicode-supporting terminals (unicode-xterm, mlterm)
        >
        >
        >
      • Tzafrir Cohen
        ... Or simply: mount -t vfat -o utf8 /dev/hda1 /dosc The Right Way Then Hebrew should be displayed in konsole, as well as in other unicode-supporting terminals
        Message 3 of 5 , Mar 12, 2003
        • 0 Attachment
          On Tue, Mar 11, 2003 at 09:25:39AM +0200, meh wrote:
          >
          > >How can I mount a vfat/fat32 partition with hebrew file names on, when
          > >mounting it hebrew appears as question marks (even within kde3.1
          > >konsole!) and the most irritating part - cp'ing it or any other action
          > >returns 'bad parameter ?????' where the question marks are the file/dir.
          > >name.
          > >What should I do?
          >
          > http://www.iglu.org.il/faq/cache/76.html:
          > What about hebrew filenames in a FAT partition? Is there really such thing?
          >
          > As far as I understand most windows versions store filenames in some
          > unicode format.
          >
          > How can I use those filenames?
          >
          > Try this:
          >
          > mount -t vfat -o iocharset=iso8859-8,codepage=862 /dev/hda1 /dosc

          Or simply:

          mount -t vfat -o utf8 /dev/hda1 /dosc

          The Right Way

          Then Hebrew should be displayed in konsole, as well as in other
          unicode-supporting terminals (unicode-xterm, mlterm)

          --
          Tzafrir Cohen http://www.technion.ac.il/~tzafrir/
          mailto:tzafrir@... sms: mailto:tzafrir+sms@...
        • Leibovich Yosef
          ... I tried it it didn t work - writing cat - HEBREW_FILE_NAME caused an Invalid Option HEBREW_FILE_NAME error both on vfat with -o utf, -o iocharset or
          Message 4 of 5 , Mar 12, 2003
          • 0 Attachment
            Tzafrir wrote:

            > The Right Way
            >
            > Then Hebrew should be displayed in konsole, as well as in > other
            > unicode-supporting terminals (unicode-xterm, mlterm)

            I tried it it didn't work - writing cat ->HEBREW_FILE_NAME caused an "Invalid Option 'HEBREW_FILE_NAME'" error both on vfat with -o utf, -o iocharset or even ext2/3
          Your message has been successfully submitted and would be delivered to recipients shortly.