Loading ...
Sorry, an error occurred while loading the content.

(newbee) 9s12c32 PLL not working in run mode. egnu with provided startup code

Expand Messages
  • Rohan
    Hi Im using a custom development board based around the 9s12c32 micro. freescales sermon is loaded and i m trying to use the PLL to keep the eclk at 24mHz in
    Message 1 of 2 , Nov 9, 2009
    • 0 Attachment
      Hi

      Im using a custom development board based around the 9s12c32 micro.

      freescales sermon is loaded and i'm trying to use the PLL to keep the eclk at 24mHz in run mode. im using egnu gcc with the custom startup code for the 9s12c32 found in egnu/lib but as soon as i hit reset the eclk reverts to the starndard 1/2 osc freq 4mHz in my case. what am i doing wrong here?
    • said jello
      Why are you using Freescale serial monitor if you are not planning on using codewarrior? I would recommend using codewarrior that allows you background
      Message 2 of 2 , Nov 9, 2009
      • 0 Attachment
        Why are you using Freescale serial monitor if you are not planning on using codewarrior?
        I would recommend using codewarrior that allows you background debugging mode.
        We need to take a look at your code before we can help out.
        In my opinion, you might be better off using codewarrior and take a look at the sample programs that come with it.
        All of them start by setting the PLL properly before doing anything.

        --- On Mon, 11/9/09, Rohan <rohan.cowley@...> wrote:

        From: Rohan <rohan.cowley@...>
        Subject: (newbee) 9s12c32 PLL not working in run mode. egnu with provided startup code
        To: gnu-m68hc11@yahoogroups.com
        Date: Monday, November 9, 2009, 6:02 AM

         

        Hi

        Im using a custom development board based around the 9s12c32 micro.

        freescales sermon is loaded and i'm trying to use the PLL to keep the eclk at 24mHz in run mode. im using egnu gcc with the custom startup code for the 9s12c32 found in egnu/lib but as soon as i hit reset the eclk reverts to the starndard 1/2 osc freq 4mHz in my case. what am i doing wrong here?


      Your message has been successfully submitted and would be delivered to recipients shortly.