Loading ...
Sorry, an error occurred while loading the content.

Re: Elevation units in MP export

Expand Messages
  • Jose Getino
    Mike, The feet meter conversion is not working for all MPs features that can have a elevation specified. According the MP documentation, section 4.2.5,
    Message 1 of 35 , Feb 1, 2007
    • 0 Attachment
      Mike,

      The feet <--> meter conversion is not working for all MPs features
      that can have a elevation specified. According the MP documentation,
      section 4.2.5, these features are:

      - Summit: 0x6616
      - Depth points: 0x6200
      - Height points: 0x6300
      - Land/depth contours: 0x20 to 0x25

      Today I had to import a mp file containing 0x6300 points having
      heights in feet and the conversion to meters failed.

      Thanks

      Jose



      --- In global_mapper@yahoogroups.com, "Global Mapper Support"
      <global_mapper@...> wrote:
      >
      > Jose,
      >
      > Thanks for the feedback. I have changed the MP contour export to
      now just round to the nearest integer on export rather than using
      decimal places. I have placed a new build with this change at
      http://www.globalmapper.com/global_mapper8.zip .
      >
      > Let me know if I can be of further assistance.
      >
      > Thanks,
      >
      > Mike
      > Global Mapper Support
      > support@...
      >
      > ----- Original Message -----
      > From: Jose Getino
      > To: global_mapper@yahoogroups.com
      > Sent: Wednesday, December 13, 2006 2:25 AM
      > Subject: [global_mapper] Re: Elevation units in MP export
      >
      >
      > Mike,
      >
      > I'm not sure is a good idea to include decimal places in contour
      > line labels. For the metric case, the most detailed contour lines
      I
      > ever seen are 5m contours. Maybe there exists more detalied maps,
      > but I guess there is no map using contours with decimal places.
      Now
      > after a double change meter->feet->meter, 120 contorus become
      > 120.091 contours. So I feel rounding contours labels is good, but
      to
      > the nearest integer. Or maybe let the user to select the
      precision
      > of the z values.
      >
      > Thanks and sorry for the inconvenience
      >
      > Jose
      >
      > --- In global_mapper@yahoogroups.com, "Global Mapper Support"
      > <global_mapper@> wrote:
      > >
      > > Jose,
      > >
      > > I have (hopefully) fixed the rounding issue and also made the
      > metric elevation values write out decimal digits of precision. I
      > have placed a new build with these changes at
      > http://www.globalmapper.com/global_mapper8.zip .
      > >
      > > Let me know if I can be of further assistance.
      > >
      > > Thanks,
      > >
      > > Mike
      > > Global Mapper Support
      > > support@
      > >
      > > ----- Original Message -----
      > > From: Jose Getino
      > > To: global_mapper@yahoogroups.com
      > > Sent: Tuesday, December 12, 2006 12:18 PM
      > > Subject: [global_mapper] Re: Elevation units in MP export
      > >
      > >
      > > Mike,
      > >
      > > I tested the new buid with a metric dgn file, with mp files and
      > used
      > > templates in meters and feet. Now Global Mapper takes correctly
      > the
      > > elevation unit from the mp header, but I think it could do a
      > better
      > > job rounding floats.
      > >
      > > Here an example:
      > >
      > > I have a 120 m contour line. In feet this makes 393.700, so the
      > > better aproach would be 394 feet, but Global Mapper gives 393
      > feet.
      > >
      > > When I try to recover te metric values from this file, Global
      > Mapper
      > > uses the 393 feet. But even 393 feet is not the not a very good
      > > rounding, it has a chance to recover the original metric value,
      > as
      > > 393 feet= 119.786, so 120 m is the best approach. With 394 feet
      > it
      > > would give 120.091 meter, even better. But Global Mapper set
      > > elevation = 119m.
      > >
      > > So the point is not to round to the floor integer, but to the
      > closer
      > > one.
      > >
      > > Thanks
      > >
      > > Jose
      > >
      > > --- In global_mapper@yahoogroups.com, "Global Mapper Support"
      > > <global_mapper@> wrote:
      > > >
      > > > Hans,
      > > >
      > > > Thanks for the additional information. I think that when I
      > > initially did my test there probably were unit labels on the
      > contour
      > > heights which is why it only worked when they were exported as
      > feet.
      > > I'm out of the office right now so I can't fully test this, but
      > I
      > > have changed the contour label export to use the configured
      > export
      > > units and placed a new build at
      > > http://www.globalmapper.com/global_mapper8.zip for you and Jose
      > to
      > > try it. Simply download that file and extract the contents over
      > your
      > > existing v8 installation to give it a try.
      > > >
      > > > Let me know if I can be of further assistance.
      > > >
      > > > Thanks,
      > > >
      > > > Mike
      > > > Global Mapper Support
      > > > support@
      > > >
      > > > ----- Original Message -----
      > > > From: Scheffler, Hans <hscheff@>
      > > > To: global_mapper@yahoogroups.com
      > > > Sent: Tuesday, December 12, 2006 1:42 AM
      > > > Subject: RE: [global_mapper] Re: Elevation units in MP export
      > > >
      > > >
      > > > Mike
      > > >
      > > > cgpsmapper does translate the contour line labels according
      to
      > > the unit
      > > > setting.
      > > > (and has been doing this since I started using it in 2003).
      > > >
      > > > However cgpsmapper does not translate the elevation labels if
      > > they are
      > > > not numerical.
      > > > IIRC global mapper initially added a unit suffix (m / ft) to
      > > contour
      > > > line labels which will cause contour line labels not to be
      > > converted. I
      > > > think this has been corrected since.
      > > >
      > > > Hans
      > > >
      > > > > -----Original Message-----
      > > > > From: global_mapper@yahoogroups.com
      > > > > [mailto:global_mapper@yahoogroups.com] On Behalf Of Global
      > > > > Mapper Support
      > > > > Sent: 12 December 2006 09:04
      > > > > To: global_mapper@yahoogroups.com
      > > > > Subject: Re: [global_mapper] Re: Elevation units in MP
      export
      > > > >
      > > > >
      > > > > Jose,
      > > > >
      > > > > This isn't a Global Mapper issue, the problem is that
      > > > > cGPSMapper doesn't do any kind of unit translation on
      > contour
      > > > > line labels based on the elevation units setting (or at
      > least
      > > > > the original version that I was testing with did not). In
      > the
      > > > > final Garmin maps the contour line label is assumed to be
      > the
      > > > > elevation of the contour line in feet and the Garmin units
      > > > > automatically convert the units to meters or feet for
      > display
      > > > > depending on the user's unit setting. Since cGPSMapper just
      > > > > passes the labels through to the final Garmin map, which
      > > > > defines the units as feet, Global Mapper has to always
      write
      > > > > those units out as feet so that the correct units will make
      > > > > it to the final Garmin .img file.
      > > > >
      > > > > Let me know if I can be of further assistance.
      > > > >
      > > > > Thanks,
      > > > >
      > > > > Mike
      > > > > Global Mapper Support
      > > > > support@
      > > > >
      > > > > ----- Original Message -----
      > > > > From: Jose Getino
      > > > > To: global_mapper@yahoogroups.com
      > > > > Sent: Tuesday, December 12, 2006 12:46 AM
      > > > > Subject: [global_mapper] Re: Elevation units in MP export
      > > > >
      > > > >
      > > > > Mike,
      > > > >
      > > > > Regarding the elevation units setting, I think it should
      > > affect the
      > > > > labels of the contours as well. In fact they are not
      > > conceptually
      > > > > different from the elevation values associated to the other
      > > feature
      > > > > types.
      > > > >
      > > > > This is a uncommon particularity of the MP format: it uses
      > > > > labels to
      > > > > specify heights. And these labels can represent either feet
      > or
      > > > > meters, depending on the setting of the header line:
      > > > >
      > > > > "Elevation=X"
      > > > >
      > > > > So, let assume your MP template is set to meters:
      > > > >
      > > > > - If you load vector data with elevations in meters, the
      > > elevation
      > > > > values in the mp exported file should keep unchanged (my
      dgn
      > > import
      > > > > case)
      > > > >
      > > > > - If you load vector data with elevations in feet, the
      > > elevation
      > > > > values in the mp exported file should be converted from
      feet
      > > to
      > > > > meters.
      > > > >
      > > > > But Global Mapper is doing just the contrary: it changes
      the
      > > units
      > > > > in the first case and keeps them in the second. This is a
      > odd
      > > > > behavoir and I can't find a way to overcome it. In
      > particular
      > > I
      > > > > don't divise a way to import the dgn files keeping the
      > > original
      > > > > values in meters in the labels of the mp file. I realized
      it
      > > after
      > > > > importing a huge mp file of 2Gb, containing 5m contours.
      > > Global
      > > > > Mapper converted all my labels to feet and I don't know how
      > to
      > > > > recover the original metric values.
      > > > >
      > > > > Thanks
      > > > >
      > > > > Jose
      > > > >
      > > > > --- In global_mapper@yahoogroups.com, "Global Mapper
      > Support"
      > > > > <global_mapper@> wrote:
      > > > > >
      > > > > > Jose,
      > > > > >
      > > > > > Regardless of what elevation units are specified in MP
      > > > > headers the
      > > > > labels for contour line features always use feet. The
      > > elevation
      > > > > units setting only affects elevation values stored with
      > other
      > > > > feature types.
      > > > > >
      > > > > > Let me know if I can be of further assistance.
      > > > > >
      > > > > > Thanks,
      > > > > >
      > > > > > Mike
      > > > > > Global Mapper Support
      > > > > > support@
      > > > > >
      > > > > > ----- Original Message -----
      > > > > > From: Jose Getino
      > > > > > To: global_mapper@yahoogroups.com
      > > > > > Sent: Monday, December 11, 2006 5:29 PM
      > > > > > Subject: [global_mapper] Elevation units in MP export
      > > > > >
      > > > > >
      > > > > > Hi Mike,
      > > > > >
      > > > > > I have a copule of doubts about how elevation units works
      > in
      > > > > Global
      > > > > > Mapper:
      > > > > >
      > > > > > 1. I have a dgn file containing contour lines, elevation
      > is
      > > > > given in
      > > > > > meters. I load this file, set line types to contours, and
      > > export
      > > > > to
      > > > > > MP using a template with Elevation set to "M". The
      > > elevations in
      > > > > the
      > > > > > resulting mp file (label fields) are converted to feet.
      > How
      > > can
      > > > > I
      > > > > > preserve the original elevation values on the dgn file?.
      > > > > >
      > > > > > 2. I load a MP file having Elevation set to "F". I export
      > > this
      > > > > file
      > > > > > using a template with Elevation set to "M". The
      elevations
      > > > > values of
      > > > > > the exported file are identical to the ones in the input
      > > file.
      > > > > Why
      > > > > > Global Mapper don't convert feet to meters in this case?
      > > > > >
      > > > > > Thanks
      > > > > >
      > > > > > Jose
      > > > > >
      > > > > >
      > > > > >
      > > > > >
      > > > > >
      > > > > > [Non-text portions of this message have been removed]
      > > > > >
      > > > >
      > > > >
      > > > >
      > > > >
      > > > >
      > > > > [Non-text portions of this message have been removed]
      > > > >
      > > > >
      > > > >
      > > > >
      > > > > Yahoo! Groups Links
      > > > >
      > > > >
      > > > >
      > > > >
      > > >
      > > >
      > > >
      > > >
      > > > [Non-text portions of this message have been removed]
      > > >
      > >
      > >
      > >
      > >
      > >
      > > [Non-text portions of this message have been removed]
      > >
      >
      >
      >
      >
      >
      > [Non-text portions of this message have been removed]
      >
    • Jose Getino
      Thanks Mike, I will keep this build along with the curent one. At present is the only way I know to completely recover the original MP file from the compiled
      Message 35 of 35 , Feb 8, 2007
      • 0 Attachment
        Thanks Mike,

        I will keep this build along with the curent one. At present is the
        only way I know to completely recover the original MP file from the
        compiled img, when it contains metric contour lines.

        Jose






        --- In global_mapper@yahoogroups.com, "Global Mapper Support"
        <global_mapper@...> wrote:
        >
        > Jose,
        >
        >
        >
        > I have placed a new build at
        > http://www.globalmapper.com/global_mapper8_jose.zip which will
        always round
        > contour elevations to the nearest integer on export to MP files.
        >
        >
        >
        > Let me know if I can be of further assistance.
        >
        >
        >
        > Thanks,
        >
        >
        >
        > Mike
        >
        > Global Mapper Support
        >
        > support@...
        >
        >
        >
        > -----Original Message-----
        > From: global_mapper@yahoogroups.com
        [mailto:global_mapper@yahoogroups.com]
        > On Behalf Of Jose Getino
        > Sent: Thursday, February 08, 2007 12:13 PM
        > To: global_mapper@yahoogroups.com
        > Subject: [global_mapper] Re: Elevation units in MP export
        >
        >
        >
        > Mike,
        >
        > it has nothing to do with img generation. A nice display is only
        part
        > of what I want. The most important feature is to be able to save
        the
        > vector file (in mp of whatever) with the original integral
        elevations
        > of the contour lines.
        >
        > Thanks
        >
        > Jose
        >
        > --- In global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > yahoogroups.com, "Global Mapper Support"
        > <global_mapper@> wrote:
        > >
        > > Jose,
        > >
        > >
        > >
        > > I'm still not clear on how rounding metric elevations to whole
        > numbers ever
        > > helps you. If you are coming from a .img file made from contour
        > lines in
        > > integer meters, you should get back to those same integer meter
        > numbers when
        > > you do the conversion.
        > >
        > >
        > >
        > > For example, a 10 m contour line in a MP file would become 33 ft
        in
        > the .img
        > > file. GPSMapEdit would bring that back in and make it 10.06 m.
        You
        > could
        > > work with that in GM, then when you export it out to a new MP
        file
        > with
        > > meters it will stay as 10.06 meters in the new MP file and be
        > converted back
        > > to 33 ft in any new .img file that you create.
        > >
        > >
        > >
        > > Are you just wanting the rounding to get nice display of whole
        > meters in
        > > Global Mapper and/or GPSMapEdit?
        > >
        > >
        > >
        > > Thanks,
        > >
        > >
        > >
        > > Mike
        > >
        > > Global Mapper Support
        > >
        > > support@
        > >
        > >
        > >
        > > -----Original Message-----
        > > From: global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > yahoogroups.com
        > [mailto:global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > yahoogroups.com]
        > > On Behalf Of Jose Getino
        > > Sent: Thursday, February 08, 2007 10:58 AM
        > > To: global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > yahoogroups.com
        > > Subject: [global_mapper] Re: Elevation units in MP export
        > >
        > >
        > >
        > > Mike
        > >
        > > I agree with you in the example you propose: 100 feet. It is a
        map
        > > made in feet. It is clear that you'll loose precision when
        > converting
        > > to meters if you round elevations for this kind of maps.
        > >
        > > However I'm not going to convert to meters this type of maps. I
        was
        > > meaning "metric" contour maps in img format, I mean contour maps
        > > originally designed in meters, with contours at 10m, 20m,
        30m,.....
        > >
        > > If you have this map in img format and use gpsMapEdit to obtain
        the
        > > MP file, all elevations will appear in feet. Is only for this
        case
        > > that I want to recover the original integral metric elevations.
        > >
        > > It is clear from your example that rounding and a bad use of
        > > conversions would cause imprecissions. And incorporating rounding
        > in
        > > the Globl Mapper would be problematic, as the elevations of
        > contours
        > > are stored in the Feature Name.
        > >
        > > Maybe the easiest way I would be able to get contour lines with
        > > integral elevations as before is to get a copy of the old build,
        if
        > > you have one, of couse.
        > >
        > > Thanks
        > >
        > > Jose
        > >
        > > but I was talking about
        > >
        > > --- In global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > yahoogroups.com, "Global Mapper Support"
        > > <global_mapper@> wrote:
        > > >
        > > > Jose,
        > > >
        > > >
        > > >
        > > > That is odd, I would actually expect that you would NOT be able
        > to
        > > maintain
        > > > the original elevation in feet with the build that always
        rounds
        > > metric
        > > > values to the nearest integer in addition to feet values. For
        > > example, so if
        > > > you started with an image and a contour of height 100 feet. If
        > you
        > > converted
        > > > that to meters and rounded, the meters value of 30.488 becomes
        > just
        > > 30. If
        > > > you then save that out and use the MP file to create a contour
        > > line, the
        > > > associated feet value would be 98.4 ft (30m * 3.28), or just 98
        > > feet in the
        > > > resulting MP file. It is only by including decimal places for
        > > meters units
        > > > that the original feet value can be maintained. Does this make
        > > sense?
        > > >
        > > >
        > > >
        > > > What Stan indicated to me was that he thought that one type of
        > > elevation
        > > > format supported decimals but he wasn't sure which one (I
        believe
        > > it is the
        > > > marine spot soundings). I did some digging and found that at
        > least
        > > some
        > > > Garmin units will not treat any elevation string longer than 5
        > > characters as
        > > > an elevation value that can be converted, so really integer
        feet
        > > are needed
        > > > for everything except the marine spot soundings that store
        their
        > > height as
        > > > an attribute and not in the text for the feature. Since
        > cGPSMapper
        > > should
        > > > automatically convert and round any meters units in strings, it
        > > should be ok
        > > > to have decimals in elevations exported as meters. Any feet
        > values
        > > should be
        > > > exported as integer-only from Global Mapper.
        > > >
        > > >
        > > >
        > > > Let me know if I can be of further assistance.
        > > >
        > > >
        > > >
        > > > Thanks,
        > > >
        > > >
        > > >
        > > > Mike
        > > >
        > > > Global Mapper Support
        > > >
        > > > support@
        > > >
        > > >
        > > >
        > > > -----Original Message-----
        > > > From: global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > yahoogroups.com
        > > [mailto:global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > yahoogroups.com]
        > > > On Behalf Of Jose Getino
        > > > Sent: Thursday, February 08, 2007 9:01 AM
        > > > To: global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > yahoogroups.com
        > > > Subject: [global_mapper] Re: Elevation units in MP export
        > > >
        > > >
        > > >
        > > > Mike
        > > >
        > > > it has nothing to do with compiling a mp file, but with having
        a
        > > way
        > > > to get a vector contour map in meters from a img file.
        > > >
        > > > I have some metric contour maps in img format, and I'd like to
        > have
        > > > it in a more redeable vector format. When exporting the img
        file
        > > with
        > > > gpsMapEdit, I get a mp file with elevations in feet.
        > > >
        > > > I was using Global Mapper so far to obatin the contours in
        > meters,
        > > I
        > > > don't know other software that could do that. I had no lose of
        > > > precission issues since you changed the rounding to the nearest
        > > > integer. Even the contrary, the rounding was able to correct
        the
        > > > imprecissions, as countour lines elevations are always integer
        > > values
        > > > (multiples of 5 in the most detailed maps). So after several
        > > changes
        > > > feet-> meters --> feet --> meters, I used to get the correct
        > > > elevation values (all of them multiples of 5).
        > > >
        > > > Now I can't get a good looking contour map in meters from an
        img
        > > > file, as I can't divise a way to round the elevations. A copy
        of
        > > the
        > > > build with the nearest integer rouding would be enough for me,
        I
        > do
        > > > not conserve copies of the older builds.
        > > >
        > > > Did you ear something from Stan about the other issues with
        > > > cgpsmapper? I mean, rounding elevations for MPs in feet and the
        > > > strange behavoir of the Spot Elevations you had discovered.
        > > >
        > > > Thanks
        > > >
        > > > Jose
        > > >
        > > > --- In global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > > yahoogroups.com, "Global Mapper Support"
        > > > <global_mapper@> wrote:
        > > > >
        > > > > Jose,
        > > > >
        > > > >
        > > > >
        > > > > Yes, now when elevations are exported in units of meters they
        > are
        > > > no longer
        > > > > rounded to the nearest integer. This is because Stan from
        > > cGPSMapper
        > > > > indicates that for metric units he automatically does the
        > > > conversion to
        > > > > feet. If Global Mapper were to write out the elevations in
        > meters
        > > > rounded to
        > > > > an integer you would lose some available precision. Are the
        > > values
        > > > not
        > > > > correct in created .img files when you have decimal elevation
        > > > values in
        > > > > meters?
        > > > >
        > > > >
        > > > >
        > > > > Thanks,
        > > > >
        > > > >
        > > > >
        > > > > Mike
        > > > >
        > > > > Global Mapper Support
        > > > >
        > > > > support@
        > > > >
        > > > >
        > > > >
        > > > > -----Original Message-----
        > > > > From: global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > > yahoogroups.com
        > > > [mailto:global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > > yahoogroups.com]
        > > > > On Behalf Of Jose Getino
        > > > > Sent: Thursday, February 08, 2007 2:35 AM
        > > > > To: global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > > yahoogroups.com
        > > > > Subject: [global_mapper] Re: Elevation units in MP export
        > > > >
        > > > >
        > > > >
        > > > > Mike
        > > > >
        > > > > I was converting to meters a MP map of countour lines with
        > units
        > > in
        > > > > feet (becuase it was extracted from a img file by means of
        > > > > gpsMapEdit) and found that the labels are no more rounded to
        > the
        > > > > nearest integer, so I'm getting strange values for
        elevations.
        > > Did
        > > > > you change this behavoir in the latest builds?
        > > > >
        > > > > Thanks
        > > > >
        > > > > Jose
        > > > >
        > > > > --- In global_mapper@ <mailto:global_mapper%40yahoogroups.com>
        > > > > yahoogroups.com, "Jose Getino" <jgetino@>
        > > > > wrote:
        > > > > >
        > > > > > Thanks Mike,
        > > > > >
        > > > > > now it works fine for my custom type, even if there is no
        > > MP_TYPE
        > > > > > attribute defined.
        > > > > >
        > > > > > Jose
        > > > > >
        > > > > >
        > > > > >
        > > > > > --- In global_mapper@ <mailto:global_mapper%
        40yahoogroups.com>
        > > > > yahoogroups.com, "Global Mapper Support"
        > > > > > <global_mapper@> wrote:
        > > > > > >
        > > > > > > Jose,
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > > I had actually just noticed the same problem with custom
        > > types
        > > > > the
        > > > > > other day
        > > > > > > myself and fixed it. There is a new build at
        > > > > > > http://www.globalma
        > > > <http://www.globalma
        > > <http://www.globalma
        > <http://www.globalma
        <http://www.globalmapper.com/global_mapper8.zip>
        > pper.com/global_mapper8.zip>
        > > pper.com/global_mapper8.zip>
        > > > pper.com/global_mapper8.zip>
        > > > > pper.com/global_mapper8.zip which should
        > > > > > properly export
        > > > > > > the elevation if the assigned MP_TYPE attribute is a
        value
        > > that
        > > > > > requires
        > > > > > > elevation.
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > > Let me know if I can be of further assistance.
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > > Thanks,
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > > Mike
        > > > > > >
        > > > > > > Global Mapper Support
        > > > > > >
        > > > > > > support@
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > > -----Original Message-----
        > > > > > > From: global_mapper@ <mailto:global_mapper%
        > 40yahoogroups.com>
        > > > > yahoogroups.com
        > > > > > [mailto:global_mapper@ <mailto:global_mapper%
        > 40yahoogroups.com>
        > > > > yahoogroups.com]
        > > > > > > On Behalf Of Jose Getino
        > > > > > > Sent: Tuesday, February 06, 2007 7:55 AM
        > > > > > > To: global_mapper@ <mailto:global_mapper%
        40yahoogroups.com>
        > > > > yahoogroups.com
        > > > > > > Subject: [global_mapper] Re: Elevation units in MP export
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > > Mike
        > > > > > >
        > > > > > > I have a custom type ("Cumbre") associated to Garmin type
        > > > 0x6616.
        > > > > I
        > > > > > > think this is because of this that Global Mapper is not
        > > > exporting
        > > > > > > ELEVATION to MP files for this type. Would you add
        > condition
        > > > > > > MP_TYPE=0x6616 to have ELEVATION exported?.
        > > > > > >
        > > > > > > Thanks
        > > > > > >
        > > > > > > Jose
        > > > > > >
        > > > > > > --- In global_mapper@ <mailto:global_mapper%
        > 40yahoogroups.com>
        > > > > > > yahoogroups.com, "Global Mapper Support"
        > > > > > > <global_mapper@> wrote:
        > > > > > > >
        > > > > > > > Jose,
        > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > > I forwarded this threads and some of my thoughts to
        Stan
        > at
        > > > > > > cGPSMapper, so
        > > > > > > > perhaps he can shed some light on the situation.
        > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > > Thanks,
        > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > > Mike
        > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > > -----Original Message-----
        > > > > > > > From: global_mapper@ <mailto:global_mapper%
        > > 40yahoogroups.com>
        > > > > > > yahoogroups.com
        > > > > > > [mailto:global_mapper@ <mailto:global_mapper%
        > > 40yahoogroups.com>
        > > > > > > yahoogroups.com]
        > > > > > > > On Behalf Of Jose Getino
        > > > > > > > Sent: Thursday, February 01, 2007 4:56 PM
        > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > 40yahoogroups.com>
        > > > > > > yahoogroups.com
        > > > > > > > Subject: [global_mapper] Re: Elevation units in MP
        export
        > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > > Mike, you are right, if the header units are meters,
        > > > cgpsmapper
        > > > > > > makes
        > > > > > > > the rounding when converting to feet, and the elevation
        > is
        > > > > always
        > > > > > > > recognized by the gps.
        > > > > > > >
        > > > > > > > But if the header units are feet, there is not rounding
        > at
        > > > all,
        > > > > > and
        > > > > > > > the elevation is not recognized by the gps if it
        contains
        > > > > decimal
        > > > > > > > places.
        > > > > > > >
        > > > > > > > So using meters is safer (it sounds like cgpsmapper
        > should
        > > be
        > > > > > > clever
        > > > > > > > whith MP files in feet).
        > > > > > > >
        > > > > > > > Jose
        > > > > > > >
        > > > > > > > --- In global_mapper@ <mailto:global_mapper%
        > > 40yahoogroups.com>
        > > > > > > > yahoogroups.com, "Global Mapper Support"
        > > > > > > > <global_mapper@> wrote:
        > > > > > > > >
        > > > > > > > > Jose,
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > > I checked the .img file that you had provided and in
        > > > the .img
        > > > > > > > viewing tools
        > > > > > > > > that I have the elevation was interpreted correctly.
        > What
        > > > > > > > cGPSMapper should
        > > > > > > > > be writing to the .img file for summits and similar
        > > > features
        > > > > is
        > > > > > > the
        > > > > > > > > elevation IN FEET after the feature label and
        > > abbreviation
        > > > > > > > character. That
        > > > > > > > > should not contain any decimal places, but it is
        really
        > > up
        > > > to
        > > > > > > > cGPSMapper to
        > > > > > > > > convert whatever numeric elevation in whatever unit
        to
        > > feet
        > > > > for
        > > > > > > > writing to
        > > > > > > > > the .img file. If it is only working for non-decimal
        > > > numbers
        > > > > > then
        > > > > > > > that is a
        > > > > > > > > cGPSMapper problem. I seem to recall decimal numbers
        > > > working
        > > > > > for
        > > > > > > > other
        > > > > > > > > places that elevation values are used.
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > > Let me know if I can be of further assistance.
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > > Thanks,
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > > Mike
        > > > > > > > >
        > > > > > > > > Global Mapper Support
        > > > > > > > >
        > > > > > > > > support@
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > > -----Original Message-----
        > > > > > > > > From: global_mapper@ <mailto:global_mapper%
        > > > 40yahoogroups.com>
        > > > > > > > yahoogroups.com
        > > > > > > > [mailto:global_mapper@ <mailto:global_mapper%
        > > > 40yahoogroups.com>
        > > > > > > > yahoogroups.com]
        > > > > > > > > On Behalf Of Jose Getino
        > > > > > > > > Sent: Thursday, February 01, 2007 3:59 PM
        > > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > > 40yahoogroups.com>
        > > > > > > > yahoogroups.com
        > > > > > > > > Subject: [global_mapper] Re: Elevation units in MP
        > export
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > > Mike, it has been really fast!.
        > > > > > > > >
        > > > > > > > > I need to make some tests in your solution for spots.
        > > With
        > > > > > > respect
        > > > > > > > > Summits, unit conversion is working fine by means of
        > the
        > > > > > > ELEVATION.
        > > > > > > > > But I see you leave decimal places in the second part
        > of
        > > > the
        > > > > > > label
        > > > > > > > > when exporting to a MP file. In the case of the test
        > file
        > > I
        > > > > > get:
        > > > > > > > >
        > > > > > > > > Label=~[0x1f]892.761
        > > > > > > > >
        > > > > > > > > Did you check if your GPS recognizes 892.761 m as an
        > > > > elevation
        > > > > > > for
        > > > > > > > a
        > > > > > > > > summit?. In my case it doesn't, I have to round to:
        > > > > > > > >
        > > > > > > > > Label=~[0x1f]893
        > > > > > > > >
        > > > > > > > > Otherwise the letter "M" after the elevation doesn't
        > > appear
        > > > > in
        > > > > > > the
        > > > > > > > > gps screen, and the change of elevation unit of my
        GPS
        > > > don't
        > > > > > > works.
        > > > > > > > >
        > > > > > > > > Thanks
        > > > > > > > >
        > > > > > > > > Jose
        > > > > > > > >
        > > > > > > > > --- In global_mapper@ <mailto:global_mapper%
        > > > 40yahoogroups.com>
        > > > > > > > > yahoogroups.com, "Global Mapper Support"
        > > > > > > > > <global_mapper@> wrote:
        > > > > > > > > >
        > > > > > > > > > Jose,
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > I took a look and found that for spot sounding and
        > spot
        > > > > > height
        > > > > > > > > features the
        > > > > > > > > > elevation values were always being interpreted as
        > > meters
        > > > if
        > > > > > > they
        > > > > > > > > did not
        > > > > > > > > > have "ft" in the name, regardless of what the
        default
        > > > > > elevation
        > > > > > > > > units for
        > > > > > > > > > the layer were set at. In addition, I found that
        the
        > > > labels
        > > > > > for
        > > > > > > > spot
        > > > > > > > > > elevation and spot sounding values need to be just
        > the
        > > > > > numeric
        > > > > > > > > elevation
        > > > > > > > > > value for the feature in order to work properly
        (this
        > > is
        > > > > the
        > > > > > > same
        > > > > > > > > way that
        > > > > > > > > > contour line labels work).
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > For GPN points like summits, the elevation is
        always
        > > > stored
        > > > > > > after
        > > > > > > > > the
        > > > > > > > > > special abbreviation character. I went ahead and
        > added
        > > > > > support
        > > > > > > > for
        > > > > > > > > detecting
        > > > > > > > > > this when importing MP files and saving that
        > elevation
        > > > > value
        > > > > > as
        > > > > > > a
        > > > > > > > > feature
        > > > > > > > > > attribute rather than keeping it in the name, thus
        > > > allowing
        > > > > > it
        > > > > > > to
        > > > > > > > be
        > > > > > > > > > properly detected and converted on export.
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > I have placed a new build with these change at
        > > > > > > > > > http://www.globalma
        > > > > > > > <http://www.globalma
        > > > > > > <http://www.globalma
        > > > > > <http://www.globalma
        > > > <http://www.globalma
        > > <http://www.globalma
        > <http://www.globalma
        <http://www.globalmapper.com/global_mapper8.zip>
        > pper.com/global_mapper8.zip>
        > > pper.com/global_mapper8.zip>
        > > > pper.com/global_mapper8.zip>
        > > > > pper.com/global_mapper8.zip>
        > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > pper.com/global_mapper8.zip . Simply download
        > > > > > > > > that file
        > > > > > > > > > and extract the contents over your existing v8
        > > > installation
        > > > > > to
        > > > > > > > give
        > > > > > > > > it a
        > > > > > > > > > try.
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > Let me know if I can be of further assistance.
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > Thanks,
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > Mike
        > > > > > > > > >
        > > > > > > > > > Global Mapper Support
        > > > > > > > > >
        > > > > > > > > > support@
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > -----Original Message-----
        > > > > > > > > > From: global_mapper@ <mailto:global_mapper%
        > > > > 40yahoogroups.com>
        > > > > > > > > yahoogroups.com
        > > > > > > > > [mailto:global_mapper@ <mailto:global_mapper%
        > > > > 40yahoogroups.com>
        > > > > > > > > yahoogroups.com]
        > > > > > > > > > On Behalf Of Jose Getino
        > > > > > > > > > Sent: Thursday, February 01, 2007 1:24 PM
        > > > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > > > 40yahoogroups.com>
        > > > > > > > > yahoogroups.com
        > > > > > > > > > Subject: [global_mapper] Re: Elevation units in MP
        > > export
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > Mike,
        > > > > > > > > >
        > > > > > > > > > The file "test foot.mp" contains several features,
        > all
        > > of
        > > > > > them
        > > > > > > > > having
        > > > > > > > > > the same elevation:
        > > > > > > > > >
        > > > > > > > > > 2929 F
        > > > > > > > > >
        > > > > > > > > > When exporting this file to MP using the
        > > > > header "Header.mp" -
        > > > > > > > which
        > > > > > > > > > set the elevation unit to be a meter- only the
        > contour
        > > > line
        > > > > > > > > converts
        > > > > > > > > > its elevation to meters: 893 m. The elevation of
        the
        > > > summit
        > > > > > and
        > > > > > > > the
        > > > > > > > > > two spot elevation/depression reamins in feet.
        > > > > > > > > >
        > > > > > > > > > I also noticed that elevation can't contain decimal
        > > > places.
        > > > > > If
        > > > > > > I
        > > > > > > > > set
        > > > > > > > > > the elevation of a Summit or a Spot to be a number
        > like
        > > > > > 2929.3
        > > > > > > > then
        > > > > > > > > > the elevations of mp file and of the compiled img
        > file
        > > > > works
        > > > > > > > > > correctely in gpsMapEdit.
        > > > > > > > > >
        > > > > > > > > > But when I upload the file to my gps (a 60csx
        unit),
        > > the
        > > > > > > > elevation
        > > > > > > > > is
        > > > > > > > > > not reconized, but considered a part of the name,
        > > because:
        > > > > > > > > >
        > > > > > > > > > - It does not appears the unit (M or F) after the
        > > > elevation
        > > > > > > value
        > > > > > > > > > - Changing the elevation unit of the gps has no
        efect
        > > on
        > > > > the
        > > > > > > > > > elevation of the feature.
        > > > > > > > > >
        > > > > > > > > > I would like other users with different gps untis
        > would
        > > > say
        > > > > > > about
        > > > > > > > > > this point, becasue nothing is said in the
        cgpsmapper
        > > > > > > > > documentation.
        > > > > > > > > > In my case is clear: elevations should always be
        > > > integers.
        > > > > If
        > > > > > > > not,
        > > > > > > > > > they are not properly recognized by my gps.
        > > > > > > > > >
        > > > > > > > > > On the other hand I also noticed that the label
        line
        > of
        > > a
        > > > > > spot
        > > > > > > > > > (0x6200 and 0x6300) must be simply:
        > > > > > > > > >
        > > > > > > > > > Label=2929
        > > > > > > > > >
        > > > > > > > > > But the label of a unnamed Summit (0x6616) must be
        > > > > > > > > >
        > > > > > > > > > Label=~[0x1f]2929
        > > > > > > > > >
        > > > > > > > > > to be recognized as an elevation. Unfortunately
        this
        > > > > implies
        > > > > > > that
        > > > > > > > > the
        > > > > > > > > > label shown in the gps will be some like
        > > > > > > > > >
        > > > > > > > > > ,893 M
        > > > > > > > > >
        > > > > > > > > > so no way to get rid of the comma.
        > > > > > > > > >
        > > > > > > > > > I'm ussing the latest verson of cgpsmapper
        > > > > > > > > >
        > > > > > > > > > Thanks
        > > > > > > > > >
        > > > > > > > > > Jose
        > > > > > > > > >
        > > > > > > > > > --- In global_mapper@ <mailto:global_mapper%
        > > > > 40yahoogroups.com>
        > > > > > > > > > yahoogroups.com, "Global Mapper Support"
        > > > > > > > > > <global_mapper@> wrote:
        > > > > > > > > > >
        > > > > > > > > > > Jose,
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > Can you provide a sample file to support@ so that
        I
        > > can
        > > > > take
        > > > > > > > > > > a look?
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > Thanks,
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > Mike
        > > > > > > > > > >
        > > > > > > > > > > Global Mapper Support
        > > > > > > > > > >
        > > > > > > > > > > support@
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > -----Original Message-----
        > > > > > > > > > > From: global_mapper@ <mailto:global_mapper%
        > > > > > 40yahoogroups.com>
        > > > > > > > > > yahoogroups.com
        > > > > > > > > > [mailto:global_mapper@ <mailto:global_mapper%
        > > > > > 40yahoogroups.com>
        > > > > > > > > > yahoogroups.com]
        > > > > > > > > > > On Behalf Of Jose Getino
        > > > > > > > > > > Sent: Thursday, February 01, 2007 8:27 AM
        > > > > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > > > > 40yahoogroups.com>
        > > > > > > > > > yahoogroups.com
        > > > > > > > > > > Subject: [global_mapper] Re: Elevation units in
        MP
        > > > export
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > Mike,
        > > > > > > > > > >
        > > > > > > > > > > The feet <--> meter conversion is not working for
        > all
        > > > MPs
        > > > > > > > > features
        > > > > > > > > > > that can have a elevation specified. According
        the
        > MP
        > > > > > > > > > documentation,
        > > > > > > > > > > section 4.2.5, these features are:
        > > > > > > > > > >
        > > > > > > > > > > - Summit: 0x6616
        > > > > > > > > > > - Depth points: 0x6200
        > > > > > > > > > > - Height points: 0x6300
        > > > > > > > > > > - Land/depth contours: 0x20 to 0x25
        > > > > > > > > > >
        > > > > > > > > > > Today I had to import a mp file containing 0x6300
        > > > points
        > > > > > > having
        > > > > > > > > > > heights in feet and the conversion to meters
        failed.
        > > > > > > > > > >
        > > > > > > > > > > Thanks
        > > > > > > > > > >
        > > > > > > > > > > Jose
        > > > > > > > > > >
        > > > > > > > > > > --- In global_mapper@ <mailto:global_mapper%
        > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com, "Global Mapper Support"
        > > > > > > > > > > <global_mapper@> wrote:
        > > > > > > > > > > >
        > > > > > > > > > > > Jose,
        > > > > > > > > > > >
        > > > > > > > > > > > Thanks for the feedback. I have changed the MP
        > > > contour
        > > > > > > export
        > > > > > > > > to
        > > > > > > > > > > now just round to the nearest integer on export
        > > rather
        > > > > than
        > > > > > > > using
        > > > > > > > > > > decimal places. I have placed a new build with
        this
        > > > > change
        > > > > > at
        > > > > > > > > > > http://www.globalma <http://www.globalma
        > > > > > > > > > <http://www.globalma
        > > > > > > > <http://www.globalma
        > > > > > > <http://www.globalma
        > > > > > <http://www.globalma
        > > > <http://www.globalma
        > > <http://www.globalma
        > <http://www.globalma
        <http://www.globalmapper.com/global_mapper8.zip>
        > pper.com/global_mapper8.zip>
        > > pper.com/global_mapper8.zip>
        > > > pper.com/global_mapper8.zip>
        > > > > pper.com/global_mapper8.zip>
        > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > > > pper.com/global_mapper8.zip .
        > > > > > > > > > > >
        > > > > > > > > > > > Let me know if I can be of further assistance.
        > > > > > > > > > > >
        > > > > > > > > > > > Thanks,
        > > > > > > > > > > >
        > > > > > > > > > > > Mike
        > > > > > > > > > > > Global Mapper Support
        > > > > > > > > > > > support@
        > > > > > > > > > > >
        > > > > > > > > > > > ----- Original Message -----
        > > > > > > > > > > > From: Jose Getino
        > > > > > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com
        > > > > > > > > > > > Sent: Wednesday, December 13, 2006 2:25 AM
        > > > > > > > > > > > Subject: [global_mapper] Re: Elevation units in
        > MP
        > > > > export
        > > > > > > > > > > >
        > > > > > > > > > > >
        > > > > > > > > > > > Mike,
        > > > > > > > > > > >
        > > > > > > > > > > > I'm not sure is a good idea to include decimal
        > > places
        > > > > in
        > > > > > > > > contour
        > > > > > > > > > > > line labels. For the metric case, the most
        > detailed
        > > > > > contour
        > > > > > > > > lines
        > > > > > > > > > > I
        > > > > > > > > > > > ever seen are 5m contours. Maybe there exists
        > more
        > > > > > detalied
        > > > > > > > > maps,
        > > > > > > > > > > > but I guess there is no map using contours with
        > > > decimal
        > > > > > > > places.
        > > > > > > > > > > Now
        > > > > > > > > > > > after a double change meter->feet->meter, 120
        > > > contorus
        > > > > > > become
        > > > > > > > > > > > 120.091 contours. So I feel rounding contours
        > > labels
        > > > is
        > > > > > > good,
        > > > > > > > > but
        > > > > > > > > > > to
        > > > > > > > > > > > the nearest integer. Or maybe let the user to
        > > select
        > > > > the
        > > > > > > > > > > precision
        > > > > > > > > > > > of the z values.
        > > > > > > > > > > >
        > > > > > > > > > > > Thanks and sorry for the inconvenience
        > > > > > > > > > > >
        > > > > > > > > > > > Jose
        > > > > > > > > > > >
        > > > > > > > > > > > --- In global_mapper@ <mailto:global_mapper%
        > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com, "Global Mapper Support"
        > > > > > > > > > > > <global_mapper@> wrote:
        > > > > > > > > > > > >
        > > > > > > > > > > > > Jose,
        > > > > > > > > > > > >
        > > > > > > > > > > > > I have (hopefully) fixed the rounding issue
        and
        > > > also
        > > > > > made
        > > > > > > > the
        > > > > > > > > > > > metric elevation values write out decimal
        digits
        > of
        > > > > > > > precision.
        > > > > > > > > I
        > > > > > > > > > > > have placed a new build with these changes at
        > > > > > > > > > > > http://www.globalma
        > > > > > > > > > <http://www.globalma
        > > > > > > > > <http://www.globalma
        > > > > > > > <http://www.globalma
        > > > > > > <http://www.globalma
        > > > > > <http://www.globalma
        > > > <http://www.globalma
        > > <http://www.globalma
        > <http://www.globalma
        <http://www.globalmapper.com/global_mapper8.zip>
        > pper.com/global_mapper8.zip>
        > > pper.com/global_mapper8.zip>
        > > > pper.com/global_mapper8.zip>
        > > > > pper.com/global_mapper8.zip>
        > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > > > pper.com/global_mapper8.zip .
        > > > > > > > > > > > >
        > > > > > > > > > > > > Let me know if I can be of further assistance.
        > > > > > > > > > > > >
        > > > > > > > > > > > > Thanks,
        > > > > > > > > > > > >
        > > > > > > > > > > > > Mike
        > > > > > > > > > > > > Global Mapper Support
        > > > > > > > > > > > > support@
        > > > > > > > > > > > >
        > > > > > > > > > > > > ----- Original Message -----
        > > > > > > > > > > > > From: Jose Getino
        > > > > > > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com
        > > > > > > > > > > > > Sent: Tuesday, December 12, 2006 12:18 PM
        > > > > > > > > > > > > Subject: [global_mapper] Re: Elevation units
        in
        > > MP
        > > > > > export
        > > > > > > > > > > > >
        > > > > > > > > > > > >
        > > > > > > > > > > > > Mike,
        > > > > > > > > > > > >
        > > > > > > > > > > > > I tested the new buid with a metric dgn file,
        > > with
        > > > mp
        > > > > > > files
        > > > > > > > > and
        > > > > > > > > > > > used
        > > > > > > > > > > > > templates in meters and feet. Now Global
        Mapper
        > > > takes
        > > > > > > > > correctly
        > > > > > > > > > > > the
        > > > > > > > > > > > > elevation unit from the mp header, but I
        think
        > it
        > > > > could
        > > > > > > do
        > > > > > > > a
        > > > > > > > > > > > better
        > > > > > > > > > > > > job rounding floats.
        > > > > > > > > > > > >
        > > > > > > > > > > > > Here an example:
        > > > > > > > > > > > >
        > > > > > > > > > > > > I have a 120 m contour line. In feet this
        makes
        > > > > > 393.700,
        > > > > > > so
        > > > > > > > > the
        > > > > > > > > > > > > better aproach would be 394 feet, but Global
        > > Mapper
        > > > > > gives
        > > > > > > > 393
        > > > > > > > > > > > feet.
        > > > > > > > > > > > >
        > > > > > > > > > > > > When I try to recover te metric values from
        > this
        > > > > file,
        > > > > > > > Global
        > > > > > > > > > > > Mapper
        > > > > > > > > > > > > uses the 393 feet. But even 393 feet is not
        the
        > > not
        > > > a
        > > > > > > very
        > > > > > > > > good
        > > > > > > > > > > > > rounding, it has a chance to recover the
        > original
        > > > > > metric
        > > > > > > > > value,
        > > > > > > > > > > > as
        > > > > > > > > > > > > 393 feet= 119.786, so 120 m is the best
        > approach.
        > > > > With
        > > > > > > 394
        > > > > > > > > feet
        > > > > > > > > > > > it
        > > > > > > > > > > > > would give 120.091 meter, even better. But
        > Global
        > > > > > Mapper
        > > > > > > > set
        > > > > > > > > > > > > elevation = 119m.
        > > > > > > > > > > > >
        > > > > > > > > > > > > So the point is not to round to the floor
        > > integer,
        > > > > but
        > > > > > to
        > > > > > > > the
        > > > > > > > > > > > closer
        > > > > > > > > > > > > one.
        > > > > > > > > > > > >
        > > > > > > > > > > > > Thanks
        > > > > > > > > > > > >
        > > > > > > > > > > > > Jose
        > > > > > > > > > > > >
        > > > > > > > > > > > > --- In global_mapper@ <mailto:global_mapper%
        > > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com, "Global Mapper Support"
        > > > > > > > > > > > > <global_mapper@> wrote:
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > Hans,
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > Thanks for the additional information. I
        > think
        > > > that
        > > > > > > when
        > > > > > > > I
        > > > > > > > > > > > > initially did my test there probably were
        unit
        > > > labels
        > > > > > on
        > > > > > > > the
        > > > > > > > > > > > contour
        > > > > > > > > > > > > heights which is why it only worked when they
        > > were
        > > > > > > exported
        > > > > > > > > as
        > > > > > > > > > > > feet.
        > > > > > > > > > > > > I'm out of the office right now so I can't
        > fully
        > > > test
        > > > > > > this,
        > > > > > > > > but
        > > > > > > > > > > > I
        > > > > > > > > > > > > have changed the contour label export to use
        > the
        > > > > > > configured
        > > > > > > > > > > > export
        > > > > > > > > > > > > units and placed a new build at
        > > > > > > > > > > > > http://www.globalma
        > > > > > > > > > <http://www.globalma
        > > > > > > > > <http://www.globalma
        > > > > > > > <http://www.globalma
        > > > > > > <http://www.globalma
        > > > > > <http://www.globalma
        > > > <http://www.globalma
        > > <http://www.globalma
        > <http://www.globalma
        <http://www.globalmapper.com/global_mapper8.zip>
        > pper.com/global_mapper8.zip>
        > > pper.com/global_mapper8.zip>
        > > > pper.com/global_mapper8.zip>
        > > > > pper.com/global_mapper8.zip>
        > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > > pper.com/global_mapper8.zip>
        > > > > > > > > > > pper.com/global_mapper8.zip for you and Jose
        > > > > > > > > > > > to
        > > > > > > > > > > > > try it. Simply download that file and extract
        > the
        > > > > > > contents
        > > > > > > > > over
        > > > > > > > > > > > your
        > > > > > > > > > > > > existing v8 installation to give it a try.
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > Let me know if I can be of further
        assistance.
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > Thanks,
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > Mike
        > > > > > > > > > > > > > Global Mapper Support
        > > > > > > > > > > > > > support@
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > ----- Original Message -----
        > > > > > > > > > > > > > From: Scheffler, Hans <hscheff@>
        > > > > > > > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com
        > > > > > > > > > > > > > Sent: Tuesday, December 12, 2006 1:42 AM
        > > > > > > > > > > > > > Subject: RE: [global_mapper] Re: Elevation
        > > units
        > > > in
        > > > > > MP
        > > > > > > > > export
        > > > > > > > > > > > > >
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > Mike
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > cgpsmapper does translate the contour line
        > > labels
        > > > > > > > according
        > > > > > > > > > > to
        > > > > > > > > > > > > the unit
        > > > > > > > > > > > > > setting.
        > > > > > > > > > > > > > (and has been doing this since I started
        > using
        > > it
        > > > > in
        > > > > > > > 2003).
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > However cgpsmapper does not translate the
        > > > elevation
        > > > > > > > labels
        > > > > > > > > if
        > > > > > > > > > > > > they are
        > > > > > > > > > > > > > not numerical.
        > > > > > > > > > > > > > IIRC global mapper initially added a unit
        > > suffix
        > > > > (m /
        > > > > > > ft)
        > > > > > > > > to
        > > > > > > > > > > > > contour
        > > > > > > > > > > > > > line labels which will cause contour line
        > > labels
        > > > > not
        > > > > > to
        > > > > > > > be
        > > > > > > > > > > > > converted. I
        > > > > > > > > > > > > > think this has been corrected since.
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > Hans
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > > -----Original Message-----
        > > > > > > > > > > > > > > From: global_mapper@
        <mailto:global_mapper%
        > > > > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com
        > > > > > > > > > > > > > > [mailto:global_mapper@
        > <mailto:global_mapper%
        > > > > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com] On Behalf Of Global
        > > > > > > > > > > > > > > Mapper Support
        > > > > > > > > > > > > > > Sent: 12 December 2006 09:04
        > > > > > > > > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > > > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com
        > > > > > > > > > > > > > > Subject: Re: [global_mapper] Re:
        Elevation
        > > > units
        > > > > in
        > > > > > > MP
        > > > > > > > > > > export
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Jose,
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > This isn't a Global Mapper issue, the
        > problem
        > > > is
        > > > > > that
        > > > > > > > > > > > > > > cGPSMapper doesn't do any kind of unit
        > > > > translation
        > > > > > on
        > > > > > > > > > > > contour
        > > > > > > > > > > > > > > line labels based on the elevation units
        > > > setting
        > > > > > (or
        > > > > > > at
        > > > > > > > > > > > least
        > > > > > > > > > > > > > > the original version that I was testing
        > with
        > > > did
        > > > > > > not).
        > > > > > > > In
        > > > > > > > > > > > the
        > > > > > > > > > > > > > > final Garmin maps the contour line label
        is
        > > > > assumed
        > > > > > > to
        > > > > > > > be
        > > > > > > > > > > > the
        > > > > > > > > > > > > > > elevation of the contour line in feet and
        > the
        > > > > > Garmin
        > > > > > > > > units
        > > > > > > > > > > > > > > automatically convert the units to meters
        > or
        > > > feet
        > > > > > for
        > > > > > > > > > > > display
        > > > > > > > > > > > > > > depending on the user's unit setting.
        Since
        > > > > > > cGPSMapper
        > > > > > > > > just
        > > > > > > > > > > > > > > passes the labels through to the final
        > Garmin
        > > > > map,
        > > > > > > > which
        > > > > > > > > > > > > > > defines the units as feet, Global Mapper
        > has
        > > to
        > > > > > > always
        > > > > > > > > > > write
        > > > > > > > > > > > > > > those units out as feet so that the
        correct
        > > > units
        > > > > > > will
        > > > > > > > > make
        > > > > > > > > > > > > > > it to the final Garmin .img file.
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Let me know if I can be of further
        > assistance.
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Thanks,
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Mike
        > > > > > > > > > > > > > > Global Mapper Support
        > > > > > > > > > > > > > > support@
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > ----- Original Message -----
        > > > > > > > > > > > > > > From: Jose Getino
        > > > > > > > > > > > > > > To: global_mapper@ <mailto:global_mapper%
        > > > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com
        > > > > > > > > > > > > > > Sent: Tuesday, December 12, 2006 12:46 AM
        > > > > > > > > > > > > > > Subject: [global_mapper] Re: Elevation
        > units
        > > in
        > > > > MP
        > > > > > > > export
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Mike,
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Regarding the elevation units setting, I
        > > think
        > > > it
        > > > > > > > should
        > > > > > > > > > > > > affect the
        > > > > > > > > > > > > > > labels of the contours as well. In fact
        > they
        > > > are
        > > > > > not
        > > > > > > > > > > > > conceptually
        > > > > > > > > > > > > > > different from the elevation values
        > > associated
        > > > to
        > > > > > the
        > > > > > > > > other
        > > > > > > > > > > > > feature
        > > > > > > > > > > > > > > types.
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > This is a uncommon particularity of the
        MP
        > > > > format:
        > > > > > it
        > > > > > > > > uses
        > > > > > > > > > > > > > > labels to
        > > > > > > > > > > > > > > specify heights. And these labels can
        > > represent
        > > > > > > either
        > > > > > > > > feet
        > > > > > > > > > > > or
        > > > > > > > > > > > > > > meters, depending on the setting of the
        > > header
        > > > > line:
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > "Elevation=X"
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > So, let assume your MP template is set to
        > > > meters:
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > - If you load vector data with elevations
        > in
        > > > > > meters,
        > > > > > > > the
        > > > > > > > > > > > > elevation
        > > > > > > > > > > > > > > values in the mp exported file should
        keep
        > > > > > unchanged
        > > > > > > > (my
        > > > > > > > > > > dgn
        > > > > > > > > > > > > import
        > > > > > > > > > > > > > > case)
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > - If you load vector data with elevations
        > in
        > > > > feet,
        > > > > > > the
        > > > > > > > > > > > > elevation
        > > > > > > > > > > > > > > values in the mp exported file should be
        > > > > converted
        > > > > > > from
        > > > > > > > > > > feet
        > > > > > > > > > > > > to
        > > > > > > > > > > > > > > meters.
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > But Global Mapper is doing just the
        > contrary:
        > > > it
        > > > > > > > changes
        > > > > > > > > > > the
        > > > > > > > > > > > > units
        > > > > > > > > > > > > > > in the first case and keeps them in the
        > > second.
        > > > > > This
        > > > > > > is
        > > > > > > > a
        > > > > > > > > > > > odd
        > > > > > > > > > > > > > > behavoir and I can't find a way to
        overcome
        > > it.
        > > > > In
        > > > > > > > > > > > particular
        > > > > > > > > > > > > I
        > > > > > > > > > > > > > > don't divise a way to import the dgn
        files
        > > > > keeping
        > > > > > > the
        > > > > > > > > > > > > original
        > > > > > > > > > > > > > > values in meters in the labels of the mp
        > > file.
        > > > I
        > > > > > > > realized
        > > > > > > > > > > it
        > > > > > > > > > > > > after
        > > > > > > > > > > > > > > importing a huge mp file of 2Gb,
        containing
        > > 5m
        > > > > > > > contours.
        > > > > > > > > > > > > Global
        > > > > > > > > > > > > > > Mapper converted all my labels to feet
        and
        > I
        > > > > don't
        > > > > > > know
        > > > > > > > > how
        > > > > > > > > > > > to
        > > > > > > > > > > > > > > recover the original metric values.
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Thanks
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Jose
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > --- In global_mapper@
        <mailto:global_mapper%
        > > > > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com, "Global Mapper
        > > > > > > > > > > > Support"
        > > > > > > > > > > > > > > <global_mapper@> wrote:
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > Jose,
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > Regardless of what elevation units are
        > > > > specified
        > > > > > in
        > > > > > > > MP
        > > > > > > > > > > > > > > headers the
        > > > > > > > > > > > > > > labels for contour line features always
        use
        > > > feet.
        > > > > > The
        > > > > > > > > > > > > elevation
        > > > > > > > > > > > > > > units setting only affects elevation
        values
        > > > > stored
        > > > > > > with
        > > > > > > > > > > > other
        > > > > > > > > > > > > > > feature types.
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > Let me know if I can be of further
        > > assistance.
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > Thanks,
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > Mike
        > > > > > > > > > > > > > > > Global Mapper Support
        > > > > > > > > > > > > > > > support@
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > ----- Original Message -----
        > > > > > > > > > > > > > > > From: Jose Getino
        > > > > > > > > > > > > > > > To: global_mapper@
        <mailto:global_mapper%
        > > > > > > > > > 40yahoogroups.com>
        > > > > > > > > > > yahoogroups.com
        > > > > > > > > > > > > > > > Sent: Monday, December 11, 2006 5:29 PM
        > > > > > > > > > > > > > > > Subject: [global_mapper] Elevation
        units
        > in
        > > > MP
        > > > > > > export
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > Hi Mike,
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > I have a copule of doubts about how
        > > elevation
        > > > > > units
        > > > > > > > > works
        > > > > > > > > > > > in
        > > > > > > > > > > > > > > Global
        > > > > > > > > > > > > > > > Mapper:
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > 1. I have a dgn file containing contour
        > > > lines,
        > > > > > > > > elevation
        > > > > > > > > > > > is
        > > > > > > > > > > > > > > given in
        > > > > > > > > > > > > > > > meters. I load this file, set line
        types
        > to
        > > > > > > contours,
        > > > > > > > > and
        > > > > > > > > > > > > export
        > > > > > > > > > > > > > > to
        > > > > > > > > > > > > > > > MP using a template with Elevation set
        > > > to "M".
        > > > > > The
        > > > > > > > > > > > > elevations in
        > > > > > > > > > > > > > > the
        > > > > > > > > > > > > > > > resulting mp file (label fields) are
        > > > converted
        > > > > to
        > > > > > > > feet.
        > > > > > > > > > > > How
        > > > > > > > > > > > > can
        > > > > > > > > > > > > > > I
        > > > > > > > > > > > > > > > preserve the original elevation values
        on
        > > the
        > > > > dgn
        > > > > > > > > file?.
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > 2. I load a MP file having Elevation
        set
        > > > > to "F".
        > > > > > I
        > > > > > > > > export
        > > > > > > > > > > > > this
        > > > > > > > > > > > > > > file
        > > > > > > > > > > > > > > > using a template with Elevation set
        > to "M".
        > > > The
        > > > > > > > > > > elevations
        > > > > > > > > > > > > > > values of
        > > > > > > > > > > > > > > > the exported file are identical to the
        > ones
        > > > in
        > > > > > the
        > > > > > > > > input
        > > > > > > > > > > > > file.
        > > > > > > > > > > > > > > Why
        > > > > > > > > > > > > > > > Global Mapper don't convert feet to
        > meters
        > > in
        > > > > > this
        > > > > > > > > case?
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > Thanks
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > Jose
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > > [Non-text portions of this message have
        > > been
        > > > > > > removed]
        > > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > [Non-text portions of this message have
        > been
        > > > > > removed]
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > > Yahoo! Groups Links
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > > >
        > > > > > > > > > > > > >
        > > > > > > > > > > > > >
        > > > > > > > > > > > > >
        > > > > > > > > > > > > >
        > > > > > > > > > > > > > [Non-text portions of this message have
        been
        > > > > removed]
        > > > > > > > > > > > > >
        > > > > > > > > > > > >
        > > > > > > > > > > > >
        > > > > > > > > > > > >
        > > > > > > > > > > > >
        > > > > > > > > > > > >
        > > > > > > > > > > > > [Non-text portions of this message have been
        > > > removed]
        > > > > > > > > > > > >
        > > > > > > > > > > >
        > > > > > > > > > > >
        > > > > > > > > > > >
        > > > > > > > > > > >
        > > > > > > > > > > >
        > > > > > > > > > > > [Non-text portions of this message have been
        > > removed]
        > > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > >
        > > > > > > > > > > [Non-text portions of this message have been
        > removed]
        > > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > >
        > > > > > > > > > [Non-text portions of this message have been
        removed]
        > > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > >
        > > > > > > > > [Non-text portions of this message have been removed]
        > > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > >
        > > > > > > > [Non-text portions of this message have been removed]
        > > > > > > >
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > >
        > > > > > > [Non-text portions of this message have been removed]
        > > > > > >
        > > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > > [Non-text portions of this message have been removed]
        > > > >
        > > >
        > > >
        > > >
        > > >
        > > >
        > > > [Non-text portions of this message have been removed]
        > > >
        > >
        > >
        > >
        > >
        > >
        > > [Non-text portions of this message have been removed]
        > >
        >
        >
        >
        >
        >
        > [Non-text portions of this message have been removed]
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.