Loading ...
Sorry, an error occurred while loading the content.

RE: [global_mapper] Problems using jp2 files

Expand Messages
  • Global Mapper Support
    Mark, I guess this means that ArcGIS does not yet handle JPEG2000 files with an alpha channel. Thanks, Mike Global Mapper Support support@globalmapper.com
    Message 1 of 6 , Mar 11, 2010
    View Source
    • 0 Attachment
      Mark,



      I guess this means that ArcGIS does not yet handle JPEG2000 files with an
      alpha channel.



      Thanks,



      Mike

      Global Mapper Support

      support@...



      From: global_mapper@yahoogroups.com [mailto:global_mapper@yahoogroups.com]
      On Behalf Of Young, James M (Mark)
      Sent: Thursday, March 11, 2010 1:33 PM
      To: global_mapper@yahoogroups.com
      Subject: RE: [global_mapper] Problems using jp2 files





      Mike,

      I was indeed checking the "make background pixels transparent" option.
      I ran another "test", this time without it checked and it worked just
      fine! Like you said, there were three bands and not four in this
      result. Thanks for all your help!

      Mark

      From: global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>

      [mailto:global_mapper@yahoogroups.com
      <mailto:global_mapper%40yahoogroups.com> ] On Behalf Of Global Mapper
      Support
      Sent: Thursday, March 11, 2010 3:20 PM
      To: global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>
      Subject: RE: [global_mapper] Problems using jp2 files

      Mark,

      Are you checking the option to make background pixels transparent when
      you
      export the file? If not I would expect just a 3-band (RGB) result. If
      the
      option is checked then you should get a 4-band (RGBA) result. The same
      thing
      applies for ECW exports.

      Thanks,

      Mike

      Global Mapper Support

      support@... <mailto:support%40globalmapper.com>
      <mailto:support%40globalmapper.com>

      From: global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>

      <mailto:global_mapper%40yahoogroups.com>
      [mailto:global_mapper@yahoogroups.com
      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com> ]
      On Behalf Of Young, James M (Mark)
      Sent: Thursday, March 11, 2010 12:32 PM
      To: global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      Subject: RE: [global_mapper] Problems using jp2 files

      Mike,

      I'm using UTM / Zone 16 / NAD 1983, which is the projection that the
      original NRCS data is stored in. I tried a different projection and get
      the same results. The error message I get back says "Invalid Raster
      Dataset. Failed to create raster layer." I noticed that there is not
      the four "Bands" that show up on most jp2 files - e.g. such as the
      original unclipped NRCS layer. ArcCatalog can "see" the layer in the
      contents section , but cannot preview the layer or look at any metadata
      for it. I tried the ECW export and that works just fine. It also
      created four bands, which is similar to what I see in the original NRCS
      data.

      I appreciate your help with this...

      Mark

      From: global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>

      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>

      [mailto:global_mapper@yahoogroups.com
      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com> ] On Behalf Of Global Mapper
      Support
      Sent: Thursday, March 11, 2010 9:22 AM
      To: global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      Subject: RE: [global_mapper] Problems using jp2 files

      Mark,

      I'm not aware of any issues with using the JP2 files in ArcGIS, nor are
      there any special settings that you should be using. What is the error
      message that you are getting? What projection/datum are you using when
      exporting? I'm just wondering if perhaps you are using a
      projection/datum
      that ArcGIS doesn't recognize or something. Also, can you try an ECW
      export
      and see if that works?

      Thanks,

      Mike

      Global Mapper Support

      support@... <mailto:support%40globalmapper.com>
      <mailto:support%40globalmapper.com>
      <mailto:support%40globalmapper.com>
      <mailto:support%40globalmapper.com>

      From: global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>

      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>

      <mailto:global_mapper%40yahoogroups.com> [mailto:
      global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com> ]
      On Behalf Of Young, James M (Mark)
      Sent: Thursday, March 11, 2010 7:13 AM
      To: global_mapper@yahoogroups.com <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      <mailto:global_mapper%40yahoogroups.com>
      Subject: [global_mapper] Problems using jp2 files

      Mike,

      I'm having problems using jpg2000 format files that I create in Global
      Mapper in ESRI's ArcGIS program. I am reading in NAIP 2008 imagery from
      NRCS into Global Mapper version 11.02 and then using a county boundary
      to clip the imagery to a given county. I'm trying to export the raster
      file in jp2 format and then read it into ESRI's ArcGIS, but for some
      reason I keep getting an error. The program reads the original NRCS
      imagery files just fine. Is there a special setting I should use when I
      export from Global Mapper to create a file that will open in ArcGIS?

      Thank you,

      Mark Young

      [Non-text portions of this message have been removed]

      [Non-text portions of this message have been removed]

      [Non-text portions of this message have been removed]

      [Non-text portions of this message have been removed]

      [Non-text portions of this message have been removed]





      [Non-text portions of this message have been removed]
    Your message has been successfully submitted and would be delivered to recipients shortly.