Loading ...
Sorry, an error occurred while loading the content.
 

Re: project vm parameters

Expand Messages
  • jdurnfor@telus.net
    Yeah, I think it would work but it s a bit of hack way to do it. I only have two JDK s I use and two projects I need this for so it wouldn t too much work to
    Message 1 of 3 , Jun 24, 2004
      Yeah, I think it would work but it's a bit of hack way to do it.
      I only have two JDK's I use and two projects I need this for so it
      wouldn't too much work to create the profiles. I was hoping there was
      some (prehaps hidden) way to do this better or maybe I could request
      a new feature. :)

      Thanks for the idea, I'll let you know if it works.


      --- In gelide@yahoogroups.com, "ianshef" <ishef@e...> wrote:
      > --- In gelide@yahoogroups.com, jdurnfor@t... wrote:
      > > How do I specifify project specific VM parameters?
      > >
      > > Currently the two ways I can see are:
      > > 1) to set JDK VM parameters in
      > > tools->options->jdk->launcher->VM Args
      > >
      > > 2) in project->properties->run->class
      > > I can prepend the classname with VM args but I select the class I
      > > want to run from the project maanger list and would have to rest
      > this
      > > everytime I change classes.
      > >
      > > tia
      > >
      > > jim
      >
      > One way would be to set up (under Tools| Options... | JDK) multiple
      > JDK's that differ only in their name (the unnamed dropdown at the
      top
      > of the dialog box) and in their Launcher | VM Arguments definition.
      > [If you have many of these, it may be easier to shut down Gel and
      > hand edit Gel's Options.xml file. Save a backup copy first!
      Attempt
      > this at your own risk!]
      >
      > Then, under Project | Properties... | Main, you can use the JDK
      > dropdown box to chossed the JDK (defined earlier) with the VM
      > arguments that you want.
      >
      > Caveat: It seems like this should work, but I haven't actually
      > attempted it.
      >
      > Good Luck!
    Your message has been successfully submitted and would be delivered to recipients shortly.