Loading ...
Sorry, an error occurred while loading the content.

2388Re: Debugger with jdk 1.3.1_07

Expand Messages
  • omertasoft
    Oct 1, 2003
    • 0 Attachment
      Yes i compile with debug info, the debugger hits the break point and
      in the debug window i can see at which line the debugger is. But the
      cursor in the editor stays at the breakpoint. It's not the colors,
      the cursor is stuck in the breakpoint line...

      I don't know if it can't parse the debug output so here is the debug
      output "Step completed: thread="Thread-3", RDVEngine.getRDVHandler(),
      line=53, bci=148"

      so the cursor should move to line 53, the breakpoint is at line 49
      and the cursor is there as well.

      Murat,

      --- In gelide@yahoogroups.com, "Gerald Nunn" <gnunn@g...> wrote:
      > - Are you compiling your files with debug info?
      > - Make sure the highlight line color is not the same as the
      background in editor options
      >
      > Gerald
      >
      > > ------------Original Message-------------
      > > From: "omertasoft" <yesildal@f...>
      > > To: gelide@yahoogroups.com
      > > Date: Wed, Oct-1-2003 1:53 PM
      > > Subject: [gelide] Re: Debugger with jdk 1.3.1_07
      > >
      > > Hi,
      > >
      > > I checked it out, its not the problem. The problem is that
      > > the editor doesn't highlight the line that the Debugger is
      executing.
      > > It's NOT highlighting another line. It's just not highlighting
      ANY
      > > line at all!!!
      > >
      > > Gerald any suggestions ? ??
      > >
      > > thanks,
      > >
      > > --- In gelide@yahoogroups.com, "Patricio Daniel Patrickson"
      > > <ppatrickson@y...> wrote:
      > > > Hi!
      > > >
      > > > Ive had the same problem but with other ide:s. The thing was
      that
      > > > the program that was running where using classes from
      another
      > > > location than the one i thought it was using. So, the actual
      > > > classes that where being run where results of previous
      > > > compilations, so therefore had other line number information
      in
      > > > them.
      > > >
      > > > Check your classpath.
      > > >
      > > > regards
      > > > /ppatrickson
      > > >
      > > > --- In gelide@yahoogroups.com, "omertasoft" <yesildal@f...>
      wrote:
      > > > > Hi,
      > > > >
      > > > > I am using jdk 1.3.1_07, and GEL 1.0.0.0 RC33b. In the
      debugger,
      > > > > after it hits the breakpoint, when you further execute line
      by
      > > > line,
      > > > > the cursor doesn't go to the line the debugger is executing,
      I
      > > read
      > > > > that some people managed to have it running and some did not.
      Is
      > > it
      > > > > my JDK version, or any settings I need to change?
      > > > >
      > > > > any help is greatly appreciated.
      > > > >
      > > > > Vito,
      > >
      > >
      > >
      > > To unsubscribe from this group, send an email to:
      > > gelide-unsubscribe@yahoogroups.com
      > >
      > >
      > >
      > > Your use of Yahoo! Groups is subject to
      http://docs.yahoo.com/info/terms/
      > >
      > >
      > >
      > >
    • Show all 5 messages in this topic