Loading ...
Sorry, an error occurred while loading the content.

myFusebox.getMySelf() and mappings

Expand Messages
  • M
    Hi, Using Fusebox5 on Tomcat. myFusebox.getMySelf() is currently returning: /railo/www/fuseboxApp/webroot/index.cfm/go: - this is where my code sits. I want it
    Message 1 of 5 , Mar 9, 2013
    • 0 Attachment
      Hi,

      Using Fusebox5 on Tomcat.

      myFusebox.getMySelf() is currently returning:

      /railo/www/fuseboxApp/webroot/index.cfm/go:
      - this is where my code sits.

      I want it to return:
      /fuseboxApp/webroot/index.cfm/go:
      - my web root

      It's messing up my <relocate xfa=""> commands.

      Is this a reasonable thing to want to do? Is there a default setting somewhere I can change?

      thanks
    • John Blayter
      What version of ColdFusion are you running? Is this on Linux, Mac or Windows? John Blayter Land line: 303.731.3009 Mobile: 303.325.1979
      Message 2 of 5 , Mar 9, 2013
      • 0 Attachment
        What version of ColdFusion are you running? Is this on Linux, Mac or Windows?

        John Blayter
        Land line: 303.731.3009
        Mobile: 303.325.1979
        http://www.blayter.com/john/

        Denver ColdFusion User Group Manager
        http://denvercfug.org/


        On Sat, Mar 9, 2013 at 5:21 AM, M <michael@...> wrote:
         

        Hi,

        Using Fusebox5 on Tomcat.

        myFusebox.getMySelf() is currently returning:

        /railo/www/fuseboxApp/webroot/index.cfm/go:
        - this is where my code sits.

        I want it to return:
        /fuseboxApp/webroot/index.cfm/go:
        - my web root

        It's messing up my <relocate xfa=""> commands.

        Is this a reasonable thing to want to do? Is there a default setting somewhere I can change?

        thanks


      • Kai Koenig
        You can try to set in fusebox.xml. Cheers Kai
        Message 3 of 5 , Mar 9, 2013
        • 0 Attachment
          You can try to set

          <parameter name="self" value="your_value" />

          in fusebox.xml.

          Cheers
          Kai


          >
          > What version of ColdFusion are you running? Is this on Linux, Mac or Windows?
          >
          > John Blayter
          > Land line: 303.731.3009
          > Mobile: 303.325.1979
          > http://www.blayter.com/john/
          >
          > Denver ColdFusion User Group Manager
          > http://denvercfug.org/
          >
          >
          > On Sat, Mar 9, 2013 at 5:21 AM, M <michael@...> wrote:
          >
          > Hi,
          >
          > Using Fusebox5 on Tomcat.
          >
          > myFusebox.getMySelf() is currently returning:
          >
          > /railo/www/fuseboxApp/webroot/index.cfm/go:
          > - this is where my code sits.
          >
          > I want it to return:
          > /fuseboxApp/webroot/index.cfm/go:
          > - my web root
          >
          > It's messing up my <relocate xfa=""> commands.
          >
          > Is this a reasonable thing to want to do? Is there a default setting somewhere I can change?
          >
          > thanks
          >
        • M
          Thanks for the replies, I have a Ubuntu server running both Railo and OpenBlueDragon under Tomcat, hence the non-standard mappings. Setting the self
          Message 4 of 5 , Mar 10, 2013
          • 0 Attachment
            Thanks for the replies, I have a Ubuntu server running both Railo and OpenBlueDragon under Tomcat, hence the non-standard mappings.

            Setting the "self" parameter fixed things.

            --- In fusebox5@yahoogroups.com, Kai Koenig <grmblzmpf@...> wrote:
            >
            > You can try to set
            >
            > <parameter name="self" value="your_value" />
            >
            > in fusebox.xml.
            >
            > Cheers
            > Kai
            >
            >
            > >
            > > What version of ColdFusion are you running? Is this on Linux, Mac or Windows?
            > >
            > > John Blayter
            > > Land line: 303.731.3009
            > > Mobile: 303.325.1979
            > > http://www.blayter.com/john/
            > >
            > > Denver ColdFusion User Group Manager
            > > http://denvercfug.org/
            > >
            > >
            > > On Sat, Mar 9, 2013 at 5:21 AM, M <michael@...> wrote:
            > >
            > > Hi,
            > >
            > > Using Fusebox5 on Tomcat.
            > >
            > > myFusebox.getMySelf() is currently returning:
            > >
            > > /railo/www/fuseboxApp/webroot/index.cfm/go:
            > > - this is where my code sits.
            > >
            > > I want it to return:
            > > /fuseboxApp/webroot/index.cfm/go:
            > > - my web root
            > >
            > > It's messing up my <relocate xfa=""> commands.
            > >
            > > Is this a reasonable thing to want to do? Is there a default setting somewhere I can change?
            > >
            > > thanks
            > >
            >
          • Sandra Clark
            I ve always set it in fusebox.init.cfm Usually I have: But you can always set it
            Message 5 of 5 , Mar 13, 2013
            • 0 Attachment

              I’ve always set it in fusebox.init.cfm

               

              Usually I have:

              <cfset self = myFusebox.getSelf() />

              <cfset myself = myFusebox.getMyself() />

               

              But you can always set it to what you need here.  (I’ve had a few places where I’ve had to change it based on domain)

               

              Sandra Clark

               

              From: fusebox5@yahoogroups.com [mailto:fusebox5@yahoogroups.com] On Behalf Of M
              Sent: Saturday, March 9, 2013 7:21 AM
              To: fusebox5@yahoogroups.com
              Subject: [fusebox5] myFusebox.getMySelf() and mappings

               

               

              Hi,

              Using Fusebox5 on Tomcat.

              myFusebox.getMySelf() is currently returning:

              /railo/www/fuseboxApp/webroot/index.cfm/go:
              - this is where my code sits.

              I want it to return:
              /fuseboxApp/webroot/index.cfm/go:
              - my web root

              It's messing up my <relocate xfa=""> commands.

              Is this a reasonable thing to want to do? Is there a default setting somewhere I can change?

              thanks

            Your message has been successfully submitted and would be delivered to recipients shortly.