Loading ...
Sorry, an error occurred while loading the content.

Re: [fusebox5] Weird Loading Error - FB5.5 noxml

Expand Messages
  • Adam Haskell
    No there is not need for a mapping but if they are different Fusebox might calculate the path incorrectly. I think the relevant code is in
    Message 1 of 4 , Apr 29, 2009
    • 0 Attachment
      No there is not need for a mapping but if they are different Fusebox might calculate the path incorrectly.

      I think the relevant code is in fuseboxApplication.cfc. If I recall I checked in the code for Fusebox 5.6 and part of that was I broke out the pathing logic in a FilePath.cfc, it might be easier to play with in it's own object. I'll see if I can find the relevent code peice later, I'll also check in my testcases (which I think I've failed to make publically available). I need to beefup the test cases still but at least FB has test cases now :-D


      Adam


      On Wed, Apr 29, 2009 at 10:23 AM, Seth Johnson <sjohnson@...> wrote:


      My sentiments exactly, it’s a shared host and I don't have direct control of the server.  Should mapping be required?  It should run right out of the box, shouldn't it?


      Thanks for your response,

       

      Seth

       

      From: fusebox5@yahoogroups.com [mailto:fusebox5@yahoogroups.com] On Behalf Of Adam Haskell
      Sent: Wednesday, April 29, 2009 10:07 AM
      To: fusebox5@yahoogroups.com
      Subject: Re: [fusebox5] Weird Loading Error - FB5.5 noxml

       




      First thoughts would be the physical paths are different to the app folder, or the mappings in the CFML engine admin are different.

      Adam

      On Wed, Apr 29, 2009 at 10:01 AM, Seth Johnson <sjohnson@...> wrote:

       

      Two sites, different servers, same set up (FB55.5+MVC+noxml):

       

      Server 1 home.main.cfm (line 9):

      <cfparam name="__fuseboxCircuitCfc_controller_home" default="#createObject('component','controller.home')#" />

       

      Server 2  home.main.cfm (line 9):

      <cfparam name="__fuseboxCircuitCfc_myrootfolder_controller_home" default="#createObject('component','myrootfolder.controller.home')#" />

       

      Server 2 has an error on load:

      Could not find the ColdFusion Component or Interface myrootfolder.controller.home. 

       

      Any ideas what could cause this?

       

      Thanks,

       

      Seth

       


    Your message has been successfully submitted and would be delivered to recipients shortly.