Loading ...
Sorry, an error occurred while loading the content.

Twisted thought: Frontier on iPhone?

Expand Messages
  • David Gewirtz
    OK, I admit it s twisted. I haven t even owned a Mac since 1994 and my phone is a very cranky Treo 700p. But since the iPhone is supposed to run something like
    Message 1 of 5 , Jun 10, 2008
    • 0 Attachment
      OK, I admit it's twisted. I haven't even owned a Mac since 1994 and my
      phone is a very cranky Treo 700p. But since the iPhone is supposed to
      run something like Mac OSX and Frontier is supposed to run on Mac
      OSX... well, ya know.

      It's just a thought.

      -- David
    • Henri Asseily
      ... Can t. PAIGE scourge first problem. No source, need recompile ARM PPC. Second, need split UI-cli. Make cli simple C (and fix slooow array behavior). Then
      Message 2 of 5 , Jun 10, 2008
      • 0 Attachment
        On Jun 10, 2008, at 11:52 AM, David Gewirtz wrote:

        > OK, I admit it's twisted. I haven't even owned a Mac since 1994 and my
        > phone is a very cranky Treo 700p. But since the iPhone is supposed to
        > run something like Mac OSX and Frontier is supposed to run on Mac
        > OSX... well, ya know.
        >

        Can't. PAIGE scourge first problem. No source, need recompile ARM PPC.
        Second, need split UI-cli. Make cli simple C (and fix slooow array
        behavior). Then redo UI in cocoa.

        Easier to create from scratch usertalk interpreter with sqlite backend
        + cocoa IDE.
      • Seth
        ... I m not sure about the sqlite backend, but basically I agree with Henri. We we can t even get Frontier working correctly on our desktops and servers, let s
        Message 3 of 5 , Jun 10, 2008
        • 0 Attachment
          On 6/10/2008, Henri Asseily said:

          >On Jun 10, 2008, at 11:52 AM, David Gewirtz wrote:
          >
          >> OK, I admit it's twisted. I haven't even owned a Mac since 1994 and my
          >> phone is a very cranky Treo 700p. But since the iPhone is supposed to
          >> run something like Mac OSX and Frontier is supposed to run on Mac
          >> OSX... well, ya know.
          >>
          >
          >Can't. PAIGE scourge first problem. No source, need recompile ARM PPC.
          >Second, need split UI-cli. Make cli simple C (and fix slooow
          >array behavior). Then redo UI in cocoa.
          >
          >Easier to create from scratch usertalk interpreter with sqlite
          >backend + cocoa IDE.

          I'm not sure about the sqlite backend, but basically I agree
          with Henri. We we can't even get Frontier working correctly on
          our desktops and servers, let's not worry about rewriting it to
          run on our phones. :-)
        • russellgum
          I agree with Henri and Seth. It seems that problems like I just had with the frontier root that were corrected after a save and reinstall of the root are
          Message 4 of 5 , Jun 10, 2008
          • 0 Attachment
            I agree with Henri and Seth. It seems that problems like I just had with the frontier root that
            were corrected after a save and reinstall of the root are symptoms of problems deep inside of
            Frontier. My question is what it would take to create from scratch usertalk interpreter with
            sqlite backend + cocoa IDE. Mac Ruby seems to be an attempt to integrate ruby with cocoa
            would it be possible to do the same with Frontier? Is it practical?

            Russ


            > >
            > >Easier to create from scratch usertalk interpreter with sqlite
            > >backend + cocoa IDE.
            >
            > I'm not sure about the sqlite backend, but basically I agree
            > with Henri. We we can't even get Frontier working correctly on
            > our desktops and servers, let's not worry about rewriting it to
            > run on our phones. :-)
            >
          • Steve Hooker
            I need to try the MySQL Verbs. But, I think I need v10.1a15. While the latest app only is v10.1a11. Where can I get a15? Steve Hooker
            Message 5 of 5 , Nov 6, 2008
            • 0 Attachment
              I need to try the MySQL Verbs. But, I think I need v10.1a15. While the
              latest app only is v10.1a11.

              Where can I get a15?

              Steve Hooker
            Your message has been successfully submitted and would be delivered to recipients shortly.