Loading ...
Sorry, an error occurred while loading the content.

4213Re: [frontierkernel] Re: a fix for the multi-core bug in the windows build

Expand Messages
  • Ted Howard
    Apr 12, 2012
    • 0 Attachment
      I'm responsible for those changes. I'll have to open up the code and take a look, but my changes were Mac specific, so I probably goofed on the #ifdef MACVERSION stuff.


      On Apr 12, 2012, at 11:17 AM, u074036 wrote:


      This morning I compiled your code into my version of Frontier (not OPML). It seems to work as designed.

      I did note a couple of issues with what is currently in SVN. My procedure was:

      Sync my folder fully with SVN
      Copy folder build_VC2K5 to build_VC2K10
      open build_VC2K10\Frontier.vcproj using Visual Studio 10
      Allow VS to convert the project
      Select the "Frontier_Release" solution configuration
      Build Solution

      I noted a pair of lines in error in icon.c. I then replaced icon.c with an older version dated 3/1/2011 and recompiled. This file compiled OK, but then there was an unresolved symbol in opicons.c. I replaced that file also with an older version (this one dated 4/20/2006) and recompiled. Now all was fine, so I proceeded to insert the multi-core bug code.

      The pair of files I have issue with were created 11/1/2011 by tedchoward, apparently to insert "loadicondatafromodb". Any chance the author could please have a look and give me a clue what to do with these lines? Thanks!

    • Show all 19 messages in this topic