Loading ...
Sorry, an error occurred while loading the content.

Re: [forms-dev] Re: Custom input validation - error messages - ErrorMessagePrefix showing twice

Expand Messages
  • Manuel Lemos
    Hello, ... Ok, I fixed the bug. You find the fixed version here. Thank you for reporting.
    Message 1 of 5 , Feb 11, 2008
    • 0 Attachment
      Hello,

      on 02/10/2008 10:28 PM fen.strat said the following:
      > If you submit the form with no input values, you'll notice that the
      > first error displayed is missing the ErrorMessagePrefix.
      >
      > If the first field to validate is NOT a custom field (i.e. uncomment
      > 'ValidateAsNotEmpty'=>1 for the normal_input), then there is no problem
      > and the prefix is displayed for each error.
      >
      > If this is run with form.php from 2007-06-02 (the last release) then,
      > for the custom inputs, no prefixes are displayed and each error is
      > outputted twice.

      Ok, I fixed the bug. You find the fixed version here. Thank you for
      reporting.

      http://www.meta-language.net/cvs/forms/forms.php?rev=HEAD;content-type=application%2Foctet-stream

      --

      Regards,
      Manuel Lemos

      PHP professionals looking for PHP jobs
      http://www.phpclasses.org/professionals/

      PHP Classes - Free ready to use OOP components written in PHP
      http://www.phpclasses.org/
    • fen.strat
      Works perfect, thanks Manuel Cheers, Saul
      Message 2 of 5 , Feb 11, 2008
      • 0 Attachment
        Works perfect, thanks Manuel

        Cheers, Saul
      Your message has been successfully submitted and would be delivered to recipients shortly.