Loading ...
Sorry, an error occurred while loading the content.

Re: Special characters (eg. Cyrillic) & TextArea

Expand Messages
  • polestar11
    Hi there It is the mx:TextArea: Here is a code snippet:
    Message 1 of 7 , Dec 1, 2009
    View Source
    • 0 Attachment
      Hi there

      It is the mx:TextArea:
      <mx:TextArea width="200" y="20" x="20" />

      Here is a code snippet:
      <mx:Box width="100%" height="100%" horizontalAlign="center" verticalAlign="middle">
      <mx:ViewStack id="viewStack" width="100%" height="100%" selectedIndex="1">
      <component:MainPanel id="mainPanel" width="100%" height="100%" />-->
      <mx:VBox width="100%" id="progressView" height="100%" horizontalAlign="center" verticalAlign="middle">
      <mx:ProgressBar height="15" indeterminate="true" label="Initializing ChessCube ..." fontSize="14" />
      </mx:VBox>
      </mx:ViewStack>
      </mx:Box>
      <mx:TextArea width="200" y="20" x="20" />

      The textarea works for special characters in debug mode, but not in release build mode. I've tried replicating / isolating the issue using different applications / projects but haven't found anything close to a solution yet, other than sometimes my tests fail for special characters even in debug mode (I think because I haven't cleaned the project properly)

      Cheers
      Tracy

      --- In flexcoders@yahoogroups.com, Gordon Smith <gosmith@...> wrote:
      >
      > BTW, are you are talking about the old MX TextArea or the or new Spark TextArea?
      >
      > Gordon Smith
      > Adobe Flex SDK Team
      >
      > From: flexcoders@yahoogroups.com [mailto:flexcoders@yahoogroups.com] On Behalf Of Andriy Panas
      > Sent: Monday, November 30, 2009 10:49 AM
      > To: flexcoders@yahoogroups.com
      > Subject: Re: [flexcoders] Special characters (eg. Cyrillic) & TextArea
      >
      >
      >
      > Hi polestar11,
      >
      > Simple code sample will definitely help to understand your issue.
      >
      > --
      > Best regards,
      > Andriy Panas
      >
      >
      > 2009/11/30 polestar11 <polestar11@...<mailto:polestar11@...>>
      >
      >
      > Hi there
      >
      > I have a problem where I am not able to paste special characters (eg. cyrillic & arabic) into a flex TextArea component. This occasionally happens in a debug version of my app and always happens in a release build.
      >
      > I created a test application in the same project to try isolate the issue. I intermittently am not able to paste special characters into a textarea. I also created a different project entirely and never experience the issue.
      >
      > My guess is that the compiler is misbehaving & getting stuck.
      >
      > Any help MUCH appreciated
      >
      > Cheers
      > Tracy
      >
    • Andriy Panas
      Hi Tracy, I am afraid your code sample is too generic and will not help me to isolate your issue. Me as a native speaker that uses Cyrillic alphabet had never
      Message 2 of 7 , Dec 1, 2009
      View Source
      • 0 Attachment
        Hi Tracy,

        I am afraid your code sample is too generic and will not help me to isolate your issue.

           Me as a native speaker that uses Cyrillic alphabet had never seen any problems with displaying Cyrillic alphabet symbols in <mx:TextArea>, but this remain valid only for  Windows OS, never tried Mac OS.

          I see that you're running Flash Player at Mac and had created the issue https://bugs.adobe.com/jira/browse/FB-24484 at Adobe JIRA bug-base, let move the discussion over this issue to Adobe JIRA.

           You should try as many Flash player dot versions as possible to test this issue, e.g 9.0.115,  9.0.246, 10.0.32.18 etc because we are talking here not about Flex SDK, but about Flash player features.

        --
        Best regards,
        Andriy Panas



        2009/12/1 polestar11 <polestar11@...>
         

        Hi there

        It is the mx:TextArea:
        <mx:TextArea width="200" y="20" x="20" />

        Here is a code snippet:
        <mx:Box width="100%" height="100%" horizontalAlign="center" verticalAlign="middle">
        <mx:ViewStack id="viewStack" width="100%" height="100%" selectedIndex="1">
        <component:MainPanel id="mainPanel" width="100%" height="100%" />-->
        <mx:VBox width="100%" id="progressView" height="100%" horizontalAlign="center" verticalAlign="middle">
        <mx:ProgressBar height="15" indeterminate="true" label="Initializing ChessCube ..." fontSize="14" />
        </mx:VBox>
        </mx:ViewStack>
        </mx:Box>
        <mx:TextArea width="200" y="20" x="20" />

        The textarea works for special characters in debug mode, but not in release build mode. I've tried replicating / isolating the issue using different applications / projects but haven't found anything close to a solution yet, other than sometimes my tests fail for special characters even in debug mode (I think because I haven't cleaned the project properly)

        Cheers
        Tracy



        --- In flexcoders@yahoogroups.com, Gordon Smith <gosmith@...> wrote:
        >
        > BTW, are you are talking about the old MX TextArea or the or new Spark TextArea?
        >
        > Gordon Smith
        > Adobe Flex SDK Team
        >
        > From: flexcoders@yahoogroups.com [mailto:flexcoders@yahoogroups.com] On Behalf Of Andriy Panas
        > Sent: Monday, November 30, 2009 10:49 AM
        > To: flexcoders@yahoogroups.com
        > Subject: Re: [flexcoders] Special characters (eg. Cyrillic) & TextArea
        >
        >
        >
        > Hi polestar11,
        >
        > Simple code sample will definitely help to understand your issue.
        >
        > --
        > Best regards,
        > Andriy Panas
        >
        >
        > 2009/11/30 polestar11 <polestar11@...<mailto:polestar11@...>>

        >
        >
        > Hi there
        >
        > I have a problem where I am not able to paste special characters (eg. cyrillic & arabic) into a flex TextArea component. This occasionally happens in a debug version of my app and always happens in a release build.
        >
        > I created a test application in the same project to try isolate the issue. I intermittently am not able to paste special characters into a textarea. I also created a different project entirely and never experience the issue.
        >
        > My guess is that the compiler is misbehaving & getting stuck.
        >
        > Any help MUCH appreciated
        >
        > Cheers
        > Tracy
        >
        ,___

      • Andriy Panas
        Hi Tracy, Are you using Safari browser under Mac OS 10.6? If yes, then probably you are victim of the following bug Can t enter cyrillic symbols
        Message 3 of 7 , Dec 1, 2009
        View Source
        • 0 Attachment
          Hi Tracy,

          Are you using Safari browser under Mac OS 10.6?

          If yes, then probably you are victim of the following bug

          "Can't enter cyrillic symbols"
          https://bugs.adobe.com/jira/browse/FP-3213
          http://www.openradar.appspot.com/7395808

          --
          Best regards,
          Andriy Panas




          2009/12/1 Andriy Panas <a.panas@...>:
          > Hi Tracy,
          > I am afraid your code sample is too generic and will not help me to isolate
          > your issue.
          >    Me as a native speaker that uses Cyrillic alphabet had never seen any
          > problems with displaying Cyrillic alphabet symbols in <mx:TextArea>, but
          > this remain valid only for  Windows OS, never tried Mac OS.
          >   I see that you're running Flash Player at Mac and had created the
          > issue https://bugs.adobe.com/jira/browse/FB-24484%c2%a0at Adobe JIRA bug-base,
          > let move the discussion over this issue to Adobe JIRA.
          >    You should try as many Flash player dot versions as possible to test this
          > issue, e.g 9.0.115,  9.0.246, 10.0.32.18 etc because we are talking here not
          > about Flex SDK, but about Flash player features.
          > --
          > Best regards,
          > Andriy Panas
          >
          >
          >
          > 2009/12/1 polestar11 <polestar11@...>
          >>
          >>
          >>
          >> Hi there
          >>
          >> It is the mx:TextArea:
          >> <mx:TextArea width="200" y="20" x="20" />
          >>
          >> Here is a code snippet:
          >> <mx:Box width="100%" height="100%" horizontalAlign="center"
          >> verticalAlign="middle">
          >> <mx:ViewStack id="viewStack" width="100%" height="100%" selectedIndex="1">
          >> <component:MainPanel id="mainPanel" width="100%" height="100%" />-->
          >> <mx:VBox width="100%" id="progressView" height="100%"
          >> horizontalAlign="center" verticalAlign="middle">
          >> <mx:ProgressBar height="15" indeterminate="true" label="Initializing
          >> ChessCube ..." fontSize="14" />
          >> </mx:VBox>
          >> </mx:ViewStack>
          >> </mx:Box>
          >> <mx:TextArea width="200" y="20" x="20" />
          >>
          >> The textarea works for special characters in debug mode, but not in
          >> release build mode. I've tried replicating / isolating the issue using
          >> different applications / projects but haven't found anything close to a
          >> solution yet, other than sometimes my tests fail for special characters even
          >> in debug mode (I think because I haven't cleaned the project properly)
          >>
          >> Cheers
          >> Tracy
          >>
          >> --- In flexcoders@yahoogroups.com, Gordon Smith <gosmith@...> wrote:
          >> >
          >> > BTW, are you are talking about the old MX TextArea or the or new Spark
          >> > TextArea?
          >> >
          >> > Gordon Smith
          >> > Adobe Flex SDK Team
          >> >
          >> > From: flexcoders@yahoogroups.com [mailto:flexcoders@yahoogroups.com] On
          >> > Behalf Of Andriy Panas
          >> > Sent: Monday, November 30, 2009 10:49 AM
          >> > To: flexcoders@yahoogroups.com
          >> > Subject: Re: [flexcoders] Special characters (eg. Cyrillic) & TextArea
          >> >
          >> >
          >> >
          >> > Hi polestar11,
          >> >
          >> > Simple code sample will definitely help to understand your issue.
          >> >
          >> > --
          >> > Best regards,
          >> > Andriy Panas
          >> >
          >> >
          >> > 2009/11/30 polestar11 <polestar11@...<mailto:polestar11@...>>
          >> >
          >> >
          >> > Hi there
          >> >
          >> > I have a problem where I am not able to paste special characters (eg.
          >> > cyrillic & arabic) into a flex TextArea component. This occasionally happens
          >> > in a debug version of my app and always happens in a release build.
          >> >
          >> > I created a test application in the same project to try isolate the
          >> > issue. I intermittently am not able to paste special characters into a
          >> > textarea. I also created a different project entirely and never experience
          >> > the issue.
          >> >
          >> > My guess is that the compiler is misbehaving & getting stuck.
          >> >
          >> > Any help MUCH appreciated
          >> >
          >> > Cheers
          >> > Tracy
          >> >
          >> ,___
          >
        • polestar11
          Thanks Andriy for your help I ve managed to track down the issue (but not explain it) One of our team - also using Mac OSX - built his project using a manually
          Message 4 of 7 , Dec 2, 2009
          View Source
          • 0 Attachment
            Thanks Andriy for your help

            I've managed to track down the issue (but not explain it)
            One of our team - also using Mac OSX - built his project using a manually updated version of Flex 3.2 sdk (versus updating to flexbuilder 3.0.2, which automatically udpates to the 3.2 sdk)

            If I build the exact same project (same checked-out items from SVN), cyrillic in a release build works fine. Since then he has upgraded to Flexbuilder 3.0.2, so theoretically he should have the same environment as me. He has since built new swc versions of his component and we still get issues with typing cyrillic in a textarea.

            For now at least there is the work around that I can build a version of his component to be used in my project and cyrillic / special characters will always work.

            It is strange that with his updated environment which is the same as mine, there is some incompatibility that is causing special characters not to display properly (now this occurs in release as well as debug builds)

            Cheers
            Tracy


            --- In flexcoders@yahoogroups.com, Andriy Panas <a.panas@...> wrote:
            >
            > Hi Tracy,
            >
            > Are you using Safari browser under Mac OS 10.6?
            >
            > If yes, then probably you are victim of the following bug
            >
            > "Can't enter cyrillic symbols"
            > https://bugs.adobe.com/jira/browse/FP-3213
            > http://www.openradar.appspot.com/7395808
            >
            > --
            > Best regards,
            > Andriy Panas
            >
            >
            >
            >
            > 2009/12/1 Andriy Panas <a.panas@...>:
            > > Hi Tracy,
            > > I am afraid your code sample is too generic and will not help me to isolate
            > > your issue.
            > >    Me as a native speaker that uses Cyrillic alphabet had never seen any
            > > problems with displaying Cyrillic alphabet symbols in <mx:TextArea>, but
            > > this remain valid only for  Windows OS, never tried Mac OS.
            > >   I see that you're running Flash Player at Mac and had created the
            > > issue https://bugs.adobe.com/jira/browse/FB-24484%c2%a0at Adobe JIRA bug-base,
            > > let move the discussion over this issue to Adobe JIRA.
            > >    You should try as many Flash player dot versions as possible to test this
            > > issue, e.g 9.0.115,  9.0.246, 10.0.32.18 etc because we are talking here not
            > > about Flex SDK, but about Flash player features.
            > > --
            > > Best regards,
            > > Andriy Panas
            > >
            > >
            > >
            > > 2009/12/1 polestar11 <polestar11@...>
            > >>
            > >>
            > >>
            > >> Hi there
            > >>
            > >> It is the mx:TextArea:
            > >> <mx:TextArea width="200" y="20" x="20" />
            > >>
            > >> Here is a code snippet:
            > >> <mx:Box width="100%" height="100%" horizontalAlign="center"
            > >> verticalAlign="middle">
            > >> <mx:ViewStack id="viewStack" width="100%" height="100%" selectedIndex="1">
            > >> <component:MainPanel id="mainPanel" width="100%" height="100%" />-->
            > >> <mx:VBox width="100%" id="progressView" height="100%"
            > >> horizontalAlign="center" verticalAlign="middle">
            > >> <mx:ProgressBar height="15" indeterminate="true" label="Initializing
            > >> ChessCube ..." fontSize="14" />
            > >> </mx:VBox>
            > >> </mx:ViewStack>
            > >> </mx:Box>
            > >> <mx:TextArea width="200" y="20" x="20" />
            > >>
            > >> The textarea works for special characters in debug mode, but not in
            > >> release build mode. I've tried replicating / isolating the issue using
            > >> different applications / projects but haven't found anything close to a
            > >> solution yet, other than sometimes my tests fail for special characters even
            > >> in debug mode (I think because I haven't cleaned the project properly)
            > >>
            > >> Cheers
            > >> Tracy
            > >>
            > >> --- In flexcoders@yahoogroups.com, Gordon Smith <gosmith@> wrote:
            > >> >
            > >> > BTW, are you are talking about the old MX TextArea or the or new Spark
            > >> > TextArea?
            > >> >
            > >> > Gordon Smith
            > >> > Adobe Flex SDK Team
            > >> >
            > >> > From: flexcoders@yahoogroups.com [mailto:flexcoders@yahoogroups.com] On
            > >> > Behalf Of Andriy Panas
            > >> > Sent: Monday, November 30, 2009 10:49 AM
            > >> > To: flexcoders@yahoogroups.com
            > >> > Subject: Re: [flexcoders] Special characters (eg. Cyrillic) & TextArea
            > >> >
            > >> >
            > >> >
            > >> > Hi polestar11,
            > >> >
            > >> > Simple code sample will definitely help to understand your issue.
            > >> >
            > >> > --
            > >> > Best regards,
            > >> > Andriy Panas
            > >> >
            > >> >
            > >> > 2009/11/30 polestar11 <polestar11@<mailto:polestar11@>>
            > >> >
            > >> >
            > >> > Hi there
            > >> >
            > >> > I have a problem where I am not able to paste special characters (eg.
            > >> > cyrillic & arabic) into a flex TextArea component. This occasionally happens
            > >> > in a debug version of my app and always happens in a release build.
            > >> >
            > >> > I created a test application in the same project to try isolate the
            > >> > issue. I intermittently am not able to paste special characters into a
            > >> > textarea. I also created a different project entirely and never experience
            > >> > the issue.
            > >> >
            > >> > My guess is that the compiler is misbehaving & getting stuck.
            > >> >
            > >> > Any help MUCH appreciated
            > >> >
            > >> > Cheers
            > >> > Tracy
            > >> >
            > >> ,___
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.