Loading ...
Sorry, an error occurred while loading the content.
 

Reg: Eclipse + Fitnesse

Expand Messages
  • sapna ponnaraseri gopinathan
    I have installed Fitnesse and use it with Eclipse. I can write a test case and make it fail. But when i write the code which will work correctly, instead of
    Message 1 of 9 , Dec 3, 2007

      I have installed Fitnesse and use it with Eclipse.  I can write a test case and make it fail.  But when i write the code which will work correctly, instead of the fitnesse table showing pass (true) it still shows the same results as before.  Why does this happen?  I have reinstalled fitnesse again but there is no change. 

      Sapma



      BBC Honeywell
    • Kimberly Kulina/HSI
      Can we post jobs here ? If not can someone tell me somewhere I might be able to post jobs for Agile and Ftinesse in the North Carolina area? ****************
      Message 2 of 9 , Dec 3, 2007

        Can we post jobs here ? If not can someone tell me somewhere I might be able to post jobs for Agile and Ftinesse in the North Carolina area?

        ****************
        Kimberly Kulina
        Technical Recruiter
        www.howardsystems.com
        Direct :856-755-9052
        Fax: 856-755-9055
        Toll Free: 800-207-4884
        http://www.linkedin.com/in/kimberlykulina
                    





        "sapna ponnaraseri gopinathan" <sapna_gopi@...>
        Sent by: fitnesse@yahoogroups.com

        12/03/2007 03:21 AM
        Please respond to fitnesse

               
                To:        fitnesse@yahoogroups.com
                cc:        
                Subject:        [fitnesse] Reg: Eclipse + Fitnesse



        I have installed Fitnesse and use it with Eclipse.  I can write a test case and make it fail.  But when i write the code which will work correctly, instead of the fitnesse table showing pass (true) it still shows the same results as before.  Why does this happen?  I have reinstalled fitnesse again but there is no change.  

        Sapma


        BBC Honeywell


      • Dassing, Andrew
        A few questions if I may? 1. How are you starting FitNesse from within Eclipse? 2. Are you starting FitNesse local to your PC, or on a remote server? 3. Is
        Message 3 of 9 , Dec 3, 2007

          A few questions if I may?

          1. How are you starting FitNesse from within Eclipse?
          2. Are you starting FitNesse local to your PC, or on a remote server?
          3. Is your Eclipse IDE installed on the same platform on which you are running FitNesse?
          4. What port, directory, and root page are displayed?
          5. How are you installing your custom fixture classes or .jar such that FitNesse can find them?
          6. Are there !path specifications to the location where your classes or .jar reside?
          7. Are there exception messages or other output echoed in the console window?

           


          From: fitnesse@yahoogroups.com [mailto: fitnesse@yahoogroups.com ] On Behalf Of sapna ponnaraseri gopinathan
          Sent: Monday, December 03, 2007 3:21 AM
          To: fitnesse@yahoogroups.com
          Subject: [fitnesse] Reg: Eclipse + Fitnesse

           

          I have installed Fitnesse and use it with Eclipse.  I can write a test case and make it fail.  But when i write the code which will work correctly, instead of the fitnesse table showing pass (true) it still shows the same results as before.  Why does this happen?  I have reinstalled fitnesse again but there is no change. 

          Sapma

           

          BBC Honeywell

        • Andy Dassing
          Let s keep this a forum for technical questions. The flavor of the opt-in is of a technical nature, not a solicitation nature. Once the door is opened to one
          Message 4 of 9 , Dec 3, 2007
            Let's keep this a forum for technical questions. The flavor of the
            opt-in is of a technical nature, not a solicitation nature.

            Once the door is opened to one placement professional, it will open
            the door for many. Setting the precedent now may create a clutter and
            a distraction.

            Your needs are better served by using services where people are
            actively seeking employment:
            * http://www.monster.com
            * http://information-
            technology.careerbuilder.com/it.ic/NorthCarolina/
            * http://www.north_carolina.jobopenings.net/
            * http://charlotte.computerwork.com/
            * http://www.engineer.info/Engineering_Jobs.asp?jobquery=entry%
            20level%20computer%20Engineer&querynumber=1&location=NC&lname=North%
            20Carolina

            --- In fitnesse@yahoogroups.com, Kimberly Kulina/HSI
            <kimberly_kulina@...> wrote:
            >
            > Can we post jobs here ? If not can someone tell me somewhere I
            might be
            > able to post jobs for Agile and Ftinesse in the North Carolina area?
            >
            > ****************
            > Kimberly Kulina
            > Technical Recruiter
            > www.howardsystems.com
            > Direct :856-755-9052
            > Fax: 856-755-9055
            > Toll Free: 800-207-4884
            > http://www.linkedin.com/in/kimberlykulina
            >
            >
            >
            >
            >
            >
            >
            >
            > "sapna ponnaraseri gopinathan" <sapna_gopi@...>
            > Sent by: fitnesse@yahoogroups.com
            > 12/03/2007 03:21 AM
            > Please respond to fitnesse
            >
            > To: fitnesse@yahoogroups.com
            > cc:
            > Subject: [fitnesse] Reg: Eclipse + Fitnesse
            >
            >
            > I have installed Fitnesse and use it with Eclipse. I can write a
            test
            > case and make it fail. But when i write the code which will work
            > correctly, instead of the fitnesse table showing pass (true) it
            still
            > shows the same results as before. Why does this happen? I have
            > reinstalled fitnesse again but there is no change.
            >
            > Sapma
            >
          • John Roth
            There s an xp-jobs list that s just for this purpose. It says xp, but it s open to just about anything agile. John Roth ... From: Kimberly Kulina/HSI
            Message 5 of 9 , Dec 3, 2007
              There's an xp-jobs list that's just for this purpose.
              It says xp, but it's open to just about anything agile.

              John Roth

              ----- Original Message -----
              From: "Kimberly Kulina/HSI" <kimberly_kulina@...>
              To: <fitnesse@yahoogroups.com>
              Cc: <fitnesse@yahoogroups.com>
              Sent: Monday, December 03, 2007 9:30 AM
              Subject: Re: [fitnesse] Reg: Eclipse + Fitnesse


              > Can we post jobs here ? If not can someone tell me somewhere I might be
              > able to post jobs for Agile and Ftinesse in the North Carolina area?
              >
              > ****************
              > Kimberly Kulina
              > Technical Recruiter
              > www.howardsystems.com
              > Direct :856-755-9052
              > Fax: 856-755-9055
              > Toll Free: 800-207-4884
              > http://www.linkedin.com/in/kimberlykulina
              >
              >
              >
              >
              >
              >
              >
              >
              > "sapna ponnaraseri gopinathan" <sapna_gopi@...>
              > Sent by: fitnesse@yahoogroups.com
              > 12/03/2007 03:21 AM
              > Please respond to fitnesse
              >
              > To: fitnesse@yahoogroups.com
              > cc:
              > Subject: [fitnesse] Reg: Eclipse + Fitnesse
              >
              >
              > I have installed Fitnesse and use it with Eclipse. I can write a test
              > case and make it fail. But when i write the code which will work
              > correctly, instead of the fitnesse table showing pass (true) it still
              > shows the same results as before. Why does this happen? I have
              > reinstalled fitnesse again but there is no change.
              >
              > Sapma
              >
              >
              >
              >
              >
            • Tim Walker
              Sounds to me like the fitnesse server you are using has a !path to a production jar or dll file and not the development jar file you re working with. Is this
              Message 6 of 9 , Dec 4, 2007
                Sounds to me like the fitnesse server you are using has a !path to a production jar or dll file and not the development jar file you're working with. Is this possible?

                Tim

                On 3 Dec 2007 08:21:25 -0000, sapna ponnaraseri gopinathan < sapna_gopi@...> wrote:

                I have installed Fitnesse and use it with Eclipse.  I can write a test case and make it fail.  But when i write the code which will work correctly, instead of the fitnesse table showing pass (true) it still shows the same results as before.  Why does this happen?  I have reinstalled fitnesse again but there is no change. 

                Sapma



                BBC Honeywell

              • sapna ponnaraseri gopinathan
                1. I am starting Fitnesse by Right Click on the Fitness folder of the related project and then Launch Fitnesse Runtime on this Root Folder 2. Local to PC
                Message 7 of 9 , Dec 5, 2007

                   
                  1.  I am starting Fitnesse by "Right Click on the Fitness folder of the related project' and then 'Launch Fitnesse Runtime on this Root Folder'
                  2.  Local to PC
                  3.  Yes, it is installed on the same platform
                  4.  http://localhost:9083/ is what is displayed when i start Fitnesse
                  5.  I use the fixture classes
                  6.  Yes, i have given the path
                  7.  Yes, it says tests executed but they are supposed to pass as the code is correct.

                  Also, I checked the code on a machine that has fitnesse installed.  It works on that machine.  Despite, reinstalling, I don't understand why it does not work. 

                  Thanks
                  Sapna

                  On Mon, 03 Dec 2007 Dassing,Andrew wrote :

                  >A few questions if I may?
                  >
                  >1.     How are you starting FitNesse from within Eclipse?
                  >2.     Are you starting FitNesse local to your PC, or on a remote
                  >server?
                  >3.     Is your Eclipse IDE installed on the same platform on which you
                  >are running FitNesse?
                  >4.     What port, directory, and root page are displayed?
                  >5.     How are you installing your custom fixture classes or .jar such
                  >that FitNesse can find them?
                  >6.     Are there !path specifications to the location where your
                  >classes or .jar reside?
                  >7.     Are there exception messages or other output echoed in the
                  >console window?
                  >
                  >
                  >
                  >________________________________
                  >
                  > From: fitnesse@yahoogroups.com [mailto:fitnesse@yahoogroups.com] On
                  >Behalf Of sapna ponnaraseri gopinathan
                  >Sent: Monday, December 03, 2007 3:21 AM
                  >To: fitnesse@yahoogroups.com
                  >Subject: [fitnesse] Reg: Eclipse + Fitnesse
                  >
                  >
                  >
                  >I have installed Fitnesse and use it with Eclipse.  I can write a test
                  >case and make it fail.  But when i write the code which will work
                  >correctly, instead of the fitnesse table showing pass (true) it still
                  >shows the same results as before.  Why does this happen?  I have
                  >reinstalled fitnesse again but there is no change.
                  >
                  >Sapma
                  >
                  >
                  >
                  >BBC Honeywell
                  ><http://adworks.rediff.com/cgi-bin/AdWorks/click.cgi/www.rediff.com/sign
                  >ature-home.htm/1050715198@Middle5/1963447_1956354/1962970/1?PARTNER=3&OA
                  >S_QUERY=null%20target=new%20>
                  >
                  >
                  >



                  Reliance Mobile
                • sapna ponnaraseri gopinathan
                  I shall check that out. Thanks! Sapna
                  Message 8 of 9 , Dec 5, 2007

                     
                    I shall check that out.

                    Thanks!
                    Sapna

                    On Tue, 04 Dec 2007 Tim Walker wrote :

                    >Sounds to me like the fitnesse server you are using has a !path to a
                    >production jar or dll file and not the development jar file you're working
                    >with. Is this possible?
                    >
                    >Tim
                    >
                    >On 3 Dec 2007 08:21:25 -0000, sapna ponnaraseri gopinathan <
                    >sapna_gopi@...> wrote:
                    >
                    > >    I have installed Fitnesse and use it with Eclipse.  I can write a test
                    > > case and make it fail.  But when i write the code which will work correctly,
                    > > instead of the fitnesse table showing pass (true) it still shows the same
                    > > results as before.  Why does this happen?  I have reinstalled fitnesse again
                    > > but there is no change.
                    > >
                    > > Sapma
                    > >
                    > >
                    > > [image: BBC Honeywell]<http://adworks.rediff.com/cgi-bin/AdWorks/click.cgi/www.rediff.com/signature-home.htm/1050715198@Middle5/1963447_1956354/1962970/1?PARTNER=3&OAS_QUERY=null+target=new+>
                    > >
                    > >



                    Magic Bricks
                  • Dassing, Andrew
                    The 9083 port implies you are using the default settings in the FitNesse plug in, yes? Try setting the FitNesse Folder Prefix value to FitNesse -o. Where the
                    Message 9 of 9 , Dec 5, 2007

                      The 9083 port implies you are using the default settings in the FitNesse plug in, yes?

                       

                      Try setting the FitNesse Folder Prefix value to FitNesse –o.  Where the –o prevents refreshing the FitNesse environment which may be interfering with your !path specifications.  The absence of the –o causes FitNesse to pop out to the Internet to update pages and runs through your environment with an "update" phase; you probably don't want that. 

                       

                      I recommend also checking your environment to verify its health and welfare.  You may need to reinstate your development !path specs, classes, etc.

                       

                      Additionally in the Window--Preferences…--Java--Build Path--Classpath Variables, check the FITNESSE_LIB and FITNESSE_LIB_SRC, and FIT_LIB values for correctness. 

                       

                      Very important:  Check the content.txt file in your fitnesse root to verify it matches the one on the system that behaves.

                       

                      Search to see if there is an old .jar or .class file somewhere in the path that might be preventing the newer code from being found.

                       

                      Please post back here on what you find when you get your problem resolved.

                       


                      From: fitnesse@yahoogroups.com [mailto:fitnesse@yahoogroups.com] On Behalf Of sapna ponnaraseri gopinathan
                      Sent: Wednesday, December 05, 2007 2:14 PM
                      To: fitnesse@yahoogroups.com
                      Subject: Re: RE: [fitnesse] Reg: Eclipse + Fitnesse

                       

                       
                      1.  I am starting Fitnesse by "Right Click on the Fitness folder of the related project' and then 'Launch Fitnesse Runtime on this Root Folder'
                      2.  Local to PC
                      3.  Yes, it is installed on the same platform
                      4.  http://localhost: 9083/ is what is displayed when i start Fitnesse
                      5.  I use the fixture classes
                      6.  Yes, i have given the path
                      7.  Yes, it says tests executed but they are supposed to pass as the code is correct.

                      Also, I checked the code on a machine that has fitnesse installed.  It works on that machine.  Despite, reinstalling, I don't understand why it does not work. 

                      Thanks
                      Sapna

                      On Mon, 03 Dec 2007 Dassing,Andrew wrote :

                      >A few questions if I may?
                      >
                      >1.     How are you starting FitNesse from within Eclipse?
                      >2.     Are you starting FitNesse local to your PC, or on a
                      remote
                      >server?
                      >3.     Is your Eclipse IDE installed on the same platform on
                      which you
                      >are running FitNesse?
                      >4.     What port, directory, and root page are displayed?
                      >5.     How are you installing your custom fixture classes or
                      .jar such
                      >that FitNesse can find them?
                      >6.     Are there !path specifications to the location where
                      your
                      >classes or .jar reside?
                      >7.     Are there exception messages or other output echoed
                      in the
                      >console window?
                      >
                      >
                      >
                      >____________ _________ _________ __
                      >
                      > From: fitnesse@yahoogroup s.com [mailto:fitnesse@ yahoogroups. com]
                      On
                      >Behalf Of sapna ponnaraseri gopinathan
                      >Sent: Monday, December 03, 2007 3:21 AM
                      >To: fitnesse@yahoogroup s.com
                      >Subject: [fitnesse] Reg: Eclipse + Fitnesse
                      >
                      >
                      >
                      >I have installed Fitnesse and use it with Eclipse.  I can write a test
                      >case and make it fail.  But when i write the code which will work
                      >correctly, instead of the fitnesse table showing pass (true) it still
                      >shows the same results as before.  Why does this happen?  I have
                      >reinstalled fitnesse again but there is no change.
                      >
                      >Sapma
                      >
                      >
                      >
                      >BBC Honeywell
                      ><http://adworks. rediff.com/ cgi-bin/AdWorks/ click.cgi/ www.rediff. com/sign
                      >ature-home.htm/ 1050715198@ Middle5/1963447_ 1956354/1962970/ 1?PARTNER= 3&OA
                      >S_QUERY=null% 20target= new%20>
                      >
                      >
                      >

                       

                      Reliance Mobile

                    Your message has been successfully submitted and would be delivered to recipients shortly.